Une page d'accueil qui "bouge" avec la barre de navigation

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Une page d'accueil qui "bouge" avec la barre de navigation

Message par Pchit le Jeu 19 Aoû 2010 - 18:13

Bonjour à tous!

Voilà mon problème: je suis en train de créer la mise en page de mon forum, et j'avoue que j'ai deux soucis majeurs pour que ça me donne quelque chose de potable, pour moi qui suis nulle avec tout ça.

problème numéro 1: ce que je vois dans le PA en prévisualisation n'est pas la même chose quand je le vois en vrai sur le forum. Mon image d'accueil se retrouve mangée par un cadre que j'ai pourtant enlevé et qui n'apparait pas dans le PA, mais qui se voit sur le fofo.

problème numéro 2: j'ai crée une page d'accueil qui.. comment pourrais-je expliquer, je ne connais pas les termes techniques... L'image d'accueil ne reste pas fixée en haut de page, elle se déplace -si on peut dire- quand on baisse ou lève la barre de navigation.
Je n'arrive pas à produire ce phénomène, du coup mon image d'accueil reste fixée en haut sans bouger.

D'où ma question générale pour mes deux problèmes: Comment on fait pour modifier? ^^
Merci de m'aider, je commence à déprimer et à m'arracher les cheveux. ^^°


Dernière édition par Pchit le Dim 29 Aoû 2010 - 16:32, édité 1 fois

Pchit
Nouveau membre

Messages : 14
Inscrit(e) le : 19/08/2010

http://pokemonnewworld.forumactif.com/index.htm
Pchit a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Invité le Jeu 19 Aoû 2010 - 18:30

Salut,

@Pchit a écrit:
problème numéro 2: j'ai crée une page d'accueil qui.. comment pourrais-je expliquer, je ne connais pas les termes techniques... L'image d'accueil ne reste pas fixée en haut de page, elle se déplace -si on peut dire- quand on baisse ou lève la barre de navigation.
Je n'arrive pas à produire ce phénomène, du coup mon image d'accueil reste fixée en haut sans bouger.

Panneau d'Administration → Affichage → Gestion des images → Mode avancé :: Image de fond de page.

Justement, moi je pense que tu dois la fixer Razz pour avoir ce que tu souhaites. Coche ce que je viens de t'encadrer dans la capture écran !



Pour le problème numéro 1, je ne comprends pas ce que tu veux. Si tu pouvais me faire une capture écran en m'expliquant, je suis preneur !

flower

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par ge80 le Jeu 19 Aoû 2010 - 18:37

Bonsoir Chôlang.

je pense que c'est un problème de centrage du logo si le lien est correct.

Cordialement
Ge

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Pchit le Jeu 19 Aoû 2010 - 18:40

yeah, mon problème 2 est réglé! Merci beaucoup =D

Alors une capture d'écran:

ça, c'est ce que je vois dans le PA, dans la prévisualisation:


ça, c'est ce qui apparait sur le forum: comme vous voyez, il y a un grand cadre blanc que j'ai normalement effacé mais qui apparait quand même et cache ce qu'il y a derrière.



je vois d'ailleurs que mon écran ajoute du noir à droite... J'ai peut-être pas fait assez grand?

Pchit
Nouveau membre

Messages : 14
Inscrit(e) le : 19/08/2010

http://pokemonnewworld.forumactif.com/index.htm
Pchit a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Invité le Jeu 19 Aoû 2010 - 18:42

Tu as essayé de mettre dans :

Panneau d'Administration → Affichage → couleurs → Couleur intérieure du cadre du forum : tu mets juste # .

Normalement, ça devrait te le mettre en transparent.

flower

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Pchit le Jeu 19 Aoû 2010 - 18:56

c'est ce que j'ai fait mais ça ne change pas. =/

Pchit
Nouveau membre

Messages : 14
Inscrit(e) le : 19/08/2010

http://pokemonnewworld.forumactif.com/index.htm
Pchit a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Invité le Jeu 19 Aoû 2010 - 19:00

Je viens de tester sur mon forum et cela fonctionne What a Face

Bon, essaye de mettre ça dans ton CSS :

.bodyline {
background-color:transparent;
}

flower



Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Pchit le Jeu 19 Aoû 2010 - 19:25

Non plus ^^° le cadre blanc reste toujours là..

Pchit
Nouveau membre

Messages : 14
Inscrit(e) le : 19/08/2010

http://pokemonnewworld.forumactif.com/index.htm
Pchit a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Invité le Jeu 19 Aoû 2010 - 19:33

Tu peux me donner le lien de ton forum par MP ?

C'est bizarre que cela reste en blanc.

Tu peux aussi me faire une capture écran des couleurs que tu as configuré ?

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Pchit le Jeu 19 Aoû 2010 - 19:45

les couleurs:
Spoiler:







edit: désolée j'abuse avec mes questions, mais vous avez une idée pour enlever le noir à droite sur la page d'accueil du forum? Faut-il que je fasse plus grand peut-être?

Pchit
Nouveau membre

Messages : 14
Inscrit(e) le : 19/08/2010

http://pokemonnewworld.forumactif.com/index.htm
Pchit a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Invité le Jeu 19 Aoû 2010 - 19:57

Re,

Je suis chiant mais je ne vois pas le "#" dans la case qui concerne la couleur à l'intérieur du cadre. Est-ce que tu peux mettre juste le dièse et valider pour voir si cela à une incidence.

Ce qui est bizarre, c'est que quand je fais le test avec ton forum, j'arrive à l'enlever car sur ton CSS, il est indiqué qu'il est blanc.


Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Pchit le Jeu 19 Aoû 2010 - 20:06

j'ai réessayé, et après être passé 3 fois (le # s'efface dès que j'enregistre), j'ai maintenant juste un cadre noir qui ne veut pas partir, comme on peut le voir ici:



mais je remarque qu'il y a en fait un "mix" entre la version que j'avais mis en attendant et celle que j'ai crée. Je vois des cadres oranges alors que je les ai mis noirs.

Pchit
Nouveau membre

Messages : 14
Inscrit(e) le : 19/08/2010

http://pokemonnewworld.forumactif.com/index.htm
Pchit a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Invité le Jeu 19 Aoû 2010 - 20:13

Alors, pour le cadre noir, tu peux le retirer. Suffit de mettre le "#" dans : Couleur du cadre du forum. Il sera invisible aussi.

Pour ce qui est de tes contours orange, il faut que tu regardes ce que tu as mis dans les champs:

Couleur du cadre des tables :

Couleur du cadre des cellules :

flower

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Pchit le Jeu 19 Aoû 2010 - 20:17

alors: quand je modifie la couleur dans "couleur du cadre du forum" ça se change, mais le temps que je réinitialise le forum, ça repart et ça remet la couleur grise d'avant.

pour les deux autres, j'ai bien vérifié, ils ne sont pas orange:


Pchit
Nouveau membre

Messages : 14
Inscrit(e) le : 19/08/2010

http://pokemonnewworld.forumactif.com/index.htm
Pchit a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Invité le Jeu 19 Aoû 2010 - 20:22

Oui mais dans ton CSS, tu as mis des couleurs précises pour les cadres :

Code:
a.forumlink:hover, a.forumlink:hover:visited{
border-left: 5px solid #F5A55E;
border-right: 5px solid #F5A55E;
-moz-border-radius:6px;}

.forumline{
border-bottom: 6px #F5A55E solid;
border-top: 1px #F5A55E dotted;
border-right: 1px #F5A55E dotted;
border-left: 1px #F5A55E dotted;}

Et je vois que #F5A55E sur Toshop, ça donne ta couleur orangée.

Il faut que tu comprennes que le CSS est pris en compte en premier. Les réglages dans ton Panneau d'Administration au niveau des couleurs sont secondaires.

Donc, fait attention.

Et pour ton cadre gris, tu es sur ? Moi je vois la couleur #444444, qui est du gris clair.

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Pchit le Jeu 19 Aoû 2010 - 20:24

Oh ça alors! Est-ce que tous ces codes apparaissent sur ma page CSS? Car je ne vois que ça moi, c'est à dire ce que vous m'avez demandé de mettre plus haut:



Pour la couleur, j'ai réussi à mettre vide mais ça continue quand même à afficher un cadre.

Je ne comprend pas comment j'ai pu avoir ces codes couleurs, je n'ai même pas photoshop. (à moins qu'il n'y ai pas de rapport ^^°)

Pchit
Nouveau membre

Messages : 14
Inscrit(e) le : 19/08/2010

http://pokemonnewworld.forumactif.com/index.htm
Pchit a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Invité le Jeu 19 Aoû 2010 - 20:27

Ah bah moi, j'ai pas ça xD

http://pokemonnewworld.forumactif.com/36-ltr.css

Voilà le CSS de ton forum :/ Et il n'y a pas de raison pour que tu ne le vois pas Surprised


Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Pchit le Jeu 19 Aoû 2010 - 20:29

Oh la la! mais j'ai rien de tout ça moi! j'ai juste ce que j'ai mis en image précédemment xD j'ai rien de tout ça qui apparait! J'y comprend rien là, comment ça se fait?

Pchit
Nouveau membre

Messages : 14
Inscrit(e) le : 19/08/2010

http://pokemonnewworld.forumactif.com/index.htm
Pchit a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Invité le Jeu 19 Aoû 2010 - 20:38

Hop, affaire réglée flower

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Pchit le Jeu 19 Aoû 2010 - 20:39

merci beaucoup! j'ai pas intérêt à changer de déco de si tôt x)

Pchit
Nouveau membre

Messages : 14
Inscrit(e) le : 19/08/2010

http://pokemonnewworld.forumactif.com/index.htm
Pchit a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Pchit le Jeu 19 Aoû 2010 - 20:45

rectification: la ligne est revenue xD

Pchit
Nouveau membre

Messages : 14
Inscrit(e) le : 19/08/2010

http://pokemonnewworld.forumactif.com/index.htm
Pchit a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Invité le Jeu 19 Aoû 2010 - 21:09

Bah oui, elle est revenue car vous l'avez remise ...



Il ne faut pas mettre une couleur ici. Enlevez le code #444444 pour mettre juste une dièse et valider.

flower

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Pchit le Ven 20 Aoû 2010 - 18:03

Je vous jure que je n'y ai pas touché!
La preuve ici, un screen de mon tableau en PA:



Je vois ça vide!

edit: je ne sais pas par quel miracle, mais tout s'est enfin mis en place. Merci beaucoup de votre aide précieuse! =)

Pchit
Nouveau membre

Messages : 14
Inscrit(e) le : 19/08/2010

http://pokemonnewworld.forumactif.com/index.htm
Pchit a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une page d'accueil qui "bouge" avec la barre de navigation

Message par Ea le Dim 29 Aoû 2010 - 16:06

Bonjour,

Où en est votre problème ? Est il résolu résolu ?
_____________________

Si vous n'avez pas eu de solutions, relancer régulièrement votre sujet (toutes les 24 heures au minimum).
Et pensez à expliquer votre problème règulièrement, à chercher par vous même et montrez que vous cherchez de votre côté et pas que vous attendez simplement d'une réponse.

_____________________

Lorsqu'un sujet est résolu :

  • Cliquez sur le bouton de votre premier message du sujet.

  • Cochez en dessous de la zone de message


  • Enfin validez avec le bouton



Pour remercier ceux qui vous ont aidés vous pouvez cliquer sur merci

A bientôt sur ForumActif
Smile

Ea
Aidactif
Aidactif

Messages : 23428
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum