Comment mettre une texture en fond de forum ?

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Comment mettre une texture en fond de forum ?

Message par Elorri le Lun 23 Aoû 2010 - 10:55

    Bonjour ^^
    Voilà un aperçu de mon forum :

    https://i35.servimg.com/u/f35/12/15/64/35/exempl10.jpg

    Mon problème est le suivant. Je voudrai que la partie blanche (avec les traits rouges), donc le fond du forum, soit remplacée par cette texture : https://i35.servimg.com/u/f35/12/15/64/35/patter12.png
    Comment faire ?
    Merci d'avance. =)


Dernière édition par Elorri le Lun 23 Aoû 2010 - 15:49, édité 1 fois

Elorri
*

Messages : 35
Inscrit(e) le : 26/04/2009

http://ch3rry_@hotmail.fr
Elorri a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Chouquette~ le Lun 23 Aoû 2010 - 12:18

    Bonjour,

    Avais-vous essayez de placer cette image dans le gestionnaire d'image, sur votre PA à l'intitulé : "Image du fond de page :" Neutral ?
    Si, oui, et si ça n'a pas marché, dans votre feuille de style CSS :
    Code:
    body{
      background-image:url('http://i35.servimg.com/u/f35/12/15/64/35/patter12.png');
    }

Chouquette~
*****

Masculin
Messages : 666
Inscrit(e) le : 15/07/2009

Chouquette~ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Elorri le Lun 23 Aoû 2010 - 13:54

Dans "le logo du fond", j'ai mon image transparente (https://i35.servimg.com/u/f35/12/15/64/35/i_logo12.png) et dans "Image du fond de page" j'ai mon header (https://i35.servimg.com/u/f35/12/15/64/35/lesenf12.jpg)

Avec ce code, ca me donne quelque chose de très étrange : https://i35.servimg.com/u/f35/12/15/64/35/regard10.png

Elorri
*

Messages : 35
Inscrit(e) le : 26/04/2009

http://ch3rry_@hotmail.fr
Elorri a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Chouquette~ le Lun 23 Aoû 2010 - 14:06

    Je ne comprend pas très bien ce que vous dîtes, serait-il possible d'avoir l'adresse dudit forum ?

Chouquette~
*****

Masculin
Messages : 666
Inscrit(e) le : 15/07/2009

Chouquette~ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Elorri le Lun 23 Aoû 2010 - 14:17

Voilà.
http://enfants-liberte.forum-canada.net/forum.htm

Elorri
*

Messages : 35
Inscrit(e) le : 26/04/2009

http://ch3rry_@hotmail.fr
Elorri a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Chouquette~ le Lun 23 Aoû 2010 - 14:45

    Bon, bon,

    J'ai un peu inspecté votre forum sous Chrome, et en fait il y a plein d'attribut qui s'entre choc et du coup il y a conflit. Puis pour garder la configuration de votre forum, à savoir sa largeur, une solution simple n'est pas possible.
    Mais d'après mes tests c'est possible ;o).

    Pré-requis :
    * version phpBB2 ou punBB => Ca c'est OK.
    * Êtes-vous fondateur, et avez vous accès aux templates ?


Dernière édition par Chouquette~ le Lun 23 Aoû 2010 - 14:50, édité 1 fois

Chouquette~
*****

Masculin
Messages : 666
Inscrit(e) le : 15/07/2009

Chouquette~ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Elorri le Lun 23 Aoû 2010 - 14:48

Oui je suis la fondatrice.

Elorri
*

Messages : 35
Inscrit(e) le : 26/04/2009

http://ch3rry_@hotmail.fr
Elorri a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Chouquette~ le Lun 23 Aoû 2010 - 15:03

    Très bien, c'est parfait.

    0) Faites une copie de votre feuille de style CSS, si vous avez inscrit quelque chose dedans, de même pour le template "overall_header_new".

    1) Problème du fond :
    * Si dans votre feuille de style, vous appliquez un quelconque attribut (lié au fond) à "body", retirez le ! (faites-en une copie papier au cas où ;o)).
    * Copier/coller ceci :
    Code:
    body{
        background-image:url('http://i35.servimg.com/u/f35/12/15/64/35/patter12.png');
        background-repeat:repeat;
    }

    2) Problème de la bannière :
    C'est ici que les choses se compliquent un peu.
    * Allez dans le template "overall_header_new", dans "onglet affichage > menu template > général".
    * Repérez les lignes :
    Code:
    <a name="top"></a>
       {JAVASCRIPT}
    * Remplacez les par :
    Code:
    <div id="id_banniere"></div>
    <a name="top"></a>
       {JAVASCRIPT}
    * Dans votre fiche de CSS ajoutez ce code :
    Code:
    #id_banniere{
        width:100%;
        height:600px;
        background-image:url('http://i35.servimg.com/u/f35/12/15/64/35/lesenf12.jpg');
        background-position:top center;
        background-repeat:no-repeat;

    #i_logo{
        height:0px;
    }
    3) Résultat :
    Spoiler:
    Normalement tout cela marche ^^.

Chouquette~
*****

Masculin
Messages : 666
Inscrit(e) le : 15/07/2009

Chouquette~ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Elorri le Lun 23 Aoû 2010 - 15:10

Huum ca ne marche pas vraiment, ou alors j'ai du faire une fausse manip, en tout cas, ca donne un effet très étrange ^^

Mon code CSS :

Spoiler:
Code:
body{
    background-image:url('http://i35.servimg.com/u/f35/12/15/64/35/patter12.png');
    background-repeat:repeat;
}

#id_banniere{
    width:100%;
    height:600px;
    background-image:url('http://i35.servimg.com/u/f35/12/15/64/35/lesenf12.jpg');
    background-position:top center;
    background-repeat:no-repeat;

#i_logo{
    height:0px;
}


Mon template :

Spoiler:
Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html dir="{S_CONTENT_DIRECTION}" id="min-width" lang="{L_LANG_HTML}" xml:lang="{L_LANG_HTML}" {NAMESPACE_FB}>
<head>
   <!-- BEGIN meta_emulate_ie7 -->
   <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
   <!-- END meta_emulate_ie7 -->
   <title>{SITENAME_TITLE}{PAGE_TITLE}</title>
   <meta http-equiv="content-type" content="text/html; charset={S_CONTENT_ENCODING};" />
   <meta http-equiv="content-script-type" content="text/javascript" />
   <meta http-equiv="content-style-type" content="text/css" />
   {META_FAVICO}
   {META}
   <meta name="title" content="{SITENAME_TITLE}{PAGE_TITLE}" />
   {T_HEAD_STYLESHEET}
   {CSS}
   <link rel="search" type="application/opensearchdescription+xml" href="/improvedsearch.xml" title="{SITENAME}" />
   <link rel="search" type="application/opensearchdescription+xml" href="{URL_BOARD_DIRECTORY}/search/improvedsearch.xml" title="{SEARCH_FORUMS}" />
   <script src="{JS_DIR}{L_LANG}.js" type="text/javascript"></script>
   <!-- BEGIN switch_fb_login -->
   <script src="http://connect.facebook.net/{switch_fb_login.FB_LOCAL}/all.js"></script>
   <script src="{switch_fb_login.JS_FB_LOGIN}" type="text/javascript"></script>
   <!-- END switch_fb_login -->
   <!-- BEGIN switch_ticker -->
   <script src="{JS_DIR}jquery/ticker/ticker.js" type="text/javascript"></script>
   <link type="text/css" rel="stylesheet" href="{JS_DIR}jquery/ticker/ticker.css" />
   <!-- END switch_ticker -->

   <!-- BEGIN switch_ticker_new -->
   <script src="{JS_DIR}jquery/jcarousel/jquery.jcarousel.js" type="text/javascript"></script>
   <script type="text/javascript">
   //<![CDATA[

   /* Definir le sens de direction en fonction du panneau admin */
   var tickerDirParam = "{switch_ticker.DIRECTION}";
   var slid_vert = false;
   var auto_dir  = 'next';
   var h_perso = parseInt({switch_ticker.HEIGHT});

   switch( tickerDirParam )
   {
      case 'top' :
         slid_vert = true;
         break;

      case 'left':
         break;

      case 'bottom':
         slid_vert = true;
         auto_dir  = 'prev';
         break;

      case 'right':
         auto_dir  = 'prev';
         break;

      default:
         slid_vert = true;
   }

   $(document).ready(function() {
      var w_cont = $('#fa_ticker_container').width();

      if (w_cont > 0)
      {
         $('#fa_ticker_container').width(w_cont);

         /* Affichage de la liste */
         $('#fa_ticker_content').css('display','block');

         /* Calcul des dimensions du conteneur et des �l�ments */
         var width_max  = $('ul#fa_ticker_content').width();
         var width_item = Math.floor(width_max / {switch_ticker.SIZE});
         var height_max = h_perso;

         /* Calcul de la hauteur maximale du contenur en fonction des �l�ments et de la hauteur personnalis�e dans l'admin */
         $('ul#fa_ticker_content li').each( function () {
            if ($(this).height() > height_max)
            {
               height_max = $(this).height();
            }
         } );

         /* Redimensionnement des �l�ments et des images trop larges */
         $('ul#fa_ticker_content li').width(width_item).height(height_max).find('img').each(function () {
            if ($(this).width() > width_item)
            {
            var ratio      = $(this).width() / width_item;
            var new_height = Math.round($(this).height() / ratio);
            $(this).height(new_height).width(width_item);
            }
         });

         /* Redimensionnement et centrage du conteneur en mode vertical */
         if (slid_vert)
         {
            $('ul#fa_ticker_content').width(width_item).height(height_max).css('marginLeft','auto').css('marginRight','auto');
         }

         /* Initialisation du caroussel */
         $('#fa_ticker_content').jcarousel({
              vertical: slid_vert,
            wrap: 'circular',
             auto: {switch_ticker.STOP_TIME},
             auto_direction: auto_dir,
              scroll: 1,
              size: {switch_ticker.SIZE},
              height_max: height_max,
              animation: {switch_ticker.SPEED}
          });
       }
       else
       {
          $('ul#fa_ticker_content li:not(:first)').css('display','none');
          $('ul#fa_ticker_content li:first').css('list-style','none').css('text-align','center');
       }
   });
   //]]>
   </script>
   <!-- END switch_ticker_new -->

   <script type="text/javascript">
   //<![CDATA[
   $(document).ready(function(){
      <!-- BEGIN switch_enable_pm_popup -->
         pm = window.open('{U_PRIVATEMSGS_POPUP}', '_faprivmsg', 'HEIGHT=225,resizable=yes,WIDTH=400');
         pm.focus();
      <!-- END switch_enable_pm_popup -->
      <!-- BEGIN switch_report_popup -->
         report = window.open('{switch_report_popup.U_REPORT_POPUP}', '_phpbbreport', 'HEIGHT={switch_report_popup.S_HEIGHT},resizable=yes,scrollbars=no,WIDTH={switch_report_popup.S_WIDTH}');
         report.focus();
      <!-- END switch_report_popup -->
      <!-- BEGIN switch_ticker -->
         ticker_start({switch_ticker.HEIGHT}, {switch_ticker.SPACING}, {switch_ticker.SPEED}, '{switch_ticker.DIRECTION}', {switch_ticker.STOP_TIME});
      <!-- END switch_ticker -->
   });

   <!-- BEGIN switch_login_popup -->
      var logInPopUpLeft, logInPopUpTop, logInPopUpWidth = {LOGIN_POPUP_WIDTH}, logInPopUpHeight = {LOGIN_POPUP_HEIGHT}, logInBackgroundResize = false, logInBackgroundClass = false;
   <!-- END switch_login_popup -->
   //]]>
   </script>

   {GREETING_POPUP}
   <!-- BEGIN hitskin_preview -->
   <style type="text/css">
   #hitskin_preview {
      margin: 0; padding: 0;
      position: fixed;
      top: 0; left: 0;
      width: 100%;
      height: 65px;
      background: url('http://illiweb.com/fa/hitskin/hitskin_bar.png') repeat-x left -15px;
      color: #fff;
   }
   * html #hitskin_preview { /* Fix for IE6 since it doesn't implement fixed positionning */
      position: absolute;
      top:expression(eval(document.compatMode && document.compatMode=='CSS1Compat') ? documentElement.scrollTop : document.body.scrollTop);
      z-index: 2;
      background: transparent url('http://illiweb.com/fa/hitskin/hitskin_bar-ie6.gif') repeat-x left -15px;
   }
   * html { /* Gunlaug's Speed fix for the above positionning fix. Sorry for the fix for the fix */
    background: #fff url(foo) fixed;
    }
   #hitskin_preview h1 {
      float: left;
      margin: 3px 0 0 0;
      padding: 0 0 0 10px;
      font: italic normal 25px Arial,sans serif;
      color: #fff;
   }
   #hitskin_preview h1 img {
      vertical-align: middle;
   }
   #hitskin_preview em {
      color: #7CBA2C;
      font-weight: bold;
   }
   #hitskin_preview a {
   color: #fff;
   }
   #hitskin_preview a:hover {
   text-decoration: underline;
   }

   #hitskin_preview .content {
      text-align: right;
   }
   #hitskin_preview .content p {
      margin: 4px 1em 0px 1em;
      font-size: 13px;
      line-height: 1.8em;
      color: #fff;
      font-weight: bold;
   }
   #hitskin_preview .content p span {
      font-weight: normal;
      font-size: 0.8em;
   }
   body {
      margin-top: 40px !important;
   }
   {hitskin_preview.HITSKIN_RTL_CSS}
   </style>
   <!-- END hitskin_preview -->

   <!-- BEGIN switch_ticker_new -->
   <style>
   .jcarousel-skin-tango .jcarousel-item {
       text-align:center;
       width: 10px;
   }

   .jcarousel-skin-tango .jcarousel-item-horizontal {
       margin-right: {switch_ticker.SPACING}px;
   }

   .jcarousel-skin-tango .jcarousel-item-vertical {
       margin-bottom: {switch_ticker.SPACING}px;
   }
   </style>
   <!-- END switch_ticker_new -->





</head>
<body background="{T_BODY_BACKGROUND}" bgcolor="{T_BODY_BGCOLOR}" text="{T_BODY_TEXT}" link="{T_BODY_LINK}" vlink="{T_BODY_VLINK}">
   <!-- BEGIN hitskin_preview -->
   <div id="hitskin_preview" style="display: block;">
      <h1><img src="http://illiweb.com/fa/hitskin/hitskin_logo.png" alt="" /> Hit<em>skin</em>.com</h1>
      <div class="content">
         <p>
            {hitskin_preview.L_THEME_SITE_PREVIEW}
            <br />
            <span>{hitskin_preview.U_INSTALL_THEME}<a href="http://{hitskin_preview.U_RETURN_THEME}">{hitskin_preview.L_RETURN_THEME}</a></span>
         </p>
      </div>
   </div>
   <!-- END hitskin_preview -->

   <!-- BEGIN switch_login_popup -->
   <div id="login_popup">
      <table class="forumline" width="{LOGIN_POPUP_WIDTH}" height="{LOGIN_POPUP_HEIGHT}" border="0" cellspacing="1" cellpadding="0">
         <tr height="25">
            <td class="catLeft">
               <span class="genmed module-title">{SITENAME}</span>
            </td>
         </tr>
         <tr height="{LOGIN_POPUP_MSG_HEIGHT}">
            <td class="row1" align="left" valign="top">
               <div id="login_popup_buttons">
                  <form action="{S_LOGIN_ACTION}" method="get">
                     <input type="submit" class="mainoption" value="{L_LOGIN}" />
                     <input type="button" class="mainoption" value="{L_REGISTER}" onclick="parent.location='{U_REGISTER}';" />
                     <input id="login_popup_close" type="button" class="button" value="{L_DONT_DISPLAY_AGAIN}" />
                  </form>
               </div>
               <span class="genmed">{LOGIN_POPUP_MSG}</span>
            </td>
         </tr>
      </table>
   </div>
   <!-- END switch_login_popup -->

   <div id="id_banniere"></div>
<a name="top"></a>
  {JAVASCRIPT}
   <table class="bodylinewidth" width="{T_BODY_TABLE_WIDTH}" cellspacing="0" cellpadding="10" border="0" align="center">
      <tr>
         <td class="bodyline">
            <table width="100%" cellspacing="0" cellpadding="0" border="0">
               <tr>
                  <!-- BEGIN switch_logo_left -->
                  <td><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a></td>
                  <td align="center" width="100%" valign="middle">
                     <div class="maintitle">{MAIN_SITENAME}</div>
                     <br />
                     <span class="gen">{SITE_DESCRIPTION}<br />&nbsp; </span>
                  </td>
                  <!-- END switch_logo_left -->

                  <!-- BEGIN switch_logo_center -->
                  <td align="center" width="100%" valign="middle">
                     <a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a><br />
                     <div class="maintitle">{MAIN_SITENAME}</div>
                     <br />
                     <span class="gen">{SITE_DESCRIPTION}</span>
                  </td>
                  <!-- END switch_logo_center -->

                  <!-- BEGIN switch_logo_right -->
                  <td align="center" width="100%" valign="middle">
                     <div class="maintitle">{MAIN_SITENAME}</div>
                     <br />
                     <span class="gen">{SITE_DESCRIPTION}<br />&nbsp; </span>
                  </td>
                  <td>
                     <a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a>
                  </td>
                  <!-- END switch_logo_right -->
               </tr>
            </table>

            <table cellspacing="0" cellpadding="0" border="0" align="{MENU_POSITION}">
               <tr>
                  <td align="{MENU_POSITION}"{MENU_NOWRAP}>{GENERATED_NAV_BAR}</td>
               </tr>
            </table>

            <div style="clear: both;"></div>

            <!-- BEGIN switch_ticker_new -->
            <div id="fa_ticker_block" style="margin-top:4px;margin-bottom:4px;">
               <table width="100%" border="0" cellspacing="0" cellpadding="0" class="forumline">
                  <tr>
                     <td {CLASS_TABLE_TYPE} align="left" class="row1">
                        <div id="fa_ticker_container">
                           <ul id="fa_ticker_content"  class="jcarousel-skin-tango" style="display:none;">
                              <!-- BEGIN ticker_row -->
                              <li>{switch_ticker.ticker_row.ELEMENT}</li>
                              <!-- END ticker_row -->
                           </ul>
                        </div>
                     </td>
                  </tr>
               </table>
            </div>
            <!-- END switch_ticker_new -->

            <!-- BEGIN switch_ticker -->
            <div id="fa_ticker_block" style="margin-top:4px;margin-bottom:4px;">
               <table width="100%" border="0" cellspacing="0" cellpadding="0" class="forumline">
                  <tr>
                     <td {CLASS_TABLE_TYPE} align="left" class="row1">
                        <div id="fa_ticker_container">
                           <div id="fa_ticker" style="height:{switch_ticker.HEIGHT}px;">
                              <div class="fa_ticker_content">
                                 <!-- BEGIN ticker_row -->
                                 <div>{switch_ticker.ticker_row.ELEMENT}</div>
                                 <!-- END ticker_row -->
                              </div>
                           </div>
                        </div>
                     </td>
                  </tr>
               </table>
            </div>
            <!-- END switch_ticker -->

            <div id="page-body">
               <div id="{ID_CONTENT_CONTAINER}"{CLASS_CONTENT_CONTAINER}>
                  <table cellpadding="0" cellspacing="0" width="100%" class="three-col">
                     <tbody>
                        <tr>
                           <td valign="top" width="{C1SIZE}">
                              <div id="{ID_LEFT}">
                                 <!-- BEGIN giefmod_index1 -->
                                 {giefmod_index1.MODVAR}
                                    <!-- BEGIN saut -->
                                    <div style="height:{SPACE_ROW}px"></div>
                                    <!-- END saut -->
                                 <!-- END giefmod_index1 -->
                              </div>
                           </td>
                           <td valign="top" width="100%">
<!-- BEGIN html_validation -->
                           </td>
                        </tr>
                     </tbody>
                  </table>
               </div>
            </div>
         </td>
      </tr>
   </table>
</body>
</html>
<!-- END html_validation -->

Elorri
*

Messages : 35
Inscrit(e) le : 26/04/2009

http://ch3rry_@hotmail.fr
Elorri a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Chouquette~ le Lun 23 Aoû 2010 - 15:14

Avez-vous appliqué le template ? En cliquant sur la petite croix verte, à côté du rouage jaune ?

Chouquette~
*****

Masculin
Messages : 666
Inscrit(e) le : 15/07/2009

Chouquette~ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Elorri le Lun 23 Aoû 2010 - 15:14

Oui. =S

Elorri
*

Messages : 35
Inscrit(e) le : 26/04/2009

http://ch3rry_@hotmail.fr
Elorri a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Chouquette~ le Lun 23 Aoû 2010 - 15:20

Preuve à l'appui que ça fonctionne : http://lokkhy-design.forums-actifs.net/forum.htm?tt=1 ^^.

Sinon, avez-vous copiez tout le CSS ?
Dans le doute : dans la gestion des image, remplacez celle de fond par http://illiweb.com/fa/empty.gif
Et décochez "fond fixe" !


Dernière édition par Chouquette~ le Lun 23 Aoû 2010 - 15:24, édité 1 fois

Chouquette~
*****

Masculin
Messages : 666
Inscrit(e) le : 15/07/2009

Chouquette~ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Elorri le Lun 23 Aoû 2010 - 15:24

Oui j'ai copié tout le CSS. D'ailleurs, après enregistrement, j'ia la notion
" Erreur détectée
Nous avons compté un nombre différent de "{" et de "}". Cela signifie que votre CSS risque de ne pas être valide et ne sera pas affiché correctement sur votre forum.

Nous vous conseillons de relire votre code. "

Et avec http://illiweb.com/fa/empty.gif , ca ne change rien du tout. =S

Elorri
*

Messages : 35
Inscrit(e) le : 26/04/2009

http://ch3rry_@hotmail.fr
Elorri a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Chouquette~ le Lun 23 Aoû 2010 - 15:27

En effet !
Remplacez
Code:
#id_banniere{
    width:100%;
    height:600px;
    background-image:url('http://i35.servimg.com/u/f35/12/15/64/35/lesenf12.jpg');
    background-position:top center;
    background-repeat:no-repeat;

#i_logo{
    height:0px;
}
Par
Code:
#id_banniere{
    width:100%;
    height:600px;
    background-image:url('http://i35.servimg.com/u/f35/12/15/64/35/lesenf12.jpg');
    background-position:top center;
    background-repeat:no-repeat;}

#i_logo{
    height:0px;
}

;o)
Remplacez l'image et décochez "fond fixe" =)

C'est bizarre tout de même =)

Chouquette~
*****

Masculin
Messages : 666
Inscrit(e) le : 15/07/2009

Chouquette~ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Elorri le Lun 23 Aoû 2010 - 15:29

Ca ne marche toujours pas... =S

Elorri
*

Messages : 35
Inscrit(e) le : 26/04/2009

http://ch3rry_@hotmail.fr
Elorri a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Chouquette~ le Lun 23 Aoû 2010 - 15:31

    Oui j'ai vu xD, l'erreur vient toujours du même endroit ^^.

    Ajoutez un } juste après "background-repeat:no-repeat;".

    On va y arriver, on va y arriver ^^'

Chouquette~
*****

Masculin
Messages : 666
Inscrit(e) le : 15/07/2009

Chouquette~ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Elorri le Lun 23 Aoû 2010 - 15:32

Vraiment, je comprend pas ca ne marche toujours pas ! xD
Code:
body{
    background-image:url('http://i35.servimg.com/u/f35/12/15/64/35/patter12.png');
    background-repeat:repeat;}


#id_banniere{
    width:100%;
    height:600px;
    background-image:url('http://i35.servimg.com/u/f35/12/15/64/35/lesenf12.jpg');
    background-position:top center;
    background-repeat:no-repeat;}

#i_logo{
    height:0px;
}

Elorri
*

Messages : 35
Inscrit(e) le : 26/04/2009

http://ch3rry_@hotmail.fr
Elorri a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Chouquette~ le Lun 23 Aoû 2010 - 15:41

En effet, c'est vraiment étrange, d'autant plus que sur un forum de test, j'y arrive parfaitement =/.

Essayez à tout hasard :
Code:
#id_banniere{
    width:100%;
    height:600px;
    background-image:url('http://i35.servimg.com/u/f35/12/15/64/35/lesenf12.jpg');
    background-position:top center;
    background-repeat:no-repeat;}

#i_logo{
    height:0px;
}

body{
    background-image:url('http://i35.servimg.com/u/f35/12/15/64/35/patter12.png');
    background-repeat:repeat;}

Si ça ne marche pas :
Code:
#id_banniere{
    width:100%;
    height:600px;
    background-image:url('http://i35.servimg.com/u/f35/12/15/64/35/lesenf12.jpg');
    background-position:top center;
    background-repeat:no-repeat;}

#i_logo{
    height:0px;
}

body{
    background-image:url('http://i35.servimg.com/u/f35/12/15/64/35/patter12.png') !important;
    background-repeat:repeat !important;}

Chouquette~
*****

Masculin
Messages : 666
Inscrit(e) le : 15/07/2009

Chouquette~ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Elorri le Lun 23 Aoû 2010 - 15:44

Ca marche enfin !
Juste un dernier problème : en général, quand on clique sur le design, c'est un raccourci pour aller sur la PA, alors que là il n'y a plus rien. Est-ce normal ? Smile

Elorri
*

Messages : 35
Inscrit(e) le : 26/04/2009

http://ch3rry_@hotmail.fr
Elorri a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Chouquette~ le Lun 23 Aoû 2010 - 15:47

    Explication : Il y avait visiblement conflit entre le CSS de base, et celui de la fiche de CSS ... Bizarre mais bon.

    Si vous parlez de la bannière en effet ce n'est plus un raccourci pour revenir à l'accueil.
    Mais on peut essayer de s'arranger pour qu'elle le redevienne ;o).

    Quand à l'accès au PA, il se fait via le lien en bas de pas, comme toujours ^^'.

Chouquette~
*****

Masculin
Messages : 666
Inscrit(e) le : 15/07/2009

Chouquette~ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Elorri le Lun 23 Aoû 2010 - 15:49

En fin de comtpe, ca ira comme ça, c'est pas si génant ^^
Merci beaucoup de votre aide ^_^

Elorri
*

Messages : 35
Inscrit(e) le : 26/04/2009

http://ch3rry_@hotmail.fr
Elorri a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment mettre une texture en fond de forum ?

Message par Chouquette~ le Lun 23 Aoû 2010 - 15:51

    De rien ;D, ce fut laborieux Confused, des fois la réaction entre les template et le CSS est bizarre Confused.

    'Fin, ce qui compte c'est le résultat dirons-nous ;o).
    Bonne continuation ;o).

Chouquette~
*****

Masculin
Messages : 666
Inscrit(e) le : 15/07/2009

Chouquette~ a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum