Problèmes les posts se mettent en "escalier"

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problèmes les posts se mettent en "escalier"

Message par Lii-aa le Mer 25 Aoû 2010 - 13:03

Bonjour,

Je ne comprend pas, depuis le bug d'hier, pas mal de post sur mon forum se mettent ''en escalier'', comme ceci :




J'ai réactualisé tous mes templates, mais rien n'y fait...
Merci d'avance de votre aide ♥

Lii-aa


Dernière édition par Lii-aa le Jeu 26 Aoû 2010 - 11:00, édité 1 fois
avatar

Lii-aa
***

Féminin
Messages : 110
Inscrit(e) le : 25/07/2009

http://www.ut-austin.org/
Lii-aa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes les posts se mettent en "escalier"

Message par Ea le Mer 25 Aoû 2010 - 14:05

Bonjour,


Il doit y avoir des problèmes d'ouverture et fermeture des balises, si je prend un post le code en le ré-indentant donne :

Code:
<tr class="post">
  <td class="row2" valign="top" width="150">
    <div style="font-size:9px;">
      <div class="cadreava">
        <span class="name">
        <a name="14943">
        </a>
        </span>
        <center>
          <font size="4">
            <SPAN style="FONT-FAMILY: futura hv">
            <a href="/profile.forum?mode=viewprofile&amp;u=125">
              Emylee H. Clarkton
            </a>
            </SPAN>
          </font>
          <br />
          <font size="3">
            <font color="#FFFFFF">
              •••••••••••••••••••
            </font>
          </font>
          <br />
          <font color="#FFFFFF">
          </font>
        </center>
        <br />
        <div align="center">
          <span class="postdetails poster-profile">
          <a href="/profile.forum?mode=viewprofile&amp;u=125">
            <img src="http://img411.imageshack.us/img411/2292/kstew31.png" alt="" />
          </a>
        </div>
        <div align="top center">
        </div>
      </div>
      <br /><br />
      <div onclick="this.firstChild.src=(this.lastChild.style.display=='none')?'http://img831.imageshack.us/img831/6999/openclosethelife.png':'http://img839.imageshack.us/img839/1179/openopenthelife.png';this.lastChild.style.display=(this.lastChild.style.display=='block')?'none':'block';">
        <img src="http://img839.imageshack.us/img839/1179/openopenthelife.png" />
        <div style="display: none;">
          <div class="profilentour">
            <span class="postdetails poster-class=" profilentour"="1"><span class="postdetails poster-profile"><span style="white-space:nowrap;"><span style="color:#E3B2A7;">■ ici depuis le</span>: </span> 17/08/2010<br /><span style="white-space:nowrap;"><span style="color:#E3B2A7;">■ messages</span>: </span> 2<br /><span style="white-space:nowrap;"><span style="color:#E3B2A7;">■ multicomptes</span>: </span> NON<br /><span style="white-space:nowrap;"><span style="color:#E3B2A7;">■ photoshoot</span>: </span>
            <img src="http://static.v41.skyrock.com/img/avatars/default.png" alt="" title="" />
            <hr />
            <center>
            </center>
            </span>
          </div>
        </div>
      </div>
      </span><br /><br />
      <img src="http://illiweb.com/fa/vide.gif" alt="" style="width: 150px; height: 1px;" />
    </td>
  </td>
  <td class="row2" valign="top" width="100%" height="28" colspan="2">
    <table width="100%" border="0" cellspacing="0" cellpadding="0">
      <tr>
        <td>
          <span class="postdetails"><img src="http://illiweb.com/fa/prosilver/icon_post_target.gif" alt="Message" title="Message" border="0" />Sujet: Re: Emylee cherche un titre &amp;Underco&nbsp; &nbsp;<img src="http://illiweb.com/fa/empty.gif" alt="" border="0" />Mar 17 Aoû - 7:50</span>
        </td>
        <td valign="top" nowrap="nowrap" class="post-options">
          <a href="/post.forum?mode=quote&amp;p=14943">
            <img src="http://illiweb.com/fa/subsilver/icon_quote_fr.gif" class="i_icon_quote" alt="Répondre en citant" title="Répondre en citant" />
          </a>
        </td>
      </tr>
      <tr>
        <td colspan="2" class="hr">
          <hr />
        </td>
      </tr>
      <tr>
        <td colspan="2">
          <span class="postbody">          <!--
          google_ad_section_start -->
          <ul>
            <br />Bonjour (:<br />Pourrait-on me réserver Kristen Stewart s'il vous plait?
          </ul>
          <!--
          google_ad_section_end --></span><span class="gensmall"></span>
        </td>
      </tr>
    </table>
  </td>
</tr>
<tr>
  <td class="row2 browse-arrows" align="center" valign="middle" width="150">
    <a href="#top">
      <img src="http://illiweb.com/fa/prosilver/arrow_up.gif" alt="Revenir en haut" />
    </a>
    &nbsp;
    <a href="#bottom">
      <img src="http://illiweb.com/fa/prosilver/arrow_down.gif" alt="Aller en bas" />
    </a>
  </td>
  <td class="row2 messaging gensmall" width="100%" height="28">
    <table border="0" cellspacing="0" cellpadding="0">
      <tr>
        <td valign="middle">
          <a href="/profile.forum?mode=viewprofile&amp;u=125" class="profile-icon" title="Voir le profil de l'utilisateur">
            <img src="http://illiweb.com/fa/subsilver/icon_profile_fr.gif" class="i_icon_profile" alt="Voir le profil de l'utilisateur" />
          </a>
          <a href="/msg.forum?mode=post&amp;u=125" class="profile-icon" title="Envoyer un message privé">
            <img src="http://illiweb.com/fa/subsilver/icon_pm.gif" class="i_icon_pm" alt="Envoyer un message privé" />
          </a>
        </td>
      </tr>
    </table>
  </td>
</tr>
Et si je regarde en vitesse le nombre de balise il y a 9 <td>, 10 </td>, 6 </div>, 7 <div>, 16 <span> et 15 </span>.

Donc il y a un </td> de fermeture de trop ( ou un <td> d'ouverture de pas assez ), 1 </div> de fermeture de trop peu ( ou un <div> d'ouverture de trop ) et un <span> d'ouverture de trop ( ou un </span de fermeture de trop peu ).

Cordialement.
avatar

Ea
Aidactif
Aidactif

Messages : 23476
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes les posts se mettent en "escalier"

Message par Lii-aa le Mer 25 Aoû 2010 - 19:03

Bonjour,

Merci beaucoup de votre aide, mais ou dois-je modifier celà ? Dans un template ? De plus, celà ne me le fait que dans certains posts, donc je ne comprends pas trop...

Merci d'avance.
avatar

Lii-aa
***

Féminin
Messages : 110
Inscrit(e) le : 25/07/2009

http://www.ut-austin.org/
Lii-aa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes les posts se mettent en "escalier"

Message par Ea le Jeu 26 Aoû 2010 - 4:36

Et bien je peux regarder la template viewtopic_body ( une erreur ne peut venir que de là ) et voir d'où vient l'erreur ^^

Cordialement.
avatar

Ea
Aidactif
Aidactif

Messages : 23476
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes les posts se mettent en "escalier"

Message par ge80 le Jeu 26 Aoû 2010 - 7:29

Bonjour

En plus de votre template, regardez la signature du membre qui provoque le premier décalage.
Après le bugue , plusieurs personnes ont eu des signature qui provoquaient exactement la même choses que vous.

Essayez de "dévalider" sa signature et regardez le résultat.

Cordialement
ge
avatar

ge80
Membre actif

Masculin
Messages : 16159
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes les posts se mettent en "escalier"

Message par Lii-aa le Jeu 26 Aoû 2010 - 11:00

J'ai d'abord regardé la signature de cette administratrice, et c'est exactement ça qui causait le soucis. Merci beaucoup de votre aide à tous les deux, le soucis est réglé. Il sufisait de retirer un élement de la signature du membre.

RESOLU
avatar

Lii-aa
***

Féminin
Messages : 110
Inscrit(e) le : 25/07/2009

http://www.ut-austin.org/
Lii-aa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes les posts se mettent en "escalier"

Message par ge80 le Jeu 26 Aoû 2010 - 11:02

C'est donc un problème dépendant du bogue de l'autre jour.

Il faut re-contrôler sa signature.

Bonne journée
avatar

ge80
Membre actif

Masculin
Messages : 16159
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes les posts se mettent en "escalier"

Message par Steakhache le Jeu 26 Aoû 2010 - 12:45

Moi je n'y connais rien mais voilà ^^

Steakhache
Nouveau membre

Messages : 1
Inscrit(e) le : 26/08/2010

http://www.mu-intensity.fr/parrain-Steakhache
Steakhache a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum