Un bug dans mon forum O_o

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 1:56

Bien voilà je vais expliqué du mieux que je peux avec des images et tout.

Dans mon panneau d'admin dans Structur et Hiearchi J'ai coché comme ceci



et sur mon forum sa donne sa :
ce n'est pas du tout ce que c'est supposer donné pour la hiearchie je ne comprends pas pourquoi sa fait sa alors je demande votre aide, une amie a dis que c'est bug peut-être dans mes templates ?!? Et aussi si vous voyez bien le sujet message de la première catégorie n'est pas en haut centrer comme les autres ?!?! comment je peux arranger sa ?!? merci beaucoup bonne soirée


Dernière édition par soleillevant le Lun 20 Sep 2010 - 6:07, édité 1 fois

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par Neptunia le Lun 20 Sep 2010 - 1:58

Bonsoir,

Serait il possible d'avoir l'adresse de votre forum ??

Neptunia
+ Hyperactif +

Féminin
Messages : 10939
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 2:13

Oui ne fai surtout pas attention au design mdr surtout le qui est en ligne c'est un de mes fofo que j'ai pris le template et j'ai pas encore mis la bonne image... :S http://d-grayman.forums-actifs.net/forum.htm Merci de ton aide Smile

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par Neptunia le Lun 20 Sep 2010 - 2:33

Pourriez vous nous fournir entre balises {code} le contenu de votre feuille css. Il y a un problème de déclaration des images de fond dans le source de votre page d'accueil.

► Panneau Admin
► Onglet Affichage
► Menu Images et Couleurs ► Couleurs
Onglet Feuille de style CSS

J'ai trouvé déjà ceci d'anormal.
Code:
background-image: url("haut.gif");
background-position: top center;
background-repeat: no-repeat;
background-color: #4c1111;
color: #ffffff;
}
.boitebas{
background-image: url("bas.gif");
background-position: bottom left;
background-repeat: no-repeat;
padding: 5px 5px 5px 5px;
}
Les url sont censées commencer par http:// !

Sinon, avez vous un/des template(s) modifiés ? Si oui lesquels.

Edit : En fait tout votre css est à revoir, on vous a fourni un canevas où il faut désormais remplacer les commentaires par les valeurs dont vous avez besoin.

Neptunia
+ Hyperactif +

Féminin
Messages : 10939
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 3:14

zut j'ai retravaille mon css et j'ai tout effacer O_o et le problème est encore la

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par Neptunia le Lun 20 Sep 2010 - 3:28

Vous n'avez rien effacé à priori.
J'ai exactement la même chose que tout à l'heure au niveau du code source.

Neptunia
+ Hyperactif +

Féminin
Messages : 10939
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 3:30

aH oui pourtant j'ai plus de code :S j'ai rien que cela
Qui est en ligne

Code:
 .statistiques{
border:0px;
background-image: url("http://i305.photobucket.com/albums/nn203/Aline1987/queel.png");
background-repeat: no-repeat;
background-position: center;
height:270px;}

.groupes{
background-color:#FFFFFF;border: 1px #D0D0D0 dotted;
-moz-border-radius : 5px 5px 5px 5px;
height:40px;padding-right:12px;padding-left:14px;padding-bottom:3px;
font-size:15px;font-weight: bold;text-align:center;
text-decoration: none !important;}
comme code en plus ce n'est pas le bon code que je voulais pour le queel je voulais mettre une autre image mais je ne trouve pas ou le mettre :S merci beaucoup edit je voudrais mettre cette image la http://i305.photobucket.com/albums/nn203/Aline1987/queel.png

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par Neptunia le Lun 20 Sep 2010 - 3:38

Je vais vous montrer ce à quoi j'ai droit en analysant voytre page d'accueil !

Attention, il ne s'agit pas de ce qui apparait dans le panneau admin au niveau de la feuille css, mais du css global de votre forum !

Message édité par l'auteur pour cause de redondance.


Dernière édition par AoF-Neptune le Lun 20 Sep 2010 - 3:53, édité 1 fois

Neptunia
+ Hyperactif +

Féminin
Messages : 10939
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 3:40

est-ce qu'est-ce qui pourrait être le problème ? :S
Code:
 Lien


 a:hover {
text-decoration: none !important;
}


Autre


a.forumlink:link, a.forumlink:visited {
font-family: georgia;
text-transform : uppercase;
text-align: center;
font-size: 100%;
border-bottom: 5px solid #couleur;
color: #couleur;
letter-spacing: 1px;
display: block;
-moz-border-radius:10px;
}


a.forumlink:hover, a.forumlink:hover:visited {
background-image: url("url de votre image");
color: #couleur;
text-align: center;
display: block;
border-bottom: 5px solid #couleur;
-moz-border-radius:10px;
}



table.bodylinewidth
{
position: relative;
top: -9px;
}

table.bodylinewidth
{
position: relative;
bottom: -9px;
}

texte

a.forumlink {
text-decoration: none;
background-color: #COULEUR DU FOND;
border-bottom: 2px double #COULEUR DU CADRE DU BAS;
border-top: 2px double #COULEUR DU CADRE DU HAUT;
-moz-border-radius: 10px ;
border-right: 5px solid #COULEUR DU CADRE A DROITE;
-moz-border-radius: 10px ;
border-left: 5px solid #COULEUR DU CADRE A GAUCHE;
display:block;

}
a.forumlink:hover {
text-decoration: none;
background-color: #COULEUR DU FOND AVEC LA SOURIS;
border-bottom:2px double #COULEUR DU CADRE DU BAS AVEC LA SOURIS;
border-top: 2px double #COULEUR DU CADRE DU HAUT AVEC LA SOURIS;
-moz-border-radius: 10px ;
border-right: 5px solid #COULEUR DU CADRE A DROITE AVEC LA SOURIS;
-moz-border-radius: 10px ;
border-left: 5px solid #COULEUR DU CADRE A GAUCHE AVEC LA SOURIS;
display:block;
}


a { text-decoration: none; }


.blur{
background-color: #ccc; /*shadow color*/
color: inherit;
margin-left: 4px;
margin-top: 4px;
}

.shadow,
.content{
position: relative;
bottom: 2px;
right: 2px;
}

.shadow{
background-color: #666; /*shadow color*/
color: inherit;
}

.content{
background-color: #fff; /*background color of content*/
color: #000; /*text color of content*/
border: 1px solid #000; /*border color*/
padding: .5em 2ex;
}

avatar

.postdetails.poster-profile a img {
-moz-border-radius-bottomleft:10px;
-moz-border-radius-bottomright:10px;
-moz-border-radius-topleft:10px;
-moz-border-radius-topright:10px;
border: 5px solid #COULEUR DU CONTOUR;
}



.mainmenu{
    font-size : 15px;
    color : #121111;
        }

a.mainmenu{
    text-decoration: none;
    color : #5E5D5D;
        background-color: #121111;
        border-bottom: 1px solid #5f4037;
filter:alpha(opacity=50);
-moz-opacity:0.5;opacity: 0.5;
}

a.mainmenu:hover{
    text-decoration:none; color : #5f4037;
    background-color : #121111;         
 border-bottom: 1px solid;
 color : #5f4037; 
filter:alpha(opacity=100);
-moz-opacity:0.5;opacity: 1;
  }

Qui est en ligne

 .statistiques{
border:0px;
background-image: url("LIEN IMAGE DU HAUT");
background-repeat: no-repeat;
background-position: center;
height:270px;}

.groupes{
background-color:#FFFFFF;border: 1px #D0D0D0 dotted;
-moz-border-radius : 5px 5px 5px 5px;
height:40px;padding-right:12px;padding-left:14px;padding-bottom:3px;
font-size:15px;font-weight: bold;text-align:center;
text-decoration: none !important;}

c'est le code que j'avais Smile

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par Neptunia le Lun 20 Sep 2010 - 3:50

Bon j'aurais au moins appris un truc cette nuit.

Votre css perso devait correspondre à cela avant que vous le l'effaciez.

Code:
.boitehaut{
width: 600px;
background-image: url("haut.gif");
background-position: top center;
background-repeat: no-repeat;
background-color: #4c1111;
color: #ffffff;
}
.boitebas{
background-image: url("bas.gif");
background-position: bottom left;
background-repeat: no-repeat;
padding: 5px 5px 5px 5px;
}


 Lien


 a:hover {
text-decoration: none !important;
}


Autre


a.forumlink:link, a.forumlink:visited {
font-family: georgia;
text-transform : uppercase;
text-align: center;
font-size: 100%;
border-bottom: 5px solid #couleur;
color: #couleur;
letter-spacing: 1px;
display: block;
-moz-border-radius:10px;
}


a.forumlink:hover, a.forumlink:hover:visited {
background-image: url("url de votre image");
color: #couleur;
text-align: center;
display: block;
border-bottom: 5px solid #couleur;
-moz-border-radius:10px;
}



table.bodylinewidth
{
position: relative;
top: -9px;
}

table.bodylinewidth
{
position: relative;
bottom: -9px;
}

texte

a.forumlink {
text-decoration: none;
background-color: #COULEUR DU FOND;
border-bottom: 2px double #COULEUR DU CADRE DU BAS;
border-top: 2px double #COULEUR DU CADRE DU HAUT;
-moz-border-radius: 10px ;
border-right: 5px solid #COULEUR DU CADRE A DROITE;
-moz-border-radius: 10px ;
border-left: 5px solid #COULEUR DU CADRE A GAUCHE;
display:block;

}
a.forumlink:hover {
text-decoration: none;
background-color: #COULEUR DU FOND AVEC LA SOURIS;
border-bottom:2px double #COULEUR DU CADRE DU BAS AVEC LA SOURIS;
border-top: 2px double #COULEUR DU CADRE DU HAUT AVEC LA SOURIS;
-moz-border-radius: 10px ;
border-right: 5px solid #COULEUR DU CADRE A DROITE AVEC LA SOURIS;
-moz-border-radius: 10px ;
border-left: 5px solid #COULEUR DU CADRE A GAUCHE AVEC LA SOURIS;
display:block;
}


a { text-decoration: none; }


.blur{
background-color: #ccc; /*shadow color*/
color: inherit;
margin-left: 4px;
margin-top: 4px;
}

.shadow,
.content{
position: relative;
bottom: 2px;
right: 2px;
}

.shadow{
background-color: #666; /*shadow color*/
color: inherit;
}

.content{
background-color: #fff; /*background color of content*/
color: #000; /*text color of content*/
border: 1px solid #000; /*border color*/
padding: .5em 2ex;
}

avatar

.postdetails.poster-profile a img {
-moz-border-radius-bottomleft:10px;
-moz-border-radius-bottomright:10px;
-moz-border-radius-topleft:10px;
-moz-border-radius-topright:10px;
border: 5px solid #COULEUR DU CONTOUR;
}



.mainmenu{
    font-size : 15px;
    color : #121111;
        }

a.mainmenu{
    text-decoration: none;
    color : #5E5D5D;
        background-color: #121111;
        border-bottom: 1px solid #5f4037;
filter:alpha(opacity=50);
-moz-opacity:0.5;opacity: 0.5;
}

a.mainmenu:hover{
    text-decoration:none; color : #5f4037;
    background-color : #121111;         
 border-bottom: 1px solid;
 color : #5f4037; 
filter:alpha(opacity=100);
-moz-opacity:0.5;opacity: 1;
  }

Qui est en ligne

 .statistiques{
border:0px;
background-image: url("LIEN IMAGE DU HAUT");
background-repeat: no-repeat;
background-position: center;
height:270px;}

.groupes{
background-color:#FFFFFF;border: 1px #D0D0D0 dotted;
-moz-border-radius : 5px 5px 5px 5px;
height:40px;padding-right:12px;padding-left:14px;padding-bottom:3px;
font-size:15px;font-weight: bold;text-align:center;
text-decoration: none !important;}

Edit : Le mien comporte deux chapitres de plus en haut !

Neptunia
+ Hyperactif +

Féminin
Messages : 10939
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 3:53

Je l'ai remis le code au complet dans ma feuille et voilà en voyant les images en haut je voudrais que la hiearchie soit moyen comme j'ai coche mais celle ci ne le montre pas comme habituel :S est-ce que c'est toujours le code le problème ?!? Merci

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par Neptunia le Lun 20 Sep 2010 - 4:00

Soyons directs 2 ou 3 minutes !

Ce n'est pas vous qui avez "pondu" ce css ??
On vous l'a fourni comme modèle mais tout est à compléter pour qu'il fonctionne !

Juste à titre d'exemple :
Code:
a.forumlink:hover, a.forumlink:hover:visited {
background-image: url("url de votre image");
color: #couleur;
text-align: center;
display: block;
border-bottom: 5px solid #couleur;
-moz-border-radius:10px;
}

La ligne background-image demande une url et cette url n'est certainement pas url de votre image
La ligne border-bottom exige quant à elle un code couleur en hexadécimal
donc #couleur est à remplacer par quelque chose ressemblant à #012345

Neptunia
+ Hyperactif +

Féminin
Messages : 10939
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 4:06

salut alors j'ai mis le lien de mon image et une couleur mais il me semble que rien change O_o c'est étrange...

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par Neptunia le Lun 20 Sep 2010 - 4:21

Je n'ai donné que ces deux exemples, c'est la quasi totalité du css qui est à revoir.

Le mieux serait peut-être de demander l'assistance de la personne qui vous a fourni ce code Wink

Neptunia
+ Hyperactif +

Féminin
Messages : 10939
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 4:26

Oki mais pour ce qui est de la hiearchie de la structure du forum c'est quoi le problème ce ne serait peut-être pas le css il n'ont aucun rapport :S avec la hiearchi

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par Neptunia le Lun 20 Sep 2010 - 4:28

Je pense qu'avec toutes les erreurs contenues dans votre css tout devient possible.

Essayez de supprimer complètement votre css pour vérifier !

Edit : Je viens d'appliquer votre css perso sur un forum test, et pas de problème quant à la compression de l'index.
Cela dit si la personne qui vous a fourni le css est la même que pour le reste, il y a fort à parier que les templates seront à éplucher également.


Dernière édition par AoF-Neptune le Lun 20 Sep 2010 - 4:40, édité 1 fois

Neptunia
+ Hyperactif +

Féminin
Messages : 10939
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 4:37

cela n'arrange rien c'est peut-être dans le template :S

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par Neptunia le Lun 20 Sep 2010 - 4:40

On s'est croisé, j'ai édité mon dernier message.

Neptunia
+ Hyperactif +

Féminin
Messages : 10939
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 4:43

La seule choses a faire est de refaire tout a zéro je crois :S est-ce qu'il y a une manière de le faire sans en supprimé le forum ?

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par Neptunia le Lun 20 Sep 2010 - 4:49

Vous supprimez tous les templates modifiés et publiés.
Ou bien vous passez par les outils du fondateur pour revenir en arrière.

Voici le tutoriel Outils réservés au Fondateur.
Voici le tutoriel Le Back-up mode d'emploi.

Neptunia
+ Hyperactif +

Féminin
Messages : 10939
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 4:55

j'ai essayé de rentrer avec mon lien de forum et ou mon e-mail rien ne fonctionne pour l'outils réservés au fondateur ?

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par Neptunia le Lun 20 Sep 2010 - 4:57

Vous êtes bien la fondatrice du forum "D.gray Man Univers" ??

Neptunia
+ Hyperactif +

Féminin
Messages : 10939
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 5:01

Oui je le suis et sa fonctionner Smile mais le problème n'est pas résolu :S il a retourné seulement le design et la hiearchie n'a pas été corriger :S

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par Neptunia le Lun 20 Sep 2010 - 5:05

Avez vous regardé si des templates sont modifiés ??

Neptunia
+ Hyperactif +

Féminin
Messages : 10939
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 5:17

j'ai arrangé j'ai changé les templates mais je sais peut-être quel est l'erreur, sa fait longtemps que j'ai pas touchez au catégorie et sous forum mdr alors que mon forum la http://cafepub.forum-canada.net a les catégorie parfaite et c'est comme sa que je voudrais avoir mes catégorie et sous-forum mais c'est que mon forum me laisse pas les faire ?!? qu'elle est l'erreur je ne sais pas :S

edit : Je voulais te remercier aussi pour ta patience et ton aide que tu m'apporte Smile

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par Neptunia le Lun 20 Sep 2010 - 5:26

Le mieux serait alors de faire un copier-coller de tous les templates modifiés de Café Pub vers D.gray Man Univers.
La même chose pour le css personnalisé.
Ensuite ne restera plus qu'à modifier les images et couleurs.

Neptunia
+ Hyperactif +

Féminin
Messages : 10939
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 5:31

Je vais laisser ce poste ouvert en cas si j'obtient un autre problème et je te remercie beaucoup pour ton aide ^^ c'est ce que je vais faire Smile

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un bug dans mon forum O_o

Message par soleillevant le Lun 20 Sep 2010 - 6:08

Je voulais dire merci a neptune pour son aide et sa patience le problème est règlé Smile

soleillevant
*****

Féminin
Messages : 608
Inscrit(e) le : 28/12/2007

soleillevant a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum