Problèmes d'onglets

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problèmes d'onglets

Message par Poupou le Lun 8 Nov 2010 - 19:42

Bonsoir !

Voilà mon petit problème. Jai créé un tableau avec des onglets. Le premier onglet contient une simple image mais elle ne saffiche pas du premier coup. On est obligé de cliquer sur un autre onglet, puis de revenir sur le premier et là elle s'affiche, mais elle sort du cadre. Voyez plutot:

IcI

Comment faire pour que l'image s'affiche de suite et bien cadrée ?

Mon code html :

Code:
<script src="http://sd-2.archive-host.com/membres/up/113965783930418818/codagepa.js"></script><div id="mes_onglets">
    <ul><li id="o_1" class="mon_onglet_selected" onclick="changeOnglet(this);">Accueil</li>
        <li id="o_2" class="mon_onglet" onclick="changeOnglet(this);">Staff & Liens</li>
        <li id="o_3" class="mon_onglet" onclick="changeOnglet(this);">Infos Forum</li>
        <li id="o_4" class="mon_onglet" onclick="changeOnglet(this);">Amis & Top Sites</li>
        <div class="clear"><div id="mes_contenus">
    <div id="co_1" class="mon_contenu" style="display: none;"><center><img src="http://i66.servimg.com/u/f66/15/46/47/34/pa_bmp10.jpg"></center></div>
    <div id="co_2" class="mon_contenu" style="display: none;"><u>TEXTE</u><br>
<br><table style="width: 100%" border="0">
  <tr>
      <td><center><img src="http://i28.servimg.com/u/f28/13/88/52/00/staff_10.jpg"></center><br>
<br></td>
      <td><center><img src="http://i28.servimg.com/u/f28/13/88/52/00/liens_10.jpg"></center></td>
  </tr>
</table></div>
    <div id="co_3" class="mon_contenu" style="display: none;"><table border="0" cellspacing="0" cols="6" frame="void" rules="all">
  <colgroup><col width="133"><col width="133"><col
 width="133"><col width="133"><col width="133"><col
 width="133"></colgroup> <tbody>
    <tr>
      <td style="border: 0px solid black; text-align: center;" colspan="4" rowspan="3" height="190">
<br><img src="http://i28.servimg.com/u/f28/13/88/52/00/news_b11.jpg">
<br><marquee onmouseout="this.start();" onmouseover="this.stop();" loop="infinite" scrolldelay="2" scrollamount="2" direction="up" behavior="slide"><img src="http://i24.servimg.com/u/f24/15/74/75/68/bt-nw010.gif"> <u>Ouverture du Forum</u> ( 00/00/00 )<br>
<br>Je déclare le forum officiellement OUVERT ! Après des semaines de dur acharnement et de boulot, il est fin prêt à vous accueillir à sabots ouverts, muhaha ! Pensez à bien lire le règlement, et si vous avez la moindre question, n'hésitez pas à me contacter !<br>

<br><img src="http://i24.servimg.com/u/f24/15/74/75/68/bt-nw010.gif"> <u>Prochaine news prochainement =P</u> ( 00/00/00 )</marquee></td>
      <td colspan="2" style="border: 0px solid transparent; text-align: center;"><img src="http://i28.servimg.com/u/f28/13/88/52/00/meteo_10.jpg"></td>
    </tr>
    <tr>
      <td style="border: 0px solid black; text-align: center;" colspan="2">
<img src="http://i28.servimg.com/u/f28/13/88/52/00/autumn10.jpg"></td>
    </tr>
    <tr>
      <td style="border: 0px solid black; text-align: center;" colspan="2">
<IMG SRC="http://i28.servimg.com/u/f28/13/88/52/00/soleil10.jpg"></td>
    </tr>
    <tr>
      <td style="border: 0px solid black; text-align: center;" colspan="3" height="20">
<IMG SRC="http://i26.servimg.com/u/f26/15/46/47/34/date_b10.jpg"></td>
      <td style="border: 0px solid black; text-align: center;" colspan="3">
<IMG SRC="http://i28.servimg.com/u/f28/13/88/52/00/chaleu10.jpg"></td>
    </tr>
  </tbody>
</table></div>
    <div id="co_4" class="mon_contenu" style="display: none;">Mon contenu 4</div>
</div></ul>


Merci =)


Dernière édition par Poupou le Lun 15 Nov 2010 - 18:22, édité 1 fois

Poupou
*

Messages : 33
Inscrit(e) le : 19/08/2010

http://g-e-v.lebonforum.com/
Poupou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes d'onglets

Message par Poupou le Mar 9 Nov 2010 - 7:52

Up sil vous plait !

Poupou
*

Messages : 33
Inscrit(e) le : 19/08/2010

http://g-e-v.lebonforum.com/
Poupou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes d'onglets

Message par Poupou le Mer 10 Nov 2010 - 1:34

Svp ..

Poupou
*

Messages : 33
Inscrit(e) le : 19/08/2010

http://g-e-v.lebonforum.com/
Poupou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes d'onglets

Message par Poupou le Jeu 11 Nov 2010 - 10:33

Up !

Poupou
*

Messages : 33
Inscrit(e) le : 19/08/2010

http://g-e-v.lebonforum.com/
Poupou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes d'onglets

Message par Poupou le Dim 14 Nov 2010 - 21:40

personne pour m'aider ??

Poupou
*

Messages : 33
Inscrit(e) le : 19/08/2010

http://g-e-v.lebonforum.com/
Poupou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes d'onglets

Message par Anzu le Dim 14 Nov 2010 - 22:05


Bonsoir,

C'est possible d'avoir votre css ?

Cordialement.

Anzu
+ Hyperactif +

Féminin
Messages : 20685
Inscrit(e) le : 30/08/2007

http://forum.forumactif.com/forum
Anzu a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes d'onglets

Message par Poupou le Lun 15 Nov 2010 - 11:41

Merci de m'avoir répondu =)

Voici mon CSS

Code:
a { text-decoration: none; }

body { cursor: defaut }
a:hover { cursor:ne-resize; }

td.cat { text-align: center; }

input, textarea, select {
-moz-border-radius-bottomleft:3px;
-moz-border-radius-bottomright:3px;
-moz-border-radius-topleft:3px;
-moz-border-radius-topright:3px;
}

.forumlink a:hover {
  background-image: url("http://uplofile.free.fr/rep5/60009556sans-titre-1.png")}

.forumline{
  background-color: #0F1110;
  background-image: url(http://uplofile.free.fr/rep5/12162512fond.jpg);
  -moz-border-radius: 13px;
  padding-left:6px;
  padding-right:6px;
  padding-bottom: 6px;
  padding-top: 6px;}

a.mainmenu
{
font-family: verdana;
font-size: 10;
text-align: center;
padding-left: defaut;
color: #0F1110;
font-variant: defaut;
background-image: url('http://uplofile.free.fr/rep5/12162512fond.jpg');
background-repeat: no-repeat;
background-color: #8B9892;
text-decoration: none;
border: 1px dashed #0F1110;
border-left: 4px solid #0F1110;
border-right: 4px solid #0F1110;
-moz-border-radius:10px;
}

a.mainmenu:hover {
text-align: center;}

a.forumlink {
  text-decoration: none;
  color: ##000000;
  display: block;
  font-family: impact;
  font-size: 14px;
  text-transform: defaut;
  font-weight: normal;
  letter-spacing: 0px;
  border-bottom: 2px solid #1E2220;
  padding-left: 0px;
  text-shadow: ##6F2640 1px 1px 1px;}
  ul, li{
      list-style: none;
    }
    .mon_onglet{
      float: left;
      padding: 4px 10px;
      margin-center: 5px;
      color: #000000;
      background: #393F3D;
      border: 3px solid #0F1110;
      cursor: pointer;
      margin-bottom: -1px;
    } 
    .mon_onglet:hover{
      background: #66716D;
    }           
    .mon_onglet_selected{
      float: left;
      padding: 2px 10px;
      margin-right: 5px;
      color: #000000;
      background: #66716D;
      border-top: 3px solid #0F1110;
      border-right: 3px solid #0F1110;
      border-left: 3px solid #0F1110; 
      border-bottom: 3px solid #0F1110; 
      cursor: pointer; 
      margin-bottom: -1px;
    }             
    .clear{
      clear: both;
    }
    .mon_contenu{
      color: #000000;
      background: #66716D;
      border: 3px solid #0F1110;
      padding: 10px;
            margin: -1px;           
    }
    #mes_contenus, #mes_onglets{
      width: 700px;
    }

Poupou
*

Messages : 33
Inscrit(e) le : 19/08/2010

http://g-e-v.lebonforum.com/
Poupou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes d'onglets

Message par BloodyJack le Lun 15 Nov 2010 - 12:20

Bonjour =)

Je pense que cela vient de votre dernier champ css
Code:
#mes_contenus, #mes_onglets{
      width: 700px;
    }
Le 700px de largeur en plus des padding ajoutés plus haut font que votre image se retrouve décalé. Agrandissez ce width, et tout devrait rentrer dans l'ordre.

Au plaisir,
Jack

BloodyJack
Nouveau membre

Messages : 11
Inscrit(e) le : 27/10/2010

http://theatrum-mundi.forumsactifs.net/
BloodyJack a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes d'onglets

Message par Poupou le Lun 15 Nov 2010 - 13:16

Non ca ne fonctionne toujours pas, l'onglet ne s'affiche pas de lui même.

J'ai agrandi comme vous me l'avez conseillé mais l'onglet sort maintenant de la page d'accueil ......

Poupou
*

Messages : 33
Inscrit(e) le : 19/08/2010

http://g-e-v.lebonforum.com/
Poupou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes d'onglets

Message par Invité le Lun 15 Nov 2010 - 15:40

Bonjour,

Essayez en ôtant style="display: none;" sur cette ligne de code dans la page d'accueil:
Code:
<div id="co_1" class="mon_contenu" style="display: none;"><center><img src="http://i66.servimg.com/u/f66/15/46/47/34/pa_bmp10.jpg"></center></div>

Cordialement.

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes d'onglets

Message par Poupou le Lun 15 Nov 2010 - 18:13

aah il y a une amélioration: l'image se met tout de suite ^^

Mais cest toujours décalé -__-

EDIT

Jai réuusssi i iiii iiiiiiiiii

en modifiant le padding =D merci quand même !

Poupou
*

Messages : 33
Inscrit(e) le : 19/08/2010

http://g-e-v.lebonforum.com/
Poupou a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum