problème de systhème d'onglet dans un message

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu problème de systhème d'onglet dans un message

Message par lili_chan le Lun 13 Déc 2010 - 12:42

J'aimerai faire une présentation sous forum d'onglet à l'intérieur d'un post j'ai essayé avec deux méthodes en inscrivant les script java et css dans le corps du html et ça affiche juste le code suivant:
Spoiler:


<style type="text/css">
ul, li{
list-style: none;
}
.mon_onglet{
float: left;
padding: 2px 10px;
margin-right: 5px;
color: #a7a277;
background: #f3e9b7;
border: 1px solid #a7a277;
cursor: pointer;
margin-bottom: -1px;
}
.mon_onglet:hover{
background: #f9efbb;
}
.mon_onglet_selected{
float: left;
padding: 2px 10px;
margin-right: 5px;
color: #a7a277;
background: #f9f3d5;
border-top: 1px solid #a7a277;
border-right: 1px solid #a7a277;
border-left: 1px solid #a7a277;
border-bottom: 1px solid #a7a277;
cursor: pointer;
margin-bottom: -1px;
}
.clear{
clear: both;
}
.mon_contenu{
color: #a7a277;
background: #f9f3d5;
border: 1px solid #a7a277;
padding: 10px;
}
#mes_contenus, #mes_onglets{
width: 400px;
}
</style>
<script type="text/javascript">
function changeOnglet(_this){
var getOnglets = document.getElementById('mes_onglets').getElementsByTagName('li');
for(var i = 0; i < getOnglets.length; i++){
if(getOnglets[i].id){
if(getOnglets[i].id == _this.id){
getOnglets[i].className = 'mon_onglet_selected';
document.getElementById('c' + _this.id).style.display = 'block';
}
else{
getOnglets[i].className = 'mon_onglet';
document.getElementById('c' + getOnglets[i].id).style.display = 'none';
}
}
}
}
</script>



<div id="mes_onglets">
<ul>
<li id="o_1" class="mon_onglet_selected" onmouseover="changeOnglet(this);">Onglet 1</li>
<li id="o_2" class="mon_onglet" onmouseover="changeOnglet(this);">Onglet 2</li>
<li id="o_3" class="mon_onglet" onmouseover="changeOnglet(this);">Onglet 3</li>
<li id="o_4" class="mon_onglet" onmouseover="changeOnglet(this);">Onglet 4</li>

<div class="clear"></div>
</ul>
</div>
<div id="mes_contenus">
<div id="co_1" class="mon_contenu">Mon contenu 1</div>
<div id="co_2" class="mon_contenu" style="display: none;">Mon contenu 2</div>
<div id="co_3" class="mon_contenu" style="display: none;">Mon contenu 3</div>
<div id="co_4" class="mon_contenu" style="display: none;">Mon contenu 4</div>
</div>

</body>



Soit en faisant un lien avec l'adresse d'une feuille css et d'une feuille java ça me donne ça:
(les onglets changent de couleur, mais le contenu ne change pas et les onglet ne pauvent pas être sélectionés)

Spoiler:

<link rel="stylesheet" href="http://www.archive-host.com/files/725194/0799dd1b381493aad18186e2d21a4cf6eb51b45f/new__3.css" type='text/css' />

<script src="http://www.archive-host.com/files/669940/0799dd1b381493aad18186e2d21a4cf6eb51b45f/new_2.js"></script>


<div id="mes_onglets">
<ul>
<li id="o_1" class="mon_onglet_selected" onmouseover="changeOnglet(this);">Onglet 1</li>
<li id="o_2" class="mon_onglet" onmouseover="changeOnglet(this);">Onglet 2</li>
<li id="o_3" class="mon_onglet" onmouseover="changeOnglet(this);">Onglet 3</li>
<li id="o_4" class="mon_onglet" onmouseover="changeOnglet(this);">Onglet 4</li>

<div class="clear"></div>
</ul>
</div>
<div id="mes_contenus">
<div id="co_1" class="mon_contenu">Mon contenu 1</div>
<div id="co_2" class="mon_contenu" style="display: none;">Mon contenu 2</div>
<div id="co_3" class="mon_contenu" style="display: none;">Mon contenu 3</div>
<div id="co_4" class="mon_contenu" style="display: none;">Mon contenu 4</div>
</div>

Je ne comprends pas ce qui ne va pas car si je mets ces deux codes sur une pagne html normal, ça marche... Merci d'avance pour l'aide que vous pourrez m'apporter


Dernière édition par lili_chan le Mar 14 Déc 2010 - 19:08, édité 6 fois

lili_chan
Nouveau membre

Féminin
Messages : 11
Inscrit(e) le : 16/11/2010

http://twilight-rpg-dream.forumactif.org/index.htm
lili_chan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème de systhème d'onglet dans un message

Message par lili_chan le Lun 13 Déc 2010 - 12:53

Je suis désolée de ce double post en voulant éditer mon message je me suis trompé et j'ai fait citer. (je n'arrive pas à le supprimer)

lili_chan
Nouveau membre

Féminin
Messages : 11
Inscrit(e) le : 16/11/2010

http://twilight-rpg-dream.forumactif.org/index.htm
lili_chan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème de systhème d'onglet dans un message

Message par Adam_sfp le Mar 14 Déc 2010 - 17:23

Bonjour

Les scripts ne fonctionnent pas dans les messages..
Peut être en essayant d'insérer votre page +html en iframe dans un post..
Cordialement.

Adam_sfp
+ Hyperactif +

Masculin
Messages : 4157
Inscrit(e) le : 18/04/2008

http://antonyadam.1fr1.net/portal.htm
Adam_sfp a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème de systhème d'onglet dans un message

Message par lili_chan le Mar 14 Déc 2010 - 19:07

merci pour l'information, je vais essayer!

lili_chan
Nouveau membre

Féminin
Messages : 11
Inscrit(e) le : 16/11/2010

http://twilight-rpg-dream.forumactif.org/index.htm
lili_chan a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum