Problème d'affichage lors d'un copier coller

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème d'affichage lors d'un copier coller

Message par Lixyr le Ven 7 Jan 2011 - 19:48

Bonsoir ForumActif.

Je viens poser ici un problème étrange dont je ne connais pas la source.
Alors depuis quelques semaines je fais des demandes de partenariats, et bien entendu, j'envoie en copier coller le code de ma fiche personnelle. Jusque là tout va bien, dès que c'est de l'ordre d'un code mis entre les balises code, seulement dès qu'il est question de poster un lien directement entre les balises url, le lien ne s'affiche pas, il y a un endroit vide à cet emplacement. J'ai beau passer la souris dessus en pensant que c'est un problème de couleur et de fond qui seraient les même : nada, il n'y a rien en fait.

Même chose lorsque je poste directement ma fiche sans la mettre entre les balises code, du contenu ne s'affiche pas. Je suis obligée de tout mettre par code.

Un exemple parmi d'autres, rencontré également de la part de l'administratrice d'un forum sur le quel j'ai fait du partenariat et qui n'arrive pas à copier coller ma fiche sans que le texte ne disparaisse (je précise que ce problème ne lui était pas arrivé avant) :

Le lien en question où la fiche n'apparait pas correctement :

Forum chocolate

La fiche originelle : (ce n'est que du html)

ma fiche partenariat

Liens indiquant le problème posé :

son poste et réponses &

les réponses


Comme je l'ai dit je ne sais pas si le problème vient de forum actif ou ne ma fiche, enfin, elle marche très bien dans d'autres forums et s'affiche mal dans d'autres. Idem, certains forums n'affichent pas quand on poste un simple lien, il faut le mettre entre les balises code.

Voilà, j'ai essayé d'être le plus précise possible.

Bonne soirée à vous.


Dernière édition par Lixyr Yrna le Lun 10 Jan 2011 - 15:49, édité 1 fois

Lixyr
Aidactive
Aidactive

Féminin
Messages : 5647
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage lors d'un copier coller

Message par Moka7 le Dim 9 Jan 2011 - 2:09

J'up le problème en espérant qu'une solution soit trouvé ^^

Moka7
***

Féminin
Messages : 117
Inscrit(e) le : 18/11/2010

http://gakuen-alice-rp.kikooforum.com/
Moka7 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage lors d'un copier coller

Message par Neptunia le Dim 9 Jan 2011 - 11:19

Bonjour !

J'apporte une précision.
Lorsqu'on prévisualise, tout fonctionne parfaitement.
Le problème n'apparait que lorsque l'on valide le message.

@ Moka7 : Désolé d'avoir posté comme invité, vous pouvez bien évidemment effacer mon message qui n'apportera rien de plus.

Neptunia
+ Hyperactif +

Féminin
Messages : 10993
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage lors d'un copier coller

Message par Lixyr le Dim 9 Jan 2011 - 16:12

Oui, lorsqu'on prévisualise, on voit bien le texte, le contenu, mais dès que l'on poste le sujet, il n'y a plus de texte : juste les titres et les liens, ainsi que la bannière.
Ca le fait aussi sur un autre forum :

galgal

Le contenu s'efface. ... = x





Lixyr
Aidactive
Aidactive

Féminin
Messages : 5647
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage lors d'un copier coller

Message par Threax le Dim 9 Jan 2011 - 17:04

Bonjour,

Le seul point commun aux deux forums cités est ce CSS :
Code:
tr.post span.gensmall {
    display: none;
}

Bien entendu, il a été ajouté pour retirer les phrases "Dernière édition par..." mais comme les admins sont toujours des grands têtus, ils n'écoutent pas les recommandations du staff (c'est à dire nous) qui dit régulièrement : attention ce code est dangereux !

Voilà un exemple qui illustre parfaitement le problème. Smile
Malheureusement ça ne sera pas suffisant pour que les gens arrêtent d'utiliser ce code.

Bref, en soit essayez de retirer les class="gensmall" de votre fiche, en remplaçant par une autre classe si possible. Wink

Threax
+ Hyperactif +

Masculin
Messages : 17277
Inscrit(e) le : 27/08/2005

http://lesforumsde.forumactif.com
Threax a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage lors d'un copier coller

Message par Lixyr le Dim 9 Jan 2011 - 23:01

Les classes gensmall !
D'accord, très bien. ^^ je vais faire ça. Merci beaucoup pour la réponse, Toto.

Heu, au passage, pour ma simple connaissance générale, ce code sert à quoi exactement ? Enfin je ne vois pas l'utilité d'un tel code ! oO





Lixyr
Aidactive
Aidactive

Féminin
Messages : 5647
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage lors d'un copier coller

Message par Threax le Lun 10 Jan 2011 - 21:07

Ce code a souvent été ajouté pour supprimer la phrase "Dernière édition par..." dans les messages. Wink

Threax
+ Hyperactif +

Masculin
Messages : 17277
Inscrit(e) le : 27/08/2005

http://lesforumsde.forumactif.com
Threax a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum