Pb d'affichage des boutons de l'éditeur de message sous Chrome

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Pb d'affichage des boutons de l'éditeur de message sous Chrome

Message par demeter1 le Lun 31 Jan 2011 - 18:22

Bonjour à tous,
Un nouveau petit bug relatif à l'affichage des boutons de l'éditeur de messages sous chrome. Le message rapide affiche correctement les boutons mais, ils sont totalement absents du message étendu.

Plusieurs de mes membres étant sous chrome ont constaté ce soucis d'affichage. Après avoir vidé tous mes caches avec ccleaner et avoir demandé à mes membres de procéder également à cette manip voici ce qui apparait.



Pas de soucis d'affichage avec Safari, firefox, internet explorer et maxthon.

ps : désolé de soulever encore un nouveau pb ; je vous avouerai que je m'en passerai bien. Ceci dit, ce soucis est d'ordre mineur et n'empêche pas la navigation sur le forum.

Edit, je viens de tenter de passer via css pour voir si je pouvais forcer les boutons à
s'afficher en les ré-hébergeant. Cela fonctionne pour le message rapide (bien qu'il n'y ait pas de soucis à ce niveau) mais pour ce qui est du message étendu, rien à faire. J'ai bien la barre de séparation des boutons mais pas les boutons ?????


Dernière édition par demeter1 le Mer 2 Fév 2011 - 23:34, édité 2 fois

demeter1
+ Hyperactif +

Masculin
Messages : 8100
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Pb d'affichage des boutons de l'éditeur de message sous Chrome

Message par Zorro le Mar 1 Fév 2011 - 9:25

Bonjour,

Vous avez des erreurs Javascript sous Chrome. Avez-vous installé des scripts ?




Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe


Zorro
Dévactif
Dévactif

Masculin
Messages : 1945
Inscrit(e) le : 05/12/2006

https://fr.wikipedia.org/wiki/Guy_Williams_(acteur)
Zorro a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Pb d'affichage des boutons de l'éditeur de message sous Chrome

Message par demeter1 le Mar 1 Fév 2011 - 18:51

Bonsoir Dauclem,
Le navigateur ne signale aucune erreur au niveau du javascript.
Aucune extension n'a été installé sur ce navigateur.
J'ai éffectivement plusieurs scripts installés sur le forum mais ce depuis plus d'un an. Le soucis d'affichage est apparu il y a deux ou trois jours d'après le signalement fait par mes membres.

La seule modif que j'ai opéré ces derniers jours est une mise en place d'un code css pour désactiver l'affichage du bouton A/A sous firefox.
Code:
/* *****************Annulation de l'affichage du bouton A/A********************* */
#text_editor_cmd_switchmode{
display: none;
}


Pensant que le pb venait de ce css, je l'ai supprimé puis j'ai vidé mes caches . Malgré ces manips, le pb est toujours présent.



demeter1
+ Hyperactif +

Masculin
Messages : 8100
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Pb d'affichage des boutons de l'éditeur de message sous Chrome

Message par Zorro le Mer 2 Fév 2011 - 9:11

Bonjour,

Effectivement je ne pense pas que le CSS soit en cause. Par contre, je vous assure que sous Chrome vous avez des erreurs Javascripts.


Je n'ai pas vu le lien vers la librairie Jquery dans votre tpl "overall_header", qui faudrait surement corriger car contient des erreurs.
Je vous donne le lien pour Jquery qu'il faut rajouter entre les balises <head></head>.

Code:
<script src="{JQUERY_PATH}" type="text/javascript"></script>






Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe


Zorro
Dévactif
Dévactif

Masculin
Messages : 1945
Inscrit(e) le : 05/12/2006

https://fr.wikipedia.org/wiki/Guy_Williams_(acteur)
Zorro a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Pb d'affichage des boutons de l'éditeur de message sous Chrome

Message par demeter1 le Mer 2 Fév 2011 - 18:38

Dauclem, que dire si ce n'est un grand , un très grand merci. L'adjonction de cette portion de code a résolu le pb d'affichage des boutons.

Je vais abuser de votre temps . Je vous avouerai m'être fié aux informations de la barre de navigation pour voir si le forum contenait des erreurs au niveau du javascript; apparemment, je m'y suis pris particulièrement mal pour effectuer ce contrôle. Sous firefox , j'arrive à trouver les erreurs mais , comment faites vous sous Chrome ? il y a t'il une extension particuliére à greffer au navigateur ?

demeter1
+ Hyperactif +

Masculin
Messages : 8100
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Pb d'affichage des boutons de l'éditeur de message sous Chrome

Message par Zorro le Mer 2 Fév 2011 - 20:01

Bonsoir,

Pas de souci. Il faut aller dans le menu > Outils > Outils de developpement ou console Javascript





Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe


Zorro
Dévactif
Dévactif

Masculin
Messages : 1945
Inscrit(e) le : 05/12/2006

https://fr.wikipedia.org/wiki/Guy_Williams_(acteur)
Zorro a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Pb d'affichage des boutons de l'éditeur de message sous Chrome

Message par demeter1 le Mer 2 Fév 2011 - 22:56

ok Dauclem. Effectivement, j'ai quelques modifs à opérer. Un grand merci pour cette aide.

demeter1
+ Hyperactif +

Masculin
Messages : 8100
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum