Probleme d'accents - le codage ne reste pas

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Probleme d'accents - le codage ne reste pas

Message par Leda le Mer 23 Fév 2011 - 20:16

Bonjour à tous !

J'ai un petit soucis d'accent dans ma page HTML. Cela concerne les accents.
Comme vous le savez ceux ci apparaissent de façon bizarre sur la page.
Mon problème n'est pas de trouver le code pour chacun des caractères problématique
mais de les garder!

Je m'explique : j'utilise la fonction créer une page web de forumactif et évidement,
il m'arrive de l'éditer pour divers besoin. Mon problème c'est que une fois que je cherche
a l'éditer tout le codage imposé pour les accents disparait.
je crois qu'il me faudrait des balises a imposer avant et après mon texte mais je ne sais pas lesquelles.

Pourriez vous m'aider s'il vous plait? Vous faudrait-il mon texte pour vous aider?

Merci d'avance !

Leda
*

Féminin
Messages : 35
Inscrit(e) le : 13/06/2010

http://crepuscule.forumgratuit.org
Leda a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Probleme d'accents - le codage ne reste pas

Message par Fuox le Mer 23 Fév 2011 - 21:11

Bonjour,
Utilisez vous le mode wysiwyg ?
Le problème vient peut-être de là...

Fuox
****

Masculin
Messages : 270
Inscrit(e) le : 02/09/2009

http://couloirsdepoudlard.forumactif.com
Fuox a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Probleme d'accents - le codage ne reste pas

Message par Leda le Mer 23 Fév 2011 - 21:13

En effet ! Je l'utilise car j'ai besoin de voir ce que donne les changements :s.

Leda
*

Féminin
Messages : 35
Inscrit(e) le : 13/06/2010

http://crepuscule.forumgratuit.org
Leda a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Probleme d'accents - le codage ne reste pas

Message par Fuox le Mer 23 Fév 2011 - 21:16

Le problème vient donc de là. Mais si vous l'utilisez, les caractères spéciaux devraient apparaître normalement sur la page html, non ?

Fuox
****

Masculin
Messages : 270
Inscrit(e) le : 02/09/2009

http://couloirsdepoudlard.forumactif.com
Fuox a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Probleme d'accents - le codage ne reste pas

Message par Leda le Mer 23 Fév 2011 - 21:59

Pas quand je cherche a l'heberger ailleurs ! En fait je creer une page de pub a mettre sur les forums de referencement !

Un lien vous permettra de voir le probleme, je pense

http://crepuscule.forumgratuit.org/h5-preparation-nouvelle-fiche-de-pub

Leda
*

Féminin
Messages : 35
Inscrit(e) le : 13/06/2010

http://crepuscule.forumgratuit.org
Leda a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Probleme d'accents - le codage ne reste pas

Message par Fuox le Mer 23 Fév 2011 - 22:03

Et quand vous revenez en mode html, les accents y sont-ils où est-ce qu'il y a les codes ?
Sinon, la meilleure solution est alors de n'utiliser que la version html ;p

Fuox
****

Masculin
Messages : 270
Inscrit(e) le : 02/09/2009

http://couloirsdepoudlard.forumactif.com
Fuox a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Probleme d'accents - le codage ne reste pas

Message par Leda le Mer 23 Fév 2011 - 22:08

en fait, on nous conseille d'ajouter ces codes la pour les caractères ''spéciaux''
http://www.scriptol.fr/creation-site-web/accents-html.php alors dans un premier temps, je code j'enregistre et ca passe !
Ce n'est que quand je cherche à l'éditer le problème se créer.
Mais si la solution est de rester en HTML alors je vais tenter d'utiliser la solution de l'iframe.

Je laisse quand mÊme le sujet ouvert au cas ou une autre solution serait quand mémé possible!

Mais je te remercie de ton attention Smile. C'est déjà très gentil de t'y être penché!

Leda
*

Féminin
Messages : 35
Inscrit(e) le : 13/06/2010

http://crepuscule.forumgratuit.org
Leda a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Probleme d'accents - le codage ne reste pas

Message par Fuox le Mer 23 Fév 2011 - 22:12

De rien, et tu peux visualiser ta page html en temps réel si tu le souhaites Wink

Fuox
****

Masculin
Messages : 270
Inscrit(e) le : 02/09/2009

http://couloirsdepoudlard.forumactif.com
Fuox a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Probleme d'accents - le codage ne reste pas

Message par Leda le Mer 23 Fév 2011 - 22:58

J'ai réussi et je donne la solution ici pour ceux qui aurait le même problème que moi. Rien ne vaut le système de l'iframe que l'on placera ensuite dans la page web en question. Comme cela, tout les codes resterons même si on édite la page principale en question Smile.
Je pense que l'on peut mettre cela en résolut !

Leda
*

Féminin
Messages : 35
Inscrit(e) le : 13/06/2010

http://crepuscule.forumgratuit.org
Leda a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Probleme d'accents - le codage ne reste pas

Message par Ea le Lun 7 Mar 2011 - 14:19

Bonjour,


Je vois bien les accents sur la page mais sinon si vous ne reprenez pas le haut et le bas du forum il faut mettre vraiment une structure de page html, là ça pourrait donner des catastrophes sur internet explorer.

Donc il faut avoir la structure :

Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html  xmlns="http://www.w3.org/1999/xhtml" dir="ltr" id="min-width" lang="fr" xml:lang="fr">
<head>
   <title>Le titre que vous souhaitez</title>
   <meta http-equiv="content-type" content="text/html; charset=utf-8;" />
   <!-- lier ici des feuilles de style, de script ou mettre des balises méta ou autre -->
</head>
<body>
   <!-- mettre ici le contenu de la page -->
</body>
</html>
Là donc ce qui importe surtout c'est la balise meta spécifiant l'encodage, si vous ne mettez pas utf8 qui correspond à l'encodage dans lequel sera codé le contenu, vous devrez mettre des é à la place des é par exemple et ainsi de suite.

@Leda a écrit:J'ai réussi et je donne la solution ici pour ceux qui aurait le même problème que moi. Rien ne vaut le système de l'iframe que l'on placera ensuite dans la page web en question. Comme cela, tout les codes resterons même si on édite la page principale en question Smile.
La seule raison de mettre une iframe ce sera si vous deviez utiliser le même contenu dans plusieurs pages, ou si vous voulez afficher une page d'un autre site.

Je déplace dans problème divers car ce n'est pas un problème de script ni vraiment un problème d'apparence ^^

Sinon c'est vous qui décidez de mettre le sujet en résolu ou non.

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23447
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum