Problème avec le systhème d'onglet

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec le systhème d'onglet

Message par Alexandra59 le Mar 12 Avr 2011 - 13:23

Bonjour,

J'avais demander un peu d'aide pour mettre en place un système d'onglet sur mon forum. Le post se trouve ici Le problème et qu'il s'affiche un cadre rouge. je voudrais l'enlever. http://forumtestcss.forumgratuit.org/

Merci de m'avoir lu.


Dernière édition par Alexandra59 le Jeu 14 Avr 2011 - 11:10, édité 1 fois

Alexandra59
****

Féminin
Messages : 230
Inscrit(e) le : 25/03/2011

http://forumtestcss.forumgratuit.org/
Alexandra59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le systhème d'onglet

Message par Alexandra59 le Mar 12 Avr 2011 - 15:15

Excusez moi du double post c'était juste pour prévenir que j'avais réussis à enlever le cadre rouge en écrivant "border : none".
Par contre quand on "navigue" sur les onglets des traits noirs en pointillait apparaisse. Comment les enlève t-on ? De plus les catégories ne sont pas fixes, elles descendent au fur et à mesure qu'on navigue sur les onglets.


Dernière édition par Alexandra59 le Mer 13 Avr 2011 - 9:03, édité 1 fois

Alexandra59
****

Féminin
Messages : 230
Inscrit(e) le : 25/03/2011

http://forumtestcss.forumgratuit.org/
Alexandra59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le systhème d'onglet

Message par Anzu le Mar 12 Avr 2011 - 15:51


Bonjour,

Pensez à utiliser la fonction :editer: la prochaine fois Wink

Pourrais je avoir votre css et votre template ?

Cordialement.

Anzu
+ Hyperactif +

Féminin
Messages : 20685
Inscrit(e) le : 30/08/2007

http://forum.forumactif.com/forum
Anzu a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le systhème d'onglet

Message par Alexandra59 le Mar 12 Avr 2011 - 15:54

Le CSS :

Code:
body { background-attachment: no-fixed; background-repeat: no-repeat; background-position: top center;}
table.forumline {border:1px dotted;}a:hover{text-transform:uppercase;}

/* code du conteneur des onglets */
#ongline {
  text-align: center;
  padding: 30px;
}
/* code s'appliquant a chacun des onglets */
#ongline a {
  text-decoration: none!important;
  color: green;
}
/* code s'appliquant a l'onglet selectionne et aux onglets survoles */
#ongline a.ccurrent,#ongline a:hover {
  border: none;
}
/* code s'appliquant a l'onglet selectionne */
#ongline a.ccurrent {
}

Le template index_body :

Code:
{JAVASCRIPT}
<!-- BEGIN message_admin_index -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
   <!-- BEGIN message_admin_titre -->
   <tr>
      <td class="catHead" height="28"><span class="cattitle">{message_admin_index.message_admin_titre.MES_TITRE}</span></td>
   </tr>
   <!-- END message_admin_titre -->
   <!-- BEGIN message_admin_txt -->
   <tr>
      <td class="row1" rowspan="3" align="center" valign="middle">
      <div class="gensmall">{message_admin_index.message_admin_txt.MES_TXT}</div>
      </td>
   </tr>
   <!-- END message_admin_txt -->
</table>
<!-- END message_admin_index -->

<!-- BEGIN switch_user_login_form_header -->
<form action="{S_LOGIN_ACTION}" method="post" name="form_login">
   <!-- BEGIN switch_fb_connect_no -->
   <table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
      <tr>
         <td class="row1" align="center">
            <table border="0" cellspacing="0" cellpadding="0">
               <tr>
                  <td><span class="genmed">{L_USERNAME}:</span> </td>
                  <td><input class="post" type="text" size="10" name="username"/> </td>
                  <td>
                     <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
                     <span class="gensmall">{L_AUTO_LOGIN}</span> 
                  </td>
               </tr>

               <tr>
                  <td><span class="genmed">{L_PASSWORD}:</span> </td>
                  <td><input class="post" type="password" size="10" name="password"/> </td>
                  <td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
               </tr>
            </table>
         </td>
      </tr>
   </table>
   <!-- END switch_fb_connect_no -->

   <!-- BEGIN switch_fb_connect -->
   <table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
      <tr>
         <td valign="top" width="100%"  class="row1" align="center">
            <table width="100%">
               <tr>
                  <td width="55%" valign="middle" align="right">
                     <table class="right">
                        <tr>
                           <td><span class="genmed">{L_USERNAME}:</span> </td>
                           <td><input class="post" type="text" size="10" name="username"/> </td>
                           <td>
                              <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
                              <span class="gensmall">{L_AUTO_LOGIN}</span> 
                           </td>
                        </tr>

                        <tr>
                           <td><span class="genmed">{L_PASSWORD}:</span> </td>
                           <td><input class="post" type="password" size="10" name="password"/> </td>
                           <td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
                        </tr>
                     </table>
                  </td>
                  <td width="10%" align="center" valign="middle">
                     <span class="genmed fb_or">{switch_user_login_form_header.switch_fb_connect.L_OR}</span>
                  </td>
                  <td width="35%" class="align_gauche"><fb:login-button size="large" onlogin="window.location='/facebook_connect.forum'" v="2" perms="{switch_user_login_form_header.switch_fb_connect.L_FB_PERMISSIONS}">{switch_user_login_form_header.switch_fb_connect.L_FB_LOGIN_BUTTON}</fb:login-button></td>
               </tr>
            </table>
         </td>
      </tr>
   </table>
   <!-- END switch_fb_connect -->
</form>
<!-- END switch_user_login_form_header -->

{CHATBOX_TOP}
<div id="forums-index">
{BOARD_INDEX}
</div>
<script type="text/javascript" src="/h1-"></script>
<table width="100%" border="0" cellspacing="0" cellpadding="0">
   <tr>
      <td width="50%" valign="top">
         <!-- BEGIN switch_user_logged_in -->
         <span class="gensmall"><a href="{U_MARK_READ}" class="gensmall">{L_MARK_FORUMS_READ}</a>
         <!-- END switch_user_logged_in -->
         <!-- BEGIN switch_delete_cookies -->
         <br /><a href="{switch_delete_cookies.U_DELETE_COOKIES}" class="gensmall">{switch_delete_cookies.L_DELETE_COOKIES}</a>
         <!-- END switch_delete_cookies -->
         </span>
      </td>
      <td width="50%" align="right">
         <span class="gensmall">
            <a href="{U_TODAY_ACTIVE}" class="gensmall">{L_TODAY_ACTIVE}</a><br />
            <a href="{U_TODAY_POSTERS}" class="gensmall">{L_TODAY_POSTERS}</a><br />
            <a href="{U_OVERALL_POSTERS}" class="gensmall">{L_OVERALL_POSTERS}</a>
            <!-- BEGIN switch_on_index -->
               <!-- BEGIN switch_delete_cookies -->
               <br /><a href="{switch_on_index.switch_delete_cookies.U_DELETE_COOKIES}" class="gensmall">{switch_on_index.switch_delete_cookies.L_DELETE_COOKIES}</a>
               <!-- END switch_delete_cookies -->
            <!-- END switch_on_index -->
         </span>
      </td>
   </tr>
</table>

<!-- BEGIN switch_user_login_form_footer -->
<form action="{S_LOGIN_ACTION}" method="post" name="form_login">
   <!-- BEGIN switch_fb_connect_no -->
   <table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
      <tr>
         <td class="row1" align="center">
            <table border="0" cellspacing="0" cellpadding="0">
               <tr>
                  <td><span class="genmed">{L_USERNAME}:</span> </td>
                  <td><input class="post" type="text" size="10" name="username"/> </td>
                  <td>
                     <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
                     <span class="gensmall">{L_AUTO_LOGIN}</span> 
                  </td>
               </tr>

               <tr>
                  <td><span class="genmed">{L_PASSWORD}:</span> </td>
                  <td><input class="post" type="password" size="10" name="password"/> </td>
                  <td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
               </tr>
            </table>
         </td>
      </tr>
   </table>
   <!-- END switch_fb_connect_no -->

   <!-- BEGIN switch_fb_connect -->
   <table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
      <tr>
         <td valign="top" width="100%"  class="row1" align="center">
            <table width="100%">
               <tr>
                  <td width="55%" valign="middle">
                     <table class="right">
                        <tr>
                           <td><span class="genmed">{L_USERNAME}:</span> </td>
                           <td><input class="post" type="text" size="10" name="username"/> </td>
                           <td>
                              <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
                              <span class="gensmall">{L_AUTO_LOGIN}</span> 
                           </td>
                        </tr>

                        <tr>
                           <td><span class="genmed">{L_PASSWORD}:</span> </td>
                           <td><input class="post" type="password" size="10" name="password"/> </td>
                           <td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
                        </tr>
                     </table>
                  </td>
                  <td width="10%" align="center" valign="middle">
                     <span class="genmed fb_or">{switch_user_login_form_footer.switch_fb_connect.L_OR}</span>
                  </td>
                  <td width="35%" class="align_gauche"><fb:login-button size="large" onlogin="window.location='/facebook_connect.forum'" v="2" perms="{switch_user_login_form_footer.switch_fb_connect.L_FB_PERMISSIONS}">{switch_user_login_form_footer.switch_fb_connect.L_FB_LOGIN_BUTTON}</fb:login-button></td>
               </tr>
            </table>
         </td>
      </tr>
   </table>
   <!-- END switch_fb_connect -->
</form>
<!-- END switch_user_login_form_footer -->

<!-- BEGIN disable_viewonline -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
   <tr>
      <td class="catHead" colspan="2" height="28">
      <!-- BEGIN switch_viewonline_link -->
      <span class="cattitle"><a class="cattitle" href="{U_VIEWONLINE}" rel="nofollow">{L_WHO_IS_ONLINE}</a></span>
      <!-- END switch_viewonline_link -->

      <!-- BEGIN switch_viewonline_nolink -->
      <span class="cattitle">{L_WHO_IS_ONLINE}</span>
      <!-- END switch_viewonline_nolink -->
      </td>
   </tr>
   <tr>
      <td class="row1" rowspan="6" align="center" valign="middle"><img src="{L_ONLINE_IMG}" id="i_whosonline" alt="{L_WHO_IS_ONLINE}" /></td>
      <td class="row1" width="100%"><span class="gensmall">{TOTAL_POSTS}<br />
      {TOTAL_USERS}<br />
      {NEWEST_USER}</span></td>
   </tr>
   <tr>
      <td class="row1"><span class="gensmall">{TOTAL_USERS_ONLINE}<br />
      {RECORD_USERS}<br />
      <br />
      {LOGGED_IN_USER_LIST}</span></td>
   </tr>
   {L_CONNECTED_MEMBERS}
   {L_WHOSBIRTHDAY_TODAY}
   {L_WHOSBIRTHDAY_WEEK}
   <tr>
      <td class="row1"><span class="gensmall">{LEGEND} : {GROUP_LEGEND}</span></td>
   </tr>
   <!-- BEGIN switch_chatbox_activate -->
   <tr>
      <td class="row1">
         <span class="gensmall">{TOTAL_CHATTERS_ONLINE} :  {CHATTERS_LIST}<br />
            <!-- BEGIN switch_chatbox_popup -->
            <div id="chatbox_popup"></div>
            <script type="text/javascript">
            //<![CDATA[
            insertChatBoxPopup('{disable_viewonline.switch_chatbox_activate.switch_chatbox_popup.U_FRAME_CHATBOX}', '{L_CLICK_TO_JOIN_CHAT}');
            //]]>
            </script>
            <!-- END switch_chatbox_popup -->
         </span>
      </td>
   </tr>
   <!-- END switch_chatbox_activate -->
</table>
<!-- END disable_viewonline -->
{CHATBOX_BOTTOM}
<br clear="all" />
<!-- BEGIN switch_legend -->
<table border="0" cellspacing="3" cellpadding="0" align="center">
   <tr>
      <td align="center" width="20"><img src="{FORUM_NEW_IMG}" alt="{L_NEW_POSTS}" /></td>
      <td><span class="gensmall">{L_NEW_POSTS}</span></td>
      <td></td>
      <td align="center" width="20"><img src="{FORUM_IMG}" alt="{L_NO_NEW_POSTS}" /></td>
      <td><span class="gensmall">{L_NO_NEW_POSTS}</span></td>
      <td>  </td>
      <td align="center" width="20"><img src="{FORUM_LOCKED_IMG}" alt="{L_FORUM_LOCKED}" /></td>
      <td><span class="gensmall">{L_FORUM_LOCKED}</span></td>
   </tr>
</table>
<!-- END switch_legend -->

{AUTO_DST}

<!-- BEGIN switch_fb_index_login -->
<div id="fb-root"></div>
<script type="text/javascript">
//<![CDATA[
FB.init({
   appId: '{switch_fb_index_login.FACEBOOK_APP_ID}',
     status: true,
     cookie: true,
     xfbml: true
});
//]]>
</script>
<!-- END switch_fb_index_login -->

Alexandra59
****

Féminin
Messages : 230
Inscrit(e) le : 25/03/2011

http://forumtestcss.forumgratuit.org/
Alexandra59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le systhème d'onglet

Message par Alexandra59 le Mar 12 Avr 2011 - 20:09

Up

Alexandra59
****

Féminin
Messages : 230
Inscrit(e) le : 25/03/2011

http://forumtestcss.forumgratuit.org/
Alexandra59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le systhème d'onglet

Message par Alexandra59 le Mer 13 Avr 2011 - 9:00

Up

Alexandra59
****

Féminin
Messages : 230
Inscrit(e) le : 25/03/2011

http://forumtestcss.forumgratuit.org/
Alexandra59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le systhème d'onglet

Message par Alexandra59 le Mer 13 Avr 2011 - 19:35

Up

Alexandra59
****

Féminin
Messages : 230
Inscrit(e) le : 25/03/2011

http://forumtestcss.forumgratuit.org/
Alexandra59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le systhème d'onglet

Message par Alexandra59 le Mer 13 Avr 2011 - 21:31

Personne ? J'en ai vraiment besoin ....

Alexandra59
****

Féminin
Messages : 230
Inscrit(e) le : 25/03/2011

http://forumtestcss.forumgratuit.org/
Alexandra59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le systhème d'onglet

Message par Ea le Mer 13 Avr 2011 - 23:50

Bonjour,


Je n'ai pas le trait noir sur les onglets, qu'est-ce que ça donne en ajoutant dans le CSS :

Code:
#ongline a { text-decoration: none!important; border: none!important; }
Pour les pointillés autour des tableaux voici un code où le tableau lui-même disparaît : ici.

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23427
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le systhème d'onglet

Message par Anzu le Mer 13 Avr 2011 - 23:51

Bonjour,

Je vous rappelle qu'il est autorisé un seul UP par tranche de 24 heures, à partir de votre dernier message posté dans le sujet concerné.

Je vous invite à lire :

A bientôt sur ForumActif Smile

Bonsoir,

Merci de bien vouloir respecter les règles Wink
La prochaine fois, votre sujet sera verrouillé.

Bien cordialement.

Edit etana : je n'y avais pas fait attention mais je plussoie.

Anzu
+ Hyperactif +

Féminin
Messages : 20685
Inscrit(e) le : 30/08/2007

http://forum.forumactif.com/forum
Anzu a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le systhème d'onglet

Message par Alexandra59 le Jeu 14 Avr 2011 - 8:18

Désolée ^^"

Mais merci de votre aide. Par contre est-ce normale que les onglets ne sont plus sur la même ligne ? (c'est peut être parce que j'ai un petit écran.

Alexandra59
****

Féminin
Messages : 230
Inscrit(e) le : 25/03/2011

http://forumtestcss.forumgratuit.org/
Alexandra59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le systhème d'onglet

Message par Ea le Jeu 14 Avr 2011 - 12:25

Petit écran moi ça va.

Vous pouvez diminuer le vide à gauche et à droite de certains onglets, par exemple :

[]
Il y a 20 pixels de transparent à gauche et à droite de l'image.

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23427
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le systhème d'onglet

Message par Alexandra59 le Jeu 14 Avr 2011 - 12:53

Merci. Je met mon sujet en "résolu". ^^

Alexandra59
****

Féminin
Messages : 230
Inscrit(e) le : 25/03/2011

http://forumtestcss.forumgratuit.org/
Alexandra59 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum