InfoBulle qui bug.

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu InfoBulle qui bug.

Message par Myriam Rose le Lun 2 Mai 2011 - 13:46

Bonjour,
J'ai un problème avec les infobulles de ma page d'accueil. Je viens d'installer FireFox 4 et mon code ne s'affiche plus comme avant. Lorsque j'étais sur Fifre fox 3.6, le code s'affichait normalement, mais ce n'est plus le cas.
Dans cette infobulle, j'ai mis des liens, en ajoutant des <div></div> pour que cela soit possible. Vous avec peut être une modification plus simple pour que j'ajoute des liens dans mes infobulles. Voici mon code :
Code:
<table><tr><td><div class="globo1"><a class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_16.png" ><span><div><b><font color="#F58F06">Peyton Sawyer</font></b><br>administratrice <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=17" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u17" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></a> </div></td>
<td> <div class="globo1"><a class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_17.png"><span><div><b><font color="#F58F06">Aerin Hellington</font></b> <br>administratrice <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=62" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u62" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></a></div> </td><td><div class="globo1"><a class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_18.png"><span><div><b><font color="#F58F06">Emily Miller</font> </b><br>modératrice <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=67" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u67" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></a> </div></td>
<td><div class="globo1"><a class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_19.png" border="0" alt=""><span><div><b><font color="#F58F06">April Stevens</font></b> <br>modératrice <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=194" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u194" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></a> </div></td>
<td><div class="globo1"><a class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_20.png" border="0" alt=""><span><div><b><font color="#F58F06">Cameron Aiden</font></b> <br>modérateur <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=179" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u179" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></span></a> </div></td></tr></table>

J'espère être clair, même si j'en ai pas l'impression,
merci en tout les cas du temps que vous allez me consacrer.

Myriam.


Dernière édition par Myriam Rose le Mar 3 Mai 2011 - 22:34, édité 1 fois

Myriam Rose
**

Féminin
Messages : 88
Inscrit(e) le : 25/08/2009

http://one-tree-hill-rpg.forumactif.com/
Myriam Rose a été remercié(e) par l'auteur de ce sujet.

Résolu Re: InfoBulle qui bug.

Message par Invité le Mar 3 Mai 2011 - 19:35

Bonsoir,

En remplaçant <a class="info">...</a> par <div class="info>...</div> , vos infobulles s'affichent correctement sur mon forum test.
Code:
<table><tr><td><div class="globo1"><div class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_16.png" ><span><div><b><font color="#F58F06">Peyton Sawyer</font></b><br>administratrice <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=17" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u17" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></div> </div></td>
<td> <div class="globo1"><div class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_17.png"><span><div><b><font color="#F58F06">Aerin Hellington</font></b> <br>administratrice <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=62" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u62" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></div></div> </td><td><div class="globo1"><div class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_18.png"><span><div><b><font color="#F58F06">Emily Miller</font> </b><br>modératrice <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=67" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u67" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></div> </div></td>
<td><div class="globo1"><div class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_19.png" border="0" alt=""><span><div><b><font color="#F58F06">April Stevens</font></b> <br>modératrice <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=194" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u194" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></div> </div></td>
<td><div class="globo1"><div class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_20.png" border="0" alt=""><span><div><b><font color="#F58F06">Cameron Aiden</font></b> <br>modérateur <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=179" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u179" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></span></div> </div></td></tr></table>
Le problème peut aussi venir de la feuille CSS si vous l'avez modifiée récemment.

Cordialement.

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: InfoBulle qui bug.

Message par Myriam Rose le Mar 3 Mai 2011 - 20:27

Alors pour moi ca ne fonctionne pas. :S J'ai pas modifié les code de la feuille CSS. Donc je sais pas à quoi c'est du. Peut être il y a-t-il un autre code possible pour insérer des liens dans les infobulles :/

Myriam Rose
**

Féminin
Messages : 88
Inscrit(e) le : 25/08/2009

http://one-tree-hill-rpg.forumactif.com/
Myriam Rose a été remercié(e) par l'auteur de ce sujet.

Résolu Re: InfoBulle qui bug.

Message par Invité le Mar 3 Mai 2011 - 22:06

N'ayant pas connaissance de votre CSS, j'ai testé avec l'un des miens.
Dans le message d'accueil, j'ai placé:
Code:
<table><tr><td><div class="globo1"><div class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_16.png" ><span><div><b><font color="#F58F06">Peyton Sawyer</font></b><br>administratrice <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=17" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u17" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></div> </div></td>
<td> <div class="globo1"><div class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_17.png"><span><div><b><font color="#F58F06">Aerin Hellington</font></b> <br>administratrice <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=62" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u62" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></div></div> </td><td><div class="globo1"><div class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_18.png"><span><div><b><font color="#F58F06">Emily Miller</font> </b><br>modératrice <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=67" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u67" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></div> </div></td>
<td><div class="globo1"><div class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_19.png" border="0" alt=""><span><div><b><font color="#F58F06">April Stevens</font></b> <br>modératrice <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=194" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u194" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></div> </div></td>
<td><div class="globo1"><div class="info"><img src="http://i62.servimg.com/u/f62/13/92/69/88/staff_20.png" border="0" alt=""><span><div><b><font color="#F58F06">Cameron Aiden</font></b> <br>modérateur <br><a href="http://one-tree-hill-rpg.forumactif.com/privmsg?mode=post&u=179" class="postlink" target="_blank" rel="nofollow">mp</a> ★ <a href="http://one-tree-hill-rpg.forumactif.com/u179" class="postlink" target="_blank" rel="nofollow">profil</a></div></span></span></div> </div></td></tr></table>

Et j'ai ajouté mis ceci dans la feuille CSS:
Code:
.info{position: relative;z-index: 0;}
.info:hover{background-color: transparent;z-index: 50;}
.info span{
  position: absolute;
  background-color: #000;
  padding: 5px;
  left: -1000px;
  visibility: hidden;
  color: #FFFFFF;}
.info:hover span{
  visibility: visible;
  top: 10px;
  left: 10px;
  width: 150px ;
  color:#FFF;
  border: 1px solid #000;}
.globo1 { border:  3px solid #000;}
Les liens MP et Profil fonctionnent bien sur mon forum test . Mais j'ai peut-être mal compris ce que vous souhaitez faire.

Cordialement.

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: InfoBulle qui bug.

Message par Myriam Rose le Mar 3 Mai 2011 - 22:24

CA FONCTIONNNE!!!
Mille Merci Wink

Myriam Rose
**

Féminin
Messages : 88
Inscrit(e) le : 25/08/2009

http://one-tree-hill-rpg.forumactif.com/
Myriam Rose a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum