Problème diaporama

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème diaporama

Message par Isunonakani le Mer 4 Mai 2011 - 10:48

Bien le bonjour,
Je viens de créer un diaporama à l'aide de Wow Slider. L'aperçu marche niquel, mais lorsque que je veux le mettre dans un message sur mon forum, je ne vois rien Oo
J'avoue avoir un petit soucis au niveau des codes qu'il faut mettre dans le message en question, et en me servant d'une iframe ça ne marche toujours pas.
J'ai tenté d'héberger le fichier sur Archive-Host mais quand je veux l'afficher, il est vide Oo

Est-ce que quelqu'un qui a déjà utiliser Wow aurait des pistes à me donner pour que cela fonctionne?
Merci d'avance pour votre aide Very Happy

Isunonakani
***

Féminin
Messages : 137
Inscrit(e) le : 01/11/2009

http://bloods-chronicles.forumactif.org/forum.htm
Isunonakani a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Alyz le Mer 4 Mai 2011 - 11:22

Salut,

Je n'ai jamais utilisé ce logiciel mais je veux bien voir le code que tu essaies d'insérer sur ton forum.

Est-ce que tu as bien vérifié que le HTML est activé partout ? (cf ce topic)

Alyz
****

Féminin
Messages : 290
Inscrit(e) le : 09/06/2010

http://r24.imgfast.net/users/2913/10/00/00/smiles/849849.gif
Alyz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Isunonakani le Mer 4 Mai 2011 - 11:25

Roh merci beaucoup I love you
Le HTML est bien activé oui Oo
En fait, le code que j'ai essayé de mettre dans mes messages était celui que me donnait firefox en affichant l'aperçu du fichier, donc bon. Du coup j'ai tenté de l'archiver, mais il est vide je comprend pas pourquoi ça fait ça Oo

En gros voilà le code bizarre:

Isunonakani
***

Féminin
Messages : 137
Inscrit(e) le : 01/11/2009

http://bloods-chronicles.forumactif.org/forum.htm
Isunonakani a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Alyz le Mer 4 Mai 2011 - 12:34

Ca indique que le fichier est sur ton ordinateur =D
Va dans tes images > dossier Fo' > dossier Blood > dossier Bla > et là, tu devrais avoir un fichier nommé gurlz.

Si tu l'ouvres, tu auras le code à l'intérieur.

Alyz
****

Féminin
Messages : 290
Inscrit(e) le : 09/06/2010

http://r24.imgfast.net/users/2913/10/00/00/smiles/849849.gif
Alyz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Isunonakani le Mer 4 Mai 2011 - 14:04

Si je l'ouvre, j'obtiens exactement la même chose que ce que j'ai donné dans mon message précédent en fait =S

Isunonakani
***

Féminin
Messages : 137
Inscrit(e) le : 01/11/2009

http://bloods-chronicles.forumactif.org/forum.htm
Isunonakani a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Alex Fowl le Jeu 5 Mai 2011 - 0:33

Bonsoir,

Il vous faut héberger votre fichier ! Smile
Donc par exemple sur Archive-Host, après avoir fait héberger votre fichier, Archive-Host vous donne un lien, c'est celui la qu'il vous faudra utiliser ! Smile
Un lien du type :
Code:
www.archive-host.com/blablabla.html
Wink

Cordialement,

Alex Fowl
+ Hyperactif +

Masculin
Messages : 7557
Inscrit(e) le : 28/03/2009

http://www.aidactif.fr
Alex Fowl a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Isunonakani le Jeu 5 Mai 2011 - 8:37

Merci pour votre réponse Alex, mais j'ai déjà fait ceci Oo
Et en l'archivant sur Archive-Host, le lien qu'il me donne mène à un fichier vide, je n'ai qu'une page blanche qui s'affiche avec le nom de mon fichier.

Isunonakani
***

Féminin
Messages : 137
Inscrit(e) le : 01/11/2009

http://bloods-chronicles.forumactif.org/forum.htm
Isunonakani a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Alyz le Jeu 5 Mai 2011 - 9:47

Salut,

Je viens de tester le logiciel. Normalement, quand tu fais "publish" il faut que tu choisisses "publish to folder" (publier dans un fichier donc sur ton ordinateur). Une fois que c'est fait, une page HTML a normalement été créée dans le fichier que tu auras sélectionné. En ouvrant la page HTML dans ton navigateur (Internet explorer, Firefox ou autre), tu devrais voir ton slide.

A ce moment-là, j'aimerais que tu nous donne ce fichier index.html ainsi que le dossier ayant pour titre "engine1" (ou proche de ce titre ayant à l'intérieur un fichier style.css entre autres) et se trouvant dans le même dossier. Je t'aiderai alors à intégrer le slide dans ton forum (parce que le script est programmé pour fonctionner sur des sites, à la base) Smile

Alyz
****

Féminin
Messages : 290
Inscrit(e) le : 09/06/2010

http://r24.imgfast.net/users/2913/10/00/00/smiles/849849.gif
Alyz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Isunonakani le Jeu 5 Mai 2011 - 9:54

Alors concernant le fichier, je suppose que je dois juste redonner l'adresse?


Et le fichier css:


Foilà en espérant que cela soit utile Oo
Merci beaucoup pour ton aide Alyz I love you

Isunonakani
***

Féminin
Messages : 137
Inscrit(e) le : 01/11/2009

http://bloods-chronicles.forumactif.org/forum.htm
Isunonakani a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Alyz le Jeu 5 Mai 2011 - 10:03

Je ne peux toujours pas accéder à "file:///C:/Users/lea/Pictures/Fo%27/Blood/Bla/index.html" puisque c'est sur ton ordinateur. On va essayer une nouvelle technique :

Ouvre ton navigateur > Fichier > ouvrir un fichier > sélectionne le index.html
Question : est-ce que tu vois le slide que tu as crée ?
Dans tous les cas, fais affichage > code source de la page et copie-moi ce qu'il y a marqué, s'il te plaît Smile

Il n'y avait pas d'images également dans engine1 ?

Alyz
****

Féminin
Messages : 290
Inscrit(e) le : 09/06/2010

http://r24.imgfast.net/users/2913/10/00/00/smiles/849849.gif
Alyz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Isunonakani le Jeu 5 Mai 2011 - 10:14

Voilà ce que j'obtiens:


Si toutes celles qui forment le diaporama Oo Genre les boutons pour défiler et tout.

Isunonakani
***

Féminin
Messages : 137
Inscrit(e) le : 01/11/2009

http://bloods-chronicles.forumactif.org/forum.htm
Isunonakani a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Alyz le Jeu 5 Mai 2011 - 10:18

Il me les faudrait également (en me précisant quel est leur nom dans le dossier si ton hébergeur change les noms), s'il te plaît Smile

Alyz
****

Féminin
Messages : 290
Inscrit(e) le : 09/06/2010

http://r24.imgfast.net/users/2913/10/00/00/smiles/849849.gif
Alyz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Isunonakani le Jeu 5 Mai 2011 - 13:46

Les voici:
- Arrows:

- bg

- bullet:

- shadow:

- triangle:

Isunonakani
***

Féminin
Messages : 137
Inscrit(e) le : 01/11/2009

http://bloods-chronicles.forumactif.org/forum.htm
Isunonakani a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Alyz le Jeu 5 Mai 2011 - 14:43

Alors voilà ton code :

Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
      "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
      <title>WOWSlider generated by WOWSlider.com</title>
      <meta http-equiv="content-type" content="text/html; charset=utf-8" />
      <meta name="keywords" content="WOW Slider, Image Carousel jQuery, 3d Image Carousel" />
      <meta name="description" content="WOWSlider created with WOW Slider, a free wizard program that helps you easily generate beautiful web slideshow" />
      <!-- Start WOWSlider.com HEAD section -->
          <link rel="stylesheet" type="text/css" href="http://www.patmax.eu/CSS1/110505141741.css" media="screen" />
  <style type="text/css">a#vlb{display:none}</style>
      <script type="text/javascript" src="http://sd-2.archive-host.com/membres/up/157799094412634124/jquery.js"></script>
      <!-- End WOWSlider.com HEAD section -->
    </head>
    <body style="background-color:#ffffff">
      <!-- Start WOWSlider.com BODY section -->
      <div id="wowslider-container1">
      <div class="ws_images">
    <a href="#"><img src="ADRESSE DE TA PREMIERE IMAGE" alt="" title="" id="wows0"/></a>
    <a href="#"><img src="ADRESSE DE TA SECONDE IMAGE" alt="" title="" id="wows1"/></a>
    </div>
    <div class="ws_bullets"><div>

    <a href="#wows0" title=""></a>
    <a href="#wows1" title=""></a>
    </div></div>
    <a style="display:none" href="http://wowslider.com">jQuery Image Carousel by WOWSlider.com v1.5</a>
      <a href="#" class="ws_frame"></a>
      <div class="ws_shadow"></div>
      </div>
      <script type="text/javascript" src="http://sd-2.archive-host.com/membres/up/157799094412634124/script.js"></script>
      <!-- End WOWSlider.com BODY section -->
    </body>

    </html>

Il faut juste que tu y ajoutes les images que tu veux mettre dans la diapo.

Si tu regardes dans le code, il y a une partie

Code:
    <a href="#"><img src="ADRESSE DE TA PREMIERE IMAGE" alt="" title="" id="wows0"/></a>
    <a href="#"><img src="ADRESSE DE TA SECONDE IMAGE" alt="" title="" id="wows1"/></a>

Apparemment, tu avais mis deux images dans ta diapo et donc il y a l'emplacement pour les deux images. Il suffit que tu les héberges et que tu en mettes l'adresse là où je l'ai indiqué (sans enlever les guillemets).

Si jamais tu veux rajouter une ou des images, il faut rajouter une ligne à chaque fois et bien penser à changer l'id. Par exemple, pour quatre images :

<a href="#"><img src="ADRESSE DE TA PREMIERE IMAGE" alt="" title="" id="wows0"/></a>
<a href="#"><img src="ADRESSE DE TA SECONDE IMAGE" alt="" title="" id="wows1"/></a>
<a href="#"><img src="ADRESSE DE TA TROISIEME IMAGE" alt="" title="" id="wows2"/></a>
<a href="#"><img src="ADRESSE DE TA QUATRIEME IMAGE" alt="" title="" id="wows3"/></a>

Et il faut aussi modifier cette partie du code :

Code:
<a href="#wows0" title=""></a>
    <a href="#wows1" title=""></a>

En ajoutant les lignes correspondantes ce qui donnerait :

<a href="#wows0" title=""></a>
<a href="#wows1" title=""></a>
<a href="#wows2" title=""></a>
<a href="#wows3" title=""></a>
Si jamais tu as trop de mal à faire cela, tu n'as qu'à me donner les images et je le ferai.

Donc, le code final est à mettre dans panneau d'admin > modules > gestion des pages HTML > créer une nouvelle page HTML.

    Configuration de ta page :

  • Titre : tu mets ce que tu veux mais mets plutôt quelque chose de cours comme "pa" (pour page d'accueil)
  • Voulez-vous utiliser le haut et le bas de page de votre forum ? non
  • Utiliser cette page en tant que page d'accueil ? non
  • Puis tu colles le code (en ayant ajouté les adresses des images, bien sûr)

    Enfin, tu valides.


Ensuite, tu pourras récupérer l'adresse de la page dans la gestion des pages HTML.
Et, lorsque tu postes, il te suffit de mettre l'adresse dans ce code et de poster ce code :

Code:
<iframe src="ADRESSE DE LA PAGE HTML" width="520px" height="340px" marginwidth="0" marginheight="0" scrolling="no" frameborder="no" noresize framespacing="0"></iframe>

Alyz
****

Féminin
Messages : 290
Inscrit(e) le : 09/06/2010

http://r24.imgfast.net/users/2913/10/00/00/smiles/849849.gif
Alyz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème diaporama

Message par Isunonakani le Jeu 5 Mai 2011 - 14:54

Han merci ça fonctionne, tu es géniale I love you
Merci beaucoupp

Isunonakani
***

Féminin
Messages : 137
Inscrit(e) le : 01/11/2009

http://bloods-chronicles.forumactif.org/forum.htm
Isunonakani a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum