Codes javascript qui ne fonctionnent pas avec le nouveau système

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Codes javascript qui ne fonctionnent pas avec le nouveau système

Message par Gaara du désert le Dim 24 Juil 2011 - 16:03

Bonjour !

Alors voilà, actuellement je suis en train de transférer mes javascript hébergés sur archive-host, sur mon forum pour éviter de m'éparpiller partout.
J'ai créé une page avec mon javascript de gradualfader, j'ai remplacé l'adresse archive-host de la description de mon forum, par l'adresse de la page où mon code était hébergé, puis j’ai validé, mais rien ne fonctionne ! ><

J'ai bien ajouté ce qui est signalé dans ce sujet : http://forum.forumactif.com/t308422-nouveaute-forumactif-gestion-des-codes-javascript

Mais tous les javascript que j'ai essayé ne fonctionner pas :/
Voici mon forum (en hide parce qu'il est en construction ><)


J'en profite pour demander quelque chose : que dois-je faire pour intégrer un javascript à mon sujet ? Je veux installer des onglets dans mon règlement et donc y lier le javascript qui gère les onglets, mais je n'arrive pas à le faire fonctionner >_<

Merci d'avance, d'autant plus que mes questions sont certainement très stupides T.T


Dernière édition par Gaara du désert le Dim 24 Juil 2011 - 22:30, édité 1 fois

Gaara du désert
*****

Féminin
Messages : 724
Inscrit(e) le : 22/03/2005

http://www.star-city-heroes.com/
Gaara du désert a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Codes javascript qui ne fonctionnent pas avec le nouveau système

Message par Ea le Dim 24 Juil 2011 - 20:36

Bonjour,


Il y a une "compression" du code javascript avant l'affichage sur le forum, voilà le début du script gradual fader par exemple après la "compression" :

Code:
var gradualFader={}gradualFader.baseopacity=0.6 gradualFader.increment=0.1 d
Ce qui n'est pas bon car le fichier original n'avait pas de ; où il fallait.

Jusqu'à présent il semble qu'il suffit de mettre le script dans http://closure-compiler.appspot.com/home en mode simple et le code résultat est bien formaté avec les ; où il faut et fonctionne bien dans la gestion des scripts du forum.

Pour l'autre problème si c'est dans un sujet ça dépend de votre script, il faut le coder autrement et mettre un script sur les sujets, dans ce script il faut mettre :

Code:
$(function(){
  if("http://forum.forumactif.fr/t3-essai-present"!=document.location.origin+document.location.pathname) return;

  /* code javascript à exécuter */
});
( ce code une fois que la page est chargée, exécute le code javascript à condition qu'on soit sur http://forum.forumactif.fr/t3-essai-present )

Ea
Aidactif
Aidactif

Messages : 23428
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Codes javascript qui ne fonctionnent pas avec le nouveau système

Message par Invité le Lun 1 Aoû 2011 - 10:50

Bonjour,

Afin de faciliter la gestion des problèmes, si votre problème est résolu, pensez à :
  • éditer votre premier message,
  • cocher l'icône résolu
  • Et enregistrer en cliquant sur


Vous pouvez également remercier les personnes qui vous ont aidé, en cliquant sur le bouton

A bientôt sur ForumActif Smile

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum