Décalage après utilisation de la balise "code"

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Décalage après utilisation de la balise "code"

Message par Arc-En-Ciela le Lun 25 Juil 2011 - 4:08



  • Bonjour !

    À chaque fois que j'utilise la balise "code", il y a un décalage dans le texte suivant, comme si j'avais ajouté un padding. Je ne crois pas avoir ajouté de CSS ou avoir modifié un template pouvant affecter cela. Petit soucis peu important d'esthétisme, mais bon, j'aimerais quand même le régler ^^. Un exemple ici.

    Merci
    Ciel@


Dernière édition par Arc-En-Ciela le Mar 26 Juil 2011 - 17:42, édité 1 fois

Arc-En-Ciela
***

Messages : 120
Inscrit(e) le : 22/08/2010

http://alter-mundus.superforum.fr/portal.htm
Arc-En-Ciela a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Décalage après utilisation de la balise "code"

Message par ge80 le Lun 25 Juil 2011 - 7:32

Bonjour

Voulez-vous dire dans le même message ou dans le message suivant ?

Côté droit ou gauche ou haut ou bas ?

Cordialement,
Ge

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Décalage après utilisation de la balise "code"

Message par Arc-En-Ciela le Lun 25 Juil 2011 - 17:22

  • Dans le même message, le texte écrit à la suite d'un texte sous balise code se padde tout seul à gauche, à droit et en bas. Je ne saurais dire pour en haut.



    Peut-être que ce schéma vous aidera. Les lignes rouges représentent le padding ajouté par les balises code et le pointillé délimite le padding automatique que j'ai inséré dans mon CSS. La bordure grise à droite et en bas sont des erreurs dans mon dessin, ne pas en prendre compte.

    Merci
    Ciel@

    Édit : je viens de m'apercevoir que la même chose arrivait lorsque j'utilise une balise "hide", une balise "citation" et une balise "spoiler".

Arc-En-Ciela
***

Messages : 120
Inscrit(e) le : 22/08/2010

http://alter-mundus.superforum.fr/portal.htm
Arc-En-Ciela a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Décalage après utilisation de la balise "code"

Message par ge80 le Lun 25 Juil 2011 - 17:38

OK
J'ai bien compris.

Pouvez-vous faire un message de test avec l'ensemble des balises à problème et me donner le lien de visualisation (comme invité) ?

Ceci me permettra de régler l'ensemble des décalages.

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Décalage après utilisation de la balise "code"

Message par Arc-En-Ciela le Mar 26 Juil 2011 - 15:54

  • Hum, la balise hide fait actuellement défaut lorsque je suis connectée, mais il est impossible de voir quoi que ce soit même en postant sur le topic en tant qu'invité. J'ai répété certaines phrases, en italique, simplement pour faire du remplissage pour bien montrer le padding. Voici le lien : http://alter-mundus.superforum.fr/t265-testing-pour-forumforumactifcom

    Merci beaucoup,
    Ciel@

Arc-En-Ciela
***

Messages : 120
Inscrit(e) le : 22/08/2010

http://alter-mundus.superforum.fr/portal.htm
Arc-En-Ciela a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Décalage après utilisation de la balise "code"

Message par ge80 le Mar 26 Juil 2011 - 15:56

OK merci

Je regarde après avoir terminé une aide en cours.

edit :

ceci provient de votre
Code:

.postbody {
   padding:15px;
   text-align: justify; display: block;
}

Enlever ce padding: 15px; qui provoque un décalage à chaque fois.

Code:

.postbody {
   text-align: justify; display: block;
}

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Décalage après utilisation de la balise "code"

Message par Arc-En-Ciela le Mar 26 Juil 2011 - 17:29

  • Ah, il n'y aurait pas une autre façon ? Parce que ça enlève mon padding automatique Confused

Arc-En-Ciela
***

Messages : 120
Inscrit(e) le : 22/08/2010

http://alter-mundus.superforum.fr/portal.htm
Arc-En-Ciela a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Décalage après utilisation de la balise "code"

Message par ge80 le Mar 26 Juil 2011 - 17:34

Comme ceci non.

Regarder sur ce forum et sur la majorité des forums, vous ne verrez pas de marge à ce niveau.

Le code relance une classe .postbody juste après code, quote ...
D'où les décalages qui augmentent.

La solution par template est faisable.


Quelqu'un a peut être une autre solution par css.

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Décalage après utilisation de la balise "code"

Message par Arc-En-Ciela le Mar 26 Juil 2011 - 17:38

  • Ah d'accord. Merci ^^ . Je fais une petite recherche par rapport à ça alors ;P

Arc-En-Ciela
***

Messages : 120
Inscrit(e) le : 22/08/2010

http://alter-mundus.superforum.fr/portal.htm
Arc-En-Ciela a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum