La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par serge4789 le Lun 22 Aoû 2011 - 15:57

Bonjour à tous,

La colorisation du texte inséré entre les balises
Code:
[code][/code]
ne fonctionne pas malgré avoir suivi le tuto à la lettre.

Je ne comprends rien.

Je tiens tout de même à vous avouer que le tuto n’est pas simple.

D’avance merci pour vos réponses et votre aide.

Veuillez agréez mes sentiments respectueux.

Au revoir et bon après-midi.


Dernière édition par serge4789 le Ven 26 Aoû 2011 - 20:20, édité 1 fois (Raison : EDIT)

serge4789
# Tropactif #

Masculin
Messages : 1061
Inscrit(e) le : 08/06/2009

http://lapince.forumotion.com
serge4789 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par ge80 le Lun 22 Aoû 2011 - 17:01

Bonjour,

Je viens de refaire le tuto et cela fonctionne. Essayons de trouver le problème.

Avez-vous bien collé le script dans son intégralité et appliqué celui -ci au sujet ?


Cordialement,
Ge

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par serge4789 le Lun 22 Aoû 2011 - 20:04

Bonsoir et merci de m’avoir répondu,
@ge80 a écrit:Bonjour,

Je viens de refaire le tuto et cela fonctionne. Essayons de trouver le problème.

Avez-vous bien collé le script dans son intégralité et appliqué celui -ci au sujet ?
Oui bien sur.

D’avance merci pour ta réponse et ton aide.

Reçois par ailleurs mes sentiments respectueux.

serge4789
# Tropactif #

Masculin
Messages : 1061
Inscrit(e) le : 08/06/2009

http://lapince.forumotion.com
serge4789 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par ge80 le Mar 23 Aoû 2011 - 8:28

Bonjour

Dans ce cas, vous devez avoir un conflit avec un autre script de votre forum.
Si vous avez un forum de test alors essayer le script de colorisation du code et, si cela fonctionne, ajouter progressivement les autres scripts afin de trouver le ou les coupables.

Cordialement,
Ge

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par serge4789 le Mar 23 Aoû 2011 - 10:21

Bonjour et merci de m’avoir répondu,
@ge80 a écrit:Bonjour

Dans ce cas, vous devez avoir un conflit avec un autre script de votre forum.
Si vous avez un forum de test alors essayer le script de colorisation du code et, si cela fonctionne, ajouter progressivement les autres scripts afin de trouver le ou les coupables.

Cordialement,
Ge
J’ai suivi à la lettre ce que tu m’as dit de faire mais rien à faire. Ca ne fonctionne pas.

Il me faudrait l’aide du staff de forumactif afin de pouvoir y arriver.

D’avance merci pour vos réponses et votre aide.

Veuillez agréez mes sentiments respectueux.

Au revoir et bonne journée.

serge4789
# Tropactif #

Masculin
Messages : 1061
Inscrit(e) le : 08/06/2009

http://lapince.forumotion.com
serge4789 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par ge80 le Mar 23 Aoû 2011 - 10:27

Bonjour

Je ne vois pas la partie javascript dans le forum donné dans votre profil.

Celle-ci http://s301826463.onlinehome.fr/fdf/viewtopic.php?pid=10#p10

Cordialement,
Ge

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par serge4789 le Mar 23 Aoû 2011 - 10:42

Bonjour et merci de m’avoir répondu rapidement,
@ge80 a écrit:Bonjour

Je ne vois pas la partie javascript dans le forum donné dans votre profil.

Celle-ci http://s301826463.onlinehome.fr/fdf/viewtopic.php?pid=10#p10

Cordialement,
Ge
Idem ce code est bien mis dans la partie javascript.

Par contre nous avons également copié ce code dans une page html comme indiqué dans le tuto mais cela ne fonctionne pas.

Je ne comprends vraiment rien à ce tuto.

D’avance merci pour vos réponses et votre aide.

Veuillez agréez mes sentiments respectueux.

Au revoir et bonne journée.

serge4789
# Tropactif #

Masculin
Messages : 1061
Inscrit(e) le : 08/06/2009

http://lapince.forumotion.com
serge4789 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par serge4789 le Mer 24 Aoû 2011 - 15:39

UP

serge4789
# Tropactif #

Masculin
Messages : 1061
Inscrit(e) le : 08/06/2009

http://lapince.forumotion.com
serge4789 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par serge4789 le Jeu 25 Aoû 2011 - 18:55

UP

serge4789
# Tropactif #

Masculin
Messages : 1061
Inscrit(e) le : 08/06/2009

http://lapince.forumotion.com
serge4789 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par Ea le Jeu 25 Aoû 2011 - 19:02

Bonjour,


Le script fonctionne bien sur le forum http://lapince.forumotion.com/t536-ebuddy par contre le CSS n'a pas été mis dans PA > Affichage > Couleurs > Feuille de style donc même si ça fonctionne on ne le voit pas.

Sinon le <script src=/h1-></script> ne fait que causer une erreur ( ça ne perturbe pas le reste, mais autant ne pas avoir une erreur qui traine sans raison ).

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par serge4789 le Jeu 25 Aoû 2011 - 19:19

Bonsoir et merci de m’avoir répondu,
Etana a écrit:Bonjour,


Le script fonctionne bien sur le forum http://lapince.forumotion.com/t536-ebuddy par contre le CSS n'a pas été mis dans PA > Affichage > Couleurs > Feuille de style donc même si ça fonctionne on ne le voit pas.
A si le CSS a bien été mis da la feuille de style CSS.
Etana a écrit:Sinon le <script src=/h1-></script> ne fait que causer une erreur ( ça ne perturbe pas le reste, mais autant ne pas avoir une erreur qui traine sans raison ).
Doit-je le supprimer pour que cela fonctionne ou non ?

D’avance merci pour votre réponse.

Veuillez agréez mes sentiments respectueux.

Au revoir et bonne soirée.

serge4789
# Tropactif #

Masculin
Messages : 1061
Inscrit(e) le : 08/06/2009

http://lapince.forumotion.com
serge4789 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par Scoubifitz le Ven 26 Aoû 2011 - 18:07

bonjour,

le copier-coller du code copie aussi les numéros de lignes ...

essayer de copier-coller avec un autre navigateur pour éviter ce bug ...

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par Ea le Ven 26 Aoû 2011 - 18:10

Effectivement dans le CSS il y a bien :

Code:
.selectCode{cursor:pointer;float:right;text-transform:uppercase}2. 3..str{color:#080}4..kwd{color:#008}5..com{color:#800}6..typ{color:#606}7..lit{color:#066}8..pun{color:#660}9..pln{color:#000}10..tag{color:#008}11..atn{color:#606}12..atv{color:#080}13..dec{color:#606}14.pre.prettyprint{padding:2px}15.ol.linenums{margin-bottom:0;margin-top:0}16.li.L0,17.li.L1,18.li.L2,19.li.L3,20.li.L5,21.li.L6,22.li.L7,23.li.L8{list-style-type:none}24.li.L1,25.li.L3,26.li.L5,27.li.L7,28.li.L9{background:#eee}29.@media print{30strcolor:#060}31. .kwd{color:#006;font-weight:700}32. .com{color:#600;font-style:italic}33. .typ{color:#404;font-weight:700}34. .lit{color:#044}35. .pun{color:#440}36. .pln{color:#000}37. .tag{color:#006;font-weight:700}38. .atn{color:#404}39. .atv{color:#060}41. 42./* Fin - Styles pour la colorisation des codes */
Mais tout les numéros de ligne au milieu rend le css pas bon, il faut le remettre sans les numéros de ligne.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par serge4789 le Ven 26 Aoû 2011 - 18:27

Bonsoir Etana,

Doit-je retirer le <script src=/h1-></script> ou pas ?

D'avance merci pour votre réponse.

Veuillez agréez mes sentiments respectueux.

Au revoir et bonne soirée.

serge4789
# Tropactif #

Masculin
Messages : 1061
Inscrit(e) le : 08/06/2009

http://lapince.forumotion.com
serge4789 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par Ea le Ven 26 Aoû 2011 - 18:28

Oui vous devez et il faut mettre le bon CSS.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par serge4789 le Ven 26 Aoû 2011 - 18:34

Bonsoir et merci de m’avoir répondu,
Etana a écrit:Oui vous devez et il faut mettre le bon CSS.
Auriez-vous la gentillesse de me donner le bon css s’il vous plait Etana (sans les numéros de ligne) ?

D’avance merci pour votre réponse.

Veuillez agréez mes sentiments respectueux.

Au revoir et bonne soirée.


Dernière édition par serge4789 le Ven 26 Aoû 2011 - 18:37, édité 1 fois (Raison : EDIT)

serge4789
# Tropactif #

Masculin
Messages : 1061
Inscrit(e) le : 08/06/2009

http://lapince.forumotion.com
serge4789 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par Ea le Ven 26 Aoû 2011 - 18:55

Et bien soit vous utilisez un autre navigateur pour faire le copier/coller.

Soit vous sélectionnez le code et vous faites CTRL+C en ayant la souris au dessus du code.

Soit vous sélectionnez le code, faites clic-droit dessus -> copier la sélection et vous n'aurez pas les numéros de ligne non plus.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par serge4789 le Ven 26 Aoû 2011 - 19:14

Bonsoir et merci de m’avoir répondu,
Etana a écrit:Et bien soit vous utilisez un autre navigateur pour faire le copier/coller.

Soit vous sélectionnez le code et vous faites CTRL+C en ayant la souris au dessus du code.

Soit vous sélectionnez le code, faites clic-droit dessus -> copier la sélection et vous n'aurez pas les numéros de ligne non plus.
Enfin ça marche cheers . Merci Wink .

Maintenant j’aimerais savoir comment faire pour avoir les numéros de ligne avec (situé à gauche)

D’avance merci pour votre réponse.

Veuillez agréez mes sentiments respectueux.

Au revoir et bonne soirée.

serge4789
# Tropactif #

Masculin
Messages : 1061
Inscrit(e) le : 08/06/2009

http://lapince.forumotion.com
serge4789 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par Ea le Ven 26 Aoû 2011 - 19:51

Pour mettre une numérotation des lignes, il faudrait changer le code que vous mettez :

http://s301826463.onlinehome.fr/fdf/viewtopic.php?pid=10#p10

Dans ça à la place du :

Code:
<pre class="prettyprint" />
Il suffit de mettre :

Code:
<pre class="prettyprint linenums" />

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: La colorisation des codes ne fonctionne pas malgré avoir suivi le tuto

Message par serge4789 le Ven 26 Aoû 2011 - 20:19

Bonsoir et merci de m’avoir répondu,

Je vous dois une fière chandelle pour votre aide.

Sans vous, je n y serait pas arrivé.

Il faudrait que vous mettiez le tuto à jour quand-même en expliquant comment faire pour ajouter les chiffres.

Merci encore à vous. Merci mille fois !!! Wink cheers

Sujet à archiver.

Veuillez agréez mes sentiments respectueux.

Au revoir et bonne soirée à vous.


Dernière édition par serge4789 le Ven 26 Aoû 2011 - 20:53, édité 2 fois (Raison : EDIT)

serge4789
# Tropactif #

Masculin
Messages : 1061
Inscrit(e) le : 08/06/2009

http://lapince.forumotion.com
serge4789 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum