Diapo non visible avec IE9 seulement

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Diapo non visible avec IE9 seulement

Message par Boupette le Mar 23 Aoû 2011 - 17:38

Bonjour!
On a un diaporama en page d'accueil sur notre forum et on peut le voir avec tous les navigateurs mais pas avec IE9, quelqu'un sait pourquoi?


Dernière édition par Boupette le Jeu 25 Aoû 2011 - 16:49, édité 1 fois

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Diapo non visible avec IE9 seulement

Message par ge80 le Mar 23 Aoû 2011 - 17:49

Bonjour

Est-il possible d'avoir l'url du forum pour faire un test avec IE 9 ?

Cordialement,
Ge

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Mar 23 Aoû 2011 - 17:55

Certainement: http://aquamania.forum-canada.net/
Il y a un diapo tout en haut de la page d'accueil.

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Diapo non visible avec IE9 seulement

Message par ge80 le Mar 23 Aoû 2011 - 18:02

Problème confirmé.

IE 9 bloque avec l'affichage.

Certainement une option à changer.
Le mode de compatibilité ne change rien....

Quel est le principe utilisé pour le changement d'image ?


ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Mar 23 Aoû 2011 - 18:11

Que voulez-vous dire? C'est un Code HTML.

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Diapo non visible avec IE9 seulement

Message par ge80 le Mar 23 Aoû 2011 - 18:16

J'ai vu l'erreur.

SEC7112: Le script de http://aquamania.forum-canada.net/h1-banniere-aleatoire a été bloqué à cause d’une incompatibilité de type mime

IE9 n'aime pas votre script dans la page bannière aléatoire.

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Mar 23 Aoû 2011 - 18:18

Fou raide ça?!!!

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Diapo non visible avec IE9 seulement

Message par ge80 le Mar 23 Aoû 2011 - 18:22

A moins qu'un autre membre n'ait la réponse, il va falloir faire des tests....

Attendons un peu afin de voir si quelqu'un sur ce forum d'entraide a déjà résolu ce problème.

ETANA a répondu ici http://forum.forumactif.com/t306655-soucis-type-mime-du-selecteur-de-theme-sous-ie-9-chrome#2682165


ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Mar 23 Aoû 2011 - 18:26

Belle évolution de Microsoft encore une fois!!! scratch Je me demande s'ils savent pourquoi ils perdent tant de monde!? Mouais C'est juste un commentaire personnel! Clin d\'oeil

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Diapo non visible avec IE9 seulement

Message par ge80 le Mar 23 Aoû 2011 - 18:30

Si aucune réponse alors j'essaierai de changer la description et le type puis l'endroit d'ajout dans le forum.

Avec hébergement cela s'est résolu...

http://forum.forumactif.com/t306655-soucis-type-mime-du-selecteur-de-theme-sous-ie-9-chrome#2682148


A quel endroit l'avez-vous ajoutée (lier votre page html) ?

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Mar 23 Aoû 2011 - 18:35

Dans la Gestion des pages HTML.

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Diapo non visible avec IE9 seulement

Message par ge80 le Mar 23 Aoû 2011 - 18:37

Et votre page, l'avez-vous chargée ou liée à partir du champ description ou par une autre manière ?

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Mar 23 Aoû 2011 - 18:41

Je ne comprends pas votre langage mais j'ai prit le script à partir d'un post ici, j'ai mit les photos sur Servimg et placé l'Url sur le script et puis dans Gestion des pages HTML.

Je dois absolument quitter, je suis de retour dans 1 heure environ.

Merci pour tout.

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Diapo non visible avec IE9 seulement

Message par ge80 le Mar 23 Aoû 2011 - 18:46

L'avez-vous appelé de cet endroit ?

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Mar 23 Aoû 2011 - 22:04

Non

PA - Modules - HTML & JAVASCRIPT - Gestion des pages html

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Mer 24 Aoû 2011 - 5:09

Quelqu'un sait -il quoi faire?

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Diapo non visible avec IE9 seulement

Message par ge80 le Mer 24 Aoû 2011 - 7:49

@Boupette a écrit:Non

PA - Modules - HTML & JAVASCRIPT - Gestion des pages html

Non ceci est pour créer la page.

Donc cette page, sauf si c'est la page d'accueil de votre forum, doit être lié à votre forum par un code du genre
Code:
<script src=/h1-banniere-aleatoire></script>

A quel endroit avez-vous placé un code ressemblant ?



Sinon pour régler simplement le problème, faire le tuto
http://forum.forumactif.com/t223082-banniere-aleatoire-ou-defilante

qui utilise les pages javascript inclues dans votre forum.

Solution préférable à l'hébergement externe.

Il vous faudra enlever l'appel de votre page HTML donc répondre à la question ci-dessus Wink

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Mer 24 Aoû 2011 - 16:57

C'est la page d'accueil de mon forum comme mentionné dans le message initial. Moi j'ai simplement fait ce qu'on m'a dit de faire pour faire un diaporama sur ma page d'acccueil.

Qu'est-ce qu'un code ressemblant? Excusez mon ignorance mais je n'ai pas grand savoir en HTML et son langage.


Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Mer 24 Aoû 2011 - 17:02

Voici ce script qu'on m'a donné et j'ai mit l'URL des photos dedans:

var banner = new Array();

document.getElementById('i_logo').src= banner[Math.floor(Math.random()*banner.length)];

setInterval("document.getElementById('i_logo').src= banner[Math.floor(new Date().getTime()/5000)%banner.length];",6000);

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Diapo non visible avec IE9 seulement

Message par ge80 le Mer 24 Aoû 2011 - 17:08

@Boupette a écrit:Voici ce script qu'on m'a donné et j'ai mit l'URL des photos dedans:

Et ensuite vous avez fait quoi ???
C'est le point clef pour enlever ce que vous avez fait puis appliquer le nouveau tutoriel qui ne passe pas par une page html et sera compatible avec IE 9 Wink

OU quel est le tutoriel que vous avez suivi ?

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Mer 24 Aoû 2011 - 17:18

@Boupette a écrit:Dans la Gestion des pages HTML.

@Boupette a écrit:Non

PA - Modules - HTML & JAVASCRIPT - Gestion des pages html

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Mer 24 Aoû 2011 - 17:23

Probablement l'ancien tuto pcq celui-ci n'est plus le même. Atttendez que je cherche...

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Diapo non visible avec IE9 seulement

Message par ge80 le Mer 24 Aoû 2011 - 17:51

Après création de cette page, il fallait l'insérer dans votre forum.
Dans le champ description, dans un template ....

Les possibilités sont multiples.

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Jeu 25 Aoû 2011 - 3:04

Bon attendez moi je suis plus du tout.

J'étais co-admin d'un autre forum avant celui-ci, qui n'existe plus, on avait le même diaporama donc le même script. À la fermeture de ce forum j'ai été chercher le script et par la suite je l'ai collé sur ce forum-ci avec mes photos à moi. Il me semble que c'est ici sur le forum d'entraide qu'on avait prit le script sinon je ne sais où.

Maintenant je fais quoi avec ce script là. Peut-on m'expliquer dans les détails. Voici le script en question:

var banner = new Array();

banner.push('url de l'image');


document.getElementById('i_logo').src= banner[Math.floor(Math.random()*banner.length)];

setInterval("document.getElementById('i_logo').src= banner[Math.floor(new Date().getTime()/5000)%banner.length];",6000);

Merci

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Jeu 25 Aoû 2011 - 5:36


Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Diapo non visible avec IE9 seulement

Message par ge80 le Jeu 25 Aoû 2011 - 7:34

Bonjour

Je réitère.
Après création d'une page il faut la lier au forum.

Essayons de la trouver pour l'enlever et passer au nouveau tutoriel.

Regarder ici


Si ce champ est vide.....

Quels sont les templates modifiés ou de couleur verte ?


Cordialement,
Ge

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Jeu 25 Aoû 2011 - 15:55

Merci

- Dans la description du forum il y a le script de la bannière que j'ai créé:
<script type='text/javascript' src='http://aquamania.forum-canada.net/h1-banniere-aleatoire'></script>

- Rien de couleur verte dans les templates, je n'ai jamais été jouer là.

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Diapo non visible avec IE9 seulement

Message par ge80 le Jeu 25 Aoû 2011 - 15:58

Voilà, vous l'avez trouvé.

Je vous l'avez demandé un peu plus haut...
par ge80 le Mar 23 Aoû 2011 - 18:46
c'est la force des images Wink

Il faut enlever ce texte puis enregistrer

Maintenant votre page ne sera plus liée et vous n'aurez plus la bannière aléatoire.

Par contre.......
vous pourrez faire l'autre tutoriel qui passe par les pages javascript et qui devrait être compatible avec IE 9.

ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Diapo non visible avec IE9 seulement

Message par Boupette le Jeu 25 Aoû 2011 - 16:06

Alors je mets le même script dans Gestion des codes Javascript? Je l'ai fait hier pour testé et rien... ou est-ce que je dois mettre le nom du script, qui lui était en .js dans la définition du forum?

Boupette
****

Féminin
Messages : 345
Inscrit(e) le : 17/12/2006

http://aquamania.forum-canada.net  http://www.discus-discussions
Boupette a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Diapo non visible avec IE9 seulement

Message par ge80 le Jeu 25 Aoû 2011 - 16:12

Il y avait un conflit avec les deux scripts (page html et page javascript)

Un seul des deux doit exister.

Il n'y a rien à déclarer pour une page en JS.

Elle est lié automatiquement à la condition que votre template ne soit pas modifié.... car dans ce cas vous devez ajouter ceci
Code:
{HOSTING_JS}

Pour les membres ayant un forum en version PhpBB2 ou PunBB avec le templates overall_header modifié
le tuto http://forum.forumactif.com/t308422-nouveaute-forumactif-gestion-des-codes-javascript


ge80
+ Hyperactif +

Masculin
Messages : 16158
Inscrit(e) le : 08/10/2006

http://tsi80.pro-forums.fr/
ge80 a été remercié(e) par l'auteur de ce sujet.

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum