Problème de code css qui ne fonctionnent plus

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème de code css qui ne fonctionnent plus

Message par Nirwar le Mer 31 Aoû 2011 - 12:36

Bonjour,

Je vais essayer de faire court, sans trop oublier de chose.


J'ai donc modifié sur de multiples points, template et CSS, mais c'est seulement une récente modification qui met beaucoup de choses en l'air:

Voici une liste des modifs que j'ai fait jusqu'ici :

- barre de navigation tout en haut de la fenêtre, restant tout le temps en haut.
- Ajout de boutons sur toutes les fenêtres du forum, bougeant également avec la fenêtre.

Et voici la plus ressente modif :
- Transformation des catégories en bouton cliquable, n'affichant que la catégorie.

Problèmes :
La barre de navigation n'est plus tout en haut et ne suis plus le mouvement.
Les boutons ajoutés ne bougent plus non plus.

voici donc les parties de CSS qui ont été ajoutés ou modifiés :
Code:
Les boutons

          #menu_1 {
                        width: 72px;
                        height: 154px;
                        left: 30px;
                        position: fixed;
                        border: 0px solid #F3F3F3;
                        background-color: transparent;
                        color: #F3F3F3;
                        top: 43px;}
          #menu_2 {
                        width: 72px;
                        height: 154px;
                        left: 30px;
                        position: fixed;
                        border: 0px solid #F3F3F3;
                        background-color: transparent;
                        color: #F3F3F3;
                        top: 65px;}
          #menu_3 {
                        width: 72px;
                        height: 154px;
                        left: 30px;
                        position: fixed;
                        border: 0px solid #F3F3F3;
                        background-color: transparent;
                        color: #F3F3F3;
                        top: 87px;}
          #menu_4 {
                        width: 72px;
                        height: 154px;
                        left: 30px;
                        position: fixed;
                        border: 0px solid #F3F3F3;
                        background-color: transparent;
                        color: #F3F3F3;
                        top: 109px;}
          #menu_5 {
                        width: 72px;
                        height: 154px;
                        left: 30px;
                        position: fixed;
                        border: 0px solid #F3F3F3;
                        background-color: transparent;
                        color: #F3F3F3;
                        top: 131px;}
          #menu_6 {
                        width: 72px;
                        height: 154px;
                        left: 30px;
                        position: fixed;
                        border: 0px solid #F3F3F3;
                        background-color: transparent;
                        color: #F3F3F3;
                        top: 153px;}
          #menu_7 {
                        width: 72px;
                        height: 154px;
                        left: 30px;
                        position: fixed;
                        border: 0px solid #F3F3F3;
                        background-color: transparent;
                        color: #F3F3F3;
                        top: 175px;}

Code:
Barre de navigation

.navig {
        top: 0px;
        left: -1px;
        width: 101%;
        margin: 0px;
        position: fixed;
        background-color: #FFFFFF;
        }

Code:
Modif catégorie

____________________________CATEGORIES FORUM

.text
{
color: #000000; (couleur du texte)
}

#cat_0,#cat_1,#cat_2,#cat_3,#cat_4,#cat_5
{
padding-top:4px;
}

.spoiler_content { display: block; }
.hidden .spoiler_content { display: none; }

.cat_forum {
background-color: none ;
margin: auto;
margin-bottom:30px;
width:800px;
}

.onglet {
display:inline-block;
margin-top:30px;
text-decoration:none; !important
}

.onglet li {
float:left;
list-style-type:none;
margin-bottom:-22px;
text-decoration:none; !important
}

.onglet li:hover {
text-decoration:none; !important
}

.onglet li a {
display:block;
text-decoration:none; !important
list-style-type: none;
}

.onglet li a: hover {
text-decoration:none;
list-style-type:none;
}

.onglet_actif {
font-size: 12px ; (taille de la police)
margin-right: 5px ;
margin-left: 5px ;
background-color : none; (couleur de fond)
border : solid 0px #000000; (type de bordure, taille et couleur)
width: 130px; (largeur de l'onglet étant actif)
height: 20px; (hauteur de l'onglet étant actif)
-moz-border-radius-bottomleft:10px; (Si tu veux faire des arrondis avec la taille de l'arrondi, sinon tu vires ce code et les trois du dessous)
-moz-border-radius-bottomright:10px;
-moz-border-radius-topleft:10px;
-moz-border-radius-topright:10px;
}

.onglet_nactif {
font-size: 12px ; (taille de la police)
margin-right: 5px ;
margin-left: 5px ;
background-color : none; (couleur de fond)
border : solid 0px #000000; (type de bordure, taille et couleur)
width: 130px; (largeur de l'onglet étant inactif)
height: 20px; (hauteur de l'onglet étant inactif)
-moz-border-radius-bottomleft:10px; (Si tu veux faire des arrondis avec la taille de l'arrondi, sinon tu vires ce code et les trois du dessous)
-moz-border-radius-bottomright:10px;
-moz-border-radius-topleft:10px;
-moz-border-radius-topright:10px;
}

Jusqu'ici tout marchait bien et c'est bien le dernier code CSS qui sème la pagaille.
Je ne sais pas si vous avez quand même besoin des templates associés, si besoin est, je les ajouterai.

Merci de votre attention.


Dernière édition par Nirwar le Mer 31 Aoû 2011 - 14:37, édité 1 fois

Nirwar
Nouveau membre

Messages : 8
Inscrit(e) le : 31/07/2011

http://mostenfer-universe.forumgratuit.org
Nirwar a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code css qui ne fonctionnent plus

Message par AenigmA le Mer 31 Aoû 2011 - 13:03

Bonjour,
Au premier abord, enlève tous les commentaires
Logiquement
(couleur de fond)
devrait être
/* couleur de fond */

Pas sûr que ce soit cela mais essaie

AenigmA
+ Hyperactif +

Masculin
Messages : 2228
Inscrit(e) le : 10/03/2005

http://aenigma.forumactif.fr/
AenigmA a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code css qui ne fonctionnent plus

Message par Nirwar le Mer 31 Aoû 2011 - 13:09

En effet (comme vous l'avez noté, j'ai donc récupéré ce code ^^")

Je vous dit ce qu'il en ai sous peu

**EDIT**

Me voilà avec un code correctement écrit, mais ça ne change rien du tout au problème, malheureusement.

Merci quand même de votre aide ^^"

**Re-EDIT**

Problème résolut, simple problème de copier collé, j'avais effacé un truc qui n'allait pas, problème réglé donc !

Nirwar
Nouveau membre

Messages : 8
Inscrit(e) le : 31/07/2011

http://mostenfer-universe.forumgratuit.org
Nirwar a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum