Problème de script avec USERNAME

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème de script avec USERNAME

Message par amazonia-piranha le Ven 23 Sep 2011 - 14:26

bonjour,

j'ai un petit souci,
je voulais mettre dans mon qeel personnalisé un Bienvenu { USERNAME }
mais le code que j'ai fait ne marche pas, avez vous une idée de comment je doit procédé, pour que mon username marche ?

Code:

<td width="433" height="76"><b>Bienvenu </b>{USER&amp;#8288;NAME}
<span class="gensmall">{TOTAL_POSTS}


{TOTAL_USERS}


{NEWEST_USER}</span></td>

Merci d'avance !


Dernière édition par amazonia-piranha le Mar 27 Sep 2011 - 17:19, édité 1 fois

amazonia-piranha
***

Masculin
Messages : 195
Inscrit(e) le : 03/05/2011

http://www.amazonia-piranha.com/forum
amazonia-piranha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script avec USERNAME

Message par Chacha le Ven 23 Sep 2011 - 14:35

Bonjour amazonia-piranha

Dans votre code, vous avez :
Code:
{USER&amp;#8288;NAME}

Il faut remplacer par :
Code:
{USER NAME}
sans l'espace entre USER et NAME


Cordialement

Chacha
Modéractif
Modéractif

Masculin
Messages : 49718
Inscrit(e) le : 21/08/2010

http://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script avec USERNAME

Message par amazonia-piranha le Ven 23 Sep 2011 - 15:47

Oui c'est ce que j'ai fait chère Chacha, mais cela ne marche pas.

amazonia-piranha
***

Masculin
Messages : 195
Inscrit(e) le : 03/05/2011

http://www.amazonia-piranha.com/forum
amazonia-piranha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script avec USERNAME

Message par Ea le Ven 23 Sep 2011 - 15:49

Bonjour,


C'est une censure mise sur le fdf ce caractère ajouté ( il y en a beaucoup qui s'amusaient à mettre des {USERNAME} pour "troubler" les autres ).

Pour le premier post, ça ne fonctionne pas car ces variables ne fonctionnent pas dans les templates, si vous voulez vous pouvez utiliser cette astuce pour avoir le même résultat :
http://forum.forumactif.com/t260631-astuce-utiliser-les-variables-user-et-forum-autre

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script avec USERNAME

Message par amazonia-piranha le Ven 23 Sep 2011 - 16:04

Merci Etana je vais allé voir cela !

amazonia-piranha
***

Masculin
Messages : 195
Inscrit(e) le : 03/05/2011

http://www.amazonia-piranha.com/forum
amazonia-piranha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script avec USERNAME

Message par amazonia-piranha le Ven 23 Sep 2011 - 16:19

et bien j'ai utilisé les codes suivant du tuto et cela ne fonctionne toujours pas.

Code:

<script type="text/javascript" src="http://tinyurl.com/var-fa"></script>

et

Code:

<span class="USERNAME"></span>

voici mon QEEL :
Spoiler:
Code:

    <!-- BEGIN disable_viewonline -->
<table id="BKG" style="width: 1200px; height: 413px; background-image: url(http://img11.hostingpics.net/pics/484180forumline03.png);" border="0">
<tbody>
<tr>
<td height="70"></td>
<td></td>
<td> </td>
<td></td>
</tr>
<tr>
<td width="25" height="76"> </td>
<td width="433" height="76"><b>Bievenu </b><span class="USERNAME"></span><br><span class="gensmall">{TOTAL_POSTS}
<br />
{TOTAL_USERS}
<br />
{NEWEST_USER}</span></td>
<td width="258"> </td>
<td width="432"><img src="http://i45.servimg.com/u/f45/16/55/53/39/lagend14.png" /><br>
<span class="gensmall">{GROUP_LEGEND}</span></td>
</tr>
<tr>
<td width="25" height="63"> </td>
<td width="433" height="63"><span class="gensmall">{TOTAL_USERS_ONLINE}
<br />
{RECORD_USERS}
<br />
{LOGGED_IN_USER_LIST}</span></td>
<td rowspan="2" width="258"> </td>
<td width="432"><img src="http://i45.servimg.com/u/f45/16/55/53/39/dernie11.png" />
<br>
<span class="gensmall"><table>{L_CONNECTED_MEMBERS}</table></span>
<!-- BEGIN switch_chatbox_activate -->
         <span class="gensmall">{CHATTERS_LIST}
            <!-- BEGIN switch_chatbox_popup -->
            <div id="chatbox_popup"></div>
            <script type="text/javascript">
            //<![CDATA[
            insertChatBoxPopup('{disable_viewonline.switch_chatbox_activate.switch_chatbox_popup.U_FRAME_CHATBOX}', '{L_CLICK_TO_JOIN_CHAT}');
            //]]>
            </script>
            <!-- END switch_chatbox_popup -->
         </span>
<!-- END switch_chatbox_activate -->
</td>
</tr>
<tr>
<td width="25" height="92"> </td>
<td width="433" height="92"> </td>
<td rowspan="2" width="432"> </td>
<td width="30"></td>
</tr>
</tbody>
</table>
    <!-- END disable_viewonline -->

j'ai coller le script en bas de ma page dans :
Code:

    <!-- BEGIN username -->
<script type="text/javascript" src="http://tinyurl.com/var-fa"></script>
    <!-- END username -->

amazonia-piranha
***

Masculin
Messages : 195
Inscrit(e) le : 03/05/2011

http://www.amazonia-piranha.com/forum
amazonia-piranha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script avec USERNAME

Message par Ea le Ven 23 Sep 2011 - 17:30

Vous pouvez le laisser en place ?

Et il ne vaut mieux pas utiliser la syntaxe :

Code:
<!-- BEGIN expression -->
contenu
<!-- END expression -->
Car c'est la syntaxe de forumactif pour cacher des éléments qui ne doivent pas apparaître ou bien faire une boucle sur le contenu ( donc en tombant sur une "expression" utilisée par forumactif on pourrait avoir un résultat inattendu ).

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script avec USERNAME

Message par amazonia-piranha le Ven 23 Sep 2011 - 17:57

même sans cela, sa ne marche pas de toute façon.

amazonia-piranha
***

Masculin
Messages : 195
Inscrit(e) le : 03/05/2011

http://www.amazonia-piranha.com/forum
amazonia-piranha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script avec USERNAME

Message par Ea le Ven 23 Sep 2011 - 18:10

Et bien je ne sais pas, je ne le vois toujours pas sur votre forum ( ou alors c'est un autre que celui de votre profil ).

Sinon là ça marche très bien : http://citron.fruitsandco.com/variables-h51.htm donc il n'y a pas de raison que ça ne fonctionne pas ailleurs ^^

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script avec USERNAME

Message par amazonia-piranha le Ven 23 Sep 2011 - 18:18

non il sagit bien de celui de mon profil ! ^^
il ya bien le "Bienvenu" mais pas de pseudo a coter ! "-_-

amazonia-piranha
***

Masculin
Messages : 195
Inscrit(e) le : 03/05/2011

http://www.amazonia-piranha.com/forum
amazonia-piranha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script avec USERNAME

Message par Ea le Ven 23 Sep 2011 - 18:24

Maintenant je vois le script ^^

Donc je vois bien le "Invité" sur google chrome et firefox Interrog

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum