"Bug" avec un Templates sur IE

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu "Bug" avec un Templates sur IE

Message par Feu Ardent le Dim 2 Oct 2011 - 10:48

Bonjour (: Je viens à nouveau parler de ce templates x')

http://forum.forumactif.com/t312734-probleme-avec-les-categories-oui-encore-1-xd

En fait, le code marche à merveille sous Firefox & Safari, mais sur IE (du moins, les versions que j'utilise chez moi et que le lycée utilise) le code "buggue" et la page "bloque" juste en dessous de la PA :/

Screen:



Comme vous pouvez le voir, la page refuse de charger le contenu sous le premier forum, ainsi que la colonne du lien vers le dernier message, etc...

Lien du forum: http://liberty-island-rpg.forumgratuit.org/

Page d'Accueil: (On sait jamais si c'est une source du problème)

Code:
Supprimé pour éviter toute forme de plagiat

index_body:

Code:
<br>
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
   <tr>
      <td valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <span class="gensmall">{LAST_VISIT_DATE}

         {CURRENT_TIME}

         </span>
         <!-- END switch_user_logged_in -->
         <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a>

         <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a>

         <!-- END switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
   </tr>
</table>
<!-- BEGIN catrow --><!-- BEGIN tablehead -->
 <center><div class="secondarytitle">{catrow.tablehead.L_FORUM}
  </div><table class="catcadre" width="690" border="0" cellspacing="0" cellpadding="0">
  <!-- END tablehead -->
   <!-- BEGIN cathead -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
         <h{catrow.cathead.LEVEL} class="hierarchy">
            <span class="cattitle">
               <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
            </span>
         </h{catrow.cathead.LEVEL}>
      </td>
      <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right"> </td>
   </tr>
   <!-- END cathead -->
   <!-- BEGIN forumrow -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
      <!-- END inc -->
<td align="center" valign="middle">
        <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
      </td>
      <td colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="100%" height="50">
        <h{catrow.forumrow.LEVEL} class="hierarchy">
            <span class="forumlink">
              <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}"><center><div class="nomforums">{catrow.forumrow.FORUM_NAME}</div></center><div style="margin-top: -15px;"></div></a>

            </span>
        </h{catrow.forumrow.LEVEL}>
        <div class="descript"><span class="genmed">{catrow.forumrow.FORUM_DESC}</span></div>
        <span class="gensmall">
            <!-- BEGIN switch_moderators_links -->
            {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
            <!-- END switch_moderators_links -->
<span class="gensmall" id="subforums"><div class="soufo"><center>{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</center></span><script type="text/javascript">
    jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,' ')).removeAttr('id');
    </script>
        </div></span>
      <br></td>
      <td align="center" valign="middle" height="50"><div style="width:150px;">
        <span class="gensmall">{catrow.forumrow.LAST_POST}</span></div>
      </td>
   </tr>

   <!-- END forumrow -->
   <!-- BEGIN catfoot -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
   </tr>
   <!-- END catfoot -->
   <!-- BEGIN tablefoot -->
</table><img src="{SPACER}" alt="" height="5" width="1" /></center><!-- END tablefoot --><!-- END catrow -->

<br>

CSS:

Code:
Supprimé pour éviter toute forme de plagiat

Merci d'avance de m'aider à trouver la source du problème, ou à compatibiliser mon forum avec IE car je ne vois pas ce qui pourrait emp6echer le forum de s'afficher :S (Les templates et moi... XDD)

Bonne journée (:


Dernière édition par Feu Ardent le Dim 2 Oct 2011 - 14:14, édité 2 fois
avatar

Feu Ardent
**

Masculin
Messages : 77
Inscrit(e) le : 29/08/2010

http://asreyd.jeunforum.com
Feu Ardent a été remercié(e) par l'auteur de ce sujet.

Résolu Re: "Bug" avec un Templates sur IE

Message par SoraNoHime le Dim 2 Oct 2011 - 11:06

Bonjour ^^

Vous utilisez quelle version de IE ? Pour moi avoir le rendu adéquat

Cordialement.
avatar

SoraNoHime
Membre actif

Féminin
Messages : 6218
Inscrit(e) le : 10/06/2010

http://fanasiacodes.bbfr.net/
SoraNoHime a été remercié(e) par l'auteur de ce sujet.

Résolu Re: "Bug" avec un Templates sur IE

Message par Threax le Dim 2 Oct 2011 - 12:04

Bonjour,

IE donne les détails de l'erreur :
Détails de l’erreur de la page Web

Horodateur : Sun, 2 Oct 2011 09:55:26 UTC
Message : HTML Parsing Error: Unable to modify the parent container element before the child element is closed (KB927917)
URI : http://liberty-island-rpg.forumgratuit.org/

Vous avez bourré des script un peu partout pour remplacer tels ou tels mots, et certains sont un peu limites, du genre :
Code:
<span><div id="truc"><center>... </center></span><script></script></div>
IE n'aime pas trop les fermetures inversées des balises, et encore moins quand un script agit dessus... Vérifiez vos différents scripts, et essayez d'éclaircir un peu ça. Smile
avatar

Threax
Membre actif

Masculin
Messages : 17277
Inscrit(e) le : 27/08/2005

http://lesforumsde.forumactif.com
Threax a été remercié(e) par l'auteur de ce sujet.

Résolu Re: "Bug" avec un Templates sur IE

Message par Feu Ardent le Dim 2 Oct 2011 - 12:29

Macema => ^^ En effet x')

J'ai la version 8, après vérification (:

Threax => Je crains que je n'ai pas très bien compris. ^^"
avatar

Feu Ardent
**

Masculin
Messages : 77
Inscrit(e) le : 29/08/2010

http://asreyd.jeunforum.com
Feu Ardent a été remercié(e) par l'auteur de ce sujet.

Résolu Re: "Bug" avec un Templates sur IE

Message par SoraNoHime le Dim 2 Oct 2011 - 13:52

Pour ce dont vous parle Threax repérez déjà :
Code:
<span class="gensmall" id="subforums"><div class="soufo"><center>{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</center></span><script type="text/javascript">
    jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,' ')).removeAttr('id');
    </script>
        </div>

changez le ainsi :
Code:
<div class="soufo" align="center"><span class="gensmall" id="subforums">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</span><script type="text/javascript">
    jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,' ')).removeAttr('id');
    </script>
        </div>

Avez-vous également modifié votre template index_body (le premier donné était l'index_box) ?

Cordialement.
avatar

SoraNoHime
Membre actif

Féminin
Messages : 6218
Inscrit(e) le : 10/06/2010

http://fanasiacodes.bbfr.net/
SoraNoHime a été remercié(e) par l'auteur de ce sujet.

Résolu Re: "Bug" avec un Templates sur IE

Message par Feu Ardent le Dim 2 Oct 2011 - 14:13

Oui, j'ai modifié index_body, cependant, ça marche maintenant. ^^ Merci infiniment Macema, vous m'avez aidé du début jusqu'à la fin, apparament. Wink

Résolu Wink
avatar

Feu Ardent
**

Masculin
Messages : 77
Inscrit(e) le : 29/08/2010

http://asreyd.jeunforum.com
Feu Ardent a été remercié(e) par l'auteur de ce sujet.

Résolu Re: "Bug" avec un Templates sur IE

Message par SoraNoHime le Dim 2 Oct 2011 - 14:21

victoire J'assure le service après vente XD

Bonne journée.
avatar

SoraNoHime
Membre actif

Féminin
Messages : 6218
Inscrit(e) le : 10/06/2010

http://fanasiacodes.bbfr.net/
SoraNoHime a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum