pb tableau PA avec onglets

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu pb tableau PA avec onglets

Message par xyz, le dernier recours le Ven 14 Oct 2011 - 14:05

Bonjour Fofoactif!

Alors voilà, je souhaiterai mettre un tableau en page d'accueil avec onglets. J'ai suivi le tuto dessus mais j'ai un problème, j'obtiens ça:
Spoiler:

J'ai tenté le tableau à onglets horizontal, et aussi le vertical mais le problème reste le même, je n'ai pas tous les onglets qui s'alignent dans leurs cases. Confused

J'ai installé à côté des catégories sous onglets aussi. Est-il possible que cela gêne?

mon javascript:
Spoiler:

function changeOnglet(_this){
var getOnglets = document.getElementById('mes_onglets').getElementsByTagName('li');
for(var i = 0; i < getOnglets.length; i++){
if(getOnglets[i].id){
if(getOnglets[i].id == _this.id){
getOnglets[i].className = 'mon_onglet_selected';
document.getElementById('c' + _this.id).style.display = 'block';
}
else{
getOnglets[i].className = 'mon_onglet';
document.getElementById('c' + getOnglets[i].id).style.display = 'none';
}
}
}
}

mon ccs :
Spoiler:

body{
background-repeat:no-repeat;
background-attachment:fixed;
}


* catégorie en onglets/

.my_modified_table{
width: 80%;
margin-left: 10%;
margin-right: 10%;
margin-top: 5px !important;

font-family: Verdana;
}

.my_forum_name{
display:none;
}
.my_img{
width: 10%;
margin-left: 50px;
}
.my_disc{
width: 70%;
text-align:center;
font-size: 15px;
}
.my_stats{

width: 20%;
text-align:center;
}

.myfoo_title{
text-align:center;
width: 100%;
-moz-border-radius: 6px;
border: 4px solid #EAEAEA;

}
.my_title{
text-align:center;
font-size: 16px;
font-family: Arial;
}

.my_cat_body{
border: 3px solid #EEE;
-moz-border-radius: 6px;

}

.my_cat ul{
margin:0;
padding: 0;
width: 800px !important;
}
.my_cat li{
margin-left: 5px;
}
.my_cat_style{
border-top: 1px #666 solid;
border-left: 1px #666 solid;
border-right: 1px #666 solid;
-moz-border-radius-topleft: 6px;
-moz-border-radius-topright: 6px;
text-align:center;
font-size: 14px;
padding-left:10px;
padding-right:10px;
display:inline;
background-color: #EAEAEA;
width: 200px;
font-family: Arial;
font-weight: bold;

}
.my_cat a{
text-decoration: none !important;
color: #000;
}

*onglets tableau/


.mon_onglet{
float: left;
padding: 2px 10px;
margin-right: 5px;
color: #000;
background: #fff;
border: 1px solid #000;
cursor: pointer;
margin-bottom: -1px;
list-style: none;
}
.mon_onglet:hover{
background: #b8efa1;
}
.mon_onglet_selected{
float: left;
padding: 2px 10px;
margin-right: 5px;
color: #000;
background: #fff;
border-top: 1px solid #000;
border-right: 1px solid #000;
border-left: 1px solid #000;
border-bottom: 1px solid #fff;
cursor: pointer;
margin-bottom: -1px;
list-style: none;}
.clear{
clear: both;
}
.mon_contenu{
color: #000;
background: #fff;
border: 1px solid #000;
padding: 10px;
line-height: normal;
font-size: 11px;}
#mes_contenus, #mes_onglets{
width: 400px;
margin: auto;}

mon HTML!
Spoiler:




  • Onglet 1

  • Onglet 2

  • Onglet 3

  • Onglet 4

    Mon contenu 1
    Mon contenu 2
    Mon contenu 3
    Mon contenu 4




C'est quoi qui bugue svp?


Dernière édition par xyz, le dernier recours le Lun 17 Oct 2011 - 15:21, édité 1 fois

xyz, le dernier recours
**

Féminin
Messages : 84
Inscrit(e) le : 01/08/2009

http://xyzledernierrecours.forumactif.org/forum.htm
xyz, le dernier recours a été remercié(e) par l'auteur de ce sujet.

Résolu Re: pb tableau PA avec onglets

Message par SoraNoHime le Dim 16 Oct 2011 - 0:05

Bonsoir Paty

il manque certains points de la css, parties en rouge à replacer :

.mon_onglet{
display : inline;

float: left;
padding: 2px 10px;
margin-right: 5px;
color: #000;
background: #fff;
border: 1px solid #000;
cursor: pointer;
margin-bottom: -1px;
list-style: none;
}
.mon_onglet:hover{
display : inline;

background: #b8efa1;
}
.mon_onglet_selected{
display : inline;

float: left;
padding: 2px 10px;
margin-right: 5px;
color: #000;
background: #fff;
border-top: 1px solid #000;
border-right: 1px solid #000;
border-left: 1px solid #000;
border-bottom: 1px solid #fff;
cursor: pointer;
margin-bottom: -1px;
list-style: none;}
.clear{
clear: both;
}

Cordialement.

SoraNoHime
+ Hyperactif +

Féminin
Messages : 6218
Inscrit(e) le : 10/06/2010

http://fanasiacodes.bbfr.net/
SoraNoHime a été remercié(e) par l'auteur de ce sujet.

Résolu Re: pb tableau PA avec onglets

Message par xyz, le dernier recours le Dim 16 Oct 2011 - 15:04

salut Cma

merci de te pencher sur mon problème u_u.
alors j'ai fait tes changements et le visuel au final reste le même. Il y a forcément un truc pour que cela me fasse un tel schmilblick! je n'ai pas tous les onglets alignés c'est bizarre. Confused

voici mon index body

Spoiler:
{JAVASCRIPT}
<!-- BEGIN message_admin_index -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
<!-- BEGIN message_admin_titre -->
<tr>
<td class="catHead" height="28"><span class="cattitle">{message_admin_index.message_admin_titre.MES_TITRE}</span></td>
</tr>
<!-- END message_admin_titre -->
<!-- BEGIN message_admin_txt -->
<tr>
<td class="row1" rowspan="3" align="center" valign="middle">
<div class="gensmall">{message_admin_index.message_admin_txt.MES_TXT}</div>
</td>
</tr>
<!-- END message_admin_txt -->
</table>
<!-- END message_admin_index -->

<!-- BEGIN switch_user_login_form_header -->
<form action="{S_LOGIN_ACTION}" method="post" name="form_login">
<!-- BEGIN switch_fb_connect_no -->
<table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
<tr>
<td class="row1" align="center">
<table border="0" cellspacing="0" cellpadding="0">
<tr>
<td><span class="genmed">{L_USERNAME}:</span> </td>
<td><input class="post" type="text" size="10" name="username"/> </td>
<td>
<input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
<span class="gensmall">{L_AUTO_LOGIN}</span> 
</td>
</tr>

<tr>
<td><span class="genmed">{L_PASSWORD}:</span> </td>
<td><input class="post" type="password" size="10" name="password"/> </td>
<td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
</tr>
</table>
</td>
</tr>
</table>
<!-- END switch_fb_connect_no -->

<!-- BEGIN switch_fb_connect -->
<table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
<tr>
<td valign="top" width="100%" class="row1" align="center">
<table width="100%">
<tr>
<td width="55%" valign="middle" align="right">
<table class="right">
<tr>
<td><span class="genmed">{L_USERNAME}:</span> </td>
<td><input class="post" type="text" size="10" name="username"/> </td>
<td>
<input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
<span class="gensmall">{L_AUTO_LOGIN}</span> 
</td>
</tr>

<tr>
<td><span class="genmed">{L_PASSWORD}:</span> </td>
<td><input class="post" type="password" size="10" name="password"/> </td>
<td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
</tr>
</table>
</td>
<td width="10%" align="center" valign="middle">
<span class="genmed fb_or">{switch_user_login_form_header.switch_fb_connect.L_OR}</span>
</td>
<td width="35%" class="align_gauche"><fb:login-button size="large" onlogin="window.location='/facebook_connect.forum'" v="2" perms="{switch_user_login_form_header.switch_fb_connect.L_FB_PERMISSIONS}">{switch_user_login_form_header.switch_fb_connect.L_FB_LOGIN_BUTTON}</fb:login-button></td>
</tr>
</table>
</td>
</tr>
</table>
<!-- END switch_fb_connect -->
</form>
<!-- END switch_user_login_form_header -->

{CHATBOX_TOP}
{BOARD_INDEX}
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td width="50%" valign="top">
<!-- BEGIN switch_user_logged_in -->
<span class="gensmall"><a href="{U_MARK_READ}" class="gensmall">{L_MARK_FORUMS_READ}</a>
<!-- END switch_user_logged_in -->
<!-- BEGIN switch_delete_cookies -->
<br /><a href="{switch_delete_cookies.U_DELETE_COOKIES}" class="gensmall">{switch_delete_cookies.L_DELETE_COOKIES}</a>
<!-- END switch_delete_cookies -->
</span>
</td>
<td width="50%" align="right">
<span class="gensmall">
<a href="{U_TODAY_ACTIVE}" class="gensmall">{L_TODAY_ACTIVE}</a><br />
<a href="{U_TODAY_POSTERS}" class="gensmall">{L_TODAY_POSTERS}</a><br />
<a href="{U_OVERALL_POSTERS}" class="gensmall">{L_OVERALL_POSTERS}</a>
<!-- BEGIN switch_on_index -->
<!-- BEGIN switch_delete_cookies -->
<br /><a href="{switch_on_index.switch_delete_cookies.U_DELETE_COOKIES}" class="gensmall">{switch_on_index.switch_delete_cookies.L_DELETE_COOKIES}</a>
<!-- END switch_delete_cookies -->
<!-- END switch_on_index -->
</span>
</td>
</tr>
</table>

<!-- BEGIN switch_user_login_form_footer -->
<form action="{S_LOGIN_ACTION}" method="post" name="form_login">
<!-- BEGIN switch_fb_connect_no -->
<table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
<tr>
<td class="row1" align="center">
<table border="0" cellspacing="0" cellpadding="0">
<tr>
<td><span class="genmed">{L_USERNAME}:</span> </td>
<td><input class="post" type="text" size="10" name="username"/> </td>
<td>
<input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
<span class="gensmall">{L_AUTO_LOGIN}</span> 
</td>
</tr>

<tr>
<td><span class="genmed">{L_PASSWORD}:</span> </td>
<td><input class="post" type="password" size="10" name="password"/> </td>
<td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
</tr>
</table>
</td>
</tr>
</table>
<!-- END switch_fb_connect_no -->

<!-- BEGIN switch_fb_connect -->
<table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
<tr>
<td valign="top" width="100%" class="row1" align="center">
<table width="100%">
<tr>
<td width="55%" valign="middle">
<table class="right">
<tr>
<td><span class="genmed">{L_USERNAME}:</span> </td>
<td><input class="post" type="text" size="10" name="username"/> </td>
<td>
<input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
<span class="gensmall">{L_AUTO_LOGIN}</span> 
</td>
</tr>

<tr>
<td><span class="genmed">{L_PASSWORD}:</span> </td>
<td><input class="post" type="password" size="10" name="password"/> </td>
<td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
</tr>
</table>
</td>
<td width="10%" align="center" valign="middle">
<span class="genmed fb_or">{switch_user_login_form_footer.switch_fb_connect.L_OR}</span>
</td>
<td width="35%" class="align_gauche"><fb:login-button size="large" onlogin="window.location='/facebook_connect.forum'" v="2" perms="{switch_user_login_form_footer.switch_fb_connect.L_FB_PERMISSIONS}">{switch_user_login_form_footer.switch_fb_connect.L_FB_LOGIN_BUTTON}</fb:login-button></td>
</tr>
</table>
</td>
</tr>
</table>
<!-- END switch_fb_connect -->
</form>
<!-- END switch_user_login_form_footer -->

<!-- BEGIN disable_viewonline -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
<tr>
<td class="catHead" colspan="2" height="28">
<!-- BEGIN switch_viewonline_link -->
<span class="cattitle"><a class="cattitle" href="{U_VIEWONLINE}" rel="nofollow">{L_WHO_IS_ONLINE}</a></span>
<!-- END switch_viewonline_link -->

<!-- BEGIN switch_viewonline_nolink -->
<span class="cattitle">{L_WHO_IS_ONLINE}</span>
<!-- END switch_viewonline_nolink -->
</td>
</tr>
<tr>
<td class="row1" rowspan="6" align="center" valign="middle"><img src="{L_ONLINE_IMG}" id="i_whosonline" alt="{L_WHO_IS_ONLINE}" /></td>
<td class="row1" width="100%"><span class="gensmall">{TOTAL_POSTS}<br />
{TOTAL_USERS}<br />
{NEWEST_USER}</span></td>
</tr>
<tr>
<td class="row1"><span class="gensmall">{TOTAL_USERS_ONLINE}<br />
{RECORD_USERS}<br />
<br />
{LOGGED_IN_USER_LIST}</span></td>
</tr>
{L_CONNECTED_MEMBERS}
{L_WHOSBIRTHDAY_TODAY}
{L_WHOSBIRTHDAY_WEEK}
<tr>
<td class="row1"><span class="gensmall">{LEGEND} : {GROUP_LEGEND}</span></td>
</tr>
<!-- BEGIN switch_chatbox_activate -->
<tr>
<td class="row1">
<span class="gensmall">{TOTAL_CHATTERS_ONLINE} :  {CHATTERS_LIST}<br />
<!-- BEGIN switch_chatbox_popup -->
<div id="chatbox_popup"></div>
<script type="text/javascript">
//<![CDATA[
insertChatBoxPopup('{disable_viewonline.switch_chatbox_activate.switch_chatbox_popup.U_FRAME_CHATBOX}', '{L_CLICK_TO_JOIN_CHAT}');
//]]>
</script>
<!-- END switch_chatbox_popup -->
</span>
</td>
</tr>
<!-- END switch_chatbox_activate -->
</table>
<!-- END disable_viewonline -->
{CHATBOX_BOTTOM}
<br clear="all" />
<!-- BEGIN switch_legend -->
<table border="0" cellspacing="3" cellpadding="0" align="center">
<tr>
<td align="center" width="20"><img src="{FORUM_NEW_IMG}" alt="{L_NEW_POSTS}" /></td>
<td><span class="gensmall">{L_NEW_POSTS}</span></td>
<td></td>
<td align="center" width="20"><img src="{FORUM_IMG}" alt="{L_NO_NEW_POSTS}" /></td>
<td><span class="gensmall">{L_NO_NEW_POSTS}</span></td>
<td>  </td>
<td align="center" width="20"><img src="{FORUM_LOCKED_IMG}" alt="{L_FORUM_LOCKED}" /></td>
<td><span class="gensmall">{L_FORUM_LOCKED}</span></td>
</tr>
</table>
<!-- END switch_legend -->

{AUTO_DST}

<!-- BEGIN switch_fb_index_login -->
<div id="fb-root"></div>
<script type="text/javascript">
//<![CDATA[
FB.init({
appId: '{switch_fb_index_login.FACEBOOK_APP_ID}',
status: true,
cookie: true,
xfbml: true
});
//]]>
</script>
<!-- END switch_fb_index_login -->

Peut-être est-ce ici que ça bloque...

xyz, le dernier recours
**

Féminin
Messages : 84
Inscrit(e) le : 01/08/2009

http://xyzledernierrecours.forumactif.org/forum.htm
xyz, le dernier recours a été remercié(e) par l'auteur de ce sujet.

Résolu Re: pb tableau PA avec onglets

Message par SoraNoHime le Dim 16 Oct 2011 - 15:05

Tu testes sur XYZ directement ou ailleurs ?

et là c'est pour les onglets forum ou tableaux qu'il reste un pépin ?

PS : peux-tu mettre sous format code tes codages ?
Code:
[/color]au début[color=red]
à la fin ^^ ça sera plus visible Mr. Green

Edit : suis passée voir et j'ai pigé le blème Wink tu as décrit tes options dans la css ainsi :
*tableau onglet/
hors pour décrire c'est
/* description */
c'est cela qui bloque tes codes, avec en plus des
display:inline-block;
à la place des
display:inline;
que je t'avais fournies ça marche impec voir mon forum test.


Dernière édition par Macema le Dim 16 Oct 2011 - 18:08, édité 2 fois

SoraNoHime
+ Hyperactif +

Féminin
Messages : 6218
Inscrit(e) le : 10/06/2010

http://fanasiacodes.bbfr.net/
SoraNoHime a été remercié(e) par l'auteur de ce sujet.

Résolu Re: pb tableau PA avec onglets

Message par xyz, le dernier recours le Dim 16 Oct 2011 - 18:00

le slash et l'étoile ok u_u a c'est fait!
les inline c'est fait

sauf que j'obtiens ceci:


l'encadré du contenu n'est pas rattaché! mdr! désolé mais je n'ai pas encore atteint ton résultat de ton fofo test mais on avance, j'ai les onglets!

PS: j'ai pas compris ton histoire de début et de fin! dwarf

xyz, le dernier recours
**

Féminin
Messages : 84
Inscrit(e) le : 01/08/2009

http://xyzledernierrecours.forumactif.org/forum.htm
xyz, le dernier recours a été remercié(e) par l'auteur de ce sujet.

Résolu Re: pb tableau PA avec onglets

Message par SoraNoHime le Dim 16 Oct 2011 - 18:04

Tu avais choisi quel tableau dans le tuto de base ? 1, 2 ou 3 ?

Tu as un conflit avec le dédikass, quand on cliques sur un onglet on à l'ouverture d'une page vers le site de ce widget, essaie déjà de les intervertir.

repasse moi ta css actuelle, que je vois la différence avec la mienne. ^^

edit : pour le début et la fin 'ai eu un problème d'affichage bbcode Mr. Green en gros 'aimerai que tu me mettes sous balises code ^^

SoraNoHime
+ Hyperactif +

Féminin
Messages : 6218
Inscrit(e) le : 10/06/2010

http://fanasiacodes.bbfr.net/
SoraNoHime a été remercié(e) par l'auteur de ce sujet.

Résolu Re: pb tableau PA avec onglets

Message par xyz, le dernier recours le Dim 16 Oct 2011 - 18:14

la voici, j'ai pris la une

Spoiler:
body{
background-repeat:no-repeat;
background-attachment:fixed;
}

/* Pour agrandir la police de la chatbox*/

.chatbox_row_1,
.chatbox_row_2,
.chatbox_row_3,
.chatbox_row_1 a,
.chatbox_row_2 a,
.chatbox_row_3 a {
color: red;
font-size: 14px;
}

/*onglets catégories*/

.my_modified_table{
width: 80%;
margin-left: 10%;
margin-right: 10%;
margin-top: 5px !important;

font-family: Verdana;
}

.my_forum_name{
display:none;
}
.my_img{
width: 10%;
margin-left: 50px;
}
.my_disc{
width: 70%;
text-align:center;
font-size: 15px;
}
.my_stats{

width: 20%;
text-align:center;
}

.myfoo_title{
text-align:center;
width: 100%;
-moz-border-radius: 6px;
border: 4px solid #EAEAEA;

}
.my_title{
text-align:center;
font-size: 16px;
font-family: Arial;
}

.my_cat_body{
border: 3px solid #EEE;
-moz-border-radius: 6px;

}

.my_cat ul{
margin:0;
padding: 0;
width: 800px !important;
}
.my_cat li{
margin-left: 5px;
}
.my_cat_style{
border-top: 1px #666 solid;
border-left: 1px #666 solid;
border-right: 1px #666 solid;
-moz-border-radius-topleft: 6px;
-moz-border-radius-topright: 6px;
text-align:center;
font-size: 14px;
padding-left:10px;
padding-right:10px;
display:inline;
background-color: #EAEAEA;
width: 200px;
font-family: Arial;
font-weight: bold;

}
.my_cat a{
text-decoration: none !important;
color: #000;
}

/*onglets tableau*/


.mon_onglet{
display : inline;
float: left;
padding: 2px 10px;
margin-right: 5px;
color: #000;
background: #fff;
border: 1px solid #000;
cursor: pointer;
margin-bottom: -1px;
list-style: none;
}
.mon_onglet:hover{
display : inline;
background: #b8efa1;
}
.mon_onglet_selected{
display : inline;
float: left;
padding: 2px 10px;
margin-right: 5px;
color: #000;
background: #fff;
border-top: 1px solid #000;
border-right: 1px solid #000;
border-left: 1px solid #000;
border-bottom: 1px solid #fff;
cursor: pointer;
margin-bottom: -1px;
list-style: none;}
.clear{
clear: both;
}

j'ai interverti le dedicass. j'ai constaté aussi ce problème. je vois pas de changement.

xyz, le dernier recours
**

Féminin
Messages : 84
Inscrit(e) le : 01/08/2009

http://xyzledernierrecours.forumactif.org/forum.htm
xyz, le dernier recours a été remercié(e) par l'auteur de ce sujet.

Résolu Re: pb tableau PA avec onglets

Message par SoraNoHime le Dim 16 Oct 2011 - 18:23

Pour ton dédikass c'est quel genre de code ? un lien, un iframe , un embed, une image dynamique ?

il pose problème au niveau du script aussi du coup, ton tableau ne change pas.

Mets déjà cette css à la place de celle que tu m'as donnée.
Code:
body{
background-repeat:no-repeat;
background-attachment:fixed;
}

/* Pour agrandir la police de la chatbox*/

.chatbox_row_1,
.chatbox_row_2,
.chatbox_row_3,
.chatbox_row_1 a,
.chatbox_row_2 a,
.chatbox_row_3 a {
color: red;
font-size: 14px;
}

/*onglets catégories*/

.my_modified_table{
width: 80%;
margin-left: 10%;
margin-right: 10%;
margin-top: 5px !important;

font-family: Verdana;
}

.my_forum_name{
display:none;
}
.my_img{
width: 10%;
margin-left: 50px;
}
.my_disc{
width: 70%;
text-align:center;
font-size: 15px;
}
.my_stats{

width: 20%;
text-align:center;
}

.myfoo_title{
text-align:center;
width: 100%;
-moz-border-radius: 6px;
border: 4px solid #EAEAEA;

}
.my_title{
text-align:center;
font-size: 16px;
font-family: Arial;
}

.my_cat_body{
border: 3px solid #EEE;
-moz-border-radius: 6px;

}

.my_cat ul{
margin:0;
padding: 0;
width: 800px !important;
}
.my_cat li{
margin-left: 5px;
}
.my_cat_style{
border-top: 1px #666 solid;
border-left: 1px #666 solid;
border-right: 1px #666 solid;
-moz-border-radius-topleft: 6px;
-moz-border-radius-topright: 6px;
text-align:center;
font-size: 14px;
padding-left:10px;
padding-right:10px;
display:inline;
background-color: #EAEAEA;
width: 200px;
font-family: Arial;
font-weight: bold;

}
.my_cat a{
text-decoration: none !important;
color: #000;
}

/*onglets tableau*/


.mon_onglet{
display : inline-block;
float: left;
padding: 2px 10px;
margin-right: 5px;
color: #000;
background: #fff;
border: 1px solid #000;
cursor: pointer;
margin-bottom: -1px;
list-style: none;
}
.mon_onglet:hover{
display : inline-block;
background: #b8efa1;
}
.mon_onglet_selected{
display : inline-block;
float: left;
padding: 2px 10px;
margin-right: 5px;
color: #000;
background: #fff;
border-top: 1px solid #000;
border-right: 1px solid #000;
border-left: 1px solid #000;
border-bottom: 1px solid #fff;
cursor: pointer;
margin-bottom: -1px;
list-style: none;}
.clear{
clear: both;
}
        .mon_contenu{
          color: #000;
          background: #fff;
          border: 1px solid #000;
          padding: 10px;
          line-height: normal;
          font-size: 11px;}
        #mes_contenus, #mes_onglets{
          width: 400px;
          margin: auto;}

SoraNoHime
+ Hyperactif +

Féminin
Messages : 6218
Inscrit(e) le : 10/06/2010

http://fanasiacodes.bbfr.net/
SoraNoHime a été remercié(e) par l'auteur de ce sujet.

Résolu Re: pb tableau PA avec onglets

Message par xyz, le dernier recours le Dim 16 Oct 2011 - 18:26

un embed je crois le voilà
Spoiler:

<br><br><script src="http://www.dedikass.com/script.php?id=33243"></script>
<noscript><a href="http://www.dedikass.com" target="_blank">ShootBox</a></noscript><a href="http://www.dedikass.com" target="_blank"><br>

xyz, le dernier recours
**

Féminin
Messages : 84
Inscrit(e) le : 01/08/2009

http://xyzledernierrecours.forumactif.org/forum.htm
xyz, le dernier recours a été remercié(e) par l'auteur de ce sujet.

Résolu Re: pb tableau PA avec onglets

Message par SoraNoHime le Dim 16 Oct 2011 - 18:34

il manque </a> à la fin de ton code pour pas qu'il empiète sur le tableau ^^

SoraNoHime
+ Hyperactif +

Féminin
Messages : 6218
Inscrit(e) le : 10/06/2010

http://fanasiacodes.bbfr.net/
SoraNoHime a été remercié(e) par l'auteur de ce sujet.

Résolu Re: pb tableau PA avec onglets

Message par xyz, le dernier recours le Dim 16 Oct 2011 - 18:42

l'ensemble est ok mais j'ai constaté deux autres problèmes!
- quand je clique sur un onglet ( 2 , 3 ou 4), le contenu de cet onglet ne s'affiche pas, je reste sur le contenu 1! Rolling Eyes ( on va y arriver tu crois?)
-comment on agrandit ce merveilleux tableau que j'ai tant de mal à mettre en place?

xyz, le dernier recours
**

Féminin
Messages : 84
Inscrit(e) le : 01/08/2009

http://xyzledernierrecours.forumactif.org/forum.htm
xyz, le dernier recours a été remercié(e) par l'auteur de ce sujet.

Résolu Re: pb tableau PA avec onglets

Message par SoraNoHime le Dim 16 Oct 2011 - 19:28

Déjà pour agrandir le tableau, il faut placer ce que tu veux mettre dedans, ça va déjà prendre en longueur, ensuite pour la largeur change ici :
#mes_contenus, #mes_onglets{
width: 400px;
margin: auto;}

par
#mes_contenus, #mes_onglets{
width: 100%;
margin: auto;}

pour le tableau scratch bizarre , tu as bien installé le code dans le javascript, avec option cochée sur l'index (si dans PA > Affichage > Structures & Hiérarchie tu as mis voir les statistiques sur l'index) ou sur toutes les pages (si cette fois c'est mis sur tout le temps) ? Ton forum me dit qu'il n'y en a pas d'attaché. Avais-tu l'overall_header modifié au moment de la mise en place de la gestion des javascripts ? voir cette annonce : http://forum.forumactif.com/t308422-

SoraNoHime
+ Hyperactif +

Féminin
Messages : 6218
Inscrit(e) le : 10/06/2010

http://fanasiacodes.bbfr.net/
SoraNoHime a été remercié(e) par l'auteur de ce sujet.

Résolu Re: pb tableau PA avec onglets

Message par xyz, le dernier recours le Lun 17 Oct 2011 - 15:20

effectivement je n'avais pas vu ce lien et maintenant ça fonctionne.

Merci cma.

Je vais voir maintenant pour customiser tout cela.^^

xyz, le dernier recours
**

Féminin
Messages : 84
Inscrit(e) le : 01/08/2009

http://xyzledernierrecours.forumactif.org/forum.htm
xyz, le dernier recours a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum