Script qui ne fonctionne pas dans le message d'accueil

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Script qui ne fonctionne pas dans le message d'accueil

Message par ludoloveisa le Lun 17 Oct 2011 - 21:48

Coucou Very Happy

Voila on m'a fait ce code pour page d’accueil a onglet ( 4 exactement)

Code:
<head>
<style type="text/css">

span{
  float:left;
  padding:12px;
  }

.bloc_texte{
  position:absolute;
  left:12px;
  top:60px;
  width :560px;
  height:400px;
  background-color: #18B2F4;
  border:1px solid black;
  -webkit-border-radius: 20px;
  -moz-border-radius: 20px;
  border-radius: 20x;
  }

.titre{
  font-size:14px;
  background-color:#013CFE;
  color:#FEFEFE;
  padding:4px;
  border:1px solid black;
  -webkit-border-radius: 35px;
  -moz-border-radius: 35px;
  border-radius: 35px;
  }

.titre:hover{
  cursor: ne-resize;
  }
 
</style>

<script type="text/javascript" src="http://code.jquery.com/jquery-1.4.2.min.js"></script>
<script type="text/javascript">
<!--
jQuery().ready(function(){
  $(".bloc_texte").hide();
  $("#1").show();
  $(".titre").mouseover(function(){
      if($(this).next("div").is(":hidden")){               
        $(".titre").next("div:visible").hide();
        $(this).next("div").show();
      }
  });
});
-->
</script>

</head>


<span><h1 class="titre">Bienvenue/Staff</h1><div class="bloc_texte" id="1"><center><h3>Bienvenue sur Academie Pub !</h3></center></br> BlablablablablablablablablaBlablablablablablablablablaBlablablablablablablablablaBlablabla</br>blablablablablabla...</br>
<center><h3>Le staff</h3></center></br>
<center><a href="lien du profil"><img src="http://t3.gstatic.com/images?q=tbn:ANd9GcTbhdvCaIeHOhvRYmLht0fQkIEBkc-zPZm1CP_NN2XBn50u7ssIjxMpxg"/></a>
<a href="lien du profil"><img src="http://t3.gstatic.com/images?q=tbn:ANd9GcTbhdvCaIeHOhvRYmLht0fQkIEBkc-zPZm1CP_NN2XBn50u7ssIjxMpxg"/></a>
<a href="lien du profil"><img src="http://t3.gstatic.com/images?q=tbn:ANd9GcTbhdvCaIeHOhvRYmLht0fQkIEBkc-zPZm1CP_NN2XBn50u7ssIjxMpxg"/></a></center></br>
<center><a href="lien du profil"><img src="http://t3.gstatic.com/images?q=tbn:ANd9GcTbhdvCaIeHOhvRYmLht0fQkIEBkc-zPZm1CP_NN2XBn50u7ssIjxMpxg"/></a>
<a href="lien du profil"><img src="http://t3.gstatic.com/images?q=tbn:ANd9GcTbhdvCaIeHOhvRYmLht0fQkIEBkc-zPZm1CP_NN2XBn50u7ssIjxMpxg"/></a></center></div></span>
<span><h1 class="titre">Logo-Staff/Remerciement</h1><div class="bloc_texte"><center><h3>Les forums du staff</h3></center></br>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a>
<a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a>
<a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center></br>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a>
<a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><h3>Remerciement</h3></center></br>
BlablablablablablablablablablaBlablablablablablablablablablaBlablablablablablablablablabla...
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>

</div></span>
<span><h1 class="titre">Partenaires</h1><div class="bloc_texte"><center><h3>Nos partenaires</h3</center></br>
</br>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center></div></span>

<span><h1 class="titre">Forum privilegier</h1><div class="bloc_texte"><center><h3>Les forums privilegier</h3></center></br>
</br>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center></div></span>

Mais quand je le met dans:

Pa>>Affichage>> page d'accueil>>>Généralité>> message sur la page d'accueil.

Sa ne marche pas du tout. On m'a dit de le mettre en page Html mais sa ne marche pas également.

pouvez vous m'aider?

Merci d'avance.


Dernière édition par ludoloveisa le Jeu 27 Oct 2011 - 8:30, édité 1 fois

ludoloveisa
**

Masculin
Messages : 79
Inscrit(e) le : 21/07/2010

http://forbiddenforest.forumactif.org
ludoloveisa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Script qui ne fonctionne pas dans le message d'accueil

Message par Ea le Mar 18 Oct 2011 - 10:06

Bonjour,


Déjà :

Code:
<script type="text/javascript" src="http://code.jquery.com/jquery-1.4.2.min.js"></script>
Vous pouvez retirer c'est déjà inclus sur les forums forumactif ( et je ne sais pas si le hotlink de cette adresse est permis d'ailleurs ).

Les <head> et </head> c'est à retirer aussi, un document html est comme ceci :

Code:
<html>
<head>
  <!-- donnée de "configuration", "style", ... pour l'affichage de la page -->
</head>
<body>
  <!-- données de la page à afficher -->
</body>
</html>
Enfin le message de la page d'accueil sera mis dans le body et ce n'est pas top de mettre une balise <head> dedans.

Ensuite je ne vois que le problème des $, comme indiqué ici en utilisant du javascript dans le message de la page d'accueil on ne peut pas utiliser $ et il faut le remplacer par jQuery, donc on arrive au code :

Code:
<style type="text/css">
 
span{
  float:left;
  padding:12px;
  }
 
.bloc_texte{
  position:absolute;
  left:12px;
  top:60px;
  width :560px;
  height:400px;
  background-color: #18B2F4;
  border:1px solid black;
  -webkit-border-radius: 20px;
  -moz-border-radius: 20px;
  border-radius: 20x;
  }
 
.titre{
  font-size:14px;
  background-color:#013CFE;
  color:#FEFEFE;
  padding:4px;
  border:1px solid black;
  -webkit-border-radius: 35px;
  -moz-border-radius: 35px;
  border-radius: 35px;
  }
 
.titre:hover{
  cursor: ne-resize;
  }
 
</style>
 
<script type="text/javascript">
<!--
jQuery().ready(function(){
  jQuery(".bloc_texte").hide();
  jQuery("#1").show();
  jQuery(".titre").mouseover(function(){
      if(jQuery(this).next("div").is(":hidden")){               
        jQuery(".titre").next("div:visible").hide();
        jQuery(this).next("div").show();
      }
  });
});
-->
</script>
 
 
<span><h1 class="titre">Bienvenue/Staff</h1><div class="bloc_texte" id="1"><center><h3>Bienvenue sur Academie Pub !</h3></center></br> BlablablablablablablablablaBlablablablablablablablablaBlablablablablablablablablaBlablabla</br>blablablablablabla...</br>
<center><h3>Le staff</h3></center></br>
<center><a href="lien du profil"><img src="http://t3.gstatic.com/images?q=tbn:ANd9GcTbhdvCaIeHOhvRYmLht0fQkIEBkc-zPZm1CP_NN2XBn50u7ssIjxMpxg"/></a>
<a href="lien du profil"><img src="http://t3.gstatic.com/images?q=tbn:ANd9GcTbhdvCaIeHOhvRYmLht0fQkIEBkc-zPZm1CP_NN2XBn50u7ssIjxMpxg"/></a>
<a href="lien du profil"><img src="http://t3.gstatic.com/images?q=tbn:ANd9GcTbhdvCaIeHOhvRYmLht0fQkIEBkc-zPZm1CP_NN2XBn50u7ssIjxMpxg"/></a></center></br>
<center><a href="lien du profil"><img src="http://t3.gstatic.com/images?q=tbn:ANd9GcTbhdvCaIeHOhvRYmLht0fQkIEBkc-zPZm1CP_NN2XBn50u7ssIjxMpxg"/></a>
<a href="lien du profil"><img src="http://t3.gstatic.com/images?q=tbn:ANd9GcTbhdvCaIeHOhvRYmLht0fQkIEBkc-zPZm1CP_NN2XBn50u7ssIjxMpxg"/></a></center></div></span>
<span><h1 class="titre">Logo-Staff/Remerciement</h1><div class="bloc_texte"><center><h3>Les forums du staff</h3></center></br>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a>
<a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a>
<a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center></br>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a>
<a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><h3>Remerciement</h3></center></br>
BlablablablablablablablablablaBlablablablablablablablablablaBlablablablablablablablablabla...
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
 
</div></span>
<span><h1 class="titre">Partenaires</h1><div class="bloc_texte"><center><h3>Nos partenaires</h3</center></br>
</br>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center></div></span>
 
<span><h1 class="titre">Forum privilegier</h1><div class="bloc_texte"><center><h3>Les forums privilegier</h3></center></br>
</br>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center>
<center><a href="lien du site web"><img src="http://img4.hostingpics.net/pics/167825Sanstitre8.png"/></a></center></div></span>
Qui si vous l'avez mis en ayant +html au dessus de l'éditeur devrait fonctionner.

Sinon utiliser des images "cachée" par google de ce style n'est pas une très bonne pratique :

Code:
http://t3.gstatic.com/images?q=tbn:ANd9GcTbhdvCaIeHOhvRYmLht0fQkIEBkc-zPZm1CP_NN2XBn50u7ssIjxMpxg
Je ne pense pas que google assure l'hébergement illimité de l'image par cette adresse.

Ea
Aidactif
Aidactif

Messages : 23442
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Script qui ne fonctionne pas dans le message d'accueil

Message par ludoloveisa le Mar 18 Oct 2011 - 10:36

Merci le code marche désormais.

Mais le tableau ne s’affiche pas en dessous des onglet il s'affiche comme sa



ludoloveisa
**

Masculin
Messages : 79
Inscrit(e) le : 21/07/2010

http://forbiddenforest.forumactif.org
ludoloveisa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Script qui ne fonctionne pas dans le message d'accueil

Message par Ea le Mar 18 Oct 2011 - 10:45

C'est ce qu'il est mis dans le CSS :

Code:
.bloc_texte{
  position:absolute;
  left:12px;
  top:60px;
Le positionnement "absolute" positionne l'élément par rapport au bords du premier élément "parent" positionné ( dans ce cas-ci c'est la page entière ), donc ici le bloc est bien à 12 pixels du bord gauche de la page et 60 pixels du bord haut.

Ea
Aidactif
Aidactif

Messages : 23442
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Script qui ne fonctionne pas dans le message d'accueil

Message par ludoloveisa le Mar 18 Oct 2011 - 10:48

Oki merci pour ton aide

ludoloveisa
**

Masculin
Messages : 79
Inscrit(e) le : 21/07/2010

http://forbiddenforest.forumactif.org
ludoloveisa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Script qui ne fonctionne pas dans le message d'accueil

Message par Ea le Jeu 27 Oct 2011 - 3:01

Bonjour,

Où en-est votre problème ?

Deux solutions :

  • Votre problème est résolu, dans ce cas pensez à nous le signaler en cochant l'icône résolu en éditant votre premier message,
  • Votre problème est toujours d'actualité, et dans ce cas pensez à faire des UP régulièrement, afin de ne pas voir votre sujet délesté,


A bientôt sur ForumActif Smile

Ea
Aidactif
Aidactif

Messages : 23442
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Script qui ne fonctionne pas dans le message d'accueil

Message par ludoloveisa le Jeu 27 Oct 2011 - 8:30

Coucou.

Voila c'est fait et encore merci

ludoloveisa
**

Masculin
Messages : 79
Inscrit(e) le : 21/07/2010

http://forbiddenforest.forumactif.org
ludoloveisa a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum