Encore un problème de générateur de formulaire...

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Encore un problème de générateur de formulaire...

Message par Squally le Mer 30 Nov 2011 - 1:30

Bonsoir/ bonjour

Oui, c'est encore moi avec un problème, mais cette fois-ci de formulaire ....
J'ai suivi plusieurs tuto disponible sur forum actif , notamment celui-ci : http://forum.forumactif.com/t280246-formulaire
Le problème ? C'est qu'il y a un problème ....
Pour l'instant, le code ne marche pas rien que sur une infime parti que je voulais tester avant "d'aller plus loin"
et voici cette partie

Code:
<script type="text/javascript">
function envoiMessage(form)
{
  var sexe = "";
  if(form.sex[0].checked == true)
    sexe = "♀ Féminin ♀";
  else if(form.sex[1].checked == true)
    sexe = "♂ Masculin ♂";


var txt_message = "
[color=cyan] [blur]Sexe :[/color][/blur]" + sexe + '\n'  +";) ";
       
  form.message.value = txt_message;
}
</script>

<form action="http://nomdemonforum.superforum.fr/post" method="post" name="post" enctype="multipart/form-data" onSubmit="envoiMessage(this)">

<input type="hidden" name="lt" value="0" />
<input type="hidden" name="mode" value="newtopic" />
<input type="hidden" name="topictype" value="0" checked="checked" />
<input type="hidden" name="message" value="" />
<input type="hidden" name="f" value="6" />

<br/>


<label> Titre de ta fiche : </label>
<input name="subject" id="titre" size="75" type="text">
<br />
<br />

        <label> Sexe : </label>
<br/>
<input type="radio"  name="sex" value="t1" />♀ (F)
<input type="radio"  name="sex" value="t2" />♂ (M)               
                <br/><br/>

<input type="submit" name="post" value="Envoyer ma fiche.">

</div>
</form>

Q1 : es-ce a cause des résidus de BBcode ?
=> J'ai essayée, c'est du pareil au même. Par contre, es-ce que j'ai le droit de le laisser ou pas dans la parti du texte final ?
Q2 : es-ce que le code est carrément faux à la base et qu'il faut tout simplement changer de méthode ?
Q3 : es-ce encore du à une erreur débile que j'ai fais par là ?!

Lorsque je le teste : Une page s'ouvre, comme lorsque l'on répond à un sujet, mais il me stipule que je dois "entrer un message avant de poster." Sur la barre de titre, le texte écrit précédemment est bien mentionné, mais il n'y a aucun contenu afficher dans le corps du message (ce qui parait logique à vu du commentaire).

Merci pour vos réponses et encore désolée pour le dérangement ><


Dernière édition par Squally le Mer 30 Nov 2011 - 19:17, édité 1 fois

Squally
Nouveau membre

Messages : 12
Inscrit(e) le : 12/07/2009

http://merankoria.superforum.fr/
Squally a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Encore un problème de générateur de formulaire...

Message par zz10 le Mer 30 Nov 2011 - 9:30

Bonjour,

Il y a au moins une erreur qui me saute aux yeux.

Vous avez mis cette ligne de code :
Code:

 var txt_message = "
        [color=cyan] [blur]Sexe :[/color][/blur]" + sexe + '\n'  +";) ";

Ce qui ne peut pas fonctionner. Il ne faut pas mettre de retour chariot (retour à la ligne) dans une chaîne de caractères. Vous auriez du écrire :

Code:
 var txt_message = "[color=cyan] [blur]Sexe :[/color][/blur]" + sexe + '\n'  +";) ";

Wink

zz10
+ Hyperactif +

Masculin
Messages : 2202
Inscrit(e) le : 04/07/2009

http://www.forum-ice-epinal.com
zz10 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Encore un problème de générateur de formulaire...

Message par Squally le Mer 30 Nov 2011 - 19:16

.... Je n'arrive pas à y croire x) ça doit faire trois semaine que je planche pour ... ça xD et bien merci beaucoup pour cette réponse ! il valait mieux que se soit un truc ridicule du genre qu'un truc plus compliqué sûrement x)
Encore merci merci merci <3

Squally
Nouveau membre

Messages : 12
Inscrit(e) le : 12/07/2009

http://merankoria.superforum.fr/
Squally a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum