Problème remplacement virgule des sous forums

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème remplacement virgule des sous forums

Message par Daewyn le Dim 4 Déc - 17:59

Bonjour, bonsoir, et merci d'avance à ceux qui voudront bien m'aider.

Il y a quelques temps j'ai utilisé le tuto permettant de remplacer la virgule séparant les liens des sous-forums. Pour rappel, il s'agit de ce code-ci :

Code:
<script type="text/javascript">
jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,' ')).removeAttr('id');
</script>

Jusque là, rien d'extraordinaire. J'ai mis mes forums à droite avec un saut de ligne, comme on le voit un peu partout (donc en remplaçant la virgule par un <br />). Sauf que, voilà. J'ai constaté un problème quand on passe la souris sur le lien du sous forum : la description s'affiche, mais avec les virgules remplacées (ici donc, par un <br />). Assez disgracieux à mon sens. Est ce qu'il y aurait un moyen de régler ce soucis ? ><

Le lien du forum concerné est celui affiché dans mon profil. Merci d'avance =)


Dernière édition par Daewyn le Mer 14 Déc - 16:41, édité 1 fois

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

Daewyn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par Daewyn le Lun 5 Déc - 17:13

Up ^^

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

Daewyn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par Daewyn le Mar 6 Déc - 16:32

Up o/

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

Daewyn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par Daewyn le Mer 7 Déc - 12:13

Up.

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

Daewyn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par Daewyn le Sam 10 Déc - 0:13

Up ^^

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

Daewyn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par Daewyn le Dim 11 Déc - 14:37

Up ~

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

Daewyn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par Daewyn le Lun 12 Déc - 13:47

Up o/

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

Daewyn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par Daewyn le Mar 13 Déc - 18:50

Up again o/

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

Daewyn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par zz10 le Mar 13 Déc - 23:49

Bonsoir,

Je ne vois pas de problème sur votre forum ? Le script est-il activé ?

zz10
+ Hyperactif +

Masculin
Messages : 2241
Inscrit(e) le : 04/07/2009

http://www.ice-epinal-forum.com
zz10 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par Daewyn le Mer 14 Déc - 2:20

Une réponse, kyah **

Je l'avais temporairement retiré pour essayer autre chose (du coup c'ets remis). Mais ce bug ne me concerne pas uniquement, je l'ai remarqué sur tous les autres forums utilisants ce script, tout navigateurs confondus. Une idée ? =/

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

Daewyn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par zz10 le Mer 14 Déc - 10:50

J'aimerai vous aider mais je n'arrive pas à trouver le problème sur votre fofo ! Pouvez-vous faire une capture d'écran ?

cdt

zz10
+ Hyperactif +

Masculin
Messages : 2241
Inscrit(e) le : 04/07/2009

http://www.ice-epinal-forum.com
zz10 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par Daewyn le Mer 14 Déc - 13:37

Bien sûr, voici le screen :

Spoiler:

Au passage de la souris sur le lien d'un sous-forum (ici l'encylopédie), la description qui s'affiche voit toutes ses virgules remplacées par le même signe que celui mis dans le script. Et je n'ai aucune idée de comment rectifier ça ><

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

Daewyn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par zz10 le Mer 14 Déc - 14:48

Est-ce qu'Etana vous avez demandé d'ajouter un id "subforum" sur le span contenant les sous forums ?

Si oui, dites moi dans quel template ça se situe Wink

zz10
+ Hyperactif +

Masculin
Messages : 2241
Inscrit(e) le : 04/07/2009

http://www.ice-epinal-forum.com
zz10 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par zz10 le Mer 14 Déc - 15:27

Si vous avez bien ajouté un id, merci d'essayer ce code :

Code:
<script type="text/javascript">
   jQuery(function(){
      var separator = " ";
      jQuery('span#subforums').each(function(){
         var links = jQuery(this).find("a");
         if(links.length > 1){
            var html = "";
            links.each(function(i){
               html += "<a href='"+jQuery(this).attr('href')+"'  title='"+jQuery(this).attr('title')+"' class='gensmall'>"+jQuery(this).text()+"</a>";
               if(i+1 != links.length){
                  html += separator;
               }
            });
            jQuery(this).html(html);
         }
         jQuery(this).removeAttr('id');
      });
   });
</script>

Pour personnaliser le nouveau caractère de remplacement, il faut modifier la valeur de

Code:
var separator = " ";

cdt

zz10
+ Hyperactif +

Masculin
Messages : 2241
Inscrit(e) le : 04/07/2009

http://www.ice-epinal-forum.com
zz10 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par Daewyn le Mer 14 Déc - 16:03

@_@ c'est encore pire ><

Mon code précédent était celui-ci (dans le template index_box) :

Code:
<div class="sous_fo"><span class="gensmall" id="subforums">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</span></div>
<script type="text/javascript">
jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,' ')).removeAttr('id');
</script>

(donc bien avec un id subforums). En remplaçant le script d'Etana par le tien, voilà ce que ça me donne :

Spoiler:

Au passage de la souris, la description se coupe cette fois dès le premier apostrophe ><

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

Daewyn a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Problème remplacement virgule des sous forums

Message par zz10 le Mer 14 Déc - 16:18

Code:
<script type="text/javascript">
   jQuery(function(){
      var separator = " ";
      jQuery('span#subforums').each(function(){
         var links = jQuery(this).find("a");
         if(links.length > 1){
            var html = "";
            links.each(function(i){
               html += "<a href='"+jQuery(this).attr('href')+"'  title=\""+jQuery(this).attr('title')+"\" class='gensmall'>"+jQuery(this).text()+"</a>";
               if(i+1 != links.length){
                  html += separator;
               }
            });
            jQuery(this).html(html);
         }
         jQuery(this).removeAttr('id');
      });
   });
</script>

zz10
+ Hyperactif +

Masculin
Messages : 2241
Inscrit(e) le : 04/07/2009

http://www.ice-epinal-forum.com
zz10 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème remplacement virgule des sous forums

Message par Daewyn le Mer 14 Déc - 16:41

C'est parfait ** Le bug est totalement réglé, merci infiniment x3

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

Daewyn a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum