Problème infobulle

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème infobulle

Message par Mila58 le Sam 17 Déc 2011 - 15:24

Bonjour,
Voilà, en fait j'ai un petit problème avec mes infobulles.
J'aimerai mettre des liens à l'intérieur, mais lorsque je mets le code pour les liens, ça me fait ça :
Spoiler:

Je ne sais pas d'où vient le problème, et je n'arrive pas à faire autrement >.<
Si quelqu'un pourrait m'aider, s'il vous plait ^.^
Merci d'avance ^.^


Dernière édition par Mila58 le Sam 17 Déc 2011 - 17:40, édité 1 fois

Mila58
Nouveau membre

Messages : 18
Inscrit(e) le : 11/08/2011

http://kurofofo.forumgratuit.org/
Mila58 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème infobulle

Message par gaspar le Sam 17 Déc 2011 - 16:14

héé j'ai le même problème avec mes infos bulles à moi Surprised
Waaaa ! si quelqu'un sait nous aider, c'est trop stylé !
tu devrais peut-être poster le script de ton infobulle Wink

perso voilà le mien :
Code:
a.info2 {
position: relative;
text-decoration: none !important;
color:#;
border-bottom: 0px gray dotted;
font-size: 12px;
}
a.info2 span {
display: none;
text-decoration: none !important;
position: absolute;
}
a.info2:hover {
background: none;
text-decoration: none !important;
z-index: 999;

}
a.info2:hover span {
text-decoration: none !important;
display: inline;
position: absolute;
top: 14px;
center: 70px;
align: absolute;
background-color: #BAD9BB;
text-align: center;
color: black;
padding: 0px;
border: 1px dotted #5E4A64;
-moz-border-radius : 3px;
}
je sais pas si t'a le même script, mais je viens de penser que dans mon cas c'est peut-être que c'est fait sur base de la balise du lien, et que donc un lien dans un lien ca ferait tout bugger...

gaspar
*****

Masculin
Messages : 826
Inscrit(e) le : 03/01/2006

http://ddaynormandy.keumforum.com
gaspar a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème infobulle

Message par Invité le Sam 17 Déc 2011 - 16:37

Bonjour,

En effet, pour vous aider, pourriez-vous nous donner le code HTML et le CSS associé qui correspondent à vos infobulles?

Cordialement.

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème infobulle

Message par Mila58 le Sam 17 Déc 2011 - 16:45

Les voilà :
Code CSS :
Code:
a.info {
position:relative;
z-index:24;
color:#000000;
text-decoration:none;
}
 
a.info:hover {
z-index:25;
background-color:#FFFFFF
}
 
a.info span {
display: none
}
 
a.info:hover span {
display:block;
position:absolute;
top:0px;
left:2em;
width:154px;
border:2px solid #000000;
background-color:#B4BEC9;
color:#000000;
font-weight:none;
padding:5px;
}

Et code HTML :
Code:
<div style="box-shadow: black 1px 1px 10px;"><div style="border: white solid 2px; width: 180px; height: 190px;"><div style="background: #7D8895;"><center><font size="4"><span style="text-shadow: black 1px 1px 1px;">Le Staff</font></span></div><br><br><center><table><tr><td><a href="#" style="text-decoration:none;" class="info"><div style="border: white solid 1px; width: 50px;"><img src="http://img15.hostingpics.net/pics/570794iconepamila1.png"></div><span><center>Mila
</br><br><div style="border: black solid 2px;" width: 150px;"><img src="http://img15.hostingpics.net/pics/722192iconemilapa2.png"></div><br>Fondatrice<br>[url=http://kurofofo.forumgratuit.org/privmsg?mode=post&u=1]MP[/url]
</center></span></a></td><td><a href="#" style="text-decoration:none;" class="info"><div style="border: white solid 1px; width: 50px;"><img src="http://img15.hostingpics.net/pics/241199iconepaliberte.png"></div><span><center>Liberté
</br><br><div style="border: black solid 2px;" width: 150px;"><img src="http://img15.hostingpics.net/pics/468170iconelibertepa2.png"></div><br>Co-Fondatrice</center></span></a></td></tr></table><table><tr><td><a href="#" style="text-decoration:none;" class="info"><div style="border: white solid 1px; width: 50px;"><img src="http://img15.hostingpics.net/pics/254429iconepaalois.png"></div><span><center>Alois
</br><br><div style="border: black solid 2px;" width: 150px;"><img src="http://img15.hostingpics.net/pics/681067iconealoispa2.png"></div><br>Modérateur</center></span></a></td><td><a href="#" style="text-decoration:none;" class="info"><div style="border: white solid 1px; width: 50px;"><img src="http://img15.hostingpics.net/pics/992829iconepaloissa.png"></div><span><center>Loïssa
</br><br><div style="border: black solid 2px;" width: 150px;"><img src="http://img15.hostingpics.net/pics/640123iconeloissapa2.png"></div><br>Modératrice</center></span></a></td></tr></table></center></div></div>

Voilà ^.^

Mila58
Nouveau membre

Messages : 18
Inscrit(e) le : 11/08/2011

http://kurofofo.forumgratuit.org/
Mila58 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème infobulle

Message par gaspar le Sam 17 Déc 2011 - 17:07

et si tu fait :
Code CSS :
Code:
b.info {
position:relative;
z-index:24;
color:#000000;
text-decoration:none;
}
 
b.info:hover {
z-index:25;
background-color:#FFFFFF
}
 
b.info span {
display: none
}
 
b.info:hover span {
display:block;
position:absolute;
top:0px;
left:2em;
width:154px;
border:2px solid #000000;
background-color:#B4BEC9;
color:#000000;
font-weight:none;
padding:5px;
}

Et code HTML :
Code:
<div style="box-shadow: black 1px 1px 10px;"><div style="border: white solid 2px; width: 180px; height: 190px;"><div style="background: #7D8895;"><center><font size="4"><span style="text-shadow: black 1px 1px 1px;">Le Staff</font></span></div><br><br><center><table><tr><td><b  style="text-decoration:none;" class="info"><div style="border: white solid 1px; width: 50px;"><img src="http://img15.hostingpics.net/pics/570794iconepamila1.png"></div><span><center>Mila
</br><br><div style="border: black solid 2px;" width: 150px;"><img src="http://img15.hostingpics.net/pics/722192iconemilapa2.png"></div><br>Fondatrice<br>[url=http://kurofofo.forumgratuit.org/privmsg?mode=post&u=1]MP[/url]
...

???
seuleument tu risque d'avoir tout en gras, m'enfin si ca marche, tu comprend l'idée ou pas ?

gaspar
*****

Masculin
Messages : 826
Inscrit(e) le : 03/01/2006

http://ddaynormandy.keumforum.com
gaspar a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème infobulle

Message par Mila58 le Sam 17 Déc 2011 - 17:16

hmm.. nan ça ne fait rien, c'est toujours pareil :/
Merci quand même ^.^

Mila58
Nouveau membre

Messages : 18
Inscrit(e) le : 11/08/2011

http://kurofofo.forumgratuit.org/
Mila58 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème infobulle

Message par Invité le Sam 17 Déc 2011 - 17:37

Essayez en remplaçant votre CSS par:
Code:
.info {
position:relative;
z-index:24;
color:#000000;
text-decoration:none;
}
 
.info:hover {
z-index:25;
background-color:#FFFFFF
}
 
.info span {
display: none
}
 
.info:hover span {
display:block;
position:absolute;
top:0px;
left:2em;
width:154px;
border:2px solid #000000;
background-color:#B4BEC9;
color:#000000;
font-weight:none;
padding:5px;
}
Et votre code HTML par:
Code:
<div style="box-shadow: black 1px 1px 10px;">
<center>
<div style="border: white solid 2px; width: 180px; height: 190px;">
<div style="background: #7D8895;">
<font size="4">
<span style="text-shadow: black 1px 1px 1px;">Le Staff</span></font>
</div>
<br/><br/>

<table>
<tr>
<td>
<div style="text-decoration:none;" class="info">
<div style="border: white solid 1px; width: 50px;">
<img src="http://img15.hostingpics.net/pics/570794iconepamila1.png" />
</div>
<span>
<center>Mila
<br /><br />
<div style="border: black solid 2px; width: 150px;">
<img src="http://img15.hostingpics.net/pics/722192iconemilapa2.png" />
</div>
<br />Fondatrice<br />
<a href="http://kurofofo.forumgratuit.org/privmsg?mode=post&u=1" class="postlink" target="_blank" rel="nofollow">MP</a>
</center>
</span>
</div>
</td>
<td>
<div style="text-decoration:none;" class="info">
<div style="border: white solid 1px; width: 50px;">
<img src="http://img15.hostingpics.net/pics/241199iconepaliberte.png">
</div>
<span>
<center>Liberté
<br /><br />
<div style="border: black solid 2px; width: 150px;">
<img src="http://img15.hostingpics.net/pics/468170iconelibertepa2.png"></div>
<br />Co-Fondatrice
</center>
</span>
</div>
</td>
</tr>
</table>
<table>
<tr>
<td>
<div style="text-decoration:none;" class="info">
<div style="border: white solid 1px; width: 50px;"><img src="http://img15.hostingpics.net/pics/254429iconepaalois.png"></div>
<span><center>Alois
<br /><br />
<div style="border: black solid 2px; width: 150px;">
<img src="http://img15.hostingpics.net/pics/681067iconealoispa2.png">
</div>
<br />Modérateur</center>
</span>
</div>

</td>
<td>
<div style="text-decoration:none;" class="info">
<div style="border: white solid 1px; width: 50px;">
<img src="http://img15.hostingpics.net/pics/992829iconepaloissa.png" />
</div>
<span>
<center>Loïssa
<br /><br />
<div style="border: black solid 2px; width: 150px;">
<img src="http://img15.hostingpics.net/pics/640123iconeloissapa2.png" />
</div>
<br />Modératrice
</center>
</span>
</div>
</td>
</tr>
</table>
</div>
</center>
</div>
J'ai remplacé les "a" qui correspondent à des liens par des "div", et donc dans le CSS j'ai supprimé aussi les "a" correspondant aux liens Wink .

Cordialement.

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème infobulle

Message par Mila58 le Sam 17 Déc 2011 - 17:40

Oui ça marche, c'est bon =)
Merci pour votre aide, problème résolu ^.^

Mila58
Nouveau membre

Messages : 18
Inscrit(e) le : 11/08/2011

http://kurofofo.forumgratuit.org/
Mila58 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum