Problème avec un code pour des réponses automatiques

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec un code pour des réponses automatiques

Message par Aya Swel le Sam 17 Déc 2011 - 16:30

Bonjour : Où ai-je fais une erreur ?
J'ai installé un code, pour créer des réponses automatiques de modération (je vais personnaliser les tags après)>> Voici le rendu, il n'y a pas de boutons pour valider.


Voici comment j'ai installé le code (comme une personne me l'a indiqué) :
Code:

 <span class="gen">{L_MOD_TOOLS}<br />{S_SELECT_MOD} <input class="liteoption" type="submit" value="{L_GO}" /></span>        </form>      </td>  </tr> <script>    function generatee() {    if(document.getElementById('fina').value == '') {    document.getElementById('fina').value = document.getElementById('mensage').value;    } else {    document.getElementById('fina').value = document.getElementById('fina').value +'n'+ document.getElementById('mensage').value;    }    }        </script>            <select id="mensage">        <option value="[table class='presentation' align='center' border='0' cellspacing='0' cellpadding='0'][tr][td]    Bonjour, Pour le bon déroulement du forum et pour améliorer l'esprit de convivialité, veuillez vous présenter afin que la communauté puisse vous connaitre. Merci de votre compréhension.[/td][/tr][/table]">Demande de présentation</option>        <option value="[size=14][color=red][b][i]Ce topic étant contraire à la charte régissant ce forum, nous nous voyons dans l'obligation de le fermer.    Merci de votre compréhension.[/i][/b][/color][/size]">Message hors charte </option>            </select>        <div class="center"><input class="button1" type="button" name="submit" value="Générer le code" onclick="generatee();"> <input class="button1" type="button" name="submit" value="Effacer" onclick="document.getElementById('fina').value = '';"></div>            <div class="post row2" style="padding: 6px; margin-top: 6px;"><dl class="codebox"><dt>Code du message de modération : (<a href="javascript: document.getElementById('fina').select();">Tout sélectionner</a>)</dt><dd><textarea class="inputbox" style="border: none; background-color: transparent; padding: 4px; width: 100%; margin: 0 auto;" id="fina"></textarea></dd></dl></div>    </table><!-- END viewtopic_bottom -->


Dernière édition par Aya Swel le Lun 19 Déc 2011 - 21:39, édité 1 fois

Aya Swel
***

Féminin
Messages : 156
Inscrit(e) le : 07/12/2011

http://bakalandpowaa.lebonforum.com
Aya Swel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un code pour des réponses automatiques

Message par demeter1 le Sam 17 Déc 2011 - 17:49

Bonjour Ayel,
On va reprendre depuis le début

Dans le template Viewtopic_body, recherchez :


Code:
   <span class="gen">{L_MOD_TOOLS}<br />{S_SELECT_MOD} <input class="liteoption" type="submit" value="{L_GO}" /></span>
         </form>


Juste après, collez
Nota : il s'agit du codage mis en place sur mon forum donc, je vous laisse faire les modifications nécéssaires.
Code:

<script>
        function generatee() {
        if(document.getElementById('fina').value == '') {
        document.getElementById('fina').value = document.getElementById('mensage').value;
        } else {
        document.getElementById('fina').value = document.getElementById('fina').value +'\n'+ document.getElementById('mensage').value;
        }
        }
       
        </script>
       
       
        <select id="mensage">
       
        <option value="[table class='presentation' align='center' border='0' cellspacing='0' cellpadding='0'][tr][td]
        Bonjour, Pour le bon déroulement du forum et pour améliorer l'esprit de convivialité, veuillez vous présenter afin que la communauté puisse vous connaitre.<br> Merci de votre compréhension.[/td][/tr][/table]">Demande de présentation</option>
 
            <option value="[table class='charte' align='center' border='0' cellspacing='0' cellpadding='0'][tr][td]
      Ce topic étant contraire à la charte régissant ce forum, nous nous voyons dans l'obligation de le fermer. <br>Merci de votre compréhension.[/td][/tr][/table]">Message hors charte</option>
 
        <option value="[table class='titre' align='center' border='0' cellspacing='0' cellpadding='0'][tr][td]
      Afin de favoriser les recherches ultérieures sur le forum, merci :<br>- De mettre un titre explicite (qui explique plus simplement le problème)<br>- De retirer les Majuscules si nécessaire.<br>
Pour cela, cliquez sur le bouton "éditer" de votre 1er message
N'oubliez pas que d'autres personnes peuvent profiter de vos questions. Il est donc impératif afin de faciliter l'utilisation de l'outil recherche d'avoir des titres de sujet explicatifs.
Merci de votre compréhension[/td][/tr][/table]">Modification du titre du sujet</option>

        <option value="[table class='verou' align='center' border='0' cellspacing='0' cellpadding='0'][tr][td]
      Le sujet a été verrouillé par l'équipe du forum.
Raison :  [/td][/tr][/table]">Verouillage de sujet</option>


       
        </select>
       
        <div class="center"><input class="liteoption" type="button" name="submit" value="Générer le code" onclick="generatee();"> <input class="liteoption" type="button" name="submit" value="Effacer" onclick="document.getElementById('fina').value = '';"></div>
       
       
        <div class="post row2" style="padding: 6px; margin-top: 6px;"><dl class="codebox"><dt><span class="gen">Code du message de modération :</span> (<a href="javascript: document.getElementById('fina').select();"><span class="gen">Tout sélectionner</span></a>)</dt><dd><textarea class="inputbox" style="border: none; background-color: white; padding: 4px; width: 100%; margin: 0 auto;" id="fina"></textarea></dd></dl></div> 


Chaque option value à une class régit par du css
Par exemple
Code:
<option value="[table class='presentation' align='center' border='0' cellspacing='0' cellpadding='0'][tr][td]
        Bonjour, Pour le bon déroulement du forum et pour améliorer l'esprit de convivialité, veuillez vous présenter afin que la communauté puisse vous connaitre.<br> Merci de votre compréhension.[/td][/tr][/table]">Demande de présentation</option>

a ce css d'associé (à placer dans la feuille de style)

Code:
.presentation{background-color:trans; background-image:url("http://i23.servimg.com/u/f23/11/93/85/24/sans_t24.png"); background-position:left; background-repeat:no-repeat; border:2px solid #FFF; color:#566c00; font-family:Arial,Helvetica,sans-serif; font-size:11px; font-weight:bold; height:150px; padding:5px 10px 5px 140px; text-decoration:none !important; text-transform:uppercase; width:auto}

Pour les class charte, titre et verou , il faut leur attribuer un css du style de celui de présentation mais en modifiant les paramètres.

Si vous souhaitez ajouter ou supprimer une phrase de modération, il faut ajouter ou supprimer cette trame :

Code:
  <option value="[table class='NOM DE LA CLASS' align='center' border='0' cellspacing='0' cellpadding='0'][tr][td]
        PHRASE DE MODERATION[/td][/tr][/table]">Demande de présentation</option>

et lui associer le css correspondant

Code:

NOM DE LA CLASS {
les éléments d'affichage (backgound, color....)
}


demeter1
+ Hyperactif +

Masculin
Messages : 8105
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un code pour des réponses automatiques

Message par Aya Swel le Dim 18 Déc 2011 - 16:52

Je vais essayer d'y arriver x)

Aya Swel
***

Féminin
Messages : 156
Inscrit(e) le : 07/12/2011

http://bakalandpowaa.lebonforum.com
Aya Swel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un code pour des réponses automatiques

Message par Aya Swel le Lun 19 Déc 2011 - 11:56

Bonjour.
je n'y arrive toujours pas ! Je suis désespérée... J'ai pourtant tout suivi, mais trop de HTML et CSS tue le html et css... xx'

Aya Swel
***

Féminin
Messages : 156
Inscrit(e) le : 07/12/2011

http://bakalandpowaa.lebonforum.com
Aya Swel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un code pour des réponses automatiques

Message par demeter1 le Lun 19 Déc 2011 - 12:52

Désolé de ne pouvoir vous aider plus mais là, je vous ai fourni tous les renseignements nécessaires. Sur quoi butez vous : l'insertion du script dans le template, le css , sur l'insertion de nouveaux tags ??????

demeter1
+ Hyperactif +

Masculin
Messages : 8105
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un code pour des réponses automatiques

Message par Aya Swel le Lun 19 Déc 2011 - 13:07

Le CSS.

Les tags, je les ai modifiés, j'ai même grapher des images spéciales.
J'ai inséré le code html, mis les images, mais je n'arrive pas avec le CSS.
Vous m'avez fourni tous les renseignement, c'est juste que moi je n'y arrive pas >_<

Aya Swel
***

Féminin
Messages : 156
Inscrit(e) le : 07/12/2011

http://bakalandpowaa.lebonforum.com
Aya Swel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un code pour des réponses automatiques

Message par demeter1 le Lun 19 Déc 2011 - 13:13

Pas de panique.
Mettez ce que vous avez mis dans les options value en englobant l'ouverture et la fermeture par exemple.

Code:
<option value="[table class='NOM DE LA CLASS' align='center' border='0' cellspacing='0' cellpadding='0'][tr][td]
        PHRASE DE MODERATION[/td][/tr][/table]">Demande de présentation</option>

Pour chaque tag fournissez nous le css que vous avez travaillé afin d'y apporter des rectifications.

demeter1
+ Hyperactif +

Masculin
Messages : 8105
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un code pour des réponses automatiques

Message par Aya Swel le Lun 19 Déc 2011 - 21:02

Bon, je mets en résolu, j'abandonne, merci d'avoir essayé de m'aider, mais c'est trop compliqué malheureusement.

Aya Swel
***

Féminin
Messages : 156
Inscrit(e) le : 07/12/2011

http://bakalandpowaa.lebonforum.com
Aya Swel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un code pour des réponses automatiques

Message par demeter1 le Lun 19 Déc 2011 - 22:48

Comme vous voulez

demeter1
+ Hyperactif +

Masculin
Messages : 8105
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un code pour des réponses automatiques

Message par Aya Swel le Mar 20 Déc 2011 - 10:38

Merci quand même de m'avoir aidée Smile

Aya Swel
***

Féminin
Messages : 156
Inscrit(e) le : 07/12/2011

http://bakalandpowaa.lebonforum.com
Aya Swel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un code pour des réponses automatiques

Message par demeter1 le Mar 20 Déc 2011 - 10:41

De rien. il ne restait plus qu'a finaliser vos phrases de modération et d'y affilier le css correspondant. C'est dommage que vous vous arrêtiez en si bon chemin.

demeter1
+ Hyperactif +

Masculin
Messages : 8105
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un code pour des réponses automatiques

Message par Aya Swel le Mar 20 Déc 2011 - 13:45

Oui, peut-être, mais je suis sûrement trop jeune pour comprendre comment marche tout cela.
je trouverais peut-être une solution.

Aya Swel
***

Féminin
Messages : 156
Inscrit(e) le : 07/12/2011

http://bakalandpowaa.lebonforum.com
Aya Swel a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum