Message en html qui apparait bien en prévisualisation mais pas une fois poster

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Message en html qui apparait bien en prévisualisation mais pas une fois poster

Message par Olivier-Design le Mar 21 Fév 2012 - 23:08

J'ai activé le html sur mon forum afin de pouvoir poster des messages formatés joliment avec des tableaux et des styles en css précis.

Après avoir créé un style, j'ai fait un test. En prévisualisation, mon message apparaît bien (sauf pour le grand espace vide avant mon tableau), mais une fois posté... c'est uniquement du code....

Où est le problème ?? D'où vient l'espace avant mon tableau en prévisualisation ?


Le code de mon message

Code:

<CENTER><TABLE class="table-recettes" cellspacing="0">

<TR>
<TD height ="30px" colspan="2" align="middle" valign="center">NOM DE LA RECETTE</TD>
</TR>

<TR>
<TD width="500" valign="top">
Difficulté : xxx
Temps de préparation : xxx
Provenance de la recette : xxx
</TD>
<TD width="250" valign="center"> Photo de la recette</TD>
</TR>

<TR>
<TD width="350px" valign="top">
Ingrédients

Section de la recette 1
xxx = Nom de l'ingrédient
xxx = Nom de l'ingrédient

Section de la recette 2
xxx = Nom de l'ingrédient
</TD>
<TD width="400px" valign="top">
Méthodologie

Section de la recette 1
Étape 1 : bla bla bla bla
Étape 2 : bla bla bla

Section de la recette 2
Étape 1 : bla bla
Étape 2 : bla
</TD>
</TR>

<TR>
<TD width="400px" valign="top">
Notes : xxx
Variantes : xxx
</TD>
<TD width="350px" valign="top">
Idées de présentation : xxx
Conseils : xxx
</TD>
</TR>
</TABLE></CENTER>


Un visuel de ce que cela me donne en prévisualisation



Le code de mon css personnalisé pour le tableau

Code:

.table-recettes{
  width:750px;
  -moz-border-radius-topleft: 15px;
  -moz-border-radius-bottomright:15px;
  -webkit-border-radius-topleft: 15px;
  -webkit-border-radius-bottomright:15px;
  background-color: #bbc78b;
  border: 2px solid #000000;
  padding:5px;
}

Olivier-Design
***

Messages : 153
Inscrit(e) le : 10/02/2012

http://plaisirsgourmands.forumactif.com
Olivier-Design a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Message en html qui apparait bien en prévisualisation mais pas une fois poster

Message par Invité le Mer 22 Fév 2012 - 6:17

Coucou,


une fois le code fait... Ne Prévisualise PAS !!

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Message en html qui apparait bien en prévisualisation mais pas une fois poster

Message par Olivier-Design le Mer 22 Fév 2012 - 15:49

Il faut bien que je prévisualise pour m'assurer que tout ressort comme je le souhaite! Certes, pour le moment, je suis en phase test et je suis seul sur mon forum, mais je ne veux pas que ma conjointe ait de problème de rendu quand elle y sera. Elle a bien d'autres choses à s'occuper que cela.

Et désolé, je viens d'essayer, même en ne faisant pas de prévisualisation, cela ne fonctionne pas

Olivier-Design
***

Messages : 153
Inscrit(e) le : 10/02/2012

http://plaisirsgourmands.forumactif.com
Olivier-Design a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Message en html qui apparait bien en prévisualisation mais pas une fois poster

Message par Olivier-Design le Mer 22 Fév 2012 - 16:28

Problème résolu

Olivier-Design
***

Messages : 153
Inscrit(e) le : 10/02/2012

http://plaisirsgourmands.forumactif.com
Olivier-Design a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum