Cadre positionné différemment selon navigateur ~

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Cadre positionné différemment selon navigateur ~

Message par chienchila le Jeu 1 Mar 2012 - 1:58

Bonsoir, je ne savais pas vraiment comment formuler mon problème... !
J'ai ajouté dans mes templates, un " cadre " afin que les partenaires de mon forum soient visibles, tout en bas du forum. Sur mon navigateur habituel, Firefox, il est parfaitement visible, bien centré, tout comme il faut:



Seulement, sur internet explorer, j'ai remarqué que mon cadre se " coupe " en son milieu, et que le bas de celui ci part complètement vers la gauche du forum, ce qui n'est pas très esthetique:



Voici le code que j'ai ajouté dans mon template " overall_footer_begin " ~


Code:
<center><table class="forumline" width="500" border="1" cellspacing="1"cellpadding="0"><tr><td class="catHead" colspan="1" height="28"><center> <img src="http://s4.noelshack.com/uploads/images/10116141604668_69.png" alt="" border="0">  <a href="http://www.root-top.com/topsite/mirry/in.php?ID=265" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/18809299521936_sans_titre_9.png" alt="" border="0"></td></tr></a> </center> <center><tr><td class="row1"><span> <a href="http://roaring-wolf.forumgratuit.be/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/1130687579934_6987.png" alt="" border="0"></a> </span> <span> <a href="http://wildlifewars.forumactif.com/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/7337067999822_6.png" alt="" border="0"></a> </span> <span> <a href="http://peoplewolf.forumzen.com/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/15049541615328_4.png" alt="" border="0"></a> </span>  <span> <a href="http://sarkan-island.forumactif.fr/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/9886337907336_po.png" alt="" border="0"></a> </span> <span> <a href="http://leselemenloups.forumouf.com/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/13173800408208_3.png" alt="" border="0"></a> </span> <span> <a href="http://wolfangel.superforum.fr/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/4891509200160_5.png" alt="" border="0"></a></span></tr></td></center></center></table>


Sauriez-vous me dire qu'est ce qui cloche exactement, comment régler ce petit soucis ? Merci par avance !

chienchila
****

Féminin
Messages : 372
Inscrit(e) le : 09/09/2005

http://poetic-animal.forumpro.fr/
chienchila a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Cadre positionné différemment selon navigateur ~

Message par no_way le Jeu 1 Mar 2012 - 2:41

Bonsoir, essayez avec ce code:
Code:
<center><table class="forumline" width="500" border="1" cellspacing="1"cellpadding="0" style="text-align:center"><tr><td class="catHead" colspan="1" height="28"><img src="http://s4.noelshack.com/uploads/images/10116141604668_69.png" alt="" border="0" />  <a href="http://www.root-top.com/topsite/mirry/in.php?ID=265" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/18809299521936_sans_titre_9.png" alt="" border="0" /></a></td></tr><tr><td class="row1"><a href="http://roaring-wolf.forumgratuit.be/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/1130687579934_6987.png" alt="" border="0" /></a><a href="http://wildlifewars.forumactif.com/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/7337067999822_6.png" alt="" border="0" /></a><a href="http://peoplewolf.forumzen.com/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/15049541615328_4.png" alt="" border="0" /></a><a href="http://sarkan-island.forumactif.fr/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/9886337907336_po.png" alt="" border="0" /></a><a href="http://leselemenloups.forumouf.com/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/13173800408208_3.png" alt="" border="0" /></a><a href="http://wolfangel.superforum.fr/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/4891509200160_5.png" alt="" border="0" /></a></td></tr></table></center>

no_way
Aidactif
Aidactif

Messages : 1739
Inscrit(e) le : 26/03/2010

no_way a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Cadre positionné différemment selon navigateur ~

Message par chienchila le Jeu 1 Mar 2012 - 3:12

Votre code fonctionne très bien, merci beaucoup ! Par contre, dernier petit problème:



Encore une fois, il y a une sorte de cadre blanc sous internet explorer, qui n'existe pas sous firefox... ! Embarassed

chienchila
****

Féminin
Messages : 372
Inscrit(e) le : 09/09/2005

http://poetic-animal.forumpro.fr/
chienchila a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Cadre positionné différemment selon navigateur ~

Message par no_way le Jeu 1 Mar 2012 - 9:08

Vous utilisez une version de IE qui ne reconnait pas la propriéte <<inherit>> en CSS, pour vous simplifier la tâche utilisez le code suivant:
Code:
<center><table class="forumline" width="500" border="1" cellspacing="1"cellpadding="0" style="text-align:center"><tr><td class="catHead" colspan="1" height="28"><img src="http://s4.noelshack.com/uploads/images/10116141604668_69.png" alt="" border="0" />  <a href="http://www.root-top.com/topsite/mirry/in.php?ID=265" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/18809299521936_sans_titre_9.png" alt="" border="0" /></a></td></tr><tr><td class="row1 catHead"><a href="http://roaring-wolf.forumgratuit.be/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/1130687579934_6987.png" alt="" border="0" /></a><a href="http://wildlifewars.forumactif.com/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/7337067999822_6.png" alt="" border="0" /></a><a href="http://peoplewolf.forumzen.com/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/15049541615328_4.png" alt="" border="0" /></a><a href="http://sarkan-island.forumactif.fr/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/9886337907336_po.png" alt="" border="0" /></a><a href="http://leselemenloups.forumouf.com/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/13173800408208_3.png" alt="" border="0" /></a><a href="http://wolfangel.superforum.fr/" class="postlink" target="_blank"><img src="http://s4.noelshack.com/uploads/images/4891509200160_5.png" alt="" border="0" /></a></td></tr></table></center>

no_way
Aidactif
Aidactif

Messages : 1739
Inscrit(e) le : 26/03/2010

no_way a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Cadre positionné différemment selon navigateur ~

Message par chienchila le Jeu 1 Mar 2012 - 13:41

Le problème est réglé, merci à vous une nouvelle fois... ! Razz

chienchila
****

Féminin
Messages : 372
Inscrit(e) le : 09/09/2005

http://poetic-animal.forumpro.fr/
chienchila a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum