Bug affichage sous Chrome/IE

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Bug affichage sous Chrome/IE

Message par kamuisuki le Sam 14 Avr 2012 - 16:58

Bonjour à tous,

Voilà je gère un peu l'interface du forum , et
étant sous netscape, je n'ai pas ce soucis.
seulement beaucoup de gens utilisant IE et Chrome m'ont fait la remarque
d'un bug sur la page d'accueil .
Je vous donne l'adresse du forum http://www.planetef1.com/
Rendez vous y avec IE par exemple vous verrez le gros paté rouge
derrière la grande image de l'annonce comme si le bandeau du titre de la catégorie
avait été étiré vers le haut.

Une idée pour fixer ce soucis? : o

Merci.

kamuisuki
**

Féminin
Messages : 54
Inscrit(e) le : 04/07/2010

http://www.forumf1.net
kamuisuki a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug affichage sous Chrome/IE

Message par Manumanu le Sam 14 Avr 2012 - 17:19

Bonjour,

J'ai exactement le même problème avec Chrome, et pour cause : Laisse-moi te copier-coller le code utilisé pour ajouter ton image :

Code:
<div style="text-align: center;" align="center"><font size="5"><span style="font-weight: bold;"><font size="3"><font size="4"></font></font></span></font><table align="left" border="0" cellpadding="0" cellspacing="0" width="100%"><tbody><tr align="left"><td style="text-align: center;"><font size="6"><span style="font-weight: bold;"></span><span style="font-weight: bold;"><span style="text-decoration: underline;"></span><span style="text-decoration: underline;"></span></span></font><span style="text-decoration: underline;"><span style="font-weight: bold;"></span></span><font size="5"><font style="font-weight: bold; font-style: italic;" size="4"><span style="text-decoration: underline;"><span style="font-style: italic;"><span style="text-decoration: underline;"></span></span></span></font><font style="font-weight: bold;" size="4"><span style="text-decoration: underline;"><span style="text-decoration: underline;"><img src="http://www.formula1.com/wi/597x478/sutton/2011/d12chn889.jpg"><br><a href="http://www.planetef1.com/t1491-2012-gp3-chine-shanghai#69721"><font size="6"><span style="font-family: Arial Black;">GP de Chine : Dimanche 15 Avril</span></font></a><br style="font-family: Arial Black;"></span></span></font><font style="font-family: Arial Black;" size="4"><span style="text-decoration: underline;"><span style="text-decoration: underline;"><span style="font-weight: bold;"></span></span></span></font><font style="font-weight: bold;" size="4"><br>Première pôle position pour Nico Rosberg !<br>Première ligne 100% Mercedes : Michael Schumacher 2e !<br><br style="font-family: Arial Black;"><span style="font-family: Arial Black;">Les jeux de la saison 2012: </span><a style="font-family: Arial Black;" href="http://www.planetef1.com/t1476-cp-2012-regles-et-resultats">Le concours des pronostiques</a><span style="font-family: Arial Black;"> et </span><a style="font-family: Arial Black;" href="http://www.planetef1.com/t1481-m-2012-regles-resultats">le manager</a></font><font style="font-weight: bold; font-style: italic;" size="4"><br></font></font></td><td><br></td></tr></tbody></table><font size="5"><span style="font-weight: bold;"><font size="3"><font size="4"><font size="3"><font size="4"><br></font><font style="font-family: Arial Black;" size="4"></font></font></font></font></span></font></div>

Ne te semble-t-il pas que ça fait un peu beaucoup ? Je ne sais pas trop ce que tu as voulu faire, mais là le mieux reste que tu enlèves tout et que tu remettes ton image et ton bout de texte proprement.

Bon courage.

Manumanu
****

Masculin
Messages : 437
Inscrit(e) le : 27/12/2011

http://helpinghelps-phpbb2.forumgratuit.org/
Manumanu a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug affichage sous Chrome/IE

Message par kamuisuki le Sam 14 Avr 2012 - 17:44

Je le fais et je regarde si ça change, car même si le code est pourri de modifications en WYSIWYG , ça s'affiche bien sur certains navigateur.

Bon effectivement ça a réglé le soucis de couleur, reste maintenant le soucis du chevauchement du texte Wink

kamuisuki
**

Féminin
Messages : 54
Inscrit(e) le : 04/07/2010

http://www.forumf1.net
kamuisuki a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug affichage sous Chrome/IE

Message par Manumanu le Sam 14 Avr 2012 - 18:32

Question de code encore une fois :

<div style="text-align: center;"><font style="font-weight: bold;" size="5"><span style="text-decoration: underline;">GRAND PRIX DE CHINE</span> </font><br><font style="font-weight: bold;" size="5">Dimanche 15 avril</font><br><br><font size="4"><span style="font-weight: bold;">Rosberg en Pôle position suivis de Michael Schumacher.</span></font><br></div>

Voilà qui devrait s'afficher correctement :
Code:
<div style="text-align: center; font-weight: 700">
   <h2 style="text-decoration: underline; text-transform: uppercase">Grand prix de chine</h2>
   <p>Dimanche 15 avrils</p>
   <p>Rosberg en Pôle position suivi de Michael Schumacher</p>
</div>

Si tu dois gérer le code, laisse tomber le WYSIWYG, de simples notions de base de html te permettront de produire un code plus propre et donc plus fonctionnel que ces logiciels. Le fait même que tu dises que ça s'affiche bien sur "certains navigateurs" est indicateur d'un problème dans le code. "Tous les navigateurs" (récents, s'entend) est un minimum. Wink

Bon courage.

Manumanu
****

Masculin
Messages : 437
Inscrit(e) le : 27/12/2011

http://helpinghelps-phpbb2.forumgratuit.org/
Manumanu a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug affichage sous Chrome/IE

Message par kamuisuki le Sam 14 Avr 2012 - 18:34

Merci, je veux bien mais le soucis c'est qu'on est 3 a changer le bandeau (L'admin un membre et moi donc les chances de pourrir le code sont énormes..)

^^' enfin je teste ça.

kamuisuki
**

Féminin
Messages : 54
Inscrit(e) le : 04/07/2010

http://www.forumf1.net
kamuisuki a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug affichage sous Chrome/IE

Message par Manumanu le Sam 14 Avr 2012 - 18:36

Effectivement...

Essayez de toujours repartir de zéro dans le bandeau, à chaque fois que vous faîtes une modification. Ça permettra d'éviter ça un moment. Wink

Bon courage.

Manumanu
****

Masculin
Messages : 437
Inscrit(e) le : 27/12/2011

http://helpinghelps-phpbb2.forumgratuit.org/
Manumanu a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug affichage sous Chrome/IE

Message par kamuisuki le Sam 14 Avr 2012 - 18:39

Mais ça n’empêche pas que ça reste un bug, car l'aperçu dans la partie Administration rend bien, il y a que une fois sur l'annonce que ça fait ça.
(Je n'avais aucun soucis en Phpbb2 , j'avais même fait une mise en page
type tableau avec l'image à gauche, la liste des news à droite, et un
encart en bas de l'image à gauche pour les choses a retenir)
Donc même s'il y a une astuce, peut-être qu'il faudrait remonter le soucis ^^'

kamuisuki
**

Féminin
Messages : 54
Inscrit(e) le : 04/07/2010

http://www.forumf1.net
kamuisuki a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug affichage sous Chrome/IE

Message par Manumanu le Sam 14 Avr 2012 - 18:43

Pas d'astuces, mais un problème dans le CSS :

Code:
* {
   margin: 0px;
   padding: 0px;
}

Ça, c'est une mauvaise méthode qui n'apporte que des soucis, dont celui-là... Le texte se comporte étrangement parce qu'il n'a pas de marges automatiques... Et maintenant que le site a été construit autour de cette base à problème, le retirer risquerait de flinguer toute la mise en page.

Code:
<div style="text-align: center; font-weight: 700">
  <h2 style="text-decoration: underline; text-transform: uppercase;margin: 1em 0 .5em">Grand prix de chine</h2>
  <p style="margin: .5em 0">Dimanche 15 avrils</p>
  <p style="margin: .5em 0">Rosberg en Pôle position suivi de Michael Schumacher</p>
</div>

Ça devrait palier, mais ça reste de la bidouille.

Manumanu
****

Masculin
Messages : 437
Inscrit(e) le : 27/12/2011

http://helpinghelps-phpbb2.forumgratuit.org/
Manumanu a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug affichage sous Chrome/IE

Message par kamuisuki le Sam 14 Avr 2012 - 18:46

C'est bizarre car bien qu'ayant modifié le CSS je ne retrouve pas la ligne de code que tu quotes en premier.
Les seules valeur de Pading & marging se rapportent aux menus.

Code:
a:link, a:visited, a:hover, a:active, a:focus {
 
  text-decoration: none;
}
div#logostrip {
background-color: #000000;
}
div#logostrip #main-title h1 {
padding-top: 0;
Align:center;
color: #000000;
background-color:#FFFFFF; 
}
.post {
border-bottom: 1px solid #9AA4B1;
}
.popmenubutton-new-out a {
background-color: #C6CCD4;
}
.popupmenu li {
background-color: #C6CCD4;
}
.popupmenu {
border: 1px solid #3C3C3C
background-color: #C6CCD4;
}
.topic-footer {
background-color: #C6CCD4;
}
.bar {
background-color: #FFFFFF;
}
#userlinks {
background-color: #FFFFFF;
border-bottom: 1px solid #FFFFFF;
}
a.topictitle {
 font-weight: bold;
}
a.mainmenu img {
background-image:url('');
margin-right:0px;
margin-left: 0px;
}
#submenu {
background-attachment: scroll;
background-color: none;
background-image:url ('');
background-position: 0% 0%;
background-repeat: repeat;
color: #3737ab;
padding-bottom: 0em;
padding-left: 0px;
padding-top: 0em;
text-align: right;
}
#submenu ul li a:hover {
background-attachment: scroll;
background-color: transparent;
background-position: 0% 0%;
background-repeat: repeat;
color: #1B8AFA;
padding-bottom: 0em;
padding-left: 0px;
padding-top: 0em;
text-align: right;
background-image:url('http://i46.servimg.com/u/f46/10/06/92/86/bd4hov10.jpg');
}
#submenu ul li {
background-position: 0% 0%;
background-repeat: repeat;
background-attachment: scroll;
text-color : #000000
background-image:url('http://i46.servimg.com/u/f46/10/06/92/86/bd410.jpg');
}
#submenu ul li a {
  padding: 0.5em 1em 0.65em 0;
  margin: 0.5em 1em 0.65em 0;
}

kamuisuki
**

Féminin
Messages : 54
Inscrit(e) le : 04/07/2010

http://www.forumf1.net
kamuisuki a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug affichage sous Chrome/IE

Message par Manumanu le Sam 14 Avr 2012 - 18:48

Alors ce doit être dans la feuille de style par défaut du forum... Ce qui est non pénible parce qu'il est du coup impossible d'y toucher.

Manumanu
****

Masculin
Messages : 437
Inscrit(e) le : 27/12/2011

http://helpinghelps-phpbb2.forumgratuit.org/
Manumanu a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug affichage sous Chrome/IE

Message par kamuisuki le Sam 14 Avr 2012 - 18:51

Donc on ne peu rien faire si je comprend bien.
bon au pire c'est pas très grave , le soucis couleur était le plus
embêtant.

kamuisuki
**

Féminin
Messages : 54
Inscrit(e) le : 04/07/2010

http://www.forumf1.net
kamuisuki a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum