CB latéral, code java qui ne marche pas.

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu CB latéral, code java qui ne marche pas.

Message par Melodiam le Jeu 19 Avr 2012 - 0:37

Bonsoir... Smile ! En une semaine c'est la deuxième fois que je poste, pioulalala...

Alors voilà, j'ai un petit problème que je ne parviens ni à expliquer ni à résoudre. o.o
J'ai utilisé le tutoriel de ce forum pour avoir une CB latérale côté gauche.
Donc ce code :
Code:
jQuery(document).ready(function() { jQuery('body').append('<table style="position: fixed; bottom: 50px; left: 0px;background-color: #ffffff;z-index:10000;"><tr><td><div id="panneau" scrolling="no" style="width: 800px; height: 400px; display: none;" marginwidth="0" marginheight="0" frameborder="0"><iframe src="/chatbox/index.forum?page=front" style="width: 800px; height: 400px;" ></iframe></div></td><td style="vertical-align: bottom;"><img src="http://i81.servimg.com/u/f81/11/21/85/73/ouvrir10.png" onClick="document.getElementById(\'panneau\').style.display=(this.src==\'http://i81.servimg.com/u/f81/11/21/85/73/ouvrir10.png\')?\'block\':\'none\';this.src=(this.src==\'http://i81.servimg.com/u/f81/11/21/85/73/ouvrir10.png\')?\'http://i81.servimg.com/u/f81/11/21/85/73/fermer10.png\':\'http://i81.servimg.com/u/f81/11/21/85/73/ouvrir10.png\';"/></td></tr></table>'); } );

J'ai activé la gestion des pages Javascript (sur toutes les pages), j'ai activé la CB, tenter de désactiver et réactiver l'affichage de celle-ci pour voir si cela changerait ou non la situation... Cela ne change rien !

Après j'ai un code CSS pour modifier l'apparence de la CB mais il n’influe pas (d'après mon constat) puisque, que je l'enlève ou le remette, la CB latérale n'apparaît toujours pas...

Auriez-vous une idée quant à ce problème ? :/


Dernière édition par Melodiam le Lun 23 Avr 2012 - 18:25, édité 1 fois

Melodiam
****

Messages : 206
Inscrit(e) le : 16/04/2012

Melodiam a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par iN-mY-wOrLd le Jeu 19 Avr 2012 - 13:00

Bonjour,

Avez-vous tout simplement activé votre CB dans "module" >"chatbox" ?

car je ne la vois pas sur votre page...

Cordialement,

iN-mY-wOrLd
****

Masculin
Messages : 477
Inscrit(e) le : 15/08/2008

http://www.forum-gem.net
iN-mY-wOrLd a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par Melodiam le Jeu 19 Avr 2012 - 18:05

Bonjour,

Oui je l'ai activé et je la vois quand je suis en ligne. Hors ligne non. ^^


Melodiam
****

Messages : 206
Inscrit(e) le : 16/04/2012

Melodiam a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par Melodiam le Ven 20 Avr 2012 - 20:53

Excusez-moi pour le double-post...

Peu importe le code Java que j'essaye de mettre (récemment j'ai voulu faire ce tuto : http://forum.forumactif.com/t327581-message-d-accueil-en-accordeon?highlight=accord%E9on - que j'ai suivis à la lettre), cela ne marche pas ! Pareil pour mes pages HTML, cela ne marche pas ! Et j'ai pourtant bien fait attention à tout activer, à vérifier si dans le script il n'y avait pas de retour à la lignes etc.

Je ne comprends pas. Confused

Melodiam
****

Messages : 206
Inscrit(e) le : 16/04/2012

Melodiam a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par iN-mY-wOrLd le Ven 20 Avr 2012 - 21:03

Mon message est surement inutile mais je n'utilise jamais chrome pour faire ce genre d'installation, je ne sais pas pourquoi mais avec chrome je ne vois pas tous les champs ni les java installés sur les autres forums....

si quelqu'un a mieux à vous proposer..enjoy !

bon courage.

iN-mY-wOrLd
****

Masculin
Messages : 477
Inscrit(e) le : 15/08/2008

http://www.forum-gem.net
iN-mY-wOrLd a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par Melodiam le Sam 21 Avr 2012 - 13:05

Hello ! Smile

Merci tout de même de ta réponse mais que ce soit IE, Chrome, Firefox ou Safari, les codes ne fonctionnent pas... :/


Mais encore merci de ta réponse ! Smile

Melodiam
****

Messages : 206
Inscrit(e) le : 16/04/2012

Melodiam a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par Invité le Sam 21 Avr 2012 - 14:36

Bonjour, pour la chatbox latérale, voici le code de départ :
Code:
jQuery(document).ready(function() { jQuery('body').append('<table style="position: fixed;bottom: 50px;left: 0px;background-color: #FFFFFF;z-index:10000;"><tr><td><iframe src="/chatbox/chatbox.forum?page=front&" id="chatboxpop" scrolling="no" style="width: 800px; height: 400px; display: none;" marginwidth="0" marginheight="0" frameborder="0"></iframe></td><td style="vertical-align: bottom;"><img src="http://i81.servimg.com/u/f81/11/21/85/73/ouvrir10.png" onClick="document.getElementById(\'chatboxpop\').style.display=(this.src==\'http://i81.servimg.com/u/f81/11/21/85/73/ouvrir10.png\')?\'block\':\'none\';this.src=(this.src==\'http://i81.servimg.com/u/f81/11/21/85/73/ouvrir10.png\')?\'http://i81.servimg.com/u/f81/11/21/85/73/fermer10.png\':\'http://i81.servimg.com/u/f81/11/21/85/73/ouvrir10.png\';"/></td></tr></table>'); } );
Pour l'installer il suffit d'aller dans votre " Panneau d'Administration -> Onglet Modules -> Gestion des codes Javascript -> ajout Créer un nouveau javascript ". Là mettez le nom que vous voulez ("Chatbox" par exemple) en bas cocher "sur toutes les pages" et plus bas mettez-y le code proposé ci-dessus et enfin enregistrez. Logiquement là le code devrait fonctionner, si ce n'est pas le cas c'est qu'il y a un problème chez vous. Essayez peut-être sur un autre ordinateur, celui d'un ami par exemple.

Cordialement,

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par Ea le Sam 21 Avr 2012 - 14:43

Bonjour,


Si c'est pour http://melodiam.forumgratuit.eu/ je n'y vois aucun code javascript, est-ce que c'est en place ? ( et ce forum ? )

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par Melodiam le Dim 22 Avr 2012 - 19:17

Bonsoir et merci à vous deux pour vos réponses !

TsukiKurai : J'ai installé le code exactement comme vous me l'avez préconisé mais rien à faire cela ne marche pas. Pourtant sur un autre forum que j'avais avant, (en utilisant le même ordi) je n'avais aucun soucis de script et c'était la même version ! reflexion

Etana, oui il s'agit de Melodiam et j'ai activé la gestion des pages Javascript.. C'est vraiment bizarre, sans doute est-ce un problème tout bête mais je ne vois vraiment pas d'où il vient.
Peut être pourrais-je vous fournir mon login et pass d'admin pour que vous voyez par vous même ?

Encore merci ! ^^

Melodiam
****

Messages : 206
Inscrit(e) le : 16/04/2012

Melodiam a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par Ea le Dim 22 Avr 2012 - 19:34

Peut être pourrais-je vous fournir mon login et pass d'admin pour que vous voyez par vous même ?
Non Smile

Sinon là sur melodiam le script est bien en place, mais pas mis à cause de la modification de template qui n'a pas été réalisée :
http://forum.forumactif.com/t308422-nouveaute-forumactif-gestion-des-codes-javascript#edit-temp

Une fois fait il ne devrait pas y avoir de problème.

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par Melodiam le Dim 22 Avr 2012 - 20:12

Merci de ta réponse Etana !
Alors effectivement je pense que c'est cela qui cloche, je n'ai pas fais cette mise à jour..

J'ai voulu la faire en cherchant la balise demandé pour coller la nouvelle avant mais je ne l'ai pas trouvé dans mon template overhall_header..
J'ai fais une recherche mais rieeeeeeen.

Voici mon template :

Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html dir="{S_CONTENT_DIRECTION}" id="min-width" lang="{L_LANG_HTML}" xml:lang="{L_LANG_HTML}" xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <!-- BEGIN meta_emulate_ie7 -->
      <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
      <!-- END meta_emulate_ie7 -->
      <title>{SITENAME_TITLE}{PAGE_TITLE}</title>
      <meta http-equiv="content-type" content="text/html; charset={S_CONTENT_ENCODING}" />
      <meta http-equiv="content-script-type" content="text/javascript" />
      <meta http-equiv="content-style-type" content="text/css" />
      {META_FAVICO}
      {META}
      <meta name="title" content="{SITENAME_TITLE}{PAGE_TITLE}" />
      {T_HEAD_STYLESHEET}
      {CSS}
      <link rel="search" type="application/opensearchdescription+xml" href="/improvedsearch.xml" title="{SITENAME}" />
      <link rel="search" type="application/opensearchdescription+xml" href="{URL_BOARD_DIRECTORY}/search/improvedsearch.xml" title="{SEARCH_FORUMS}" />
      <script src="{JQUERY_PATH}" type="text/javascript"></script><script src="{JS_DIR}{L_LANG}.js" type="text/javascript"></script>
      <!-- BEGIN switch_ticker -->
      <script src="{JS_DIR}jquery/ticker/ticker.js" type="text/javascript"></script>
      <link type="text/css" rel="stylesheet" href="{JS_DIR}jquery/ticker/ticker.css" />
      <!-- END switch_ticker -->
      <script type="text/javascript">
      //<![CDATA[
      $(document).ready(function(){
          <!-- BEGIN switch_enable_pm_popup -->
            pm = window.open('{U_PRIVATEMSGS_POPUP}', '_faprivmsg', 'HEIGHT=225,resizable=yes,WIDTH=400');
            pm.focus();
          <!-- END switch_enable_pm_popup -->
          <!-- BEGIN switch_report_popup -->
            report = window.open('{switch_report_popup.U_REPORT_POPUP}', '_phpbbreport', 'HEIGHT={switch_report_popup.S_HEIGHT},resizable=yes,scrollbars=no,WIDTH={switch_report_popup.S_WIDTH}');
            report.focus();
          <!-- END switch_report_popup -->
          <!-- BEGIN switch_ticker -->
            ticker_start({switch_ticker.HEIGHT}, {switch_ticker.SPACING}, {switch_ticker.SPEED}, '{switch_ticker.DIRECTION}', {switch_ticker.STOP_TIME});
          <!-- END switch_ticker -->
      });

      <!-- BEGIN switch_login_popup -->
          var logInPopUpLeft, logInPopUpTop, logInPopUpWidth = {LOGIN_POPUP_WIDTH}, logInPopUpHeight = {LOGIN_POPUP_HEIGHT}, logInBackgroundResize = false, logInBackgroundClass = false;
      <!-- END switch_login_popup -->
      //]]>
      </script>
      {GREETING_POPUP}
      <!-- BEGIN hitskin_preview -->
      <style type="text/css">
      #hitskin_preview {
          margin: 0; padding: 0;
          position: fixed;
          top: 0; left: 0;
          width: 100%;
          height: 65px;
          background: url('http://illiweb.com/fa/hitskin/hitskin_bar.png') repeat-x left -15px;
          color: #fff;
      }
      * html #hitskin_preview { /* Fix for IE6 since it doesn't implement fixed positionning */
          position: absolute;
          top:expression(eval(document.compatMode && document.compatMode=='CSS1Compat') ? documentElement.scrollTop : document.body.scrollTop);
          z-index: 2;
          background: transparent url('http://illiweb.com/fa/hitskin/hitskin_bar-ie6.gif') repeat-x left -15px;
      }
      * html { /* Gunlaug's Speed fix for the above positionning fix. Sorry for the fix for the fix */
        background: #fff url(foo) fixed;
        }
      #hitskin_preview h1 {
          float: left;
          margin: 3px 0 0 0;
          padding: 0 0 0 10px;
          font: italic normal 25px Arial,sans serif;
          color: #fff;
      }
      #hitskin_preview h1 img {
          vertical-align: middle;
      }
      #hitskin_preview em {
          color: #7CBA2C;
          font-weight: bold;
      }
      #hitskin_preview a {
      color: #fff;
      }
      #hitskin_preview a:hover {
      text-decoration: underline;
      }

      #hitskin_preview .content {
          text-align: right;
      }
      #hitskin_preview .content p {
          margin: 4px 1em 0px 1em;
          font-size: 13px;
          line-height: 1.8em;
          color: #fff;
          font-weight: bold;
      }
      #hitskin_preview .content p span {
          font-weight: normal;
          font-size: 0.8em;
      }
      body {
          margin-top: 40px !important;
      }
      {hitskin_preview.HITSKIN_RTL_CSS}
      </style>
      <!-- END hitskin_preview -->
    <script type="text/javascript">
    function visibilite(thingId)
    {
    var targetElement;
    targetElement = document.getElementById(thingId) ;
    if (targetElement.style.display == "none")
    {
    targetElement.style.display = "" ;
    } else {
    targetElement.style.display = "none" ;
    }
    }
    </script>   
    <script type="text/javascript" src="http://sd-2.archive-host.com/membres/up/198368448645211924/accordeons.js"></script>

    </head>
    <body background="{T_BODY_BACKGROUND}" bgcolor="{T_BODY_BGCOLOR}" text="{T_BODY_TEXT}" link="{T_BODY_LINK}" vlink="{T_BODY_VLINK}">
      <!-- BEGIN hitskin_preview -->
      <div id="hitskin_preview" style="display: block;">
          <h1><img src="http://illiweb.com/fa/hitskin/hitskin_logo.png" alt="" /> Hit<em>skin</em>.com</h1>
          <div class="content">
            <p>
                {hitskin_preview.L_THEME_SITE_PREVIEW}
                <br />
                <span>{hitskin_preview.U_INSTALL_THEME}<a href="http://{hitskin_preview.U_RETURN_THEME}">{hitskin_preview.L_RETURN_THEME}</a></span>
            </p>
          </div>
      </div>
      <!-- END hitskin_preview -->

      <!-- BEGIN switch_login_popup -->
      <div id="login_popup">
          <table class="forumline" width="{LOGIN_POPUP_WIDTH}" height="{LOGIN_POPUP_HEIGHT}" border="0" cellspacing="1" cellpadding="0">
            <tr height="25">
                <td class="catLeft">
                  <span class="genmed module-title">{SITENAME}</span>
                </td>
            </tr>
            <tr height="{LOGIN_POPUP_MSG_HEIGHT}">
                <td class="row1" align="left" valign="top">
                  <div id="login_popup_buttons">
                      <form action="{S_LOGIN_ACTION}" method="get">
                        <input type="submit" class="mainoption" value="{L_LOGIN}" />
                        <input type="button" class="mainoption" value="{L_REGISTER}" onclick="parent.location='{U_REGISTER}';" />
                        <input id="login_popup_close" type="button" class="button" value="{L_DONT_DISPLAY_AGAIN}" />
                      </form>
                  </div>
                  <span class="genmed">{LOGIN_POPUP_MSG}</span>
                </td>
            </tr>
          </table>
      </div>
      <!-- END switch_login_popup -->

      <a name="top"></a>
      {JAVASCRIPT}
      <table class="bodylinewidth" width="{T_BODY_TABLE_WIDTH}" cellspacing="0" cellpadding="10" border="0" align="center">
          <tr>
            <td class="bodyline">
                        <table cellspacing="0" width="100%" cellpadding="0" border="0" align="center">
                  <tr>
                    <td><center><div class="navig">{GENERATED_NAV_BAR}</div></center></td>
                  </tr>
                </table><br/>
                <table width="100%" cellspacing="0" cellpadding="0" border="0">
                  <tr>
                      <!-- BEGIN switch_logo_left -->
                      <td><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a></td>
                      <td align="center" width="100%" valign="middle">
                        <div class="maintitle">{MAIN_SITENAME}</div>
                        <br />
                        <span class="gen">{SITE_DESCRIPTION}<br />  </span>
                      </td>
                      <!-- END switch_logo_left -->

                      <!-- BEGIN switch_logo_center -->
                      <td align="center" width="100%" valign="middle">
                        <a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a><br />
                        <div class="maintitle">{MAIN_SITENAME}</div>
                        <br />
                        <span class="gen">{SITE_DESCRIPTION}</span>
                      </td>
                      <!-- END switch_logo_center -->

                      <!-- BEGIN switch_logo_right -->
                      <td align="center" width="100%" valign="middle">
                        <div class="maintitle">{MAIN_SITENAME}</div>
                        <br />
                        <span class="gen">{SITE_DESCRIPTION}<br />  </span>
                      </td>
                      <td>
                        <a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a>
                      </td>
                      <!-- END switch_logo_right -->
                  </tr>
                </table>


            <div style="clear: both;"></div>

                <!-- BEGIN switch_ticker -->
                <div id="fa_ticker_block" style="margin-top:4px;margin-bottom:4px;">
                  <table width="100%" border="0" cellspacing="0" cellpadding="0" class="forumline">
                      <tr>
                        <td {CLASS_TABLE_TYPE} align="left" class="row1">
                            <div id="fa_ticker_container">
                              <div id="fa_ticker" style="height:{switch_ticker.HEIGHT}px;">
                                  <div class="fa_ticker_content">
                                    <!-- BEGIN ticker_row -->
                                    <div>{switch_ticker.ticker_row.ELEMENT}</div>
                                    <!-- END ticker_row -->
                                  </div>
                              </div>
                            </div>
                        </td>
                      </tr>
                  </table>
                </div>
                <!-- END switch_ticker -->

                <div id="page-body">
                  <div id="{ID_CONTENT_CONTAINER}"{CLASS_CONTENT_CONTAINER}>
                      <table cellpadding="0" cellspacing="0" width="100%" class="three-col">
                        <tbody>
                            <tr>
                              <td valign="top" width="{C1SIZE}">
                                  <div id="{ID_LEFT}">
                                    <!-- BEGIN giefmod_index1 -->
                                    {giefmod_index1.MODVAR}
                                        <!-- BEGIN saut -->
                                        <div style="height:{SPACE_ROW}px"></div>
                                        <!-- END saut -->
                                    <!-- END giefmod_index1 -->
                                  </div>
                              </td>
                              <td valign="top" width="100%">
    <!-- BEGIN html_validation -->
                              </td>
                            </tr>
                        </tbody>
                      </table>
                  </div>
                </div>
            </td>
          </tr>
      </table>
    </body>
    </html>
    <!-- END html_validation -->

Je suis désolée de vous enquiquiner..

Melodiam
****

Messages : 206
Inscrit(e) le : 16/04/2012

Melodiam a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par Ea le Dim 22 Avr 2012 - 22:29

Vous avez probablement une mise à jour précédente pas encore mise non plu.

Vous pouvez ajouter ça avant :

Code:
<!-- BEGIN switch_ticker -->
Cordialement.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par Melodiam le Lun 23 Avr 2012 - 17:41

Excusez-moi encore de vous déranger..

Où dois-je mettre ce code précisément ? Si je le mets après le javascript marchera ?

Cordialement.

Melodiam
****

Messages : 206
Inscrit(e) le : 16/04/2012

Melodiam a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par Ea le Lun 23 Avr 2012 - 18:07

Le code qu'il est dit d'ajouter, vous pouvez le mettre avant :

Code:
<!-- BEGIN switch_ticker -->
Cordialement.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CB latéral, code java qui ne marche pas.

Message par Melodiam le Lun 23 Avr 2012 - 18:25

ENFIN CELA MARCHE ! Hallelujah !

Merci énormément pour votre patience et temps !!!!!!!!!! cheers

Cordialement.

Melodiam
****

Messages : 206
Inscrit(e) le : 16/04/2012

Melodiam a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum