Problèmes avec les sous-forums

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problèmes avec les sous-forums

Message par gaellecathleen le Dim 6 Mai 2012 - 7:01

Bonjour, alors voilà j'ai un petit soucis. J'aimerais bien faire ce genre de chose là ou il est écrit lien 1, lien 2.

http://i43.servimg.com/u/f43/11/93/43/22/aperau11.jpg

Malheureusement, je n'arrive pas du tout à y parvenir -_-. Es que quelqu'un saurait m'aider ou au moins essayer de m'expliquer comment faire.

Merci (aa)


Dernière édition par gaellecathleen le Dim 6 Mai 2012 - 12:49, édité 1 fois

gaellecathleen
**

Messages : 64
Inscrit(e) le : 06/05/2012

gaellecathleen a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes avec les sous-forums

Message par tupac le Dim 6 Mai 2012 - 8:48

Lien 1,lien 2 sont en fait les sous-forum,ils sont placés en colonne a l'aide d'un script puis placé dans une barre de défilement.
Les modifications se font dans la template index_box.

Pour les sous forum en colonne il s'agit de ce script.
Code:
<span class="gensmall" id="subforums">{catrow.forumrow.L_LINKS}                {catrow.forumrow.LINKS}</span></div>
          <script type="text/javascript">jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,'<br />')).removeAttr('id');</script>

Pour la barre de défilement placer le script (ci-dessus)pour les sous-forum entre les div.
Code:
<div class="barre_defilement"> sous forum ici </div>

puis le css pour le défilement de la barre a placer dans votre feuille de style,n'oubliez pas de mettre une hauteur et largeur .
Code:
.barre_defilement {
overflow: auto;
width: LARGEURpx;
height: HAUTEURpx;
}

Essayez déjà par vous même et si vous avez des difficultés pour mettre en place tout ça faite nous signe.

tupac
+ Hyperactif +

Masculin
Messages : 2331
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes avec les sous-forums

Message par gaellecathleen le Dim 6 Mai 2012 - 9:10

Merci, effectivement j'ai du mal à mettre cela en place :-s Je ne suis pas du tout douée pour jouer avec les templates

gaellecathleen
**

Messages : 64
Inscrit(e) le : 06/05/2012

gaellecathleen a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes avec les sous-forums

Message par tupac le Dim 6 Mai 2012 - 9:20

Je vais vous aider.
Votre template a-t-il subi des modifications ?
Si c'est le cas pouvez-vous nous le poster entre les balise CODE svp.

tupac
+ Hyperactif +

Masculin
Messages : 2331
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes avec les sous-forums

Message par gaellecathleen le Dim 6 Mai 2012 - 9:33

merci beaucoup c'est gentil ^^

Code:
      <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.5/jquery.min.js"></script>
            <table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
              <tr>
                  <td valign="bottom">
                    <!-- BEGIN switch_user_logged_in -->
                    <span class="gensmall">{LAST_VISIT_DATE}<br />
                    {CURRENT_TIME}<br />
                    </span>
                    <!-- END switch_user_logged_in -->
                    <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
                  </td>
                  <td class="gensmall" align="right" valign="bottom">
                    <!-- BEGIN switch_user_logged_in -->
                    <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
                    <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
                    <!-- END switch_user_logged_in -->
                    <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
                  </td>
              </tr>
            </table>
            <br />
              <!-- BEGIN catrow --><!-- BEGIN tablehead -->
              <FIELDSET style="border:#131313 3px solid; -moz-border-radius: 8px; -webkit-border-radius: 8px; background-image: url('http://obsession27.free.fr/divers/fonds/bo2.jpg'); -webkit-box-shadow:1px 1px 12px #0e0e0e; -moz-box-shadow:1px 1px 12px #0e0e0e;"><LEGEND><span class="cattitle"><span class="titrecategorie"> {catrow.tablehead.L_FORUM} </span></span></LEGEND>
              <table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
              <!-- END tablehead -->
              <!-- BEGIN cathead -->
              <tr>
                  <!-- BEGIN inc -->
                  <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
                  <!-- END inc -->
                  <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
                    <h{catrow.cathead.LEVEL} class="hierarchy">
                        <span class="cattitle">
                          <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
                        </span>
                    </h{catrow.cathead.LEVEL}>
                  </td>
                  <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right"> </td>
              </tr>
                  <!-- END cathead -->
              <!-- BEGIN forumrow -->
              <tr>
                  <!-- BEGIN inc -->
                  <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
                  <!-- END inc -->
                  <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="100%" height="50">
                    <h{catrow.forumrow.LEVEL} class="hierarchy">
                        <span class="forumlink">
                        </span>
                    </h{catrow.forumrow.LEVEL}>
         
<FIELDSET style="border:#131313 3px solid; -moz-border-radius: 8px; -webkit-border-radius: 8px; background-image: url('http://obsession27.free.fr/divers/fonds/bo2.jpg'); -webkit-box-shadow:1px 1px 12px #0e0e0e; -moz-box-shadow:1px 1px 12px #0e0e0e;">
<LEGEND style="color:#5B120C;">
<table width="100%" ;><tr><td><div class="fondcat"> <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a> </div></td></tr><tr><td align="right">
<div class="liensinf"> <span class="gensmall">  {catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</span></div></td></tr></table>
</LEGEND><table width="100%" ;><tr><td><span class="icones"><img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
<a class="vignettes"></a></span></td><td><span class="genmed">{catrow.forumrow.FORUM_DESC}</span></td><td><div class="sous" style="font-size: 11px; text-align: right; margin-right: 2px; margin-top: 1px;">
<span class="gensmall"><span class="infodes"><b>Sujets :</b> {catrow.forumrow.TOPICS} | <b>Messages :</b> {catrow.forumrow.POSTS} | <b>Dernier :</b> {catrow.forumrow.LAST_POST}</span></span></div>
<span class="gensmall">
              </span></td></tr></table></FIELDSET></td>
                  <!-- BEGIN forum_link_no -->
            <!-- END forum_link_no -->
                  <!-- BEGIN forum_link -->
                  <td class="row3" colspan="3" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.forum_link.HIT_COUNT}</span></td>
                  <!-- END forum_link -->
              </tr>
              <!-- END forumrow -->
              <!-- BEGIN catfoot -->
              <tr>
                  <!-- BEGIN inc -->
                  <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
                  <!-- END inc -->
                  <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
              </tr>
            <!-- END catfoot -->
              <!-- BEGIN tablefoot -->
            <img src="{SPACER}" alt="" height="5" width="1" /></table></FIELDSET><!-- END tablefoot --><!-- END catrow -->div>

gaellecathleen
**

Messages : 64
Inscrit(e) le : 06/05/2012

gaellecathleen a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes avec les sous-forums

Message par tupac le Dim 6 Mai 2012 - 12:04

Bon repérer la partie suivante dans votre template index_box puis supprimez-là..

Code:
<tr>
<td align="right">
<div class="liensinf"> <span class="gensmall">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</span></div>
</td>
</tr>
Supprimez ensuite cette partie.
Code:
<span class="genmed">{catrow.forumrow.FORUM_DESC}</span>
et remplacez-là par celle-ci.
Code:
<table class="description" width="100%">
<tr>
<td valign="top" width="20%"><div align="center" class="sous_forum">
<span class="sousforum" id="subforums">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</div></span><script type="text/javascript">
        jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,'<br />')).removeAttr('id');</script>
</td>     
<td align="center" width="80%"><span class="genmed">{catrow.forumrow.FORUM_DESC}</span>       
</td>
</tr>
</table>

tupac
+ Hyperactif +

Masculin
Messages : 2331
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes avec les sous-forums

Message par gaellecathleen le Dim 6 Mai 2012 - 12:29

mercçi beaucoup ca marche^^ encore merci mille fois, depuis le temps que j essayais de faire ca^^

gaellecathleen
**

Messages : 64
Inscrit(e) le : 06/05/2012

gaellecathleen a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes avec les sous-forums

Message par tupac le Dim 6 Mai 2012 - 12:31

Mais de rien Wink
Voulez-vous éditer votre premier message et cocher résolu svp.

Bon dimanche.

tupac
+ Hyperactif +

Masculin
Messages : 2331
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum