Forum gratuit : Le forum des forums actifs
Bienvenue sur le forum de support de ForumActif.

Afin de profiter pleinement de tout ce que vous offre notre forum, merci de vous identifier si vous êtes déjà membre ou de rejoindre notre communauté si vous ne l'êtes pas encore.

Créer un forum gratuit semblable à ce forum !
Créer un forum gratuit

Rechercher
Magic FDFRechercher parmi les tutoriels...
Pensez à effectuer une recherche parmi les tutoriels existants avant d'ouvrir un sujet dans l'Entraide !



Afficher sous forme de :


Les posteurs les plus actifs de la semaine
Chacha
 
Vivi
 
Tech
 
SeLfde4Th7
 
Neptune-
 
Nesquik
 
Space Sapien
 
FANCH 56
 
kiwi14637
 
Kinotto
 

Thèmes du mois
  • Thème forum rentrée
  • Thème forum
  • Thème magic septembre 2014
  • Thème Fairy Tail
  • Thème rentrée scolaire
  • Thème Minecraft
  • Thème forum
  • Thème Vive la rentrée
  • Thème pokémon
  • Thème pastel printemps
  • Thème SAO
Derniers sujets
Qui est en ligne ?
Il y a en tout 197 utilisateurs en ligne :: 7 Enregistrés, 0 Invisible et 190 Invités :: 2 Moteurs de recherche

:Dark-CO:, At0mic, FELENIUS, Grimm, Renald, Satsujinsa, sssshut

Le record du nombre d'utilisateurs en ligne est de 1877 le Jeu 19 Mai 2011 - 15:00

Problème de positionnement

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème de positionnement

Message par Saena26 le Lun 7 Mai 2012 - 22:39

Bonjour,

J'ai des problèmes avec les positionnements de certains de mes éléments de ma page.

Pour expliquer plus amplement mon problème, voici l'image que j'ai rajouté tout en haut de mon forum pour faire comme une nouvelle barre de "menu"/navigation :



Ce qui est encadré en rouge > est la barre de navigation de mon forum. J'ai simplement remplacé les liens par des images et j'ai réussi à placer ma barre de navigation au dessus de mon image (avec le fond bleu, et les NOUVELLES, TRADUCTIONS, etc...)

Mon seul problème est que pour faire apparaître ma barre de navigation au dessus de mon image, j'ai tout rentré dans un tableau : un td avec l'image, un autre td avec ma barre de navigation.. Mais j'ai du mettre ma barre de navigation en position: absolute pour que ça marche ... et après jouer avec les valeurs de top: XXpx left: XXpx, etc...

Du coup, pour ma résolution d'écran, pas de problème, tout est en place, mais forcément une fois que la résolution change, ma barre de navigation se décale vers la droite ou la gauche.

Je savais que ça poserait problème mais je ne voyais pas comment faire d'autre et j'ai du mal avec toutes les propriétés pour positionner tous mes éléments où je le veux... ^^; J'ai du mal à saisir comment me servir du float, positon relative, etc... Je ne vois pas comment faire.

J'aurais donc besoin d'un petite coup de pouce à ce niveau.

En bref, j'aimerais que ma barre de navigation reste fixée au même endroit au dessus de mon image peu importe la résolution d'écran.

Voici la partie concernée de mon template overall_header (il faut poster pour voir les codes)




Et le CSS associé :



Dernière édition par Saena26 le Mar 8 Mai 2012 - 17:43, édité 2 fois

Saena26
**

Féminin
Messages: 72
Réputation: 0
Inscrit(e) le: 16/05/2010

http://hoonichi.forums-actifs.com/

Revenir en haut Aller en bas

Résolu Re: Problème de positionnement

Message par Elysion28 le Mar 8 Mai 2012 - 10:59

tu aurais mieux fait de mettre en spoiler qu'en hide lol, ça aurait été plus vite pour regarder.


Edit: dans ton css tu peux toujours essayer de jouer avec les margin-left, margin-right, en mettant des -Xpx, ou des valeurs positives... mais je ne sais pas si ça va fonctionner pour ton problème... sinon tu as la valeur align="center" ou carrément, encadré ton nouveau tableau des balises
Code:
<center>  </center>

Elysion28
*

Féminin
Messages: 32
Réputation: 1
Inscrit(e) le: 11/03/2011

http://elysion-forumtest.forumgratuit.org/

Revenir en haut Aller en bas

Résolu Re: Problème de positionnement

Message par Saena26 le Mar 8 Mai 2012 - 17:43

Bonjour,

Merci pour votre aide, mais ça ne marche pas de cette façon.^^ J'ai réussi à trouver tout de même en essayant votre technique.
En fait il faut mettre l'image en fond du tableau et ça marche. ^^

Merci, sujet résolu

Saena26
**

Féminin
Messages: 72
Réputation: 0
Inscrit(e) le: 16/05/2010

http://hoonichi.forums-actifs.com/

Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum