Problème avec le cadre d'accueil

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec le cadre d'accueil

Message par lily1412 le Mer 8 Aoû 2012 - 20:54

Bonsoir, il y a quelques mois j'avais fait un cadre d'accueil avec tableau, en mettant notamment des images en fond etc.. Mais j'ai malheureusement perdu le code de ma page d'accueil & je n'arrive plus à rien >_<

Dans généralité, j'ai donc mis ceci :

Code:
<div><tr><td style="background-image: url(http://d3.e-loader.net/lQ6bqUkpuv.jpg); align:left;  width: 473px; height: 144px;></td>
<td style="background-image: url(http://d17.e-loader.net/VQVyTsamHX.jpg); align:right;  width: 473px; height: 144px;>Annonce !!!</td></tr></div>

Mon site: http://test-t-ara.forumgratuit.org/

J'aimerai notamment comprendre pourquoi mon image se met à droite et non à gauche ? Pourquoi mes deux photos de fond n'apparaissent pas ?

Tout ce que j'ai pu essayer, rien n'a marché, donc je fais appel à vous. Merci d'avance.


Dernière édition par lily1412 le Jeu 9 Aoû 2012 - 10:29, édité 1 fois

lily1412
Nouveau membre

Féminin
Messages : 28
Inscrit(e) le : 05/05/2011

http://t-ara-fansub.forumgratuit.org/
lily1412 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le cadre d'accueil

Message par Alex Fowl le Mer 8 Aoû 2012 - 21:11

Bonsoir,

Remplacez ceci en message d'accueil :
Code:
<div><tr><td class="cadre1"></td>
<td class="cadre2">Annonce !!!</td></tr></div>

Et ceci dans votre code css (Panneau d'administration => Affichage => Couleurs => Feuille de style CSS) :
Code:
.cadre1 {
background-image: url('http://d3.e-loader.net/lQ6bqUkpuv.jpg');
align:left;
width:473px;
height:144px;
}

.cabre2 {
background-image: url('http://d17.e-loader.net/VQVyTsamHX.jpg');
align:right;
width: 473px;
height: 144px;
}

Cordialement,

Alex Fowl
+ Hyperactif +

Masculin
Messages : 7557
Inscrit(e) le : 28/03/2009

http://www.aidactif.fr
Alex Fowl a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le cadre d'accueil

Message par lily1412 le Mer 8 Aoû 2012 - 21:27

Je n'avais pas du tout fait comme ça la première fois, je dois dire.

J'obtiens un gros bord sur la gauche, et l'image de droite n'apparaît pas :/
Je vous mets le code mon CSS, si ça peut vous aider :

Code:
.groupes{
background-color:#FFFFFF;border: 1px #D0D0D0 dotted;
-moz-border-radius : 5px 5px 5px 5px;
height:40px;padding-right:12px;padding-left:14px;padding-bottom:3px;
font-size:15px;font-weight: bold;text-align:center;
text-decoration: none !important;}


a.forumlink {
background-color: #transparent;
text-shadow: #f5f8de 1px 1px 1px;
background-image: url('http://nsa15.casimages.com/img/2010/05/09/100509044510844127.png');
color: #894E45;
display: block;
font-family: Calibri;
font-size: 14px;
text-transform: uppercase;
text-align: center;
letter-spacing: -1px;
-moz-border-radius:5px;
-moz-box-shadow: 0px 2px 2px #a49896;
}

a.forumlink:hover{
background-color: #transparent;
text-shadow: #635f5e 1px 1px 1px;
background-image: url('http://i45.servimg.com/u/f45/16/55/75/45/erthyj10.png');
color: #f9fced;
display: block;
font-family: Calibri;
font-size: 14px;
text-transform: uppercase;
text-align: center;
letter-spacing: -1px;
-moz-border-radius:5px;
-moz-box-shadow: 0px 2px 2px #a49896;
}


 
.mon_onglet{
  display: inline;
    padding: 2px;
  margin: 15px;
  color: #000;
  background: #fff;
-moz-border-radius:6px;
-webkit-border-radius:6px;
border-radius:6px;
border:3px solid #ede1ea;
  }
 
.mon_onglet:hover{
  background: #b8efa1;}
       
.mon_onglet_selected{
  display: inline;
 
  padding: 2px;
  margin: 15px;
  color: #000;
  background: #ffff;
-moz-border-radius:6px;
-webkit-border-radius:6px;
border-radius:6px;
border:3px solid #ede1ea;
  } 
       
.clear{
  clear: both;}
 
.mon_contenu{
  color: #000;
  background: #fff;
-moz-border-radius:6px;
-webkit-border-radius:6px;
border-radius:6px;
border:3px solid #ede1ea;
  padding: 10px;
  margin: 10 px;
  height: 120px;
  line-height: normal;
  font-size: 9px;}
 
#mes_contenus, #mes_onglets{
  height: 100%;
  width:100%;}

 
.infobulle{
position: relative;
z-index: 0;}
 
.infobulle:hover{
background-color: transparent;
z-index: 50;}
 
.infobulle span{
position: absolute;
background-color: #B3B3B3;
padding: 5px;
left: -1000px;
visibility: hidden;
color: #FFFFFF;
-webkit-border-radius:6px;
border:5px solid #666466;}
 
.infobulle span img{
border: 2px;
padding: 5px;}
 
.infobulle:hover span{
visibility: visible;
top: 60px;
left: 25px;
width: 140px ;
color:#2F2F30;
font-size: 11px;
border: 1px #2F2F30;
-moz-border-radius:6px;
-webkit-border-radius:6px;
border-radius:6px;
border:5px solid #666466;}

.profil{
  text-align: center;
  font-family: Lobster1.4;
  font-size: 20px;
  padding: 8px;
  background-color: white;
-moz-border-radius: 10px;
-webkit-border-radius: 10px;
  border-radius: 10px;
  border:3px solid #000000;}




 
.mon_onglet{
  float: left;
  padding: 2px 10px;
  margin-right: 5px;
  color: #000;
  background: #fff;
  border: 1px solid #000;
  cursor: pointer;
  margin-bottom: -1px;
  list-style: none;
}
.mon_onglet:hover{
  background: #b8efa1;
}       
.mon_onglet_selected{
  float: left;
  padding: 2px 10px;
  margin-right: 5px;
  color: #000;
  background: #fff;
  border-top: 1px solid #000;
  border-right: 1px solid #000;
  border-left: 1px solid #000;
  border-bottom: 1px solid #fff;
  cursor: pointer;
  margin-bottom: -1px;
  list-style: none;}         
.clear{
  clear: both;
}
.mon_contenu{
  color: #000;
  background: #fff;
  border: 1px solid #000;
  padding: 10px;
  line-height: normal;
  font-size: 11px;}
#mes_contenus, #mes_onglets{
  width: 400px;
  margin: auto;}

div.topictitle strong {
display: none;
}
.bouhautbas {
bottom: 40px;
right: 10px;
position: fixed;
z-index: 100;
}
body { background-repeat: no-repeat;
background-position: center -50px;
}
#i_logo {
margin-bottom: 500px; text-align: center;
}
.avatar
{
-moz-border-radius-bottomleft:10px;
-moz-border-radius-bottomright:10px;
-moz-border-radius-topleft:10px;
-moz-border-radius-topright:10px;
border: 5px solid #E25A47;
}
.navig {
position: absolute;
top: 0px;
width: 100%;
}

.ban1 { background-image: url('http://d26.e-loader.net/ER2iZNeX8j.jpg'); }
.ban2 { background-image: url('http://d30.e-loader.net/qPfmGrQvki.bmp'); }
.ban3 { background-image: url('http://d8.e-loader.net/BRdLOyXwCR.bmp'); }
.ban4 { background-image: url('http://d19.e-loader.net/EcFbIXHcYF.bmp'); }
.ban5 { background-image: url('http://d16.e-loader.net/KnHQKvORdM.bmp'); }
.ban6 { background-image: url('http://d26.e-loader.net/6WuMNd4qPQ.bmp'); }
.ban7 { background-image: url('http://d30.e-loader.net/a6F4W5PwoH.jpg'); }

.cadre1 {
background-image: url('http://d3.e-loader.net/lQ6bqUkpuv.jpg');
align:left;
width:470px;
height:144px;
}
 
.cabre2 {
background-image: url('http://d17.e-loader.net/VQVyTsamHX.jpg');
align:right;
width: 470px;
height: 144px;
}

Merci de votre réponse en tout cas.

lily1412
Nouveau membre

Féminin
Messages : 28
Inscrit(e) le : 05/05/2011

http://t-ara-fansub.forumgratuit.org/
lily1412 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le cadre d'accueil

Message par Alex Fowl le Mer 8 Aoû 2012 - 21:40

Essayez ce code alors ! Smile

Code:
<div><tr><td style="background-image: url('http://d3.e-loader.net/lQ6bqUkpuv.jpg'); align:left; width:473px; height:144px;"></td>
<td style="background-image: url('http://d17.e-loader.net/VQVyTsamHX.jpg'); align:right; width: 473px; height: 144px;">Annonce !!!</td></tr></div>

Cordialement,

Alex Fowl
+ Hyperactif +

Masculin
Messages : 7557
Inscrit(e) le : 28/03/2009

http://www.aidactif.fr
Alex Fowl a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le cadre d'accueil

Message par lily1412 le Mer 8 Aoû 2012 - 21:52

Ah, je vous remercie, ça commence à ressembler à quelque chose ^^
Mais pourquoi y'a-t-il une bande de couleur plus épaisse à gauche qu'à droite ?
Et, est-ce possible d'enlever la barre de couleur entre les deux images ? Je voudrais qu'il n'y ait pas de séparations, pour pouvoir obtenir quelque chose comme ça :



Edit: Après recherche, j'ai fait le choix d'enlever le cadre mais pourquoi j'ai toujours cette barre à gauche ? Je comprends pas :/

lily1412
Nouveau membre

Féminin
Messages : 28
Inscrit(e) le : 05/05/2011

http://t-ara-fansub.forumgratuit.org/
lily1412 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le cadre d'accueil

Message par Alex Fowl le Mer 8 Aoû 2012 - 23:15

Il s'agit de ce code :

Code:
<td class="row1" rowspan="3" align="center" valign="middle"><div class="gensmall"><div></div></div></td>

Il se trouve soit dans le message d'accueil ou dans une de vos templates modifiée ! Smile

Cordialement,

Alex Fowl
+ Hyperactif +

Masculin
Messages : 7557
Inscrit(e) le : 28/03/2009

http://www.aidactif.fr
Alex Fowl a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le cadre d'accueil

Message par lily1412 le Mer 8 Aoû 2012 - 23:20

Oui, je suis allée dans "index body" pour pouvoir enlever le contour, j'ai donc ceci dans le templates :

Code:
<!-- BEGIN message_admin_index -->
<table class="forumline css_accueil" width="100%" border="0" cellspacing="1" cellpadding="0">
  <!-- BEGIN message_admin_titre -->
  <tr>
      <td class="catHead" height="28"><span class="cattitle">{message_admin_index.message_admin_titre.MES_TITRE}</span></td>
  </tr>
  <!-- END message_admin_titre -->
  <!-- BEGIN message_admin_txt -->
  <tr>
      <td class="row1" rowspan="3" align="center" valign="middle">
      <div class="gensmall">{message_admin_index.message_admin_txt.MES_TXT}</div>
      </td>
  </tr>
  <!-- END message_admin_txt -->
</table>
<!-- END message_admin_index -->

Et j'ai rajouté ceci, dans le CSS

Code:
.css_accueil {
  border: none;
  box-shadow: none;
  background: none;
}

Je suis censée rajouter quelque chose ? Ou bien, j'ai fait une erreur quelque part ?

Merci d'avance.

lily1412
Nouveau membre

Féminin
Messages : 28
Inscrit(e) le : 05/05/2011

http://t-ara-fansub.forumgratuit.org/
lily1412 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Problème avec le cadre d'accueil

Message par Alex Fowl le Jeu 9 Aoû 2012 - 0:19

Il y a encore un problème ? Je ne vois plus de barre à gauche ? Smile

Cordialement,

Alex Fowl
+ Hyperactif +

Masculin
Messages : 7557
Inscrit(e) le : 28/03/2009

http://www.aidactif.fr
Alex Fowl a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le cadre d'accueil

Message par lily1412 le Jeu 9 Aoû 2012 - 0:44

J'avais zappé de mettre <table>, cela m'a permis d'enlever la barre plus épaisse à gauche.
Mais j'ai à nouveau un cadre :/ Puis-je l'enlever ou le mettre de la même couleur beige que mon fond de forum ?

Et aussi, comment faire pour que tout le fond de mon cadre d'accueil soit beige, et que je n'ai plus cette barre "rouge" entre mon image "bienvenue" et mon image "Annonce et liens" ?

Merci d'avance.

lily1412
Nouveau membre

Féminin
Messages : 28
Inscrit(e) le : 05/05/2011

http://t-ara-fansub.forumgratuit.org/
lily1412 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le cadre d'accueil

Message par Alex Fowl le Jeu 9 Aoû 2012 - 0:57

Dans votre template :
Code:
<!-- BEGIN message_admin_txt -->
  <tr>
      <td class="row1" rowspan="3" align="center" valign="middle">
      <div class="gensmall">{message_admin_index.message_admin_txt.MES_TXT}</div>
      </td>
  </tr>
  <!-- END message_admin_txt -->
Supprimez "class="row1"" ! Smile

Cordialement,

Alex Fowl
+ Hyperactif +

Masculin
Messages : 7557
Inscrit(e) le : 28/03/2009

http://www.aidactif.fr
Alex Fowl a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le cadre d'accueil

Message par lily1412 le Jeu 9 Aoû 2012 - 10:28

Merci beaucoup, d'avoir pris le temps de répondre à toutes mes questions Smile
Je pense que ce sera bon maintenant ^__^

lily1412
Nouveau membre

Féminin
Messages : 28
Inscrit(e) le : 05/05/2011

http://t-ara-fansub.forumgratuit.org/
lily1412 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum