Mettre une image en fond de catégorie

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Mettre une image en fond de catégorie

Message par NyT0 le Dim 12 Aoû 2012 - 18:19

Bien l'bonjour m'dames et m'sieurs Smile

- l'URL du forum est http://habbom.superforum.fr/
- la version de mon Forum : phpBB2
- une capture d'écran du problème : ci-bas
- statut sur le forum : Fondateur
- si vous avez modifié des templates : Aucun
- si vous avez du CSS personnalisé : Aucun hormis celui que j'ai téléchargé en même temps que le thème hitskin dont je parle ci-bas
- votre navigateur : Mozilla Firefox exclusivement (le dernier je crois)

Je tiens à vous prévenir, je ne maîtrise absolument pas le CSS, les templates et autres fonctions "avancées". J'espère que ça ne posera pas -trop- problème. Je ferai tout mon possible en tout cas.

Voici mon problème. J'avais envie de changer le thème de mon Forum. Je suis donc allé faire un tour sur hitskin et j'ai rapidement trouvé mon bonheur. C'est le thème qu'il me faut (lien ici). Je l'ai donc installé sur mon Forum depuis la page hitskin.

Le thème est installé. Je retourne sur mon Forum. Malheur ! Lorsque je me rends sur un message apparaît ce qui semble être une image expirée (je l'ai encadrée en rouge sur le screen) :

http://imageshack.us/photo/my-images/859/normechose.png

Elle se place en tête de tous mes messages même quand ils sont vides. C'est très gênant, donc je décide de trifouiller les profondeurs abyssales du panneau d'administration, sait-on jamais. Cela m'amène dans l'onglet CSS.

Je vous colle ici le CSS que propose le thème que j'ai installé. Je n'ai rien touché :

Code:
.bodyline{
width:100%;
border:0px solid #1D1D1D;
padding:0PX;
margin:0;
   }

body{
padding:0;
margin:0;
background-position:center;
}


a strong {
background: url(http://www.klamaraby.com/vb/images/rating/star3.gif) no-repeat right;
padding: 13px;
}


tr.post td {

text-align: center;

}


#page-footer
{
height:200px;
background:url(http://rooosana.ps/Down.php?d=VCPn) no-repeat bottom;
}

.row1
{
border:1px solid #F2F2F2;
background-image:url(http://rooosana.ps/Down.php?d=HDZv);
border-collapse: separate;
}
.row2
{
border:1px solid #F2F2F2;
background-image:url(http://rooosana.ps/Down.php?d=HDZv);
}
.row3
{
border:1px solid #F2F2F2;
background-image:url(http://rooosana.ps/Down.php?d=HDZv);
}



table.forumline {
background: #00CCFF url(http://rooosana.ps/Down.php?d=FHoyR);
padding: 1px 0px 18px 1px;
background-position: bottom;
}




a strong {
background: url(http://illiweb.com/fa/Online.png) no-repeat right;
padding: 13px;
}



.quote{
-moz-border-radius-bottomleft: 8px;
-moz-border-radius-bottomright: 8px;
-moz-border-radius-topleft: 8px;
-moz-border-radius-topright: 8px;
background-color: #ffffff ;
background-image: url('http://i88.servimg.com/u/f88/13/18/50/92/qoute10.jpg');
background-repeat: no-repeat;
border : 1px dotted #ef9e10;
color : #888888;
font-size: 14px;
font-weight: bold;
display: block;
overflow: auto;
padding: 7px;
}



.hr {
background: url(http://i26.tinypic.com/2exajch.png) no-repeat center;
border-top: thin groove;
padding: 67px;
line-height: 20px;
}

BEGIN Image resize */
#posts IMG
{
max-width: 95%;
height: expression(this.height > 1024 ? "1024px" : true);
width: expression(this.width > 400 ? "400px" : true);
}
#collapseobj_threadreview IMG {
max-width: 95%;
height: expression(this.height > 1024 ? "1024px" : true);

width: expression(this.width > 400 ? "400px" : true);
}
/* END Image resize */



a:link
{
text-decoration: none;
}
a:visited
{
text-decoration: none;
}
a:active
{
text-decoration: none;
}
a:hover
{
text-decoration: none;
}



J'ai essayé d'être logique. J'ai cherché d'où venait le problème et j'ai cru le corriger : en fait, j'ai juste réussi à faire trembler mon forum (il tremblait que je passais le curser sur de l'italique).

J'ai donc remis le thème par défaut. J'ai réessayé une nouvelle fois, tentant de remplacer cette image expirée par une autre dans le CSS, en vain. Quand j'arrive à résoudre un problème, j'en crée un autre etc. l'effet dominos. J'ai donc pensé à subtiliser du code CSS les deux images qui forment les fonds que je convoite tant, afin de les mettre par un moyen ou un autre en image de fond de catégorie :
http://rooosana.ps/store/6/10_03_05-06_35_21-DQuD@0.png
et
http://rooosana.ps/store/6/10_03_05-06_56_34-UarK@0.png

En vain. Pourtant, j'ai cherché sur le Forum (peut-être mal je vous l'accorde mais j'ai fait mon possible) et je suis tombé sur des sujets de ce type :
http://forum.forumactif.com/t304691-image-en-fond-de-categorie
http://forum.forumactif.com/t283042-probleme-css-deux-images-en-background

Seulement je n'arrive pas à comprendre, pas faute d'avoir essayé pourtant. Je décide finalement de m'en remettre à ce support de fins connaisseurs.
J'aimerais que vous m’aidiez à corriger le problème de la feuille CSS afin qu'elle marche comme elle devrait marcher. J'ai recopié les couleurs du thème moi-même, je n'attends maintenant plus que la feuille CSS prête à servir. Encore une fois, j'espère que vous pourrez m'aider. Je vous remercie énormément par avance et vous souhaite un bon début de soirée ! Smile

NyT0
Nouveau membre

Messages : 14
Inscrit(e) le : 12/08/2012

http://sacra-corona-unita.org
NyT0 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum