Problème avec une iframe sous Chrome

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec une iframe sous Chrome

Message par Lixyr le Lun 10 Sep 2012 - 14:07

Re- bonjour, ForumActif.

J'ai encore un problème suite à ma refonte :
Un problème très étrange qui concerne Google Chrome. ch

Voici le problème :

- j'ai installé un widget latéral à gauche de mon forum contenant une phrase et de la musique. De là pas de soucis, mon iframe marche très bien. Seulement voilà : quand je poste un nouveau message sous Chrome, il suffit que je fasse une manipulation (la plus probante étant ctrl + X) et mon iframe bouge de place, et vient se caler sur la zone de texte.
Pour que l'iframe retourne à sa place, je suis obligée de scroller ma page (scroller dans la zone de texte ne change rien).

Ce problème ne survint pas sur Firefox. Il n'est apparut que sur Chrome.


Pour plus de précision :
- mon widget latéral est codé en javascript, JQUERY (c'est le tuto d'alex pour la chat-box latérale), sauf qu'il ne contient pas la chat-box, mais une iframe en position fixe, dont le lien source est http://fantasmagoria.roleaddict.com/h4-widgets-lateraux

bref, voici le code javascript : :

Code:
jQuery(document).ready(function() { jQuery('body').append('<iframe src="http://fantasmagoria.roleaddict.com/h4-widgets-lateraux" style="position: fixed; top:115px; left: 0px;background-color: #;z-index:10000;width:200px;height:355px; display:block;" scrolling="no" frameborder="0"></iframe>'); } );

le lien source de mon iframe est une page html contenant tout le code html.

bref, voici le code de ma page html :

Code:
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<style type="text/css">
.widget {width:150px;height:250px;padding: 5px;
  -moz-box-shadow:4px 4px 20px #000;box-shadow:4px 4px 20px #000;
  -webkit-box-shadow:4px 4px 20px #000;
  border:2px solid #180906;border-top:1px solid #180906;
  background-color:#080100;
  font-size:12px;
  color:white;
  text-align:center;
}
a {color:#DBC3A7;text-decoration:none;}
a:visited {color:#E3BE94;text-decoration:none;}
a:hover {color:#E3BE94;text-decoration:none;}
h1 {text-align:center;word-spacing:2pt;color:#bc9d51;font-size:12px;}
</style>
</head>
<body style="background:#010101;">

<div class="widget"><h1>Phrase du mois</h1>
<center>« C'était juste une monstrueuse chieuse. » </center>

<div align="right" style="font-size:9px;"><a href="http://fantasmagoria.roleaddict.com/t378p60-la-tombe-maudite-le-commencement#1894" target="_blank">Helena Halley</a></div><br /><br /><h1>Un RP en musique :</h1>

<object type="application/x-shockwave-flash" data="http://flash-mp3-player.net/medias/player_mp3_multi.swf" width="120" height="100">
    <param name="movie" value="http://flash-mp3-player.net/medias/player_mp3_multi.swf" />
    <param name="bgcolor" value="#000000" />
    <param name="FlashVars" value="mp3=http%3A//www.archive-host.com/files/1473182/96de005e35ffd2b9823d2b1d229d90d18341a601/The_Heartbeat.mp3%7Chttp%3A//www.archive-host.com/files/1524594/96de005e35ffd2b9823d2b1d229d90d18341a601/Original_Soundtrack_-_IT_Richard_Bellis.mp3%7Chttp%3A//www.archive-host.com/files/1710248/96de005e35ffd2b9823d2b1d229d90d18341a601/Silent_Hill_2_Soundtrack_-_True.mp3%7Chttp%3A//www.archive-host.com/files/1710256/96de005e35ffd2b9823d2b1d229d90d18341a601/Final_Fantasy_VIII_OST_-_Find_Your_Way.mp3%7Chttp%3A//www.archive-host.com/files/1710259/96de005e35ffd2b9823d2b1d229d90d18341a601/Silent_Hill_2_OST_-_Theme_Of_Laura.mp3%7Chttp%3A//www.archive-host.com/files/1719668/96de005e35ffd2b9823d2b1d229d90d18341a601/Dead_Silence_Theme_Music.mp3%7Chttp%3A//www.archive-host.com/files/1720914/96de005e35ffd2b9823d2b1d229d90d18341a601/Saw_SoundTrack.mp3&amp;title=The Hearthbeat|IT original Soundtrack|True Theme|Find your way|Laura Theme|Dead Silence|Saw soundtrack&amp;width=120&amp;loop=0&amp;shuffle=0&amp;showvolume=1&amp;showslider=0&amp;showloading=never&amp;buttonwidth=20&amp;bgcolor=000000&amp;bgcolor1=230000&amp;slidercolor1=230000&amp;slidercolor2=230000&amp;buttonovercolor=666666&amp;playlistalpha=75&amp;currentmp3color=E3BE94&amp;scrollbarcolor=170906&amp;scrollbarovercolor=230000" />
</object>

</div>

</body>
</html>


Il semblerait que l'iframe se fixe à un endroit précis sur la page : en fonction de la zone de texte Textatera, car n'importe où je suis sur la page, tant que la zone de texte textatera est visible à l'écran, et que je manipule à l'intérieur, l'iframe va bouger pour se mettre toujours au même endroit. Scroller la page est le seul moyen que j'ai trouvé pour que l'iframe retourne à sa place.

Voici le forum où le problème persiste (visible dans mon profil) : http://fantasmagoria.roleaddict.com/forum
Pour les manipulations, vous pouvez aller ici : http://fantasmagoria.roleaddict.com/f27-flood-discussions c'est accessible aux invités.


Bonne chance à celui qui trouvera le problème et saura le résoudre. ::pourtoi::


Dernière édition par Lixyr le Mar 11 Sep 2012 - 18:41, édité 1 fois

Lixyr
Aidactive
Aidactive

Féminin
Messages : 5595
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Ea le Lun 10 Sep 2012 - 15:25

Bonjour,


Moi je n'ai pas le problème.

Vous pouvez faire un screenshot, et également un screenshot en faisant :

- CTRL + SHIFT + J ( pour faire apparaître les outils de chrome )
- sélectionner la loupe en bas à gauche
- cliquer sur un truc du l'iframe fixed
- remonter à l'élément :

Code:
<iframe src="http://fantasmagoria.roleaddict.com/h4-widgets-lateraux" style="position: fixed; top:115px; left: 0px;background-color: #;z-index:10000;width:200px;height:355px; display:block;" scrolling="no" frameborder="0">
- et là prendre le screenshot

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Lixyr le Lun 10 Sep 2012 - 18:07

Bonjour, Ea.

Alors pour les screen :

le premier screen demandé, en ayant en visu l'iframe complète :


sans le bug :


les erreurs signalées dans la console :


Spoiler:
Unsafe JavaScript attempt to access frame with URL http://fantasmagoria.roleaddict.com/post?p=2078&mode=editpost from frame with URL http://ad.z5x.net/st?ad_type=iframe&ad_size=728x90&section=1649939. Domains, protocols and ports must match.
Unsafe JavaScript attempt to access frame with URL http://ad.z5x.net/st?ad_type=iframe&ad_size=728x90&section=1649939 from frame with URL http://fantasmagoria.roleaddict.com/post?p=2078&mode=editpost. Domains, protocols and ports must match.
99251.js:1

et là pouf, si je fais ctrl + x j'ai ça :


Je ne peux pas sélectionner l'iframe quand elle se déplace, ça me sélectionne la zone de texte en dessous :


L'iframe est toujours considérée à sa place, même après déplacement.


J'espère avoir été assez précise.





Lixyr
Aidactive
Aidactive

Féminin
Messages : 5595
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Ea le Lun 10 Sep 2012 - 19:07

Bizarre. J'ai jamais vu ça du code sauter d'une iframe ^^

Cela donne la même chose avec un code javascript du style :

Code:
jQuery(document).ready(function() {
  jQuery('body').append('<div style="width:200px;height:355px; position: fixed; top:115px; left: 0;z-index:10000;"><iframe src="http://fantasmagoria.roleaddict.com/h4-widgets-lateraux" style="background-color: #;width:200px;height:355px; display:block;" scrolling="no" frameborder="0"></iframe>');
});
?

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Lixyr le Lun 10 Sep 2012 - 21:08

Oui, ça donne la même chose. Par contre je viens de remarquer un truc :
le bug n'apparait que lorsque le contenu est assez long pour avoir un scroll dans le champ textatera. Lorsqu'il n'y a pas de scroll, il n'y a pas de bug.





Lixyr
Aidactive
Aidactive

Féminin
Messages : 5595
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Ea le Lun 10 Sep 2012 - 22:27

j'ai essayé sur un écran plus grand, mais je n'ai pas non plus le bug reflexion

il y aurait moyen de faire des captures d'écran comme http://i34.servimg.com/u/f34/12/84/27/91/screen15.jpg mais en sélectionnant l'iframe pour une, et le <body style="background:#010101;"> pour l'autre

aussi peut-être essayer de mettre :

Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" id="min-width" lang="fr" xml:lang="fr"  >
à la place du <html> du code de l'iframe.

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Lixyr le Lun 10 Sep 2012 - 23:33

Le code ne change rien.
J'ai donc pris les screens demandés :

iframe sélectionné :


body sélectionné :

http://i34.servimg.com/u/f34/12/84/27/91/screen17.jpg

Lixyr
Aidactive
Aidactive

Féminin
Messages : 5595
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Ea le Mar 11 Sep 2012 - 0:43

j'essayerais demain sur des pc windows pour voir si j'ai le bug, mais là je vois pas comment ça arrive


sinon j'ai fait des essais, le bug arrive aussi sur ces pages :

- http://s301826463.onlinehome.fr/tfa/test1.html ( en ne mettant pas une montagne de code de body dans <head> )
- http://s301826463.onlinehome.fr/tfa/test2.html ( pareille + en retirant tout les scripts )
- http://s301826463.onlinehome.fr/tfa/test2.html ( pareille + je retire tout autre html que le textarea et le div )

?

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Lixyr le Mar 11 Sep 2012 - 9:08

Ouah, je suis Tech ! xD

Sinon, pour le premier lien :
le bug est encore là

pour le deuxième lien :
le bug est encore là

pour le troisième lien :
le bug est encore là

Ça ne viendrait tout simplement pas de Chrome, ou de l'iframe mal codée ?





Lixyr
Aidactive
Aidactive

Féminin
Messages : 5595
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Ea le Mar 11 Sep 2012 - 14:36

Me suis trompé de lien pour la 3ème :
http://s301826463.onlinehome.fr/tfa/test3.html

Ben la disparition d'une barre de défilement d'un textarea qui fait sauter le contenu d'un iframe hors de l'iframe, le problème vient surement de chrome ou webkit ^^

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Lixyr le Mar 11 Sep 2012 - 14:44

Pour le dernier lien, ça ne fait rien puisqu'il n'y pas de zone textatera.


*edit*

Oh... ohhh.... si, il y en a une. J'ai donc mis du texte. Beaucoup de texte, et j'ai fait mes manipulations : il ne s'est rien passé. \O/

Lixyr
Aidactive
Aidactive

Féminin
Messages : 5595
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Ea le Mar 11 Sep 2012 - 15:26

Bof j'ai essayé sur d'autre pc et je n'ai pas non plus le problème.

Le plus simple serait probablement de ne pas utiliser d'iframe, et de classer ce problème comme mystère de la vie. Voilà une page pour convertir ce qu'on veut en chaîne javascript :
http://www.maonyn.com/h16-

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Lixyr le Mar 11 Sep 2012 - 15:28

Et donc je mets le contenu de mon iframe dans le champ texte et je convertis tout en javascript ?





Lixyr
Aidactive
Aidactive

Féminin
Messages : 5595
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Ea le Mar 11 Sep 2012 - 15:45

convertir quelque chose comme ça :

Code:
<div  class="widget-zik">
  <h1>Phrase du mois</h1>
  <center>« C'était juste une monstrueuse chieuse. » </center>
  <div align="right" style="font-size:9px;"><a href="http://fantasmagoria.roleaddict.com/t378p60-la-tombe-maudite-le-commencement#1894" target="_blank">Helena Halley</a></div><br /><br /><h1>Un RP en musique :</h1>
 
  <object type="application/x-shockwave-flash" data="http://flash-mp3-player.net/medias/player_mp3_multi.swf" width="120" height="100">
    <param name="movie" value="http://flash-mp3-player.net/medias/player_mp3_multi.swf" />
    <param name="bgcolor" value="#000000" />
    <param name="FlashVars" value="mp3=http%3A//www.archive-host.com/files/1473182/96de005e35ffd2b9823d2b1d229d90d18341a601/The_Heartbeat.mp3%7Chttp%3A//www.archive-host.com/files/1524594/96de005e35ffd2b9823d2b1d229d90d18341a601/Original_Soundtrack_-_IT_Richard_Bellis.mp3%7Chttp%3A//www.archive-host.com/files/1710248/96de005e35ffd2b9823d2b1d229d90d18341a601/Silent_Hill_2_Soundtrack_-_True.mp3%7Chttp%3A//www.archive-host.com/files/1710256/96de005e35ffd2b9823d2b1d229d90d18341a601/Final_Fantasy_VIII_OST_-_Find_Your_Way.mp3%7Chttp%3A//www.archive-host.com/files/1710259/96de005e35ffd2b9823d2b1d229d90d18341a601/Silent_Hill_2_OST_-_Theme_Of_Laura.mp3%7Chttp%3A//www.archive-host.com/files/1719668/96de005e35ffd2b9823d2b1d229d90d18341a601/Dead_Silence_Theme_Music.mp3%7Chttp%3A//www.archive-host.com/files/1720914/96de005e35ffd2b9823d2b1d229d90d18341a601/Saw_SoundTrack.mp3&amp;title=The Hearthbeat|IT original Soundtrack|True Theme|Find your way|Laura Theme|Dead Silence|Saw soundtrack&amp;width=120&amp;loop=0&amp;shuffle=0&amp;showvolume=1&amp;showslider=0&amp;showloading=never&amp;buttonwidth=20&amp;bgcolor=000000&amp;bgcolor1=230000&amp;slidercolor1=230000&amp;slidercolor2=230000&amp;buttonovercolor=666666&amp;playlistalpha=75&amp;currentmp3color=E3BE94&amp;scrollbarcolor=170906&amp;scrollbarovercolor=230000" />
  </object>
</div>
( en fait ça remplace juste les retours à la ligne par \n et ça met un \ devant les ' ou " suivant le caractère de bord )

puis mettre le résultat dans le script :

Code:
jQuery(document).ready(function() { jQuery('body').append(' LE TRUC "CONVERTI" '); } );
puis mettre dans le css un code du style :

Code:
.widget-zik {
  background:#010101;position: fixed; top:115px; left: 0px;background-color: #;z-index:10000;width:200px;height:355px; padding: 5px;
  -moz-box-shadow:4px 4px 20px #000;box-shadow:4px 4px 20px #000;
  -webkit-box-shadow:4px 4px 20px #000;
  border:2px solid #180906;border-top:1px solid #180906;
  background-color:#080100;
  font-size:12px;
  color:white;
  text-align:center;
}
.widget-zik  a {color:#DBC3A7;text-decoration:none;}
.widget-zik  a:visited {color:#E3BE94;text-decoration:none;}
.widget-zik  a:hover {color:#E3BE94;text-decoration:none;}
.widget-zik  h1 {text-align:center;word-spacing:2pt;color:#bc9d51;font-size:12px;}

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Lixyr le Mar 11 Sep 2012 - 16:04

Ouf, j'étais partie pour refaire le code, oui, et c'était bien l'idée que je m'étais faite de ce que je devais faire.
Avec le convertisseur ça va plus vite... Mr. Green
Par contre, il ne me prend pas en compte les retours à la ligne. (alors que j'ai bien mis \n\n)


*edit*

Non de dieu, depuis tout à l'heure je cherche pourquoi il ne me fait pas deux retours à la ligne quand je mets \n\n (peut-être parce qu'il n'en prend qu'un seul en compte, non ?), et puis finalement je viens de penser à un truc. oO Puisqu'il prend les balises ... il peut bien prendre aussi <br />... alors j'ai testé et ça marche. T-T
bref, maintenant j'ai réussi à obtenir exactement le même widget que précédemment mais sans iframe. Ce qui n'est pas plus mal.

(pourquoi tout le monde boude les iframes ? Parce que les iframes, c'est pratique, mais c'est chiant.)
Merci Ea !!


Dernière édition par Lixyr le Mar 11 Sep 2012 - 16:43, édité 2 fois

Lixyr
Aidactive
Aidactive

Féminin
Messages : 5595
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Ea le Mar 11 Sep 2012 - 16:39

Dans du html, des retours à la ligne ça sert à :

- faire un espace
- aérer le code
- à faire un retour à la ligne dans certains trucs spéciaux comme un <textarea>

Si un retour à la ligne visible est voulu, il faut le joyeux <br>.

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Lixyr le Mar 11 Sep 2012 - 16:42

Oui... j'ai finalement pensé à tester ça, j'ai éditer mon poste plus haut...

Merci EA !!





Lixyr
Aidactive
Aidactive

Féminin
Messages : 5595
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Ea le Mar 11 Sep 2012 - 16:43

Mais la grande question c'est, est-ce que ça ne bug plus comme cela ?

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Lixyr le Mar 11 Sep 2012 - 16:48

... tu vas rire. J'ai le contenu de ma musique qui bouge. Il semble donc qu'au final, ce soit ce petit code qui gêne.








Lixyr
Aidactive
Aidactive

Féminin
Messages : 5595
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Ea le Mar 11 Sep 2012 - 17:07

Ce serait plus un bug par rapport à flash alors j'imagine.

En mettant plutôt :

Code:
<div style="position:relative"><object type="application/x-shockwave-flash" data="http://flash-mp3-player.net/medias/player_mp3_multi.swf" style="position:absolute;top:0;left:0" width="120" height="100"><param name="movie" value="http://flash-mp3-player.net/medias/player_mp3_multi.swf" /><param name="bgcolor" value="#000000" /><param name="FlashVars" value="mp3=http%3A//www.archive-host.com/files/1473182/96de005e35ffd2b9823d2b1d229d90d18341a601/The_Heartbeat.mp3%7Chttp%3A//www.archive-host.com/files/1524594/96de005e35ffd2b9823d2b1d229d90d18341a601/Original_Soundtrack_-_IT_Richard_Bellis.mp3%7Chttp%3A//www.archive-host.com/files/1710248/96de005e35ffd2b9823d2b1d229d90d18341a601/Silent_Hill_2_Soundtrack_-_True.mp3%7Chttp%3A//www.archive-host.com/files/1710256/96de005e35ffd2b9823d2b1d229d90d18341a601/Final_Fantasy_VIII_OST_-_Find_Your_Way.mp3%7Chttp%3A//www.archive-host.com/files/1710259/96de005e35ffd2b9823d2b1d229d90d18341a601/Silent_Hill_2_OST_-_Theme_Of_Laura.mp3%7Chttp%3A//www.archive-host.com/files/1719668/96de005e35ffd2b9823d2b1d229d90d18341a601/Dead_Silence_Theme_Music.mp3%7Chttp%3A//www.archive-host.com/files/1720914/96de005e35ffd2b9823d2b1d229d90d18341a601/Saw_SoundTrack.mp3&amp;title=The Hearthbeat|IT original Soundtrack|True Theme|Find your way|Laura Theme|Dead Silence|Saw soundtrack&amp;width=120&amp;loop=0&amp;shuffle=0&amp;showvolume=1&amp;showslider=0&amp;showloading=never&amp;buttonwidth=20&amp;bgcolor=000000&amp;bgcolor1=230000&amp;slidercolor1=230000&amp;slidercolor2=230000&amp;buttonovercolor=666666&amp;playlistalpha=75&amp;currentmp3color=E3BE94&amp;scrollbarcolor=170906&amp;scrollbarovercolor=230000" /></object></div>
Cela s'en va encore ?

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Lixyr le Mar 11 Sep 2012 - 17:18

Oui. J'ai déjà testé la position fixe, absolue, et maintenant relative, et ça bouge encore.

Comme la membre qui a ce bug est celle qui m'a demandé de mettre la playlist, j'ai bien envie de lui dire "prout". oO Si ça vient du flash, on ne pourra rien y faire, n'est-ce pas ?





Lixyr
Aidactive
Aidactive

Féminin
Messages : 5595
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Ea le Mar 11 Sep 2012 - 17:46

Et en mettant :

Code:
<div style="position:relative;width:120px;height:100px;overflow:hidden"><object type="application/x-shockwave-flash" data="http://flash-mp3-player.net/medias/player_mp3_multi.swf" style="position:absolute;top:0;left:0" width="120" height="100"><param name="movie" value="http://flash-mp3-player.net/medias/player_mp3_multi.swf" /><param name="bgcolor" value="#000000" /><param name="FlashVars" value="mp3=http%3A//www.archive-host.com/files/1473182/96de005e35ffd2b9823d2b1d229d90d18341a601/The_Heartbeat.mp3%7Chttp%3A//www.archive-host.com/files/1524594/96de005e35ffd2b9823d2b1d229d90d18341a601/Original_Soundtrack_-_IT_Richard_Bellis.mp3%7Chttp%3A//www.archive-host.com/files/1710248/96de005e35ffd2b9823d2b1d229d90d18341a601/Silent_Hill_2_Soundtrack_-_True.mp3%7Chttp%3A//www.archive-host.com/files/1710256/96de005e35ffd2b9823d2b1d229d90d18341a601/Final_Fantasy_VIII_OST_-_Find_Your_Way.mp3%7Chttp%3A//www.archive-host.com/files/1710259/96de005e35ffd2b9823d2b1d229d90d18341a601/Silent_Hill_2_OST_-_Theme_Of_Laura.mp3%7Chttp%3A//www.archive-host.com/files/1719668/96de005e35ffd2b9823d2b1d229d90d18341a601/Dead_Silence_Theme_Music.mp3%7Chttp%3A//www.archive-host.com/files/1720914/96de005e35ffd2b9823d2b1d229d90d18341a601/Saw_SoundTrack.mp3&amp;title=The Hearthbeat|IT original Soundtrack|True Theme|Find your way|Laura Theme|Dead Silence|Saw soundtrack&amp;width=120&amp;loop=0&amp;shuffle=0&amp;showvolume=1&amp;showslider=0&amp;showloading=never&amp;buttonwidth=20&amp;bgcolor=000000&amp;bgcolor1=230000&amp;slidercolor1=230000&amp;slidercolor2=230000&amp;buttonovercolor=666666&amp;playlistalpha=75&amp;currentmp3color=E3BE94&amp;scrollbarcolor=170906&amp;scrollbarovercolor=230000" /></object></div>
pour que normalement, si ça sorte du div ça ne soit pas visible ?

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec une iframe sous Chrome

Message par Lixyr le Mar 11 Sep 2012 - 17:54

Ah oui, en effet : ça bug, mais ça disparait, ça ne se met plus sous le textatera.





Lixyr
Aidactive
Aidactive

Féminin
Messages : 5595
Inscrit(e) le : 22/07/2010

http://forum-test-in-lixyr.rpg-dynasty.com/
Lixyr a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum