Problème avec un tutoriel

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec un tutoriel

Message par J-CHamel le Mar 11 Sep 2012 - 6:21

Bonjour!

Mon problème est le suivant. Après avoir suivi le tutoriel (mettre la barre de navigation en haut du forum) j'ai omis de faire une copie de mon ‘‘overhall_header’’par manque d'expérience lol. Je me retrouve donc avec une fonction (où ligne de commande) qui ne fonctionne pas (barre de navigation complètement disparue) et que je ne peux réinitialiser sans votre aide.

J'aurais donc besoin de connaitre l'endroit ou remettre le code original dans ‘‘overhall_header’’.

Merci de votre compréhension!


Dernière édition par J-CHamel le Sam 22 Sep 2012 - 3:51, édité 1 fois

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Mar 11 Sep 2012 - 9:38

Bonjour,

Si vous voulez retrouver le template par défaut, il suffit d'aller sur les templates et avant d'appuyer sur edit trouver la phrase "valeur par défaut" et cliquez dessus, vous aurez le template de base puis cliquez sur :enreg:

Cordialement

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par J-CHamel le Mar 11 Sep 2012 - 23:17

Ouf! Un GROS merci _backdraft_!
J'ai réussi à réinitialiser grâce à toi. J'ai donc une partie de mon problème qui est résolu mais quant à l'autre...je me retrouve quand même bredouille et insatisfait puisque je n'ai pas réussi à obtenir le résultat escompté qui est:de‘‘mettre la barre de navigation en haut du forum’’.

Je me demande par contre:
-Pourquoi est-ce que ma barre a complètement disparu?
-Suis-je le seul à qui c'est arrivé?
-Est-ce le code qui comporte une erreur ou bien,
-Est-ce bien moi qui...
Sincèrement, je doute de la dernière option car le tutoriel est très clair et simple à suivre.

Pour terminer, j'aimerais savoir si toi _backdraft_ ou quelqu'un d'autre pourriez m'aider à réaliser cet objectif?

Cordialement et à+ je l'espère!

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Mer 12 Sep 2012 - 18:37

Bonjour,

Je suis au regret de vous annoncer que ce tutoriel marche très bien ^^ et que beaucoup de monde l'ont mis en oeuvre. Essayez de le refaire calmement et si ça ne fonctionne toujours pas on essayera de voir ou ça bloque.

Cordialement.

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par J-CHamel le Ven 14 Sep 2012 - 1:01

Bonsoir _backdraft_!

Hier après avoir lu ton message, j'ai eu une petite idée, changer de thème juste pour le cas où. Aujourd'hui,je viens de refaire le tutoriel (calmement Laughing ) et ...surprise,ma barre de navigation est en haut. Un GROS merci à toi! UN PROBLÈME DE RÉSOLU !

Par contre, je ne sais pas si je peux continuer sur ce post ou bien débuter un nouveau sujet mais bon...je risque.

Voici l’adresse de mon forum: bsglejeu.1fr1.net
Disons que...j'ai plusieurs questions et les voici:

1-À quoi sert l'index du forum puisqu'il est pareil comme le portail?

Ensuite, ma deuxième question concerne le/les portail(s) que j'ai créé(s) (j'ai 3 portails).
2- À quoi bon pouvoir en créer plusieurs si on ne peut les lier (les 3) tous/plusieurs à la fois?

Et pour finir, j'aimerais pouvoir mettre une image (imagine une feuille mobile dont on coupe les 4 coins plutôt que de les arrondir). Exemple : un membre désire répondre à un message. Une fenêtre s'ouvrirait avec cette image (un rectangle aux coins coupés en background) et il pourrait y écrire du texte à l'intérieur. Est-ce possible ?

Merci de ton soutien et à +

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Ven 14 Sep 2012 - 21:41

Bonjour,

L'accueil vous permet d'accéder aux différentes parties de votre forum, le portail lui vous permet de faire en quelque sorte une page d'accueil de votre forum ou vous pouvez y mettre différents widgets (derniers messages, des stats, etc...)

Pour votre deuxième questions, celà ne vous sert pas à vous mais si il y a cette fonctionnalité c'est qu'elle sert à d'autres Wink

Pour la fin couper les coins en CSS ce n'est pas possible par contre mettre une image en fond avec déjà les angles coupé c'est possible. Pour ce qui est d'ouvrir une fenêtre pour répondre à un message ce serait beaucoup trop compliqué (peut être réalisable via des formulaires mais il faudrait créer autant de formulaire que de sujet et en créer à chaque ouverture de sujet...).

Cordialement

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par J-CHamel le Sam 15 Sep 2012 - 0:26

Bonjour _backdraft_!

Premièrement, merci pour ta patience car loin de moi l'idée de vouloir te faire perdre ton temps.

Et deuxièmement, encore merci pour ton soutien, tes réponses franches, claires et précises. C'est vraiment apprécié.

Bon, maintenant revenons à nos moutons. Désolé car je me suis mal exprimé où expliqué (enfin, je pense) dans la deuxième partie de ma troisième question. J'ai mentionné ‘‘une fenêtre s'ouvrirait’’. En fait, je voulais dire quand on clique sur Nouveau ou répondre pour composer un message ou un sujet des forums et sous-forums (la box dans laquelle je suis en train d'écrire) c'est celle dont je parlais. Je sais que c'est possible car déjà vu sur un site de RPG (La Taverne Des Royaumes Oubliés) voir l'image ici:. Eux ils avaient mis un parchemin en background des box. Voici ce que moi je voudrais:
http://fr.battlestarwiki.org/wiki/Accueil
Juste le cadre sans l'intérieur mais avec les quatre coins plus prononcés comme cette image-ci:
On a déjà un bout de fait puisque
par contre mettre une image en fond avec déjà les angles coupé c'est possible.
Reste que pour la suite, peux-tu me donner un coup de pouce ? Merci à l'avance de ton temps, ton aide ainsi que ta compréhension.

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Sam 15 Sep 2012 - 2:12

J'ai pas tout compris en faite vous voulez que quand vous cliquez sur répondre ou nouveau une fenêtre différente s'ouvre pour créer un message ? Et que dans cette nouvelle fenêtre le fond d'écran soit une image avec les 4 coins coupés ?

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par J-CHamel le Sam 15 Sep 2012 - 3:02

Re salut _backdraft_!

J'ai pas tout compris en faite vous voulez que quand vous cliquez sur
répondre ou nouveau une fenêtre différente s'ouvre pour créer un message
? Et que dans cette nouvelle fenêtre le fond d'écran soit une image
avec les 4 coins coupés ?

En fait,tout est bon sauf ce qui est en rouge. La fenêtre où la box en question est la même dans laquelle je suis en train d'écrire ce message présentement. Regarde:
Insérer l'image de fond dans ce cadre. Remarque que...si on peut changer l'aspect de cette boîte aussi, je suis preneur lol. Mais chaque chose en son temps.

À+

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Sam 15 Sep 2012 - 10:18

Ok c'est bon j'ai enfin compris ^^

Essayez le code CSS suivant : mettez le dans panneau d'administration > Affichage > Couleurs > Feuille de style CSS mettez le code et cliquez sur :enreg: .

Code:
form#quick_reply textarea#text_editor_textarea {
background-image: url(URL DE L IMAGE);
}

(remplacez URL DE L IMAGE par l'url de l'image que vous voulez mettre en fond.)

Cordialement

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par Nyko-neko le Sam 15 Sep 2012 - 10:34

bonjour/bonsoir, j'ai essayer de suivre votre code, mais ça ne marche pas sur mon forum >.<

Nyko-neko
****

Masculin
Messages : 306
Inscrit(e) le : 10/06/2012

http://fairytale-world.forums-rpg.com/
Nyko-neko a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Sam 15 Sep 2012 - 10:41

Petite précision le "url" bleu dans le code doit rester tel quel

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par J-CHamel le Sam 15 Sep 2012 - 18:23

Bonjour _backdraft_!

Dans mon cas, ton code fonctionne en partie:de cette façon = ne fonctionne pas (je ne vois pas d'image dans la box)

Code: Sélectionner le contenu

  1. form#quick_reply textarea#text_editor_textarea {
  2. background-image: url(URL DE L IMAGE);
  3. }


Mais, de cette façon = oui (je vois une image dans la box)

Code: Sélectionner le contenu

  1. textarea {
  2. background-image: url(URL DE L IMAGE);
  3. }

Par contre, pour le résultat...C'est comme si la box ne tenait pas compte de mon image. En fait, quand je compose un message, j'ai juste une image de fond avec du texte par dessus point. Le texte dépasse toujours de mon image (c'est comme si les marges n'existent pas). J'ai fait un test en changeant les dimensions de mon image mais le résultat demeure le même. Y a-t-il quelque chose à faire et comment remédier au problème ?

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Sam 15 Sep 2012 - 19:14

Le problème est que je n'y ai pas accès et sans pouvoir allé voir sur votre forum pour trouver les bons identifiants ça sera dure.

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par J-CHamel le Sam 15 Sep 2012 - 21:11

Re-salut!

Bien...tu pourrais t'enregistrer sur mon site et puis je te met second admin (dans mon groupe)! Ainsi, tu y auras accès. À toi de voir!

http://bsglejeu.1fr1.net

Quoi qu'il en soit, j'ai effectué d'autres tests et je dois dire que c'est catastrophique. Je ne sais pas si je suis le seul qui a ce problème
mais même avec la boîte originale (ainsi qu'avec d'autres thèmes), le problème persiste. Exemple : quand on écrit du texte dans la boîte, le texte demeure sur une seule ligne et la boîte s'élargit en fonction du texte donc jusqu'à l'infini. Comment règle-t-on ce problème ?

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Dim 16 Sep 2012 - 0:16

Non pas besoin d'être admin en membre je verrais ce dont j'ai besoin de voir.

Je vous tiens au courant.

Cordialement

EDIT : en tant que membre je ne peux poster nul part des messages du coup je ne peux pas voir la box...

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par J-CHamel le Dim 16 Sep 2012 - 0:41

Si tu peux!

Dans Portails, Liste des portails, BSG-75.

Remplis la box de blablabla et clique Envoyer. Tu vas voir le beau résultat.

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Dim 16 Sep 2012 - 11:13

Re pour le fond utilisez ce code :

Code:
textarea#text_editor_textarea {
background-image: url(URL DE L IMAGE);
}

Pour votre autre problème allez dans :
Panneau d'administration > Général > Forum > Configuration et en face de "Largeur du forum (nombre ou %) :" mettez 95%

Cordialement

PS : vous n'avez pas modifié vos templates ?

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par J-CHamel le Dim 16 Sep 2012 - 17:40

Bonjour _backdraft_!

Premièrement en ce qui concerne le code, il semble être fonctionnel mais difficile d'en être sûr à 100% puisque mon autre problème semble entrer en conflit. Quoi qu'il en soit, j'ai effectué les deux changements (toujours en place) et j'aimerais que tu jettes un œil sur l'exemple du résultat dans le message que je t'ai laissé. Voici le lien: http://bsglejeu.1fr1.net/t3-blablablablablabla

Deuxièmement, le 95% n'a rien donné de bon mis à part d’élargir le forum sans plus.

Et pour finir, en ce qui concerne mes templates. Oui j'en avais modifié plusieurs, mais par la force des choses, j'ai dû (et ce à mainte reprises) effectué plusieurs changements de thèmes/versions en raison de certains problèmes récurrents pour effectuer des tests pour tenter de trouver la source par moi-même ainsi qu'avec ton soutien.

Mise en garde : ceci est seulement mon opinion personnelle. Il me semble futile d'essayer de faire tant de modifications en vue d'embellir mon forum si je dois constamment changer de thème en raison de problèmes différents d'un thème à l'autre. En effet, j'ai remarqué que plusieurs thèmes contiennent des erreurs ce qui m'empêche d'avancer dans mon projet. Pourquoi ne pas commencer à zéro (une page de démarrage contenant seulement la base) plutôt que de choisir un thème qui a été créé avec des erreurs ?

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Dim 16 Sep 2012 - 18:22

C'est à vous de voir, c'est toujours plus gratifiant de faire tout le forum soit même et de le modifier comme bon nous semble plutot que d installer des thèmes préfabriqué et en cas de problème vous aurez toujours des personnes sur le forum des forums qui pourront vous aider.

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Dim 16 Sep 2012 - 18:32

PS : essayez le CSS suivant pour le retour à la ligne :

Code:
#page-body
{display: inline !important;
}

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par J-CHamel le Dim 16 Sep 2012 - 18:51

Désolé !
Aucun changement Crying or Very sad ! Voir ici: http://bsglejeu.1fr1.net/t3-blablablablablabla#4

Juste en passant, pourquoi ne pas utiliser le chatbox de mon forum?

À+

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Dim 16 Sep 2012 - 19:36

Parce que je n'ai pas assez de temps pour celà désolé...

Cordialement

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par J-CHamel le Lun 17 Sep 2012 - 0:30

Oui, je comprends!
As-tu trouvé une façon de régler mon problème? Je sais que tu y a mis beaucoup de temps déjà et que ce n'est pas évident. J'espère que tu trouveras car pendant ce temps, je n'avance pas du tout dans mon travail. De peur d'avoir à changer encore une fois de thème.

En tous les cas, je te dis un GROS merci de m'apporter ton aide et ton soutien.

À+

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Mar 18 Sep 2012 - 9:58

Peux tu mettre ton CSS entier ici stp.

Cordialement.

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par J-CHamel le Mar 18 Sep 2012 - 12:02

Oui, le voici!

textarea#text_editor_textarea {
background-image: url(http://i36.servimg.com/u/f36/17/26/87/42/cadre_20.jpg);
}
#page-body
{display: inline !important;
}
p
{
width: 350px; /* On a indiqué une largeur (obligatoire) */
margin: auto; /* On peut donc demander à ce que le bloc soit centré avec auto */
border: 1px solid black;
text-align: justify;
padding: 12px;
margin-bottom: 20px;
}
p
{
word-wrap: break-word; /* la césure sera forcée dès que le texte risque de dépasser (couper les textes trop larges) */
}

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Mar 18 Sep 2012 - 17:26

C'est tous ce que vous avez ?

Avec quoi doivent intervenir les classes "p" ?

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par J-CHamel le Mar 18 Sep 2012 - 22:49

Ben...oui, c'est tous!

Tu t'attendais à quoi au juste? Comme je te l'ais dis plus haut, j'ai changé mainte et mainte fois de forum/versions pour effectuer des tests. Concernant les classes P, j'ai tous simplement omis de retirer le code, suite à un test. Désolé!

À+

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par _backdraft_ le Mer 19 Sep 2012 - 23:15

Je pensais que l'interdiction du retour à la ligne venais du CSS mais du coup la je ne vois pas d'ou ça vient désolé...

Juste vous n'avez pas de code Javascript ?

_backdraft_
# Tropactif #

Masculin
Messages : 1505
Inscrit(e) le : 04/03/2010

http://www.caserne35.com
_backdraft_ a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par J-CHamel le Mer 19 Sep 2012 - 23:41

Salut _backdraft_!

Non, je n'ai pas de javascript.
Pourrais-tu contacter un techniciens s.v.p?

À+

J-CHamel
***

Messages : 193
Inscrit(e) le : 10/09/2012

http://bsglejeu.1fr1.net
J-CHamel a été remercié(e) par l'auteur de ce sujet.

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum