Bug d'affichage suite à modification du thème du forum

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Bug d'affichage suite à modification du thème du forum

Message par Sayan d'Oriale le Sam 27 Oct 2012 - 1:00

Bonsoir,

Je suis actuellement en pleine modification du thème de mon forum et je rencontre de nombreux bugs. Le forum est en version PHBB3

Tout d'abord, alors que je ne modifie que les couleurs (après de nombreux tests couleurs/images, en thème temporaire puis directement sur le forum suite à l'apparition de ces bugs), l'image du fond de page et l'image du fond de tableau sont modifiées à l'affichage du forum (screen 1), alors que je ne les ai pas encore modifiées dans le PA (screen 2).

screen1
Spoiler:

screen 2

Spoiler:

Ensuite, lors de la mise en place des nouvelles images, les couleurs se modifient subitement, avec des couleurs "tests" à la place des couleurs que j'avais mises, mais encore une fois seulement à l'affichage.

Enfin, la hauteur et largeur des cellules des sous forums se modifient aussi (sreen 1), alors que dans le PA elles sont encore à leur valeur "initiale" (screen 3).

Screen 3

Spoiler:

J'en suis au sixième thème sur ce forum, et c'est la première fois que je rencontre ce problème. Je m'arrache les cheveux dessus depuis deux jours maintenant...

Pour le moment, je vais laisser l'ancien thème, car ces bugs sont vraiment "dérangeants". Mon navigateur est mozilla 16.0.1.

Merci de votre aide !


Dernière édition par Sayan d'Oriale le Sam 27 Oct 2012 - 3:53, édité 1 fois

Sayan d'Oriale
Nouveau membre

Messages : 15
Inscrit(e) le : 27/05/2012

http://juste-une-histoire.forumactif.com/
Sayan d'Oriale a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug d'affichage suite à modification du thème du forum

Message par demeter1 le Sam 27 Oct 2012 - 1:33

Contrôlez le css de base du thème que vous venez de choisir. Il est fort possible que certains éléments influent directement sur la visualisation du forum alors que vous n'avez procédé à aucun changement.

demeter1
+ Hyperactif +

Masculin
Messages : 8101
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug d'affichage suite à modification du thème du forum

Message par Sayan d'Oriale le Sam 27 Oct 2012 - 1:41

Je passe directement par le PA d'affichage, pour modifier couleurs et images, le thème en lui-même n'a pas été modifié, seulement son apparence. Dans ce cas, comment aurai-je pu modifier le CSS ? Désolée, je suis un peu néophyte en la matière.
Les images sont de même types et taille que celles précédemment utilisées.

Et petite omission de ma part, ces bugs se manifestent de manière aléatoire et sans logique. Ce n'est jamais au même nombre d'image ni même à la même image qu'ils apparaissent...

Et quand j'importe mon ancien thème que j'ai sauvegardé, ils peut aussi arriver qu'ils soient encore présents.

Sayan d'Oriale
Nouveau membre

Messages : 15
Inscrit(e) le : 27/05/2012

http://juste-une-histoire.forumactif.com/
Sayan d'Oriale a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug d'affichage suite à modification du thème du forum

Message par demeter1 le Sam 27 Oct 2012 - 1:55

Vous allez dans votre feuille de style et vous cliquez sur "voir le css de base".



Pour vous donner une exemple concret , admettons que dans ce css de base vous ayez une couleur de déterminé pour le body (fond de page), vous aurez beau modifier la couleur du fond de page par le biais de la gestion des couleurs, il reviendra automatiquement à la couleur déterminée par le css de base.

Commencez déjà par étudier votre css de base pour voir si vous voulez modifier certains éléments.

Vous avez également la possibilité de désactiver le css par défaut mais cela entrainera la désactivation de certains éléments qui vous ont fait choisir ce thème.

demeter1
+ Hyperactif +

Masculin
Messages : 8101
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug d'affichage suite à modification du thème du forum

Message par Sayan d'Oriale le Sam 27 Oct 2012 - 2:16

Je comprends mieux le principe du CSS, merci pour vos explications. Le soucis, c'est que les modifications vont être effectives pendant un court moment (peut être le temps de remplacer 4 ou 5 images) et d'un coup, ça devient du grand n'importe quoi.

En gros, je mets du bleu, je change une partie des boutons de navigation de la page d'accueil (forum, faq, mp etc etc) et pouf, j'ai du rouge à la place de mon bleu. Pareil pour la largeur et hauteur des cellules. Au bout de 4 ou 5 images, ça se modifie tout seul.

Et pourquoi, quand je modifie les couleurs, des images se modifient aussi toutes seules ? C'est encore le CSS qui fait ça ?

Je suis désolée, je veux bien vérifier le CSS, mais est-il déjà normal, si le problème vient bien de là, qu'il se modifie tout seul au bout d'un temps X ?

Et comme je l'expliquai dans mon second message, alors que j'avais ré-importé mon ancien thème (donc le CSS est revenu à ce qu'il était à l'origine si j'ai tout bien compris), qui a toujours fonctionné sans aucun bugs, ceux-ci étaient encore présents, les nouvelles couleurs à la place des anciennes.

Sayan d'Oriale
Nouveau membre

Messages : 15
Inscrit(e) le : 27/05/2012

http://juste-une-histoire.forumactif.com/
Sayan d'Oriale a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug d'affichage suite à modification du thème du forum

Message par demeter1 le Sam 27 Oct 2012 - 2:34

@Sayan d'Oriale a écrit:Je comprends mieux le principe du CSS, merci pour vos explications. Le soucis, c'est que les modifications vont être effectives pendant un court moment (peut être le temps de remplacer 4 ou 5 images) et d'un coup, ça devient du grand n'importe quoi.

En gros, je mets du bleu, je change une partie des boutons de navigation de la page d'accueil (forum, faq, mp etc etc) et pouf, j'ai du rouge à la place de mon bleu. Pareil pour la largeur et hauteur des cellules. Au bout de 4 ou 5 images, ça se modifie tout seul.
C'est bien le css de base qui agit en appliquant les modifications qu'il contient.

@Sayan d'Oriale a écrit:Et pourquoi, quand je modifie les couleurs, des images se modifient aussi toutes seules ? C'est encore le CSS qui fait ça ?
Je suis désolée, je veux bien vérifier le CSS, mais est-il déjà normal, si le problème vient bien de là, qu'il se modifie tout seul au bout d'un temps X ?
Les modificationque vous faites s'annulent dés que la page est réactualisée et que vos caches enregistrent une nouvelle configuration.

@Sayan d'Oriale a écrit:Et comme je l'expliquai dans mon second message, alors que j'avais ré-importé mon ancien thème (donc le CSS est revenu à ce qu'il était à l'origine si j'ai tout bien compris), qui a toujours fonctionné sans aucun bugs, ceux-ci étaient encore présents, les nouvelles couleurs à la place des anciennes.

Si vous n'aviez pas de css personnalisé, l'importation de l'ancien thème fonctionnait avec le css de base donc, dans ce cas, il est normal que vous n'ayez constaté aucun bug d'affichage.

Si vous aviez un css personnalisé, la, ce n'est pas normal à moins que vous ne soyez passé par une restauration.

demeter1
+ Hyperactif +

Masculin
Messages : 8101
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug d'affichage suite à modification du thème du forum

Message par Sayan d'Oriale le Sam 27 Oct 2012 - 2:52

Bon, soit je suis vraiment nulle, soit je ne comprends absolument rien.

En gros, à chaque fois que je modifie le thème du forum, je modifie le CSS de base ou pas ?

En tout cas, je n'ai l'ai jamais changé, consciemment en tout cas. Je ne modifie que les images et les couleurs via l'interface du PA. Donc pourquoi des bugs maintenant, alors qu'il n'y en avait pas dans les thèmes versions 2 à 4 du forum ?

@demeter1 a écrit:Si vous n'aviez pas de css personnalisé, l'importation de l'ancien thème fonctionnait avec le css de base donc, dans ce cas, il est normal que vous n'ayez constaté aucun bug d'affichage.

Si vous aviez un css personnalisé, la, ce n'est pas normal à moins que vous ne soyez passé par une restauration.

Et donc, si je n'avais pas de CSS personnalisé, pourquoi encore des bugs à l'affichage ?
Et si j'avais bien un CSS personnalisé, il a fallut que je passe par une restauration pour que les bugs d'affichage cessent justement...

Je suis désolée, je ne comprends absolument rien...

Sayan d'Oriale
Nouveau membre

Messages : 15
Inscrit(e) le : 27/05/2012

http://juste-une-histoire.forumactif.com/
Sayan d'Oriale a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug d'affichage suite à modification du thème du forum

Message par demeter1 le Sam 27 Oct 2012 - 3:11

Bon , avant d'aller dormir, je reprends de a à z pour vous expliquer comment fonctionne le css.

1/ à la création du forum ou lors d'un changement de thème vous importez un css de base. Celui ci détermine les éléments d'affichage du thème que vous avez choisi.

2/ si vous souhaitez opérer une modification sur votre forum et que vous constatez que cette modification n'est pas prise en compte c'est que le css de base prend déjà en charge cette modification.

3/ si vous souhaitez modifié un élément qui est déjà pris en charge par le css de base, il faut réécrire un css dans dans votre feuille de style pour contrecarrer le css du css de base.


Prenons un exemple
Vous voulez changer la couleur du fond de page qui est noir sur votre thème d'origine (couleur #000000). Vous allez dans la gestion des couleurs et vous modifiez votre couleur.

2 cas possible
1/ ça marche-->cela veut dire que le css de base ne gère pas l'élément

2/ça ne marche pas -->cela veut dire que votre css de base gère l'élément

que faire.
1/ vérifier le css de base en recherchant ceci
Code:
body {background-color: #000000;}

2/ vous l'avez trouvé ce qui veut dire que le css de base gère bien l'élément.

3/ il ne vous reste plus qu'à modifier l'élément dans votre feuille de style en appliquant un autre css qui va modifier la couleur #000000 par celle que vous voulez.
Code:
body {background-color: la couleur choisie;}


demeter1
+ Hyperactif +

Masculin
Messages : 8101
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug d'affichage suite à modification du thème du forum

Message par Sayan d'Oriale le Sam 27 Oct 2012 - 3:32

@demeter1 a écrit:

2/ si vous souhaitez opérer une modification sur votre forum et que vous constatez que cette modification n'est pas prise en compte c'est que le css de base prend déjà en charge cette modification.

Heum, je suis blonde, mais quand même Very Happy Je ne comprends pas cette phrase, comment quelque chose peut ne pas être pris en compte, tout en l'étant ?

@demeter1 a écrit:
Prenons un exemple
Vous voulez changer la couleur du fond de page qui est noir sur votre thème d'origine (couleur #000000). Vous allez dans la gestion des couleurs et vous modifiez votre couleur.

2 cas possible
1/ ça marche-->cela veut dire que le css de base ne gère pas l'élément

2/ça ne marche pas -->cela veut dire que votre css de base gère l'élément

que faire.
1/ vérifier le css de base en recherchant ceci
Code:
body {background-color: #000000;}

2/ vous l'avez trouvé ce qui veut dire que le css de base gère bien l'élément.

3/ il ne vous reste plus qu'à modifier l'élément dans votre feuille de style en appliquant un autre css qui va modifier la couleur #000000 par celle que vous voulez.
Code:
body {background-color: la couleur choisie;}


Bref, tout ça, je l'ai bien compris, mais ça ne m'explique pas pourquoi, quand je modifie une couleur dans le PA et donc le CSS, il y a aussi des images qui se modifient sur le forum. Et pourquoi, quand je modifie couleur ou images, la largeur et hauteur des cellules se modifient aussi toutes seules.

En tout cas, après vérification, l'image de fond, puisque c'est l'une de celles qui posent problème, se modifie sur le forum, mais ni dans le Pa ni dans le CSS. Idem pour largeur et hauteur des cellules.

C'est comme si demain, je veux envoyer un sms à une amie, et que mon téléphone décide d'appeler quelqu'un d'autre tout seul ou de prendre une photo. Un forum n'est quand même pas sensé se modifier tout seul si son admin ne le veut pas >.<

Merci de votre patience en tout cas.

Edit : Après une nouvelle tentative, tout fonctionne correctement, alors que j'ai procédé comme les trois ou quatre fois précédentes (depuis jeudi soir) pour modifier le thème du forum, c'est à dire en passant par le PA, en choisissant ma couleur via son code, en copiant collant les liens de mes images... C'est à n'y rien comprendre Shocked Shocked Shocked Zen ! Zen ! Zen !

Encore merci pour votre aide, et si quelqu'un a un élément de réponse pour ces bugs, je suis quand même preneuse !

Sayan d'Oriale
Nouveau membre

Messages : 15
Inscrit(e) le : 27/05/2012

http://juste-une-histoire.forumactif.com/
Sayan d'Oriale a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum