Problème d'affichage d'image

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème d'affichage d'image

Message par alliottom59 le Mer 26 Déc 2012 - 17:26

Bonjour,

j'ai un problème d'affichage sur mon forum.
Exemple:

Je souhaite dans un sujet joindre l'image de la carte de France.
J'utilise un hébergeur d'image.
Mais une fois l'image postée, elle fait que le moitié sur la largeur, pourtant si on clic dessus le lien s'ouvre, est elle bien complète.

Je n'es malheureusement pas trouvé de solution.

Merci pour votre aide

Bonne fêtes a tous

alliottom59
***

Masculin
Messages : 160
Inscrit(e) le : 10/12/2012

http://lemondedudiagauto.com
alliottom59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par Matriochka le Mer 26 Déc 2012 - 17:40

Bonsoir,

Serait-il possible d’avoir un lien vers le sujet où le problème est constaté ?

Matriochka
+ Hyperactif +

Messages : 7604
Inscrit(e) le : 14/07/2010

Matriochka a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par alliottom59 le Mer 26 Déc 2012 - 18:08

je ne peu malheureusement me le permettre
je te joint une photo
merci de ta compréhension


alliottom59
***

Masculin
Messages : 160
Inscrit(e) le : 10/12/2012

http://lemondedudiagauto.com
alliottom59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par Matriochka le Mer 26 Déc 2012 - 18:51

Est-ce qu’il y a des codes dans :
Panneau d’administration > Affichage > Couleurs > Feuille de styles CSS ?

As-tu activé la fonction permettant de réduire la taille des images dans les messages ?

Ce serait quand même plus facile si on avait accès au sujet, pour pouvoir analyser pleinement le problème silent

Matriochka
+ Hyperactif +

Messages : 7604
Inscrit(e) le : 14/07/2010

Matriochka a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par alliottom59 le Mer 26 Déc 2012 - 19:08

oui j'utilise le css pour la réduction des liens

alliottom59
***

Masculin
Messages : 160
Inscrit(e) le : 10/12/2012

http://lemondedudiagauto.com
alliottom59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par Matriochka le Mer 26 Déc 2012 - 21:03

N’as-tu pas moyen d’ouvrir l’accès aux invités pour le sujet dans lequel se trouve le problème ? Ce serait vraiment plus simple pour te venir en aide, car là, on a vraiment peu de moyen pour cibler le problème…

Ce n’est que temporaire, juste le temps que l’on puisse régler ceci.

Matriochka
+ Hyperactif +

Messages : 7604
Inscrit(e) le : 14/07/2010

Matriochka a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par alliottom59 le Mer 26 Déc 2012 - 22:11

oui merci
j'ai déplacé le sujet vers une section invité

http://www.lemondedudiagauto.com/t393-carte-des-membres

merci

alliottom59
***

Masculin
Messages : 160
Inscrit(e) le : 10/12/2012

http://lemondedudiagauto.com
alliottom59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par alliottom59 le Mer 26 Déc 2012 - 22:16

je ne comprends rien
en profil invité je la vois correctement
en profil membre et admin je vois que la moitié de la carte

alliottom59
***

Masculin
Messages : 160
Inscrit(e) le : 10/12/2012

http://lemondedudiagauto.com
alliottom59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par Matriochka le Mer 26 Déc 2012 - 22:24

Je viens de créer un compte sur ton forum pour visualiser le problème en tant que membre et effectivement, l’image est entière en invité, mais une fois connecté, elle est coupée. Ça provient sans doute du fait qu’il y ait un lien dessus et que les liens soient désactivés pour les invités.

Essaye un peu de retirer les codes que tu as mis pour raccourcir l’affichage des liens ? Quelque chose me dit que ça vient de là…

Matriochka
+ Hyperactif +

Messages : 7604
Inscrit(e) le : 14/07/2010

Matriochka a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par alliottom59 le Mer 26 Déc 2012 - 22:31

Merci a toi

j'ai effectivement effacé le code css
il a bien résolu mon problème
je te remercie
mais de ce faite mon problème de lien reviens d'actualité

alliottom59
***

Masculin
Messages : 160
Inscrit(e) le : 10/12/2012

http://lemondedudiagauto.com
alliottom59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par Matriochka le Mer 26 Déc 2012 - 22:35

Étrange que ça interfère avec tes images… Sinon, tu peux toujours remettre ton code et retirer le lien sur la carte (c’est un lien qui renvoie vers l’hébergeur servimg, donc pas très utile).

Matriochka
+ Hyperactif +

Messages : 7604
Inscrit(e) le : 14/07/2010

Matriochka a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par alliottom59 le Mer 26 Déc 2012 - 22:38

oui
mais beaucoup de membre utilise cette façon de faire
par hébergeur d'image.

donc se serait une solution a court terme ?


Dernière édition par alliottom59 le Jeu 27 Déc 2012 - 0:08, édité 1 fois

alliottom59
***

Masculin
Messages : 160
Inscrit(e) le : 10/12/2012

http://lemondedudiagauto.com
alliottom59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par Matriochka le Mer 26 Déc 2012 - 22:44

À court terme, oui.

Tu devrais laisser ton topic ouvert encore un peu, je pense que quelqu’un passera pour te dire ce qui cloche avec ce code. Je vais faire quelques recherches de mon côté, mais je ne te promets rien pour le moment Smile

Matriochka
+ Hyperactif +

Messages : 7604
Inscrit(e) le : 14/07/2010

Matriochka a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par alliottom59 le Mer 26 Déc 2012 - 22:47

merci a toi
ensemble on a déjà cerné le problème.

je laisse la carte de membre ouverte au invités pour qu'ils puissent voir le problème
je vais remettre le code css

ci dessous:

.postbody a {
display: inline-block;
max-width: 300px;
overflow: hidden;
white-space: nowrap;
text-overflow: ellipsis;
}


alliottom59
***

Masculin
Messages : 160
Inscrit(e) le : 10/12/2012

http://lemondedudiagauto.com
alliottom59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par Automne le Jeu 27 Déc 2012 - 0:04

Bonjour,

Je n'ai pas vu comment c'était avant, donc je vais tenter un truc a partir des infos que j'ai. Je dirais que votre image est coupé peut etre a cause d'une class a postbody, max-width, qui est inférieure a la taille de votre image.

si je me trompe, vous pouvez remettre comme c'était avant (ou bien le problème est toujours présent en tant que membre seulement, que je jette un oeil Wink


Automne
+ Hyperactif +

Messages : 8422
Inscrit(e) le : 22/03/2010

http://gilles570.forumactif.info/
Automne a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par alliottom59 le Jeu 27 Déc 2012 - 0:11

bonsoir

sans le code css pour raccourcir les liens, invités ou pas la carte est complète
mais
avec le code css seul les invités l'on complète.


actuellement le code css est en fonction
donc en profil invité pas de soucis
mais après inscription vous allez remarquer le problème

merci

alliottom59
***

Masculin
Messages : 160
Inscrit(e) le : 10/12/2012

http://lemondedudiagauto.com
alliottom59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par alliottom59 le Jeu 27 Déc 2012 - 0:59

Je ne comprends pas
j'ai reçu un email pour une réponse sur ce sujet a 0h30
mais il n'y a rien ?

alliottom59
***

Masculin
Messages : 160
Inscrit(e) le : 10/12/2012

http://lemondedudiagauto.com
alliottom59 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par Automne le Jeu 27 Déc 2012 - 1:24

Coucou,

J'ai effacé Wink

Si vous utilisiez le javascript, plutot que le css. Raccourcissement par un code javascript http://forum.forumactif.com/t339898-raccourcir-l-affichage-de-longs-liens

vous supprimer le css
.postbody a {
display: inline-block;
max-width: 300px;
overflow: hidden;
white-space: nowrap;
text-overflow: ellipsis;
}

et mettez le code javascript dans module, gestion des javascripts.

Automne
+ Hyperactif +

Messages : 8422
Inscrit(e) le : 22/03/2010

http://gilles570.forumactif.info/
Automne a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage d'image

Message par alliottom59 le Jeu 27 Déc 2012 - 9:29

Coucou

je te remercie, j'ai réalisée ceci
donc pour le moment mon carte est vu correctement et les liens sont bien raccourci

Bravo a vous tous
très Pro

Bonne fêtes

alliottom59
***

Masculin
Messages : 160
Inscrit(e) le : 10/12/2012

http://lemondedudiagauto.com
alliottom59 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum