Problème d'affichage des templates

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème d'affichage des templates

Message par Pikari le Lun 4 Mar 2013 - 11:18

Bonjour !

Alors voilà je vous expose mon problème : j'ai récemment créé un nouveau forum, et j'ai donc commencé à travailler sur les CSS et les templates. Or, lors de la modification du template du Qui est en ligne (le template index_body donc), j'ai rencontré un problème qui s'avère assez gênant : à chaque actualisation de la page du forum, je tombe sur un affichage différent... Le forum se souvient en effet de chaque version modifiée du template index_body. L'apparence du Qui est en ligne n'est jamais la même à chaque fois que j'actualise la page. Je vous illustre le problème avec des screens :

Screen 1
Screen 2
Screen 3
Screen 4

J'ai bel et bien fait une recherche sur ce forum à la recherche d'une solution - j'ai donc vidé mon cache, mais rien n'y fait. Mon problème semble similaire à celui de ce topic , cependant aucune réelle solution n'est apportée dedans.
Je précise également que je ne suis pas la seule dans ce cas, une amie qui a récemment créé un forum rencontre le même problème : son forum se souvient d'anciens templates modifiés lorsqu'on actualise plusieurs fois la page.. Dès qu'on supprime les templates, plus de problème cependant. Je suis un peu bloquée maintenant, je ne sais pas si le problème provient de mes codes ou d'autre chose.

Je vous copie/colle le template modifié en question :

Code:
{JAVASCRIPT}
<!-- BEGIN message_admin_index -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
   <!-- BEGIN message_admin_titre -->
   <tr>
      <td class="catHead" height="28"><span class="cattitle">{message_admin_index.message_admin_titre.MES_TITRE}</span></td>
   </tr>
   <!-- END message_admin_titre -->
   <!-- BEGIN message_admin_txt -->
   <tr>
      <td class="row1" rowspan="3" align="center" valign="middle">
      <div class="gensmall">{message_admin_index.message_admin_txt.MES_TXT}</div>
      </td>
   </tr>
   <!-- END message_admin_txt -->
</table>
<!-- END message_admin_index -->

<!-- BEGIN switch_user_login_form_header -->
<form action="{S_LOGIN_ACTION}" method="post" name="form_login">
   <!-- BEGIN switch_fb_connect_no -->
   <table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
      <tr>
         <td class="row1" align="center">
            <table border="0" cellspacing="0" cellpadding="0">
               <tr>
                  <td><span class="genmed">{L_USERNAME}:</span> </td>
                  <td><input class="post" type="text" size="10" name="username"/> </td>
                  <td>
                     <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
                     <span class="gensmall">{L_AUTO_LOGIN}</span> 
                  </td>
               </tr>

               <tr>
                  <td><span class="genmed">{L_PASSWORD}:</span> </td>
                  <td><input class="post" type="password" size="10" name="password"/> </td>
                  <td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
               </tr>
            </table>
         </td>
      </tr>
   </table>
   <!-- END switch_fb_connect_no -->

   <!-- BEGIN switch_fb_connect -->
   <table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
      <tr>
         <td valign="top" width="100%" class="row1" align="center">
            <table width="100%">
               <tr>
                  <td width="55%" valign="middle" align="right">
                     <table class="right">
                        <tr>
                           <td><span class="genmed">{L_USERNAME}:</span> </td>
                           <td><input class="post" type="text" size="10" name="username"/> </td>
                           <td>
                              <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
                              <span class="gensmall">{L_AUTO_LOGIN}</span> 
                           </td>
                        </tr>

                        <tr>
                           <td><span class="genmed">{L_PASSWORD}:</span> </td>
                           <td><input class="post" type="password" size="10" name="password"/> </td>
                           <td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
                        </tr>
                     </table>
                  </td>
                  <td width="10%" align="center" valign="middle">
                     <span class="genmed fb_or">{switch_user_login_form_header.switch_fb_connect.L_OR}</span>
                  </td>
                  <td width="35%" class="align_gauche"><fb:login-button size="large" onlogin="window.location='/facebook_connect.forum'" v="2" scope="{switch_user_login_form_header.switch_fb_connect.L_FB_PERMISSIONS}">{switch_user_login_form_header.switch_fb_connect.L_FB_LOGIN_BUTTON}</fb:login-button></td>
               </tr>
            </table>
         </td>
      </tr>
   </table>
   <!-- END switch_fb_connect -->
</form>
<!-- END switch_user_login_form_header -->

{CHATBOX_TOP}
{BOARD_INDEX}
<table width="100%" border="0" cellspacing="0" cellpadding="0">
   <tr>
      <td width="50%" valign="top">
         <!-- BEGIN switch_user_logged_in -->
         <span class="gensmall"><a href="{U_MARK_READ}" class="gensmall">{L_MARK_FORUMS_READ}</a>
         <!-- END switch_user_logged_in -->
         <!-- BEGIN switch_delete_cookies -->
         <br /><a href="{switch_delete_cookies.U_DELETE_COOKIES}" class="gensmall">{switch_delete_cookies.L_DELETE_COOKIES}</a>
         <!-- END switch_delete_cookies -->
         </span>
      </td>
      <td width="50%" align="right">
         <span class="gensmall">
            <a href="{U_TODAY_ACTIVE}" class="gensmall">{L_TODAY_ACTIVE}</a><br />
            <a href="{U_TODAY_POSTERS}" class="gensmall">{L_TODAY_POSTERS}</a><br />
            <a href="{U_OVERALL_POSTERS}" class="gensmall">{L_OVERALL_POSTERS}</a>
            <!-- BEGIN switch_on_index -->
               <!-- BEGIN switch_delete_cookies -->
               <br /><a href="{switch_on_index.switch_delete_cookies.U_DELETE_COOKIES}" class="gensmall">{switch_on_index.switch_delete_cookies.L_DELETE_COOKIES}</a>
               <!-- END switch_delete_cookies -->
            <!-- END switch_on_index -->
         </span>
      </td>
   </tr>
</table>

<!-- BEGIN switch_user_login_form_footer -->
<form action="{S_LOGIN_ACTION}" method="post" name="form_login">
   <!-- BEGIN switch_fb_connect_no -->
   <table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
      <tr>
         <td class="row1" align="center">
            <table border="0" cellspacing="0" cellpadding="0">
               <tr>
                  <td><span class="genmed">{L_USERNAME}:</span> </td>
                  <td><input class="post" type="text" size="10" name="username"/> </td>
                  <td>
                     <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
                     <span class="gensmall">{L_AUTO_LOGIN}</span> 
                  </td>
               </tr>

               <tr>
                  <td><span class="genmed">{L_PASSWORD}:</span> </td>
                  <td><input class="post" type="password" size="10" name="password"/> </td>
                  <td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
               </tr>
            </table>
         </td>
      </tr>
   </table>
   <!-- END switch_fb_connect_no -->

   <!-- BEGIN switch_fb_connect -->
   <table width="100%" border="0" cellspacing="0" cellpadding="0" class="user_login_form forumline">
      <tr>
         <td valign="top" width="100%" class="row1" align="center">
            <table width="100%">
               <tr>
                  <td width="55%" valign="middle">
                     <table class="right">
                        <tr>
                           <td><span class="genmed">{L_USERNAME}:</span> </td>
                           <td><input class="post" type="text" size="10" name="username"/> </td>
                           <td>
                              <input class="radio" type="checkbox" name="autologin" {AUTOLOGIN_CHECKED} />
                              <span class="gensmall">{L_AUTO_LOGIN}</span> 
                           </td>
                        </tr>

                        <tr>
                           <td><span class="genmed">{L_PASSWORD}:</span> </td>
                           <td><input class="post" type="password" size="10" name="password"/> </td>
                           <td>{S_HIDDEN_FIELDS}<input class="mainoption" type="submit" name="login" value="{L_LOGIN}" /></td>
                        </tr>
                     </table>
                  </td>
                  <td width="10%" align="center" valign="middle">
                     <span class="genmed fb_or">{switch_user_login_form_footer.switch_fb_connect.L_OR}</span>
                  </td>
                  <td width="35%" class="align_gauche"><fb:login-button size="large" onlogin="window.location='/facebook_connect.forum'" v="2" scope="{switch_user_login_form_footer.switch_fb_connect.L_FB_PERMISSIONS}">{switch_user_login_form_footer.switch_fb_connect.L_FB_LOGIN_BUTTON}</fb:login-button></td>
               </tr>
            </table>
         </td>
      </tr>
   </table>
   <!-- END switch_fb_connect -->
</form>
<!-- END switch_user_login_form_footer -->

<!-- BEGIN disable_viewonline -->
<div class="fondqeel"> <table>
   <tr>
      <td width="50%"> <center><img src="http://i1084.photobucket.com/albums/j419/FairyFaith_/qeel-4_zps01f205ed.png"></center>
      </td>
            <td width="50%"> <center>
            <a href="http://skieskingdom.forumactif.org/g3-royaume-riche"><img src="http://i1084.photobucket.com/albums/j419/FairyFaith_/groupe1_zpsb4916f89.png"></a>
            <a href="http://skieskingdom.forumactif.org/g4-royaume-modeste"><img src="http://i1084.photobucket.com/albums/j419/FairyFaith_/groupe2_zpsae505260.png"></a>
            <a href="http://skieskingdom.forumactif.org/g5-royaume-pauvre"><img src="http://i1084.photobucket.com/albums/j419/FairyFaith_/groupe3_zps5c34019d.png"></a>
            <a href="http://skieskingdom.forumactif.org/g6-exiles"><img src="http://i1084.photobucket.com/albums/j419/FairyFaith_/groupe4_zps3f8889f7.png"></a>
      </center> </td>
   </tr>
   <tr>
   <td width="50%"> <div class="fondinfo"> Skies Kingdom, c'est... <br>
   <span id="nb_membres"> {TOTAL_USERS} <script type="text/javascript">document.getElementById('nb_membres').innerHTML=document.getElementById('nb_membres').innerHTML.replace(/Nous avons/,"♕");</script></span> et <span id="nb_messages">{TOTAL_POSTS} <script type="text/javascript">document.getElementById('nb_messages').innerHTML=document.getElementById('nb_messages').innerHTML.replace(/Nos membres ont posté un total de/,"♔");</script></span> postés. <br>
   Mais c'est aussi du Miyazaki, du fun, du fou ! <br>
   C'est pour ça <span id="usersonline"> {TOTAL_USERS_ONLINE} <script type="text/javascript">document.getElementById('usersonline').innerHTML=document.getElementById('usersonline').innerHTML.replace(/Il y a en tout/,"qu'il y a");</script></span> sur le forum, et
   <span id="newuser"> {NEWEST_USER} <script type="text/javascript">document.getElementById('newuser').innerHTML=document.getElementById('newuser').innerHTML.replace(/L'utilisateur enregistré le plus récent est/,"que");</script></span> nous a rejoint ! On lui souhaite la bienvenue ! <br>
   <br> {LOGGED_IN_USER_LIST}
   </div>
   </td>
      <td width="50%"> <div class="fondonline"> <img src="http://i1084.photobucket.com/albums/j419/FairyFaith_/qeel-4_zps01f205ed.png"> <br>
      <img src="http://i1084.photobucket.com/albums/j419/FairyFaith_/qeel-4_zps01f205ed.png">
   </div> </table>
   </td>
   </tr>
</table> </div>
<!-- END disable_viewonline -->
{CHATBOX_BOTTOM}
<br clear="all" />
<!-- BEGIN switch_legend -->
<table border="0" cellspacing="3" cellpadding="0" align="center">
   <tr>
      <td align="center" width="20"><img src="{FORUM_NEW_IMG}" alt="{L_NEW_POSTS}" /></td>
      <td><span class="gensmall">{L_NEW_POSTS}</span></td>
      <td></td>
      <td align="center" width="20"><img src="{FORUM_IMG}" alt="{L_NO_NEW_POSTS}" /></td>
      <td><span class="gensmall">{L_NO_NEW_POSTS}</span></td>
      <td>  </td>
      <td align="center" width="20"><img src="{FORUM_LOCKED_IMG}" alt="{L_FORUM_LOCKED}" /></td>
      <td><span class="gensmall">{L_FORUM_LOCKED}</span></td>
   </tr>
</table>
<!-- END switch_legend -->

{AUTO_DST}

<!-- BEGIN switch_fb_index_login -->
<div id="fb-root"></div>
<script type="text/javascript">
//<![CDATA[
FB.init({
   appId: '{switch_fb_index_login.FACEBOOK_APP_ID}',
    status: true,
    cookie: true,
    xfbml: true,
   oauth: true
});
//]]>
</script>
<!-- END switch_fb_index_login -->

Bref, je vous remercie d'avance !


Dernière édition par Pikari le Mer 13 Mar 2013 - 12:13, édité 1 fois

Pikari
Nouveau membre

Messages : 4
Inscrit(e) le : 04/03/2013

Pikari a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage des templates

Message par Matriochka le Lun 4 Mar 2013 - 11:39

Bonjour et Bienvenue
sur le Forum des Forums Forumactif
Vu que vous êtes nouveau, voici quelques sujets importants :
Sécurité : mail de fondation - Ce qu'il ne faut pas faire
N'hésitez pas à ouvrir un nouveau sujet si vous ne trouvez pas votre réponse Wink

Il me semble qu’il y a actuellement quelques soucis avec la gestion des templates, c’est pour quoi tu n’es pas la seule à constater ce souci (je l’ai également sur mon propre forum).

Il faudra sans doute attendre que les techniciens règle ce petit désagrément… Smile

Matriochka
+ Hyperactif +

Messages : 7604
Inscrit(e) le : 14/07/2010

Matriochka a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage des templates

Message par Pikari le Lun 4 Mar 2013 - 14:07

D'accord, merci pour votre réponse ! Nous allons donc attendre patiemment que le soucis soit réglé. : )

Pikari
Nouveau membre

Messages : 4
Inscrit(e) le : 04/03/2013

Pikari a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage des templates

Message par Pikari le Dim 10 Mar 2013 - 22:21

Bonjour,
Un petit up pour savoir si les choses avancent ou non, y a-t-il moyen de savoir si ce sera bientôt réparé ? :< Merci.

Pikari
Nouveau membre

Messages : 4
Inscrit(e) le : 04/03/2013

Pikari a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'affichage des templates

Message par Pikari le Mer 13 Mar 2013 - 12:15

Bonjour, tout semble bien fonctionner, je n'ai plus de problème avec le template capricieux !
Problème résolu pour ma part donc, merci. Smile

Pikari
Nouveau membre

Messages : 4
Inscrit(e) le : 04/03/2013

Pikari a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum