Problème Javascript

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème Javascript

Message par Joebar14 le Sam 27 Avr 2013 - 12:17

Bonjour à tous !
Après avoir fait des recherches sur mon problème et suivis des tutos & astuces de près, je commence à désespérer donc je vous fait part de mon problème :

- J'ai suivis l'astuce ci joint qui permettait de mettre une image en fond de forum et donc avoir un rendu du style :



Mais en activant le code java et après avoir actualisé le forum, je suis toujours en possession du thème choisit lors de la création du forum.
Voici le code java :

$(function(){

var bg= "http://imageshack.us/photo/my-images/209/taille1920x1200.jpg/";

if(screen.width < 801) bg="http://imageshack.us/photo/my-images/259/taille800.jpg/";
else if(screen.width < 1025) bg="http://imageshack.us/photo/my-images/690/taille1024.jpg/";
else if(screen.width < 1281) bg="http://imageshack.us/photo/my-images/94/taille1280.jpg/";
else if(screen.width < 1601) bg="http://imageshack.us/photo/my-images/521/taille1600.jpg/";

document.body.style.backgroundImage="url(\""+bg+"\")";

});
- Ma version du forum est phpBB2, et voici son url.
- J'ai utilisé un code CSS pour afficher des images en titre de forum.
- J'utilise Chrome comme navigateur.
- Ais-je raté une étape pour activer la transparence de mon forum & laisser place à l'image de fond ?

J'espère avoir assez détaillé mon problème, j'ai fait du mieux que j'ai pu.


Dernière édition par Joebar14 le Sam 27 Avr 2013 - 15:28, édité 1 fois

Joebar14
Nouveau membre

Messages : 7
Inscrit(e) le : 15/04/2013

http://tbd-tera.forumolympic.com
Joebar14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Javascript

Message par Scipion le Sam 27 Avr 2013 - 13:05

Bonjour

Je viens de tester vos images mais elles ne s'affichent pas, même en dehors du code. Je vous suggère d'héberger à nouveau l'image originale sur ServImg et faire les redimensionnements nécessaires pour obtenir les valeurs requises par le tutoriel.

Cordialement

Scipion
+ Hyperactif +

Masculin
Messages : 8655
Inscrit(e) le : 03/02/2010

http://forum.forumactif.com/
Scipion a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Javascript

Message par Arlem le Sam 27 Avr 2013 - 13:53

Bonjour,

Les images sont bien hébergées, cependant tu n'as pas pris le bon lien, il faut prendre le lien direct vers l'image soit :
En 1920*1200 : http://imageshack.us/a/img209/9452/taille1920x1200.jpg
En 1600 : http://imageshack.us/a/img521/9973/taille1600.jpg
En 1280 : http://imageshack.us/a/img94/6338/taille1280.jpg
En 1024 : http://imageshack.us/a/img690/8126/taille1024.jpg
En 800 : http://imageshack.us/a/img259/1176/taille800.jpg

Arlem
+ Hyperactif +

Messages : 2550
Inscrit(e) le : 30/06/2009

Arlem a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Javascript

Message par Joebar14 le Sam 27 Avr 2013 - 14:53

J'essaye ça de suite et je vous tiens au courant Yes

Joebar14
Nouveau membre

Messages : 7
Inscrit(e) le : 15/04/2013

http://tbd-tera.forumolympic.com
Joebar14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Javascript

Message par Joebar14 le Sam 27 Avr 2013 - 15:28

Cool !
Ça marche ! Bravo2
Manque plus qu'à fignoler les réglages Very Happy

Problème : Résolu

Joebar14
Nouveau membre

Messages : 7
Inscrit(e) le : 15/04/2013

http://tbd-tera.forumolympic.com
Joebar14 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum