Problème de code qui ne fonctionne pas sur mon forum

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème de code qui ne fonctionne pas sur mon forum

Message par seb03000 le Mer 1 Mai 2013 - 13:14

Bonjour a tous.

Je me permet de vous écrire car je rencontre une difficulté , je dirai même, que votre tuto ne fonctionne

pas sur mon forum, qui est: Coloriser les cases des Note et des annonces , fait par Matriochka

J'ai suivit le tuto a la lettre , je suis en mode punBB, voici le lien de mon forum http://robotique-projet.lebonforum.com/forum

j'ai bien activer la gestion des codes Javascript sur oui , et j'ai cocher la casse Sur les sujets.

Voila les code que j'ai mis sur mon forum:

Code:
      $(function() {
        /* Ajoute une class à la cellule des annonces */
        $('img[src="http://hitskin.com/themes/14/99/04/i_folder_announce.png"]').closest('tr').addClass('annonce');
        /* Ajoute une class à la cellule des Note*/
        $('img[src="http://hitskin.com/themes/14/99/04/i_folder_sticky.png"]').closest('tr').addClass('Note');
        });

et le CSS:

Code:
tr.annonce td {background-color:#314DFF;} /* Modifie la couleur de fond des annonces */
        tr.Note td {background-color:#3C9291;} /* Modifie la couleur de fond des Note */

Puis pour les Complément : icône de sujets, annonces globales.

Code:
                $(function() {
                /* Ajoute une class aux sujets portant l’icône Résolu */
                $('img[src="http://r24.imgfast.net/users/2913/10/00/00/smiles/505812.png"]').closest('tr').addClass('resolu');
                });

Et le CSS:

Code:
tr.resolu td {background-color:#006500;} /* Modifie la couleur de fond des Note */

Voila j'ai pratiquer comme dis sur votre forum , et rien ne se passe ^^

Merci d'avance , en attente de votre message.

@Cordialement.


Dernière édition par seb03000 le Jeu 2 Mai 2013 - 7:18, édité 2 fois

seb03000
**

Masculin
Messages : 78
Inscrit(e) le : 08/08/2010

http://robotique-projet.lebonforum.com/forum
seb03000 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code qui ne fonctionne pas sur mon forum

Message par seb03000 le Mer 1 Mai 2013 - 19:12

UP les amies

seb03000
**

Masculin
Messages : 78
Inscrit(e) le : 08/08/2010

http://robotique-projet.lebonforum.com/forum
seb03000 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Problème de code qui ne fonctionne pas sur mon forum

Message par Milouze14 le Mer 1 Mai 2013 - 19:40

Salut seb03000,
édites ton javascript décoches " Sur les sujets" et coche la case :
Sur les sous-forums Wink .

Et ensuite ta feuille de style:
Code:

tr.annonce td.tcl.tdtopics{background-color:#314DFF;} /* Modifie la couleur de fond des annonces */
tr.Note td.tcl.tdtopics{background-color:#3C9291;} /* Modifie la couleur de fond des Note */
Code:
 tr.resolu td.tcl.tdtopics {background-color:#006500;} /* Modifie la couleur de fond des Note */
a++

Milouze14
+ Hyperactif +

Masculin
Messages : 4628
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code qui ne fonctionne pas sur mon forum

Message par seb03000 le Mer 1 Mai 2013 - 19:45

Merci Milouze14 , je viens de procédé ta méthode que tu ma fourni cela ne fonctionne toujours pas.

seb03000
**

Masculin
Messages : 78
Inscrit(e) le : 08/08/2010

http://robotique-projet.lebonforum.com/forum
seb03000 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code qui ne fonctionne pas sur mon forum

Message par Milouze14 le Mer 1 Mai 2013 - 19:52

Re,
Edit:voir le message suivant:

a++


Dernière édition par Milouze14 le Mer 1 Mai 2013 - 20:01, édité 1 fois

Milouze14
+ Hyperactif +

Masculin
Messages : 4628
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code qui ne fonctionne pas sur mon forum

Message par Milouze14 le Mer 1 Mai 2013 - 19:58

Re,
ton code fonctionne :


a++

Milouze14
+ Hyperactif +

Masculin
Messages : 4628
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code qui ne fonctionne pas sur mon forum

Message par seb03000 le Mer 1 Mai 2013 - 20:04

A oui cela fonctionne j'ai du avoir un différé je pence.

Par contre se qui ne fonctionne pas sur mon forum c'est le bouton résolut , qui na pas laire de faire effet

seb03000
**

Masculin
Messages : 78
Inscrit(e) le : 08/08/2010

http://robotique-projet.lebonforum.com/forum
seb03000 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code qui ne fonctionne pas sur mon forum

Message par Milouze14 le Mer 1 Mai 2013 - 20:08

Re,
tu as modifié dans ta C.S.S ?
Code:
tr.resolu td.tcl.tdtopics {background-color:#006500;} /* Modifie la couleur de fond des resolus */

As tu un lien visible aux invités dans les résolus qui pourrait nous aider sur ton forum ?

a++

Milouze14
+ Hyperactif +

Masculin
Messages : 4628
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code qui ne fonctionne pas sur mon forum

Message par seb03000 le Mer 1 Mai 2013 - 20:17

Oui j'ai bien modifier le css voici un lien http://robotique-projet.lebonforum.com/f11-presentations-des-menbres vous aller voir marquer [resolu] mais il y a pas la couleur et le bouton résolu reste le même car normalement quand on édite un sujet et que lon veux le passé en résolu le bouton dois être comme ce si mais cela n'est pas le cas il reste d'origine

seb03000
**

Masculin
Messages : 78
Inscrit(e) le : 08/08/2010

http://robotique-projet.lebonforum.com/forum
seb03000 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code qui ne fonctionne pas sur mon forum

Message par seb03000 le Mer 1 Mai 2013 - 20:22

Sinon voici le code javscript

Code:
$(function() {
                /* Ajoute une class à la cellule des annonces */
                $('img[src="http://hitskin.com/themes/14/99/04/i_folder_announce.png"]').closest('tr').addClass('annonce');
                /* Ajoute une class à la cellule des Note*/
                $('img[src="http://hitskin.com/themes/14/99/04/i_folder_sticky.png"]').closest('tr').addClass('Note');
        /* Ajoute une class aux sujets portant l’icône Résolu */
        $('img[src="http://r24.imgfast.net/users/2913/10/00/00/smiles/505812.png"]').closest('tr').addClass('resolu');
        });

et le code CSS:

Code:
        tr.annonce td.tcl.tdtopics{background-color:#314DFF;} /* Modifie la couleur de fond des annonces */
        tr.Note td.tcl.tdtopics{background-color:#BB0000;} /* Modifie la couleur de fond des Note */
        tr.resolu td.tcl.tdtopics {background-color:#006200;} /* Modifie la couleur de fond des resolut */

seb03000
**

Masculin
Messages : 78
Inscrit(e) le : 08/08/2010

http://robotique-projet.lebonforum.com/forum
seb03000 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code qui ne fonctionne pas sur mon forum

Message par seb03000 le Jeu 2 Mai 2013 - 1:13

UP les amies

seb03000
**

Masculin
Messages : 78
Inscrit(e) le : 08/08/2010

http://robotique-projet.lebonforum.com/forum
seb03000 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Problème de code qui ne fonctionne pas sur mon forum

Message par Milouze14 le Jeu 2 Mai 2013 - 7:04

Salut Seb03000 ,
le code fonctionne parfaitement ,
l'image résolu est bien dans la gestion des images :

Passes en mode avancé en cliquant sur :
Affichage/Images et couleurs/Gestion des images/Mode avançé

Icônes de messages
Clique sur créer puis:
Nom de l'icône : Résolu
Icône : le lien ci-dessous:
http://r24.imgfast.net/users/2913/10/00/00/smiles/505812.png

Niveau d'autorisations : autorises le niveau
Utilisé par défaut: ne coche rien

a++

a++


Milouze14
+ Hyperactif +

Masculin
Messages : 4628
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code qui ne fonctionne pas sur mon forum

Message par seb03000 le Jeu 2 Mai 2013 - 7:17

A enfin , grand merci a toi Milouze14 sa fonctionne.

Voila encore une affaire résolu encor merci Milouze14

seb03000
**

Masculin
Messages : 78
Inscrit(e) le : 08/08/2010

http://robotique-projet.lebonforum.com/forum
seb03000 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum