Une barre de navigation qui ne s'affiche pas

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Une barre de navigation qui ne s'affiche pas

Message par Adminemrod le Ven 28 Juin 2013 - 19:10

Bonjour/ Bonsoir,

voilà, j'ai créé mon propre forum depuis peu et, comme la plupart des fondateurs, je souhaite y intégrer ma propre barre de navigation.

J'ai donc fait toutes les démarches (du moins, celles que je connais) pour y parvenir, c'est à dire cocher le "Oui" pour l'affichage des images, et mettre les miennes dans le mode avancé de leur gestion, vous m'suivez ? Le seul hic, et pas des moindres, est que ma navigation ne s'affiche toujours pas (d'où le titre de mon sujet).

Voici un aperçu:
Ainsi que le lien de mon forum : http://nemrod.forumactif.org/

Je ne sais quel template est relatif à la barre de navigation donc, je ne pourrais vous dire si je l'ai modifié par erreur >.< J'espère que vous trouverez solution(s) à mon problème Smile

Amicalement,
quelqu'un qui vous veut du bien.

Adminemrod
Nouveau membre

Messages : 4
Inscrit(e) le : 28/06/2013

http://nemrod.forumactif.org/
Adminemrod a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une barre de navigation qui ne s'affiche pas

Message par Matriochka le Sam 29 Juin 2013 - 10:06

Bonjour et Bienvenue
sur le Forum des Forums Forumactif
Vu que vous êtes nouveau, voici quelques sujets importants :
Sécurité : mail de fondation - Ce qu'il ne faut pas faire

N'hésitez pas à ouvrir un nouveau sujet si vous ne trouvez pas votre réponse Wink
Bonjour,

Deux solutions :
1. Tu as retiré la variable {GENERATED_NAVBAR} du template overall_header
2. Tu n'a spas coché la bonne case dans Panneau d'administration > Affichage > Page d'accueil > En-tête et navigation > "Afficher seulement des images dans la barre des liens"

Smile

Matriochka
+ Hyperactif +

Messages : 7604
Inscrit(e) le : 14/07/2010

Matriochka a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une barre de navigation qui ne s'affiche pas

Message par Adminemrod le Sam 29 Juin 2013 - 12:35

Effectivement, cette variable n’apparaît pas dans mon template ! Pourriez- vous m'indiquer l'emplacement exact de cette variable ? Merci encore Smile

Adminemrod
Nouveau membre

Messages : 4
Inscrit(e) le : 28/06/2013

http://nemrod.forumactif.org/
Adminemrod a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une barre de navigation qui ne s'affiche pas

Message par Matriochka le Sam 29 Juin 2013 - 12:36

Techniquement, si tu veux qu'elle se trouve sous la bannière, il faut qu'elle soit sous cette partie :
Code:
<table width="100%" cellspacing="0" cellpadding="0" border="0">
               <tr>
                  <!-- BEGIN switch_logo_left -->
                  <td><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a></td>
                  <!-- END switch_logo_left -->
                  <td align="center" width="100%" valign="middle">
                     <!-- BEGIN switch_logo_center -->
                     <a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a>
                     <br />
                     <!-- END switch_logo_center -->
                     <div class="maintitle">{MAIN_SITENAME}</div>
                     <br />
                     <span class="gen">{SITE_DESCRIPTION}<br />  </span>
                  </td>
                  <!-- BEGIN switch_logo_right -->
                  <td><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a></td>
                  <!-- END switch_logo_right -->
               </tr>
            </table>

Matriochka
+ Hyperactif +

Messages : 7604
Inscrit(e) le : 14/07/2010

Matriochka a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une barre de navigation qui ne s'affiche pas

Message par Adminemrod le Sam 29 Juin 2013 - 12:54

Comme ceci ?
Code:
<table width="100%" cellspacing="0" cellpadding="0" border="0">
               <tr>
                  <!-- BEGIN switch_logo_left -->
                  <td><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a></td>
                  <!-- END switch_logo_left -->
                  <td align="center" width="100%" valign="middle">
                     <!-- BEGIN switch_logo_center -->
                     <a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a>
                     <br />
                     <!-- END switch_logo_center -->
                     <div class="maintitle">{MAIN_SITENAME}</div>
                     <br />
                     <span class="gen">{SITE_DESCRIPTION}<br />  </span>
                  </td>
                  <!-- BEGIN switch_logo_right -->
                  <td><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a></td>
                  <!-- END switch_logo_right -->
               </tr>
            </table>
                          {GENERATED_NAVBAR}

Adminemrod
Nouveau membre

Messages : 4
Inscrit(e) le : 28/06/2013

http://nemrod.forumactif.org/
Adminemrod a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une barre de navigation qui ne s'affiche pas

Message par Matriochka le Sam 29 Juin 2013 - 12:56

Oui Smile

Et si on veut bien faire les choses en reprenant la structure par défaut :
Code:
<table width="100%" cellspacing="0" cellpadding="0" border="0">
               <tr>
                  <!-- BEGIN switch_logo_left -->
                  <td><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a></td>
                  <!-- END switch_logo_left -->
                  <td align="center" width="100%" valign="middle">
                     <!-- BEGIN switch_logo_center -->
                     <a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a>
                     <br />
                     <!-- END switch_logo_center -->
                     <div class="maintitle">{MAIN_SITENAME}</div>
                     <br />
                     <span class="gen">{SITE_DESCRIPTION}<br />  </span>
                  </td>
                  <!-- BEGIN switch_logo_right -->
                  <td><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a></td>
                  <!-- END switch_logo_right -->
               </tr>
            </table>

            <table cellspacing="0" cellpadding="0" border="0" align="{MENU_POSITION}">
               <tr>
                  <td align="{MENU_POSITION}"{MENU_NOWRAP}>{GENERATED_NAV_BAR}</td>
               </tr>
            </table>

Matriochka
+ Hyperactif +

Messages : 7604
Inscrit(e) le : 14/07/2010

Matriochka a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Une barre de navigation qui ne s'affiche pas

Message par Adminemrod le Sam 29 Juin 2013 - 13:12

Oui, ça marche ! Plus que quelques modif' et ce sera parfait Smile Merci infiniment pour votre aide !

Adminemrod
Nouveau membre

Messages : 4
Inscrit(e) le : 28/06/2013

http://nemrod.forumactif.org/
Adminemrod a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum