Problème script

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème script

Message par Lugatique le Dim 7 Juil 2013 - 20:20

Bonjour,

Alors j'ai mis ce code

Code:
 
      <td class="{postrow.displayed.ROW_CLASS}"{postrow.displayed.THANK_BGCOLOR} valign="top" width="150">
            <span class="postdetails poster-profile">
            {postrow.displayed.POSTER_AVATAR}
 
        <span class="name"><a name="{postrow.displayed.U_POST_ID}"></a><strong>{postrow.displayed.POSTER_NAME}</strong></span>
 
            {postrow.displayed.POSTER_RANK}
 
            {postrow.displayed.RANK_IMAGE}
 
            <!-- BEGIN profile_field -->
            {postrow.displayed.profile_field.LABEL} {postrow.displayed.profile_field.CONTENT}{postrow.displayed.profile_field.SEPARATOR}
            <!-- END profile_field -->
            {postrow.displayed.POSTER_RPG}
        </span>
 
        <img src="http://illiweb.com/fa/vide.gif" alt="" style="width:150px;height:1px" />
      </td>


Pour pouvoir mettre le rang en dessous de l'image mais le seuls problème c'est que le titre du rang est a côté du nom d’utilisateur ! Aider moi aidez moi 

Site : lyxyland.forumactif.org


Dernière édition par Lugatique le Lun 8 Juil 2013 - 8:55, édité 1 fois

Lugatique
**

Masculin
Messages : 60
Inscrit(e) le : 20/06/2013

http://smoozyland.forumactif.org
Lugatique a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème script

Message par [AoH]Insane le Lun 8 Juil 2013 - 5:12

C'est un problème assez simple à régler; je vais donc te dire les étapes à suivre pour pouvoir mettre le rang où tu le souhaites. Premièrement, tu dois accéder au Tempate qui se nomme viewtopic_body :

Panneau d'Administration (PA) Arrow Affichage Arrow Templates Arrow Général Arrow viewtopic_body

Une fois dans le bon Template, tu devras remplacer le code actuel que tu as qui se trouve être ceci:

Code:
 
      <td class="{postrow.displayed.ROW_CLASS}"{postrow.displayed.THANK_BGCOLOR} valign="top" width="150">
            <span class="postdetails poster-profile">
            {postrow.displayed.POSTER_AVATAR}
 
        <span class="name"><a name="{postrow.displayed.U_POST_ID}"></a><strong>{postrow.displayed.POSTER_NAME}</strong></span>
 
            {postrow.displayed.POSTER_RANK}
 
            {postrow.displayed.RANK_IMAGE}
 
            <!-- BEGIN profile_field -->
            {postrow.displayed.profile_field.LABEL} {postrow.displayed.profile_field.CONTENT}{postrow.displayed.profile_field.SEPARATOR}
            <!-- END profile_field -->
            {postrow.displayed.POSTER_RPG}
        </span>
 
        <img src="http://illiweb.com/fa/vide.gif" alt="" style="width:150px;height:1px" />
      </td>

Par ce code là:

Code:
<td class="{postrow.displayed.ROW_CLASS}"{postrow.displayed.THANK_BGCOLOR} valign="top" width="150">
         <span class="name"><a name="{postrow.displayed.U_POST_ID}"></a><strong>{postrow.displayed.POSTER_NAME}</strong></span><br />
            <span id="message" class="postdetails poster-profile">
            {postrow.displayed.POSTER_AVATAR}<br />
            {postrow.displayed.POSTER_RANK}
                                {postrow.displayed.RANK_IMAGE}<br /><br />
            <!-- BEGIN profile_field -->
                                 {postrow.displayed.profile_field.LABEL} {postrow.displayed.profile_field.CONTENT}{postrow.displayed.profile_field.SEPARATOR}
            <!-- END profile_field -->
                                  {postrow.displayed.POSTER_RPG}
                                  </span>
         <img src="http://illiweb.com/fa/empty.gif" alt="" style="width:150px;height:1px" />
      </td>

Ce précédent code fait en sorte que le rang et l'image qui y est associé se trouve sous l'avatar. Le pseudonyme est donc au dessus de l'avatar, puis le rang sous l'avatar. Si tu veux que le pseudonyme sois aussi sous l'avatar, il te faudrait plutôt mettre ce code:

Code:
<td class="{postrow.displayed.ROW_CLASS}"{postrow.displayed.THANK_BGCOLOR} valign="top" width="150">
            <span id="message" class="postdetails poster-profile">
            {postrow.displayed.POSTER_AVATAR}<br />
<span class="name"><a name="{postrow.displayed.U_POST_ID}"></a><strong>{postrow.displayed.POSTER_NAME}</strong></span><br />
            {postrow.displayed.POSTER_RANK}
                                {postrow.displayed.RANK_IMAGE}<br /><br />
            <!-- BEGIN profile_field -->
                                 {postrow.displayed.profile_field.LABEL} {postrow.displayed.profile_field.CONTENT}{postrow.displayed.profile_field.SEPARATOR}
            <!-- END profile_field -->
                                  {postrow.displayed.POSTER_RPG}
                                  </span>
         <img src="http://illiweb.com/fa/empty.gif" alt="" style="width:150px;height:1px" />
      </td>

En espérant avoir aidé

[AoH]Insane
***

Masculin
Messages : 118
Inscrit(e) le : 04/07/2013

http://aoh-rpg.forum-canada.com/
[AoH]Insane a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème script

Message par Lugatique le Lun 8 Juil 2013 - 7:14

Salut merci de ton aide mais j'ai mis le 2 eme code pour le pseudonyme et la c'est le rang et l'image du rang qui sont collé !

Lugatique
**

Masculin
Messages : 60
Inscrit(e) le : 20/06/2013

http://smoozyland.forumactif.org
Lugatique a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème script

Message par [AoH]Insane le Lun 8 Juil 2013 - 8:03

Probablement car ton image de rang est assez petite pour entrer dans l'espace prévu entre l'après-{postrow.displayed.POSTER_RANK} et la fin de <span id="message" class="postdetails poster-profile"></span>. En langage plus clair, ton image entre dans l'espace alloué entre ton rang et la fin de la section dédié au profil du membre. Voici le nouveau code:

Code:
<td class="{postrow.displayed.ROW_CLASS}"{postrow.displayed.THANK_BGCOLOR} valign="top" width="150">
            <span id="message" class="postdetails poster-profile">
            {postrow.displayed.POSTER_AVATAR}<br />
<span class="name"><a name="{postrow.displayed.U_POST_ID}"></a><strong>{postrow.displayed.POSTER_NAME}</strong></span><br />
            {postrow.displayed.POSTER_RANK}<br />
                                {postrow.displayed.RANK_IMAGE}<br /><br />
            <!-- BEGIN profile_field -->
                                {postrow.displayed.profile_field.LABEL} {postrow.displayed.profile_field.CONTENT}{postrow.displayed.profile_field.SEPARATOR}
            <!-- END profile_field -->
                                  {postrow.displayed.POSTER_RPG}
                                  </span>
        <img src="http://illiweb.com/fa/empty.gif" alt="" style="width:150px;height:1px" />
      </td>

En espérant avoir aidé

[AoH]Insane
***

Masculin
Messages : 118
Inscrit(e) le : 04/07/2013

http://aoh-rpg.forum-canada.com/
[AoH]Insane a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème script

Message par Lugatique le Lun 8 Juil 2013 - 8:55

Merci de ton aide ! Very Happy

Lugatique
**

Masculin
Messages : 60
Inscrit(e) le : 20/06/2013

http://smoozyland.forumactif.org
Lugatique a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum