CSS3 ne s'affiche pas

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu CSS3 ne s'affiche pas

Message par Yume-sama le Ven 26 Juil 2013 - 23:22

Bonjour,

Je suis fondatrice sur mon forum phpbb2. J'ai modifié plusieurs template incontournables telles que overall_hearder, index_body, index_box, overall_footer_end, topics_list_box. Ma feuille CSS est déjà bien remplie.

Mon problème concerne le CSS3. Tout bonnement, il ne s'affiche pas. J'ai essayé plusieurs codes pour diverses choses et il n'y aucun changement !

Si quelqu'un a le solution, ce serait vraiment gentil de me filer un coup de main Smile


Dernière édition par Yume-sama le Ven 2 Aoû 2013 - 21:32, édité 1 fois

Yume-sama
Nouveau membre

Féminin
Messages : 17
Inscrit(e) le : 01/02/2013

http://universitehanachi.forumactif.com/
Yume-sama a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CSS3 ne s'affiche pas

Message par Izumi375 le Sam 27 Juil 2013 - 0:23

Coucou,

pourrais je voir le css3 qui ne s'affiche pas? Histoire de comparer avec le code source =)

Izumi375
****

Féminin
Messages : 318
Inscrit(e) le : 31/08/2009

http://keikoku.forumpro.fr
Izumi375 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CSS3 ne s'affiche pas

Message par Yume-sama le Sam 27 Juil 2013 - 8:19

Par exemple, pour cette PA :



Les radius ne s'affichent pas, comme le rendu devrait être :
http://akinotest.forumgratuit.org/h2-cottw2

Tous ce que je mets avec des radius ne fonctionnent pas, ne s'affichent simplement pas.

De plus j'ai essayé d'autres codes, par exemple pour des cadres que j'insèrerai dans mes messages ensuite :

Code:
.cadre2 {
background-color: #fefefe;
border-bottom-left-radius: 20px 20px;
border-bottom-right-radius: 20px 20px;
border-top-left-radius: 20px 20px;
border-top-right-radius: 20px 20px;
line-height: 10px;
padding-bottom: 5px;
padding-left: 5px;
padding-right: 5px;
padding-top: 5px;
}


Je les ai retiré, mais j'ai aussi essayé des codes pour background multiples et enlever le soulignement des liens. Tout était du CSS3 et rien n'a fonctionné !

Yume-sama
Nouveau membre

Féminin
Messages : 17
Inscrit(e) le : 01/02/2013

http://universitehanachi.forumactif.com/
Yume-sama a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CSS3 ne s'affiche pas

Message par MasDan le Sam 27 Juil 2013 - 20:22

Bonjour,

Pour les border-radius Mozilla et Webkit (dont Chrome) ont implémenté leur propre version. Et comme les 4 coins ont exactement la même définition, nous pouvons à une seule définition.   Le padding aussi pourrait subir le même traitement.
Code:
-moz-border-radius : 20px;
-webkit-border-radius : 20px;
border-radius : 20px;
padding: 5px;
Les lignes 1 à 3 remplacent les lignes 3 à 6 de votre css.
La ligne 4 remplacent les lignes 8 à 11.

MasDan
*****

Masculin
Messages : 856
Inscrit(e) le : 24/05/2011

http://projetaum2.forumactif.com/
MasDan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CSS3 ne s'affiche pas

Message par Ea le Sam 27 Juil 2013 - 20:37

Bonjour,


D'après le tableau de compatibilité là :
https://developer.mozilla.org/en-US/docs/Web/CSS/border-radius

Les versions avec prefix de border-radius ne devrait presque plus servir du tout.

Si une règle css ne fonctionne pas c'est :

- que le navigateur ne la comprend pas ( si vous avez google chrome ça ne doit pas être le cas )
- qu'il y a une erreur dans le css

Il faudrait donner un code problématique, dire ce qu'est son action et donner le lien d'une page sur laquelle on devrait voir le code en action mais où il ne fonctionne pas.

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23442
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CSS3 ne s'affiche pas

Message par Yume-sama le Sam 27 Juil 2013 - 21:35

Merci pour vos réponses !

@Masdan Je ne suis pas sûre de tout comprendre... ça m'a l'air bien compliqué !


@Ea Je crois avoir à peu près saisit le sens du tableau de comptabilité.
Concernant les codes, je les ai pourtant prit dans des bases de données destinées à Forumactif et les utilisateurs en étaient satisfaits.... Certains proviennent d'ici, notamment celui-ci :

http://forum.forumactif.com/t327631-banniere-en-background-un-deuxieme-fond
Il me semble qu'il s'agit CSS3, mais de toutes façons rien ne s'affiche !

Yume-sama
Nouveau membre

Féminin
Messages : 17
Inscrit(e) le : 01/02/2013

http://universitehanachi.forumactif.com/
Yume-sama a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CSS3 ne s'affiche pas

Message par Anzu le Ven 2 Aoû 2013 - 21:00

Bonjour,

Attention, cela fait 6 jours que nous n'avons pas de nouvelles concernant votre demande, si vous ne voulez pas voir délester votre sujet, merci de poster dans les 24h qui suivent ce message.

Si votre sujet est résolu, dans ce cas, :editer: votre premier message et cochez l'icône résolu

A bientôt sur ForumActif Smile

Anzu
+ Hyperactif +

Féminin
Messages : 20685
Inscrit(e) le : 30/08/2007

http://forum.forumactif.com/forum
Anzu a été remercié(e) par l'auteur de ce sujet.

Résolu Re: CSS3 ne s'affiche pas

Message par Yume-sama le Ven 2 Aoû 2013 - 21:31

J'ai résolu le problème aujourd'hui même ! En fait, résoudre est un grand mot : au final le CSS3 a toujours fonctionner, seulement les couleurs du forum masquaient les résultats des différents codes ! *stupide* Il n'y a donc jamais eu de problèmes. Si quelqu'un fais les mêmes erreurs que moi, vérifier les couleurs dans les codes ainsi que celles de votre forum, essayer de les retirer Smile

Yume-sama
Nouveau membre

Féminin
Messages : 17
Inscrit(e) le : 01/02/2013

http://universitehanachi.forumactif.com/
Yume-sama a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum