Afficher / Masquer les widgets du forum bug sous Chrome

Page 2 sur 2 Précédent  1, 2

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Afficher / Masquer les widgets du forum bug sous Chrome

Message par 2011N2 le Ven 16 Aoû 2013 - 15:40

Rappel du premier message :

Bonjour,

J'ai suivi cette astuce : http://forum.forumactif.com/t286805-afficher-masquer-les-widgets-du-forum
Visiblement, cela n'est pas censé fonctionner sur un forum Phpbb2 comme le mien, mais pourtant si. Sauf qu'il y a juste un bug uniquement sous Google Chrome (aucun souci sous Firefox et Internet Explorer).

Lorsqu'on souhaite cacher les widgets, tout se passe bien. En revanche, lorsqu'on souhaite les réafficher, ils se réaffichent vers la droite (et non vers la gauche vu que mes widgets sont à droite), ce qui déforme le forum et affiche une barre de défilement. En revanche, après réactualisation ils réapparaissent normalement.

Voici ce que ça donne avec le bug :


Alors que normalement ça devrait être ainsi :


Pensez-vous qu'il est possible de résoudre ce problème sur Chrome, ou bien c'est du à l'incompatibilité du script pour Phpbb2 ?

Merci pour l'aide,

Gabriel.


Dernière édition par 2011N2 le Mer 18 Sep 2013 - 20:44, édité 1 fois

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Afficher / Masquer les widgets du forum bug sous Chrome

Message par Tech le Mer 18 Sep 2013 - 20:06

Les codes ont depuis évolués, je vous invite à utiliser ceux-ci : http://forum.forumactif.com/t290241-afficher-masquer-les-widgets-du-forum

Cordialement.



{ Règles Générales } { Question & Réponses Fréquentes } { Le Staff de ForumActif }

Tech
Modéractif
Modéractif

Masculin
Messages : 20889
Inscrit(e) le : 01/12/2007

http://forum.forumactif.com
Tech a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Afficher / Masquer les widgets du forum bug sous Chrome

Message par 2011N2 le Mer 18 Sep 2013 - 20:15

Re,

En effet c'est totalement différent, j'ai donc supprimé les deux widgets et ajouté les nouveaux codes (Javacript + CSS), cependant je ne vois même pas le bouton, que ce soit sur Chrome ou Firefox... scratch

Sur la capture c'est montré pour un forum ayant les widgets à gauche (ici), or sur mon forum c'est à droite. Cela a-t-il une importance ?

Merci,

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Afficher / Masquer les widgets du forum bug sous Chrome

Message par Tech le Mer 18 Sep 2013 - 20:35

Non ça n'influence pas normalement.

Par contre je vois une erreur js sur votre forum :
Code:
Horodatage : 18/09/2013 20:27:24
Erreur : ReferenceError: \u00C2$ is not defined
Fichier Source : http://www.forum-entraide-informatique.com/99803.js
Ligne : 1
On peut déjà voir ceci à la fin d'un code : Â

Cordialement.



{ Règles Générales } { Question & Réponses Fréquentes } { Le Staff de ForumActif }

Tech
Modéractif
Modéractif

Masculin
Messages : 20889
Inscrit(e) le : 01/12/2007

http://forum.forumactif.com
Tech a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Afficher / Masquer les widgets du forum bug sous Chrome

Message par 2011N2 le Mer 18 Sep 2013 - 20:37

Re,

Ah ouais ok, j'ai effectivement supprimé ce "Ã".
Plus d'erreur sur ce code ?

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Afficher / Masquer les widgets du forum bug sous Chrome

Message par Tech le Mer 18 Sep 2013 - 20:42

Oui c'est bon. Et maintenant chez moi l'astuce fonctionne bien sur Firefox et Google Chrome.

Problème résolu ?

Cordialement.



{ Règles Générales } { Question & Réponses Fréquentes } { Le Staff de ForumActif }

Tech
Modéractif
Modéractif

Masculin
Messages : 20889
Inscrit(e) le : 01/12/2007

http://forum.forumactif.com
Tech a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Afficher / Masquer les widgets du forum bug sous Chrome

Message par 2011N2 le Mer 18 Sep 2013 - 20:44

Re,

Je viens de voir apparaître le bouton à l'instant^^

Après avoir testé sur Chrome, FF et IE, ça m'a l'air ok.

Un problème de résolu, on avance, merci beaucoup pour l'aide. Wink

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Page 2 sur 2 Précédent  1, 2

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum