Bug bouton mise en forme

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Bug bouton mise en forme

Message par kelteros le Sam 24 Aoû 2013 - 21:02

Bonjour,

Mon forum : lespingouins.forumactif.com
Version : phpbb2
Template modifié : oui
Css modifié : oui

J’ai un problème depuis peu et je n'arrive pas a trouver d'ou sa vient, car sans même touché au template ou au css, l'encart réservé à la réponse rapide est devenu blanc, rien de bien gênant en soit, mais quand on clic sur répondre, ou nouveau sujet, tous les boutons de mise en forme du texte et les smiley n’apparaisse plus.

Voici une image qui parle souvent mieux que des mots :



Je précise que avant tous fonctionnait correctement et que ce soucis est apparu tous suel sans que je ne modifie rien du forum, donc je pense que forumactif doit avoir modifier quelque chose ... mais quoi ....

Cordialement,


Dernière édition par kelteros le Mar 27 Aoû 2013 - 16:28, édité 1 fois

kelteros
**

Messages : 83
Inscrit(e) le : 07/06/2010

http://j'en ai pas encore.com
kelteros a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug bouton mise en forme

Message par Milouze14 le Sam 24 Aoû 2013 - 22:03

Salut kelteros,

il va falloir modifier quelques lignes suite à cette mise à jour de l'éditeur :

http://forum.forumactif.com/t352401-nouvel-editeur-de-messages-pour-les-forums-forumactif#3001046

a++

Milouze14
+ Hyperactif +

Masculin
Messages : 4563
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug bouton mise en forme

Message par kelteros le Dim 25 Aoû 2013 - 1:13

Merci de l'information, j'ai récupéré tous les bouton, seul hic sa m'a tous changer et c'est tous blanc .... je suppose que sa doit être du css supplémentaire a modifier.

Mais quid malgré toute les modification j'ai toujours pas les smiley a gauche ...

kelteros
**

Messages : 83
Inscrit(e) le : 07/06/2010

http://j'en ai pas encore.com
kelteros a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug bouton mise en forme

Message par kelteros le Dim 25 Aoû 2013 - 1:55

info en plus, j'ai essayer de changer la couleur en css avec :

.sceditor-container iframe, .sceditor-container textarea
{
background-color: #2D1910;
}
mais sa ne modifie rien ^^

kelteros
**

Messages : 83
Inscrit(e) le : 07/06/2010

http://j'en ai pas encore.com
kelteros a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug bouton mise en forme

Message par Milouze14 le Dim 25 Aoû 2013 - 7:42

Salut kelteros

essayes ceci :


Code:

.sceditor-container textarea , #text_editor_iframe
{
background-color: #2D1910;
}
a++

Milouze14
+ Hyperactif +

Masculin
Messages : 4563
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug bouton mise en forme

Message par kelteros le Lun 26 Aoû 2013 - 13:10

Cela ne fonctionne pas non plus Milouze .... et j'arrive toujours pas a récupéré mes smiley ...

kelteros
**

Messages : 83
Inscrit(e) le : 07/06/2010

http://j'en ai pas encore.com
kelteros a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug bouton mise en forme

Message par Milouze14 le Mar 27 Aoû 2013 - 7:47

Salut kelteros ,
pour les smileys, tu as due oublier de modifier quelque chose sur les mises à jour des deux templates:
http://forum.forumactif.com/t352401-nouvel-editeur-de-messages-pour-les-forums-forumactif#3001510

Ensuite , on va supprimer la css donnée plus haut:
Code:

        
       .sceditor-container textarea , #text_editor_iframe
        {
        background-color: #2D1910;
        }
Dépose ceci en changeant les couleurs:
Code:

/* pour le mode html*/
.sceditor-container textarea
{
color: pink !important;/*la couleur de police*/
background:yellow !important;/*la couleur de fond*/
}
Pour le mode wysiwyg il faut passer par un javascript Wink :

Modules/HTML&JAVASCRIPT/Gestion des codes Javascript/Créer un nouveau Javascript

Mettre un titre explicite.
Cocher sur toutes les pages.

Dépose ceci en changeant les couleurs ici:
background-color:yellow;color:blue;


Code:

$(function(){$(function() {
$("#text_editor_textarea").sceditor('instance')
.css('body, code:before, html, p, table {background-color:yellow;color:blue;}')
        })});
Pensez à cliquer sur le bouton

a++

Milouze14
+ Hyperactif +

Masculin
Messages : 4563
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug bouton mise en forme

Message par kelteros le Mar 27 Aoû 2013 - 13:27

Bonjour Milouze, alors j'ai inséré ces deux code :

Celui-ci dans la feuille de style css
/* pour le mode html*/
.sceditor-container textarea
{
color: #E3D19E !important;/*la couleur de police*/
background:#2E1A11 !important;/*la couleur de fond*/
}
Et celui-ci dans les code java script :

$(function(){$(function() {
$("#text_editor_textarea").sceditor('instance')
.css('body, code:before, html, p, table {background-color:#2E1A11;color:#E3D19E;}')
})});
je n'est fait que modifier pour adapter aux couleurs de mon forum mais cela n'a pas fonctionner ....

Et concernant les smileys, pourtant j'ai tous fait comme demande dans la partie tuto pour phpbb2 .....

Cordialement,

kelteros
**

Messages : 83
Inscrit(e) le : 07/06/2010

http://j'en ai pas encore.com
kelteros a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bug bouton mise en forme

Message par kelteros le Mar 27 Aoû 2013 - 16:27

Rectification, ( c'est moi l'idiot qui n'avais pas fait CTRL + F5 mais juste F5 .... ) les code css fonctionne a la perfection, en revanche pas ceux en javascript, mais bon c'est secondaire et pas grave, temps que celui de base fonctionne bien ....

Et pour les smiley, méaculpa, y a deuxième post plus bas sur les modification et bug concernant les smiley.

Merci Milouze de ton aide précieuse, je met en résolu.

kelteros
**

Messages : 83
Inscrit(e) le : 07/06/2010

http://j'en ai pas encore.com
kelteros a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum