Problème de sous-forums qui doublent

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème de sous-forums qui doublent

Message par Myresis le Dim 25 Aoû 2013 - 2:09

Bonsoir !

Je viens vers vous en panique totale
Voilà, nous venons d'installer notre nouveau design avec mon collègue admin, pas de soucis, nous avons corrigé tout ce qui n'allait pas mais un problème vient de nous sauter aux yeux, et on a beau cherché, que ce soit en fouillant sur le net ou en épluchant les codes, on ne trouve absolument pas de solution.

En effet, nous avons remarqué que les sous-forums se dédoublaient :

Spoiler:

Le forum est bien en phpbb2 et sur Forumactif ! Le bug apparaît peu importe le  navigateur utilisé.

Voici l'index_box si vous cela peut vous aider

Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center" style="padding-bottom:5px;">
 <tr>
 <td valign="bottom">
 <!-- BEGIN switch_user_logged_in -->
 <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
 <!-- END switch_user_logged_in -->
 
</td>
 <td class="gensmall" align="right" valign="bottom">
 <!-- BEGIN switch_user_logged_in -->
 <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
 
<!-- END switch_user_logged_in -->
 
</td>
 </tr>
</table>
<!-- BEGIN catrow --><!-- BEGIN tablehead --><table class="forumline" width="100%" border="0" cellspacing="0" cellpadding="0">
 <tr>
 <th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle"> {catrow.tablehead.L_FORUM} </th>

 <th nowrap="nowrap" width="150"><div style="width:150px;">{L_LASTPOST}</div></th>
 </tr>
 <!-- END tablehead -->
 <!-- BEGIN cathead -->
 <tr>
 <!-- BEGIN inc -->
 <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
 <!-- END inc -->
 <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
 <h{catrow.cathead.LEVEL} class="hierarchy">
 <span class="cattitle">
 <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
 </span>
 </h{catrow.cathead.LEVEL}>
 </td>
 <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right"> </td>
 </tr>
 <!-- END cathead -->
 <!-- BEGIN forumrow -->
 <tr>
 <!-- BEGIN inc -->
 <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
 <!-- END inc -->
 <td class="{catrow.forumrow.INC_CLASS}" align="center" valign="middle" id="fondforum1">
 <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
 </td>
 <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="100%" height="50">
 <h{catrow.forumrow.LEVEL} class="hierarchy">
 
                         
 </h{catrow.forumrow.LEVEL}>
                  <br />
 <div class ="descri"><span class="genmed">
                        <span class="forumlink"><a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a></span>
                       {catrow.forumrow.FORUM_DESC}</span></div>
 <span class="gensmall">
 <!-- BEGIN switch_moderators_links -->
 {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
 <!-- END switch_moderators_links -->
 <div class="descri_2">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</div>

 </span>

 </td>
      <!-- BEGIN forum_link_no -->
      <td class="row3 over" align="center" valign="middle" height="50">
         <div class="kael_last_post"><span class="gensmall">{catrow.forumrow.LAST_POST}</span></div>

<div class="kael_messages_postes"><span class="gensmall">{catrow.forumrow.TOPICS} sujets</span> | <span class="gensmall">{catrow.forumrow.POSTS} messages</span></div>

      </td>
      <!-- END forum_link_no -->
 <!-- BEGIN forum_link -->
 <td class="row3" colspan="3" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.forum_link.HIT_COUNT}</span></td>
 <!-- END forum_link -->
 </tr>
 <!-- END forumrow -->
 <!-- BEGIN catfoot -->
 <tr>
 <!-- BEGIN inc -->
 <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
 <!-- END inc -->
 <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
 </tr>
 <!-- END catfoot -->
 <!-- BEGIN tablefoot -->
</table><img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --><!-- END catrow -->
Nous nous débrouillons en css et en HTML basique, mais lorsque cela touche aux templates, nous avons vraiment du mal.

En vous remerciant par avance de votre aide  et en m'excusant aussi si cela vient d'une toute petite manip qui nous aurait échappée ><, nous vous souhaitons une bonne soirée !

Myresis
Nouveau membre

Messages : 2
Inscrit(e) le : 25/08/2013

http://www.les-guerres-d-origine.org/
Myresis a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de sous-forums qui doublent

Message par Neptunia le Dim 25 Aoû 2013 - 3:31

Bonjour, et bienvenue sur le Forum des Forums ForumActif



Alors j'ai testé votre Index_box qui semble OK.

A mon avis le souci vient de votre index_body.
Semblerait que vous ayez deux lignes avec
Code:
{BOARD_INDEX}
Suffit d'effacer le doublon et tout devrait rentrer dans l'ordre.

Neptunia
+ Hyperactif +

Féminin
Messages : 10933
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de sous-forums qui doublent

Message par Myresis le Dim 25 Aoû 2013 - 11:34

Bonjour !
Merci pour votre réponse rapide en tout cas !
Je pense m'être mal exprimée dans mon titre en fait (l'heure tardive combinée à la panique <<), car ce ne sont pas les sous-forums sur la PA qui doublent mais les catégories à l'intérieur si on clique sur les sous-forums. Du coup j'ai bien le Board Index en une seule fois dans la bonne templates.

J'ai fait un nouveau screen sans doute plus explicite pour expliquer la situation><

Spoiler:

Désolée pour mon erreur du coup, ça vous a fait travailler pour rien ><
Merci par avance !

Bonne journée !


EDITION : PROBLEME RESOLU !!! Le board index était en double dans la Templates viewforum_body !! Tout est rentré dans l'ordre ! Merci beaucoup pour votre aide !

Bonne journée !

Myresis
Nouveau membre

Messages : 2
Inscrit(e) le : 25/08/2013

http://www.les-guerres-d-origine.org/
Myresis a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum