Problème avec le hide

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec le hide

Message par Comette13 le Mer 16 Oct 2013 - 16:48

- l'URL du forum : http://top11france.forumactif.org
- la version du forum : phpBB2 (subsilver)
- Mon statut sur le forum : administrateur non fondateur
- Vous avez modifié des templates : non
- Vous avez du CSS personnalisé : non
- navigateur : chrome
- Le code qui pose problème : hide

Bonjour à tous^^

J'ai fais des recherches un peu partout dans le forum mais je n'ai pas trouvé réponse à mon problème.

Je suis administrateur non fondateur de mon forum et je voudrais lorsque l'on utilise la fonction hide qu'il y ait un message texte du genre [répondre au sujet pour voir ce qui est caché].

Je sais que sur d'autre forum tels que un concurrent, il y a la possibilité de faire ceci.

J'ai fais plusieurs essais après avoir visité les différents sujets déjà existant mais rien ne fonctionne.

Lorsque je publie ou répond à un message en utilisant la fonction hide, il n’apparaît rien du tout à l'endroit ou j'ai utilisé le code.

Je vous montre en image.

Voici mon texte :



Ce que je vois après avoir cliqué sur "envoyer" :



Ce que voient les membres du forum (un message vide) :



Ce que je voudrais que les membres du forum voient :



Si vous pouviez m'aider afin de trouver une solution à mon problème.

Merci d'avance Smile


Dernière édition par Comette13 le Mer 16 Oct 2013 - 19:02, édité 1 fois

Comette13
*

Masculin
Messages : 37
Inscrit(e) le : 16/10/2013

http://top11france.forumactif.org
Comette13 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le hide

Message par AenigmA le Mer 16 Oct 2013 - 17:05

Bonjour, un truc du genre peut être

Répondre au sujet pour voir:

AenigmA
+ Hyperactif +

Masculin
Messages : 2228
Inscrit(e) le : 10/03/2005

http://aenigma.forumactif.fr/
AenigmA a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le hide

Message par Comette13 le Mer 16 Oct 2013 - 17:12

Oui, c'est quelques chose comme ça, mais sans le code "spoiler", uniquement le code "hide"

Comette13
*

Masculin
Messages : 37
Inscrit(e) le : 16/10/2013

http://top11france.forumactif.org
Comette13 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le hide

Message par AenigmA le Mer 16 Oct 2013 - 17:45

A la limite tu peux l'automatiser ainsi par un bouton bien que ce soit vite écrit ta phrase ...

Dans javascript (cocher sur toutes les pages)

Code:
$(function(){$(function(){
               
                $('<a class="sceditor-button" unselectable="on" title="HIDE"><div unselectable="on" style="background-image:url(http://i34.servimg.com/u/f34/11/40/46/60/aaaatt10.gif); margin: 3px 0;">Réponse attendue</div></a>').insertBefore('.sceditor-button.sceditor-button-bold').click(function(){
                    $("#text_editor_textarea").sceditor("instance").insertText("Répondre au sujet pour voir [hide]","[/hide]");
                  });
               
              })});

AenigmA
+ Hyperactif +

Masculin
Messages : 2228
Inscrit(e) le : 10/03/2005

http://aenigma.forumactif.fr/
AenigmA a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le hide

Message par Comette13 le Mer 16 Oct 2013 - 17:52

Merci pour ta réponse, je vais essayer ça et je tiens au courant Smile

Comette13
*

Masculin
Messages : 37
Inscrit(e) le : 16/10/2013

http://top11france.forumactif.org
Comette13 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le hide

Message par Comette13 le Mer 16 Oct 2013 - 18:00

Et bien non, ça ne marche toujours pas, je suis maudit aidez moi 

Comette13
*

Masculin
Messages : 37
Inscrit(e) le : 16/10/2013

http://top11france.forumactif.org
Comette13 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le hide

Message par AenigmA le Mer 16 Oct 2013 - 18:20

Pourtant ça fonctionne, je l'ai essayé.

AenigmA
+ Hyperactif +

Masculin
Messages : 2228
Inscrit(e) le : 10/03/2005

http://aenigma.forumactif.fr/
AenigmA a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le hide

Message par Comette13 le Mer 16 Oct 2013 - 18:41

Pourtant j'ai bien inséré le code javascript comme tu me l'as donné. Ensuite je me suis connecté en tant qu'invité et je vois toujours un message vide.

J'ai du louper quelques chose...

Comette13
*

Masculin
Messages : 37
Inscrit(e) le : 16/10/2013

http://top11france.forumactif.org
Comette13 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le hide

Message par AenigmA le Mer 16 Oct 2013 - 18:55

Si tu vois le bouton rouge dans l'éditeur
Crée un nouveau sujet sur ton forum et essaie, car ça ne modifiera pas les anciens

AenigmA
+ Hyperactif +

Masculin
Messages : 2228
Inscrit(e) le : 10/03/2005

http://aenigma.forumactif.fr/
AenigmA a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec le hide

Message par Comette13 le Mer 16 Oct 2013 - 18:58

[Edit] haaaa!!!!!! Merci infiniment,ça marche^^

Problème résolu Thanks 

Comette13
*

Masculin
Messages : 37
Inscrit(e) le : 16/10/2013

http://top11france.forumactif.org
Comette13 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum