[phpBB3]Code de Ea pour MP automatique lors de déplacement ne fonctionne pas

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu [phpBB3]Code de Ea pour MP automatique lors de déplacement ne fonctionne pas

Message par alissad le Jeu 12 Déc 2013 - 20:41

Bonjour à tous,

Mon forum est sous phpBB3 ( http://allpost.forumgratuit.be/ ) et j'ai voulu ajouter ce code sur mon forum qu'Ea a donné pour un MP automatique lors d'un déplacement de sujet:

Code:
       $(function() {
          if (document.location.pathname.match(/^\/t[1-9][0-9]*(p[1-9][0-9]*)?-/)) {
            $(".quickmod select[name='mode']").removeAttr("onchange").change(function(e) {
              if (this.value == "move" && /^f[1-9][0-9]*$/.test($("fieldset.jumpbox select[name='selected_id']").val())) {
                $(this).after('<input type="hidden" name="new_forum" value="' + $("fieldset.jumpbox select[name='selected_id']").val() + '" /><input type="hidden" name="confirm" value="Oui" />').closest("form").attr("method", "post").attr("name", "movetopic");
                $("body").append('<div style="width:1px;height: 1px; position: absolute; visibility: hidden; overflow: hidden"><iframe name="mp" onload="$(\'form[name=movetopic]\')[0].submit()"></iframe><form name="mpsend" action="/privmsg" method="post" target="mp"><input type="hidden" name="post" value="Envoyer" /><input type="submit" /><input type="hidden" name="attach_sig" value="1" /><input type="hidden" name="username[]" value="' + $(".post:first p.author a").text().replace(/"/g, """).replace(/</g,
               "<").replace(/>/g, ">") + '" /><input type="hidden" name="subject" value="D\u00e9placement de sujet" /><input type="hidden" name="message" value="Bonjour,\n\n\nVotre sujet [url=http://forum.forumactif.com/t' + document.location.pathname.replace(/^\/t([1-9][0-9]*).*?$/, "$1") + "-]" + $(".post:first h2.topic-title a").text().replace(/"/g, """).replace(/</g, "<").replace(/>/g, ">") + '[/url] a \u00e9t\u00e9 d\u00e9plac\u00e9 dans une section plus appropri\u00e9e.\n\n[i][size=10](ceci est un message envoy\u00e9 automatiquement avec le d\u00e9placement de votre sujet par un mod\u00e9rateur, merci de ne pas r\u00e9pondre)[/size][/i]\n\nCordialement." /></form>');
                $("form[name='mpsend']")[0].submit();
              } else {
                this.form.submit();
              }
            });
          }
        });

Mais j'essaie de déplacer un sujet comme dit avec la méthode "sauter vers" et outil "déplacer le sujet", mais ça ne fonctionne pas.

Je me suis dit que c'est peut-être un autre code javascript qui empêche le phénomène alors j'ai fait sur mon forum de test qu'il n'a aucuns codes javascript, et ça ne fonctionne pas aussi. (C'est un phpBB3 aussi).

Déjà, lorsque je sélectionne le sujet sur sauter vers et que je sélectionner "déplacer le sujet" le "déplacer le sujet" me redirige automatiquement vers la sélection du sous forum de déplacement. C'est peut-être de là que vient le problème??

Merci à vous de vos futures réponses !


Dernière édition par alissad le Ven 13 Déc 2013 - 10:30, édité 1 fois

alissad
****

Messages : 324
Inscrit(e) le : 03/11/2012

http://allpost.forumgratuit.be/
alissad a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [phpBB3]Code de Ea pour MP automatique lors de déplacement ne fonctionne pas

Message par Ea le Jeu 12 Déc 2013 - 20:49

Bonjour,

Dans le code que vous avez collé dans votre message, il y a un certain nombre d'erreur.

Vous avez essayé en utilisant directement le code présent dans ce message :
http://forum.forumactif.com/t346258-message-mp-automatique#2956626
?

Cordialement.


Ea
Aidactif
Aidactif

Messages : 23447
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [phpBB3]Code de Ea pour MP automatique lors de déplacement ne fonctionne pas

Message par alissad le Jeu 12 Déc 2013 - 20:56

ça ne marche toujours pas :/

Je sélectionne un sous-forum avec "sauter vers" puis je sélectionner "déplacer le sujet" et ça me redirige encore sur la sélection du sous-forum de destination :/

alissad
****

Messages : 324
Inscrit(e) le : 03/11/2012

http://allpost.forumgratuit.be/
alissad a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [phpBB3]Code de Ea pour MP automatique lors de déplacement ne fonctionne pas

Message par alissad le Jeu 12 Déc 2013 - 21:03

Si vous voulez, vous pouvez vous inscrire sur mon forum et je dis à ma co-admin de vous mettre administratrice dès que vous êtes inscrite pour voir Wink

alissad
****

Messages : 324
Inscrit(e) le : 03/11/2012

http://allpost.forumgratuit.be/
alissad a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [phpBB3]Code de Ea pour MP automatique lors de déplacement ne fonctionne pas

Message par Ea le Jeu 12 Déc 2013 - 21:34

awip

le code du message dont j'ai donné le lien est un exemple non-fonctionnel

il faudrait soit :
- l'entour de $(function(){ });
- essayer les scripts suivant dans le sujet
- essayer ce script qui est mis et fonctionne sur ce forum ( donc devrait fonctionner pour du phpbb3 ) :

Code:
 $(function(){
    if (document.location.pathname.match(/^\/t[1-9][0-9]*(p[1-9][0-9]*)?-/)) {
        $(".quickmod select[name='mode']").removeAttr("onchange").change(function (e) {
            if (this.value == "move" && /^f[1-9][0-9]*$/.test($("fieldset.jumpbox select[name='selected_id']").val())) {
                $(this).after('<input type="hidden" name="new_forum" value="' + $("fieldset.jumpbox select[name='selected_id']").val() + '" /><input type="hidden" name="confirm" value="Oui" />').closest("form").attr("method", "post").attr("name", "movetopic");
                $("body").append('<div style="width:1px;height: 1px; position: absolute; visibility: hidden; overflow: hidden"><iframe name="mp" onload="$(\'form[name=movetopic]\')[0].submit()"></iframe><form name="mpsend" action="/privmsg" method="post" target="mp"><input type="hidden" name="post" value="Envoyer" /><input type="submit" /><input type="hidden" name="attach_sig" value="1" /><input type="hidden" name="username[]" value="' + ($(".post:first p.author a").text().replace(/"/g, "&quot;").replace(/</g, "&lt;").replace(/>/g, "&gt;")) + '" /><input type="hidden" name="subject" value="Déplacement de sujet" /><input type="hidden" name="message" value="Bonjour,\n\n\nVotre sujet [url=http://'+location.hostname+'/t' + document.location.pathname.replace(/^\/t([1-9][0-9]*).*?$/, "$1") + '-]' + $(".post:first h2.topic-title a").text().replace(/"/g, "&quot;").replace(/</g, "&lt;").replace(/>/g, "&gt;") + '[/url] a été déplacé dans une section plus appropriée.\n\n[i][size=10](ceci est un message envoyé automatiquement avec le déplacement de votre sujet par un modérateur, [b][color=red]merci de ne pas répondre[/color][/b])[/size][/i]\n\nCordialement." /></form>');
                $("form[name='mpsend']")[0].submit();
            } else this.form.submit();
        });
    }
});

Ea
Aidactif
Aidactif

Messages : 23447
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [phpBB3]Code de Ea pour MP automatique lors de déplacement ne fonctionne pas

Message par alissad le Ven 13 Déc 2013 - 10:25

@Ea a écrit:awip

le code du message dont j'ai donné le lien est un exemple non-fonctionnel

il faudrait soit :
- l'entour de $(function(){ });
- essayer les scripts suivant dans le sujet
- essayer ce script qui est mis et fonctionne sur ce forum ( donc devrait fonctionner pour du phpbb3 ) :

Code:
 $(function(){
    if (document.location.pathname.match(/^\/t[1-9][0-9]*(p[1-9][0-9]*)?-/)) {
        $(".quickmod select[name='mode']").removeAttr("onchange").change(function (e) {
            if (this.value == "move" && /^f[1-9][0-9]*$/.test($("fieldset.jumpbox select[name='selected_id']").val())) {
                $(this).after('<input type="hidden" name="new_forum" value="' + $("fieldset.jumpbox select[name='selected_id']").val() + '" /><input type="hidden" name="confirm" value="Oui" />').closest("form").attr("method", "post").attr("name", "movetopic");
                $("body").append('<div style="width:1px;height: 1px; position: absolute; visibility: hidden; overflow: hidden"><iframe name="mp" onload="$(\'form[name=movetopic]\')[0].submit()"></iframe><form name="mpsend" action="/privmsg" method="post" target="mp"><input type="hidden" name="post" value="Envoyer" /><input type="submit" /><input type="hidden" name="attach_sig" value="1" /><input type="hidden" name="username[]" value="' + ($(".post:first p.author a").text().replace(/"/g, """).replace(/</g, "<").replace(/>/g, ">")) + '" /><input type="hidden" name="subject" value="Déplacement de sujet" /><input type="hidden" name="message" value="Bonjour,\n\n\nVotre sujet [url=http://'+location.hostname+'/t' + document.location.pathname.replace(/^\/t([1-9][0-9]*).*?$/, "$1") + '-]' + $(".post:first h2.topic-title a").text().replace(/"/g, """).replace(/</g, "<").replace(/>/g, ">") + '[/url] a été déplacé dans une section plus appropriée.\n\n[i][size=10](ceci est un message envoyé automatiquement avec le déplacement de votre sujet par un modérateur, [b][color=red]merci de ne pas répondre[/color][/b])[/size][/i]\n\nCordialement." /></form>');
                $("form[name='mpsend']")[0].submit();
            } else this.form.submit();
        });
    }
});


Ah oui ça fonctionne enfin merci <3

J'en avais marre d'essayer environ 5/6 codes et qu'aucuns ne fonctionnait lol

Merci beaucoup Smile

alissad
****

Messages : 324
Inscrit(e) le : 03/11/2012

http://allpost.forumgratuit.be/
alissad a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum