Forum lent

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Forum lent

Message par 2011N2 le Sam 14 Déc 2013 - 15:10

Bonjour,

Depuis déjà plusieurs moi, mon forum est plutôt lent (lien de mon profil). Je me disais que c'était surtout parce qu'il y avait beaucoup d'éléments (images, codes javascripts, etc.). Cette lenteur est constante, et absolument sur toutes les pages (les plus chargées comme les moins chargées). Ce qui est le plus long, on dirait que c'est le temps de réponse du serveur : lorsqu'on charge une page, le premier affichage de la page met beaucoup de temps à s'afficher, après c'est plutôt rapide. Je viens de tester, en moyenne, avant de voir le premier aperçu, il faut en moyenne 4.5 secondes. Sur les autres forums FA, c'est quasiment instantané.
J'ai décidé de me pencher un peu plus sur le souci ce matin. J'ai donc désactivé, un à un les éléments suivantes : tous les codes Javascript, vider la feuille de style CSS, désactivé les widgets.
Cependant, aucun changement.
Toutes les images sont hébergées sur servimg.
On peut constater ici que le temps de chargement est important. Cependant, dans les détails, aucun élément n'est vraiment long à se charger.

Du coup, j'ai créé un forum test pour reproduire un peu la structure de mon forum. Mais j'ai remarqué que même dans mon panneau d'administration, les pages sont extrêmement longues à se charger comparé au forum de test. Or, aucun script ne se charge dans le PA à ma connaissance (sauf les pages contenant un aperçu du site).
Exemple, si je charge 2 pages totalement identiques (Modules > Galerie > Configuration) :
- Presque 4 secondes sur mon forum.
- 0.5 seconde sur le forum de test.

Soit plus de 8 fois plus long.

Certains forums seraient-ils hébergés sur des serveurs moins performants que d'autres... ?

Merci d'avance,

Gabriel.


Dernière édition par 2011N2 le Sam 1 Fév 2014 - 13:36, édité 1 fois

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par Chacha le Sam 14 Déc 2013 - 15:41

Bonjour,

Votre forum charge quand même 140 requêtes à l'ouverture et ce en 2.95 secondes.



D'après ce rapport de test, indiquée en rouge, ce lien ne charge pas :
http://www.forum-entraide-informatique.com/date_heure.js

Cordialement.


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Chacha
Modéractif
Modéractif

Masculin
Messages : 51031
Inscrit(e) le : 21/08/2010

http://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Sam 14 Déc 2013 - 15:49

Bonjour,

Merci pour la réponse.

Cela ne doit pas prendre en compte le temps de réponse du serveur... Pourquoi une telle différence entre deux outils d'analyse ? http://www.monitoring-transactionnel.com/outils-gratuits/7e93396f86c2e57686ea06109dd50b4cdce732c7
Étrange. scratch

Et si vous cliquez sur le lien suivant et que vous chronométrez, il se charge vraiment en moins de 3 secondes ? http://www.forum-entraide-informatique.com/
Je viens de retester : 6.60 secondes (4.5 secondes pour le premier aperçu, donc le temps de réponse du serveur je pense, et 2.10 secondes de plus pour l'affichage entier, ce qui est correct pour cette dernière valeur).

Et je doute que cela soit dû aux nombres d'éléments, étant donné que c'est tout aussi lent dans le panneau d'administration contrairement à celui du forum de test. Non ?

Merci,

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par Chacha le Sam 14 Déc 2013 - 15:58

Re,

Déjà, on ne peut pas modifier la ville, (Paris indiqué), ni la version de Firefox (24 indiqué, alors que j'ai la version 26.0), donc le résultat sera faussé.

Le résultat trouve sur cette page.


Cordialement.


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Chacha
Modéractif
Modéractif

Masculin
Messages : 51031
Inscrit(e) le : 21/08/2010

http://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Sam 14 Déc 2013 - 16:01

Re,

Certes on ne peut pas modifier la ville et la version mais je constate moi-même que mon forum est lent, même dans le PA, donc même si le résultat est faussé cela confirme bien une lenteur.

Sinon, pour la ligne en rouge, c'est l'affichage de la date en haut des widgets, les robots n'arrivent pas à la charger apparemment (vu que c'est l'heure du PC de l'internaute qui est affichée).

Le résultat trouve sur cette page.

Ça je n'ai pas compris. scratch

Merci,

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par Chacha le Sam 14 Déc 2013 - 16:05

Re,

Et bien en cliquant sur "cette page" du message précédent, c'est le lien vers le test que vous avez demandé http://www.monitoring-transactionnel.com/outils-gratuits/e364c16eb31eeae20c73f803af5a630bde53024d Smile

En fait j'avais mal compris, j'ai cliqué sur votre forum et regardé l'horloge digitale, il se charge en 3 secondes environ. Wink


Cordialement.


EDIT 16h16 : Voici un autre test par ce site : http://www.internetvista.com/fr/soumission-test-disponibilite-site-web.htm



Cela dépend également de votre connexion Internet, que vous pouvez tester ici http://www.speedtest.net/

Mon résultat : http://www.speedtest.net/my-result/3165119526


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Chacha
Modéractif
Modéractif

Masculin
Messages : 51031
Inscrit(e) le : 21/08/2010

http://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Sam 14 Déc 2013 - 16:30

Re,

Ok, mais qu'est-ce qui explique que le PA de mon site est 8 fois plus lent que celui du forum de test ?
De plus je constate bien qu'il y a un souci de lenteur avant le premier aperçu (après c'est bon) par rapport aux autres sites.
Et ces tests ne doivent pas prendre en compte le temps avant le premier aperçu. En revanche, Google Analytics, lui le prend en compte, et voici le résultat :


Merci,

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par Chacha le Sam 14 Déc 2013 - 16:33

Re,

Là je laisse à d'autres personnes le soin de vous répondre. Wink


Cordialement.


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Chacha
Modéractif
Modéractif

Masculin
Messages : 51031
Inscrit(e) le : 21/08/2010

http://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Sam 14 Déc 2013 - 16:33

Re,

D'accord. Wink

Merci d'avoir répondu et bonne journée,

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Lun 16 Déc 2013 - 19:24

Up

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par Chacha le Mer 18 Déc 2013 - 13:33

Bonjour,

Peut-être que ce nouveau test vous donnera des indications supplémentaires, de nombreux liens sont cliquables. Wink



Si la page du rapport ne veut plus s'afficher, vous pouvez réaliser le test vous-même par ce lien.


Cordialement.


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Chacha
Modéractif
Modéractif

Masculin
Messages : 51031
Inscrit(e) le : 21/08/2010

http://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par alissad le Mer 18 Déc 2013 - 15:26

Le site que vous avez utilisé au départ n'est pas bon...

http://www.monitoring-transactionnel.com/outils-gratuits/df8ffe6f2804b1a6f308d44dfd4e4a2ebf556959

Ils disent que je mets 14 secondes pour faire apparaître la page de mon site hors qu'en même pas 2 secondes elle apparaît sur mon forum la page d'accueil.

alissad
****

Messages : 324
Inscrit(e) le : 03/11/2012

http://allpost.forumgratuit.be/
alissad a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Forum lent

Message par FANCH 56 le Mer 18 Déc 2013 - 15:53

@alissad a écrit:Le site que vous avez utilisé au départ n'est pas bon...

http://www.monitoring-transactionnel.com/outils-gratuits/df8ffe6f2804b1a6f308d44dfd4e4a2ebf556959

Ils disent que je mets 14 secondes pour faire apparaître la page de mon site hors qu'en même pas 2 secondes elle apparaît sur mon forum la page d'accueil.

On perle ici, du temps mis pour charger TOUS les éléments., et non l'affichage de la page sur votre écran.

FANCH 56
+ Hyperactif +

Masculin
Messages : 13260
Inscrit(e) le : 25/07/2005

http://www.anciens-cols-bleus.net/
FANCH 56 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Forum lent

Message par 2011N2 le Sam 21 Déc 2013 - 18:23

Bonsoir,

Si si le site est bon, après c'est le temps de leurs robots, ça peut être plus rapide chez certains, comme plus long.
Merci pour la réponse Chacha, justement j'avais examiné ce lien.

Mais je ne peux pas faire grand chose. Quand on prendre point par point :

- Éliminer les codes JavaScript et CSS qui bloquent l'affichage du contenu au-dessus de la ligne de flottaison :
Supprimez les ressources JavaScript qui bloquent l'affichage :
http://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js
http://illiweb.com/rs3/99/frm/lang/fr.js
http://www.forum-entraide-informatique.com/99820.js
http://www.forum-entraide-informatique.com/11049.js
http://www.forum-entraide-informatique.com/18970.js
http://www.forum-entraide-informatique.com/45087.js
http://illiweb.com/…sc/99/frm/jquery/cookie/jquery.cookie.js
http://illiweb.com/rs3/99/frm/jquery/toolbar/FAToolbar.js
Optimisez l'affichage des styles CSS pour les URL suivantes :
http://www.forum-entraide-informatique.com/12-ltr.css

À part les 4 codes JS du milieu, je n'ai pas accès au reste à priori. Pour les 4 (99820, 11049, 18970, 45087), il faudrait que j'arrive à les faire passer en asynchrone pour régler le souci, mais je n'ai pas réussi à le faire.
En outre, j'ai testé en désactivant tous les javascript, ça change quasiment rien, juste une note de 79/100 au lieu de 78.

- Optimiser les images
Ça pas de souci, je vais essayer le faire quand je vais avoir un peu plus de temps devant moi. Smile
Mais pas sûr que ça accélère vraiment.

- Exploiter la mise en cache du navigateur
Pas sûr que je puisse le faire non plus moi-même. scratch

- Réduire le temps de réponse du serveur
Voilà le souci principal à priori, mais ça je ne peux vraiment rien y faire... J'ai testé avec le site du FDF, le temps de réponse est correcte. Des serveurs moins puissants chez FA ?

- Réduire la taille des ressources JavaScript
Faudrait que je vois comment faire, mais au final ça ne ferai gagner que 4Ko, donc bon... ^^

- Réduire la taille des ressources HTML
Là aussi ça ne fait gagner que 803 octets... ^^

Donc au final, à part réduire le poids des images, et trouver comment passer les js en asynchrone, je ne vois pas trop quoi faire.

Merci,

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Lun 23 Déc 2013 - 15:31

Up Smile

J'ai d'ailleurs l'impression que c'est surtout avec mon compte admin que c'est très lent, j'ai comparé en navigation privée avec un compte de test et mon compte admin, c'est bien plus lent sur mon compte admin pour une même page... scratch

Merci,

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Forum lent

Message par Chacha le Lun 23 Déc 2013 - 15:39

@2011N2 a écrit:Up Smile

J'ai d'ailleurs l'impression que c'est surtout avec mon compte admin que c'est très lent, j'ai comparé en navigation privée avec un compte de test et mon compte admin, c'est bien plus lent sur mon compte admin pour une même page... scratch

Merci,

Gabriel.
Bonjour,

J'ai signalé votre sujet au Staff pro. Wink


Cordialement.


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Chacha
Modéractif
Modéractif

Masculin
Messages : 51031
Inscrit(e) le : 21/08/2010

http://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Forum lent

Message par 2011N2 le Lun 23 Déc 2013 - 15:42

Bonjour Chacha,

Merci à vous. Wink

Bonne journée,

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par Shadow le Mar 24 Déc 2013 - 9:04

Bonjour,

Nos techniciens se sont penchés dessus. Cela serait causé par votre nombre de forums très important (356).

Nous étudions encore le problème pour trouver peut être une solution Wink


Bonne journée et à bientot


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Shadow
Adminactive
Adminactive

Féminin
Messages : 23946
Inscrit(e) le : 30/03/2007

http://forum.forumactif.com
Shadow a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Mar 24 Déc 2013 - 12:19

Bonjour,

D'accord merci. Smile

Il est quasi sûr que cela provienne du nombre de forums (c'est à cause des formations) ? Cela expliquerait la lenteur particulièrement sur mon compte admin et dans le PA ?
Si oui, je peux essayer de réduire ce nombre de catégories... Wink

Joyeuses fêtes,

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par Shadow le Mar 24 Déc 2013 - 14:17

Oui il est en effet quasi sur  Embarassed 


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Shadow
Adminactive
Adminactive

Féminin
Messages : 23946
Inscrit(e) le : 30/03/2007

http://forum.forumactif.com
Shadow a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Mar 24 Déc 2013 - 14:19

C'est une bonne nouvelle, au moins on sait d'où ça vient. Wink

Je vais faire quelques manipulations puis je vous tiens au courant dès que possible.

@+

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Mar 24 Déc 2013 - 14:37

Re,

Je viens de me passer mon compte test qui était en simple membre et qui était plutôt fluide par rapport à mon compte admin en administrateur. Cependant, ce n'est pas spécialement plus long. Et dans le panneau d'administration, avec cet autre compte, c'est tout à fait fluide.
Et pourtant, il a bien accès aux 356 forums du site.

Étrange non ?

Merci Smile

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Dim 29 Déc 2013 - 20:39

Bonjour,

Donc ? Very Happy

Merci,

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Mar 31 Déc 2013 - 13:50

Up

S'il faut je veux bien faire le tri des catégories, mais ça va me prendre beaucoup de temps, donc je voudrais être sûr que ça résolve le souci sur mon compte fondateur. Wink
Parce que c'est bizarre que ça ne bug pas sur un autre compte admin ayant accès aux mêmes éléments.

Merci,

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Sam 4 Jan 2014 - 16:28

Up

Bonne année au passage Smile

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Dim 5 Jan 2014 - 21:19

Up

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par Chacha le Dim 12 Jan 2014 - 10:46

Bonjour,

Nous n'avons plus de nouvelle de l'auteur de ce sujet depuis plus de 7 jours. Nous considérons donc ce problème comme résolu ou abandonné. La prochaine fois, merci de nous tenir au courant de l'évolution de votre problème, ou à faire un UP régulièrement ! Wink

Ce sujet est corbeillé (rappel de pourquoi), merci d'ouvrir un nouveau sujet si nécessaire, en respectant les Règles générales du forum.

A bientôt sur ForumActif Smile


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Chacha
Modéractif
Modéractif

Masculin
Messages : 51031
Inscrit(e) le : 21/08/2010

http://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par Chacha le Lun 13 Jan 2014 - 10:11

Bonjour,

Le topic est replacé à la demande de l'auteur du sujet.

A bientôt sur ForumActif Smile


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Chacha
Modéractif
Modéractif

Masculin
Messages : 51031
Inscrit(e) le : 21/08/2010

http://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par 2011N2 le Mar 14 Jan 2014 - 7:42

Bonjour,

Merci. Smile

Avec mon compte fondateur où ça rame, environ 18 à 20 secondes pour poster un message (sur mon forum).
Et ici sur le FDF, 5 à 6 secondes.

Donc c'est effectivement très long... ^^

Je peux essayer de réduire le nombre de catégories mais je voudrai être sûr que ça résolve le problème, étant donné qu'avec un autre compte administrateur il n'y a pas de souci spécial.

Gabriel.

2011N2
# Tropactif #

Masculin
Messages : 1415
Inscrit(e) le : 10/04/2011

http://www.forum-entraide-informatique.com/
2011N2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Forum lent

Message par Shadow le Mar 14 Jan 2014 - 9:21

Bonjour,


Comme je vous ai déjà dit les techniciens pensent que c'est du à ca. Je ne peux pas vous l'assurer mais nous pensons que c'est ceci et en plus de ca il n'y a que votre forum de concerné Sad


Bonne journée et à bientot


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Shadow
Adminactive
Adminactive

Féminin
Messages : 23946
Inscrit(e) le : 30/03/2007

http://forum.forumactif.com
Shadow a été remercié(e) par l'auteur de ce sujet.

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum