Soucis avec les balises span et nav sur l'éditeur contenu dans la description des catégories et des forums.

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Soucis avec les balises span et nav sur l'éditeur contenu dans la description des catégories et des forums.

Message par demeter1 le Dim 19 Jan 2014 - 15:34

Bonjour à tous,
Juste pour signaler un dysfonctionnement au niveau de l'éditeur contenu dans la description des catégories et des forums.
A l'édition du code inséré, les balises nav et span se ferment automatiquement juste après l'ouverture.

Code:
<div class="description_forum">
    Forum d'aide aux membres d'Altitude tropicale pour régler leurs petits soucis techniques dans l'utilisation du site (forums, liens, photos, etc.) . Cette partie vous permettra également de faire des suggestions dans le but d'améliorer le forum.<br /><br />
   <center>
   
          <nav>
      <ul>   
         <li class="vert-nav">
            
            <h2>
                Accès rapide
            </h2>
             <span>  
            <ul>
               
               <li>
                   <a href="http://altitudetropicale.forums-actifs.com/f55-vos-questions"><img style="width: 10px;" src="http://s3.noelshack.com/uploads/images/12109310967798_arrow_next.png" />« Vos questions» </a>
               </li>
               
               <li>
                   <a href="http://altitudetropicale.forums-actifs.com/f10-vos-suggestions-pour-ameliorer-le-siten-oubliez-pas-de-consulter-la-faq"><img style="width: 10px;" src="http://s3.noelshack.com/uploads/images/12109310967798_arrow_next.png" /> « Vos suggestions pour améliorer le site»</a>
               </li>
               
            </ul></span>
         </li>
         
      </ul></nav>
   </center>
    </div>

se transforme en

Code:

<div class="description_forum">
    Forum d'aide aux membres d'Altitude tropicale pour régler leurs petits soucis techniques dans l'utilisation du site (forums, liens, photos, etc.) . Cette partie vous permettra également de faire des suggestions dans le but d'améliorer le forum.<br /><br />

 
<center>
    <nav> </nav>
   <ul style="">
      
      <li class="vert-nav">
         
         <h2>
             Accès rapide
         </h2>
          <span> </span>
         <ul style="">
            
            <li>
                <a href="http://altitudetropicale.forums-actifs.com/f55-vos-questions"><img src="http://s3.noelshack.com/uploads/images/12109310967798_arrow_next.png" style="width: 10px;" />« Vos questions» </a>
            </li>
            
            <li>
                <a href="http://altitudetropicale.forums-actifs.com/f10-vos-suggestions-pour-ameliorer-le-siten-oubliez-pas-de-consulter-la-faq"><img src="http://s3.noelshack.com/uploads/images/12109310967798_arrow_next.png" style="width: 10px;" /> « Vos suggestions pour améliorer le site»</a>
            </li>
            
         </ul><span></span>
      </li>
      
   </ul><nav></nav>
</center></div>

edit : transfert du sujet du forum intitulé "soucis avec le panneau d'administration" vers "Gérer l'apparence de son forum"!!!!! je ne sais trop pourquoi puisqu'il s'agit d'un soucis avec l'éditeur contenu dans le panneau d'administration.


Dernière édition par demeter1 le Mar 21 Jan 2014 - 6:47, édité 1 fois

demeter1
+ Hyperactif +

Masculin
Messages : 8224
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Soucis avec les balises span et nav sur l'éditeur contenu dans la description des catégories et des forums.

Message par MlleAlys le Dim 19 Jan 2014 - 17:40

bonjour,
je suppose que c'est le même souci qu'avec un certain nombre d'autres balises : les balises span, qui sont des balises inline, ne peuvent plus contenir de balises tyle block comme les div et ul. Et il y a aussi un souci avec la balise nav apparemment... Essayez de modifier la structure de votre code pour éviter ce problème, par exemple comme ça (j'ai entre autres retiré les balises de liste et nav et modifié du coup la balise portant la class "vert-nav", qui devient une div) :

Code:
<div class="description_forum">Forum d'aide aux membres d'Altitude tropicale pour régler leurs petits soucis techniques dans l'utilisation du site (forums, liens, photos, etc.) . Cette partie vous permettra également de faire des suggestions dans le but d'améliorer le forum.
    <br />
    <br />
    <div class="vert-nav">
         <h2>
             Accès rapide
        </h2>

        <div> <a href="http://altitudetropicale.forums-actifs.com/f55-vos-questions">
                                    <img style="width: 10px;" src="http://s3.noelshack.com/uploads/images/12109310967798_arrow_next.png" /> « Vos questions»
                                </a>

            <br/> <a href="http://altitudetropicale.forums-actifs.com/f10-vos-suggestions-pour-ameliorer-le-siten-oubliez-pas-de-consulter-la-faq">
                                    <img style="width: 10px;" src="http://s3.noelshack.com/uploads/images/12109310967798_arrow_next.png" /> « Vos suggestions pour améliorer le site»
                                </a>
        </div>
    </div>
</div>

Le css sera certainement à adapter du coup ^^"


édit : petite erreur corrigée donc, désolée et merci ! xP


Dernière édition par MlleAlys le Dim 19 Jan 2014 - 17:54, édité 2 fois

MlleAlys
+ Hyperactif +

Messages : 4404
Inscrit(e) le : 12/09/2012

MlleAlys a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Soucis avec les balises span et nav sur l'éditeur contenu dans la description des catégories et des forums.

Message par Manumanu le Dim 19 Jan 2014 - 17:45

Salut,

Petite précision : La balise nav (qui est un block et non un inline, même si dans le html5 on ne parle plus de ça mais de model-content) n'a rien à faire dans un forum phpbb, qui sont en xhtml et n'intègrent donc pas cette balise. Ça risque de générer des problèmes, car les navigateurs pourraient tout simplement choisir de ne pas en tenir compte. Donc, je recommande de s'en tenir aux div pour la mise en forme. Wink

D'ailleurs, il est très possible que l'éditeur de FA n'ait pas été fait pour prendre en compte ces balises non plus.

Manumanu
****

Masculin
Messages : 437
Inscrit(e) le : 27/12/2011

http://helpinghelps-phpbb2.forumgratuit.org/
Manumanu a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Soucis avec les balises span et nav sur l'éditeur contenu dans la description des catégories et des forums.

Message par MlleAlys le Dim 19 Jan 2014 - 17:57

oh, merci pour la précision ! =)

MlleAlys
+ Hyperactif +

Messages : 4404
Inscrit(e) le : 12/09/2012

MlleAlys a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Soucis avec les balises span et nav sur l'éditeur contenu dans la description des catégories et des forums.

Message par Manumanu le Dim 19 Jan 2014 - 18:01

Pas de soucis Smile

Manumanu
****

Masculin
Messages : 437
Inscrit(e) le : 27/12/2011

http://helpinghelps-phpbb2.forumgratuit.org/
Manumanu a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Soucis avec les balises span et nav sur l'éditeur contenu dans la description des catégories et des forums.

Message par demeter1 le Mar 21 Jan 2014 - 6:47

Bonjour MlleAlys, cela fonctionne à merveille. un grand merci pour cette correction de code.

Bonjour et merci Manumanu pour cette info.

Pour ce qui concerne l'éditeur; comment faire pire en essayant de faire mieux mais bon, ceci est un autre débat.

En tout cas, merci à vous deux et bonne journée.

demeter1
+ Hyperactif +

Masculin
Messages : 8224
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum